Jira和Confluence部署在同一台服务器上,跑一段时间后,发现访问jira和confluence时,打开越来越缓慢。这是因为根据主机物理内存不同,默认的java虚拟机内存也会不同(一个较低值),有时候不够用,可以修改JAVA默认的JVM内存设置,改善内存不足导致的问题。操作如下:

1、Jira修改JVM内存(根据自己服务器的内存情况进行修改)

[root@jira-wiki ~]# cd /opt/atlassian/jira/bin/
[root@jira-wiki bin]# cp setenv.sh setenv.sh.bak
[root@jira-wiki bin]# vim setenv.sh
.......
JVM_MINIMUM_MEMORY="4096m" #默认是384m
JVM_MAXIMUM_MEMORY="8192m" #默认是768m 重启jira服务
[root@jira-wiki bin]# /etc/init.d/jira stop
[root@jira-wiki bin]# /etc/init.d/jira start
[root@jira-wiki bin]# lsof -i:8080 #确认8080端口起来。重启服务后,过一会儿端口才会起来

2、Confluence修改JVM内存

[root@jira-wiki ~]# cd /opt/atlassian/confluence/bin/
[root@jira-wiki bin]# cp setenv.sh setenv.sh.bak20180803
[root@jira-wiki bin]# vim setenv.sh
......
CATALINA_OPTS="-Xms4096m -Xmx8192m -XX:+UseG1GC ${CATALINA_OPTS}" 重启confluence服务
[root@jira-wiki bin]# /etc/init.d/confluence restart
[root@jira-wiki bin]# lsof -i:8090 #确认8090端口起来 ----------------------------------------------------------------------------
还可以修改文件/var/atlassian/application-data/confluence/confluence.cfg.xml文件中的数值,如下:
[root@file-server ~]# cat /var/atlassian/application-data/confluence/confluence.cfg.xml
.......
<property name="hibernate.c3p0.acquire_increment">10</property> #默认为1
<property name="hibernate.c3p0.idle_test_period">100</property>
<property name="hibernate.c3p0.max_size">60</property>
<property name="hibernate.c3p0.max_statements">60</property> #默认为0
<property name="hibernate.c3p0.min_size">20</property>
<property name="hibernate.c3p0.timeout">120</property> #默认为30

3、实践过程遇到过的问题

如上调整后,发现过一段时间,confluence突然打不开了,出现502报错!
查看/var/atlassian/application-data/confluence/logs/atlassian-confluence.log日志,出现下面报错:
........

WARN [synchrony-interop-executor:thread-2] [plugins.synchrony.bootstrap.DefaultSynchronyProxyMonitor] pollHealthcheck Could not ping the synchrony-proxy [http://127.0.0.1:8090/synchrony-proxy/healthcheck]: {}
java.net.SocketTimeoutException: Read timed out 

最后发现是上面调整的confluence的jvm内存给的太大了,适当将内存调小一些,或恢复为默认内存大小,重启confluence服务,即可恢复正常访问!
所以,jira和confluence的JVM内存并非是设置的越大,它们访问就越快!一般内存设置到1024M或者2048M即可!

---------------------------------------------书山有路勤为径,学海无涯苦作舟--------------------------------------------------------

关于访问Jira和Confluence服务越来越缓慢的解决办法阐述的更多相关文章

  1. wamp服务下部署禅道或其它项目时访问缓慢的解决办法

    原因其实很简单: WAMP服务默认是不支持外网访问的,如果公司内外网在一起就会引起缓慢甚至超时的问题,直接修改WAPM的配置文件让它可以访问外网即可解决问题.   解决的方法/步骤   1.解决办法: ...

  2. NTP服务放大攻击的解决办法

    什么是NTP服务? 网络时间协议NTP(Network Time Protocol)是用于互联网中时间同步的标准互联网协议.NTP服务器通过NTP服务向网络上的计算机或其他设备提供标准的授时服务,以保 ...

  3. 控制台窗口和powershell运行服务会卡住的解决办法

    之前使用nodejs做了一个简单的web服务,通过控制台窗口运行,通过浏览器访问发现有时候浏览器等很久数据都加载不出来,以为是代码有问题,后来发现是控制台卡住了,按一下enter键就好了,当时百度了一 ...

  4. win10的MySQL客户端连接centos7虚拟机的mysql服务端连接不上解决办法

    分别在win10和Centos虚拟机上装有MYSQL,但用电脑的mysql客户端连接centos7的服务端报错如下: 解决办法: 如果可以从虚拟机连接到电脑的MYSQL服务端, 那就是CentOS7的 ...

  5. struts2整合axis2后,访问不到wsdl,被struts2拦截的解决办法

    在struts2中整合axis2后,访问wsdl的时候显示404  not found There is no Action mapped for action name xxxxxxxx. 解决办法 ...

  6. win2003 HookPort 服务启动失败的解决办法!

    Win2003系统每次开机启动时都弹出个对话框报HookPort 服务启动失败,很多网友都遇到同类问题,问题根源是360安全卫士引起的,官方一直没有给出解决方案 问题描述:Win2003系统每次开机启 ...

  7. JIRA和Confluence更改JVM内存大小解决访问打开缓慢问题

    原因: 根据主机物理内存不同,默认的java虚拟机内存也会不同(一个较低值),有时候不够用,可以修改默认设置,改善内存不足导致的问题. 操作步骤: JIRA 1. 打开至相应目录: ~]# cd  / ...

  8. 关于SQL配置管理器的服务无法启动的解决办法!

    由于各种问题的因素,导致SQL服务无法启动,然后去事件查看器里看了下,有两个关于SQL 的错误.分别是实例中master.mdf和master.ldf的文件系统拒绝访问! 为了赶作业,带着焦急的心情去 ...

  9. [问题]通过IIS宿主发布WCF服务,客户端添加服务引用出错的解决办法

    环境配置:Web服务器:Windows Server 2008,iis7.5,.net4.0客户端:XPsp3 vs2010 sp1 问题描述:1.确定WCF服务访问地址  http://servic ...

随机推荐

  1. 【公众号系列】SAP的新零售

    公众号:SAP Technical 本文作者:matinal 原文出处:http://www.cnblogs.com/SAPmatinal/ 原文链接:[公众号系列]SAP的新零售   写在前面 还是 ...

  2. python3 deque(双向队列)

    创建双向队列 import collections d = collections.deque() append(往右边添加一个元素) import collections d = collectio ...

  3. Bootstrap Multiselect插件使用步骤以及常见参数配置介绍

    Multiselect是基于jQuery插件的,它可以以下拉列表的形式为用户提供选择内容,能进行单选或者多选.它应用的主要步骤如下: 一,引入需要的相关js和css文件 既然是Bootstrap插件, ...

  4. 交替方向乘子法(ADMM)

    交替方向乘子法(ADMM) 参考1 参考2 经典的ADMM算法适用于求解如下2-block的凸优化问题( 是最优值,令 表示一组最优解): Block指我们可以将决策域分块,分成两组变量, 这里面 都 ...

  5. 如何删除windows中运行的历史记录

    参照下图进入到注册表,依次打开红圈中的路径,在RunMRU里面列出来的全部是记录,全部删除即可

  6. 这可能是把ZooKeeper概念讲的最清楚的一篇文章

    我本人曾经使用过 ZooKeeper 作为 Dubbo 的注册中心,另外在搭建 Solr 集群的时候,我使用到了 ZooKeeper 作为 Solr 集群的管理工具. 前几天,总结项目经验的时候,我突 ...

  7. JS&Java实现常见算法面试题

    Github上的算法repo地址:https://github.com/qcer/Algo-Practice (如果你觉得有帮助,可以给颗星星收藏之~~~) 一.Java实现部分 参见随笔分类的算法部 ...

  8. 【转】localStorage使用总结

    原文地址:https://www.cnblogs.com/st-leslie/p/5617130.html 一.什么是localStorage.sessionStorage 在HTML5中,新加入了一 ...

  9. Elasticsearch通关教程(五):如何通过SQL查询Elasticsearch

    前言 这篇博文本来是想放在全系列的大概第五.六篇的时候再讲的,毕竟查询是在索引创建.索引文档数据生成和一些基本概念介绍完之后才需要的.当前面的一些知识概念全都讲解完之后再讲解查询是最好的,但是最近公司 ...

  10. Eruda 一个被人遗忘的移动端调试神器

    引言 ​ 日常工作中再牛逼的大佬都不敢说自己的代码是完全没有问题的,既然有问题,那就也就有调试,说到调试工具,大家可能对于fiddler.Charles.chrome devtools.Firebug ...