我在使用mysqll客户端连接我的mysql服务器的时候,出现了上述的问题。我的操作系统是ubuntu,安装版本是对应的64位服务器。我的服务器的启动方式是sudo service mysql start.

我对服务器的改动仅限于新增了一个mysql的配置文件,配置文件的位置在/etc/my.cnf。配置文件如下(不要在意设置的具体值):

[mysqld]
# GENERAL
datadir = /var/lib/mysql
socket = /var/lib/mysql/mysql.sock
pid_file = /var/lib/mysql/mysql.pid
user = mysql
port = p3306
default_storage_engine = InnoDB
#INNODB
innodb_buffer_pool_size = 2G
innodb_log_file_size = 300M
# LOGGING
log_error = /var/lib/mysql/mysql-error.log
slow_query_log_file = /var/lib/mysql/mysql-slow.log
# OTHER
tmp_table_size = 32M
max_heap_table_size = 32M
#query_cache_type = 0
#query_cache_size = 0
max_connections = 200
thread_cache_size = 50
table_open_cache = 300
open_files_limit = 65535
[client]
socket = /var/lib/mysql/mysql.sock
port = 3306

首先我要说明一点,使用mysql客户端不能连接到mysql服务端,是因为mysql连接的时候,使用了这个配置文件的client部分,也就是

[client]

socket = /var/lib/mysql/mysql.sock

而服务端的socket文件的位置不在这里,自然会出现问题。我查看/var/lib/mysql文件夹,都不存在mysql.sock文件。

那么服务端的socket文件保存在哪里呢?

答案是/var/run/mysqld文件夹,这里有一个mysqld.sock文件. 这个文件的位置是由/etc/my.cnf->/etc/mysql.cnf里面配置的文件/etc/mysql/mysql.conf.d/mysqld.cnf指定的。

查看mysqld.cnf文件夹,还可以如下配置:

[mysqld]
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
datadir = /var/lib/mysql
log-error = /var/log/mysql/error.log

可以查看对应文件夹,发现上述配置都生效了。我们查看mysql官网,可以看到如下警告语句:

Note

On Unix platforms, MySQL ignores configuration files that are world-writable. This is intentional as a security measure.

你检查一下你的/etc/my.cnf文件,然后改成/etc/mysql/mysql.cnf相同的访问属性,发现,仍然出现相同的问题。

你又会惊奇地发现,官网上面有如下说明:

On Unix and Unix-like systems, MySQL programs read startup options from the files shown in the following table, in the specified order (files listed first are read first, files read later take precedence).

你会觉得这里是/etc/mysql/mysql.conf.d/mysqld.cnf配置文件替换了/etc/my.cnf中的值。然后你选择删除/etc/my.cnf中关于client的配置,你发现不报上述错误了。当你进去之后,使用show gloabal variables命令,发现根本没有生效。

那么这个又是为什么?

然后你可以进行如下操作:在/etc/mysql/mysql.cnf中添加一句port = 3306,修改后,如下:

port = 3306
!includedir /etc/mysql/conf.d/
!includedir /etc/mysql/mysql.conf.d/

然后你调用sudo service mysql start命令,会发现如下错误:

Job for mysql.service failed because the control process exited with error code.
See "systemctl status mysql.service" and "journalctl -xe" for details.

然后你调用systemctl status mysql.service命令,得到如下错误:

4月 14 00:11:35 sun-Lenovo-IdeaPad-Y480 mysql-systemd-start[25400]: my_print_defaults: [ERROR] Fatal error in defaults handling. Program abort
4月 14 00:11:35 sun-Lenovo-IdeaPad-Y480 mysqld[25439]: mysqld: [ERROR] Found option without preceding group in config file /etc/mysql/my.cnf a
4月 14 00:11:35 sun-Lenovo-IdeaPad-Y480 mysqld[25439]: mysqld: [ERROR] Fatal error in defaults handling. Program aborted!
4月 14 00:11:35 sun-Lenovo-IdeaPad-Y480 systemd[1]: mysql.service: Main process exited, code=exited, status=1/FAILURE
4月 14 00:11:35 sun-Lenovo-IdeaPad-Y480 systemd[1]: mysql.service: Failed with result 'exit-code'.
4月 14 00:11:35 sun-Lenovo-IdeaPad-Y480 systemd[1]: Failed to start MySQL Community Server.

然后你移除/etc/mysql/mysql.cnf中的port = 3306,改为在/etc/my.cnf中只添加这一行。

port = 3306

你发现调用sudo service mysql start没有报错。按照上述的表现来看,mysql应该根本就不会读取/etc/my.cnf,所以你之前添加的这个文件,只是对mysql客户端链接产生了影响。

如果你想在使用sudo service mysql start方式启动时的服务端参数,最简单的方法是将原先的/etc/mysql/mysql.conf.d/mysqld.cnf备份一下,然后直接修改这个文件的值。修改之后,可能会遇到其他问题,再想办法解决了。

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (13)解答的更多相关文章

  1. ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

    有时候,当我们使用"mysql"."mysqladmin"."mysqldump"等命令管理数据库时,服务器抛出类似如下错误: 一.错误现场 ...

  2. ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

    从供应商手中接手一个云平台(Windwos Azure)上的MySQL数据库,登录数据库时遇到错误: $mysql -uroot -p Enter password: ERROR 2002 (HY00 ...

  3. ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var mysql 启动不了(转载)

    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var mysql 启动不了   ps -A | gr ...

  4. Mac mySql ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)的解决办法

    我的环境:Mac 10.11.6 ,mysql  5.7.14  . mac mySql 报错ERROR 2002 (HY000): Can't connect to local MySQL serv ...

  5. linux云服务器mysql ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/tmp/mysql.sock’

    一早上过来发现网站打开报错,数据库连接不上.. 有人改密码? putty进去,mysql -uroot -p 输入密码后,报错 ERROR 2002 (HY000): Can't connect to ...

  6. 更换mysql数据目录后出现ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) 的解决办法

    服务器上的mysql默认数据目录为/var/lib/mysql/,同时服务器的/空间不是很大,而近期又有大量的日志需要导入进行分析,时常搞得/的空间捉襟见肘,晚上一狠心就想把mysql的数据目录转移到 ...

  7. 启动mysql错误ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2)

    ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ ( ...

  8. 安装mysql后ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var mysql 启动不了

    ps -A | grep -i mysql kill 列出来的进程 service mysql start 我的问题就解决了 ------------------------------------- ...

  9. ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) 背景: mys ...

  10. mac ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

    好久不用mysql,今天突然想用的时候, mysql -uroot -p 直接报了下面的错误 ERROR 2002 (HY000): Can't connect to local MySQL serv ...

随机推荐

  1. 浅谈在java中list集合的排序问题

    定义实体类: public class Person { private Integer id; private String name; private Integer age; public In ...

  2. 王者荣耀交流协会final发布-第3次scrum立会

    1.例会照片 成员高远博,冉华,王磊,王玉玲,任思佳,袁玥出席.拍照的是王磊同学,王超同学因参加比赛不在学校,不能出席. master:任思佳 2.时间跨度 2017年12月3日 18:00 — 18 ...

  3. mysql新增用户并开启远程连接

    之前使用mysql一直使用root来连接登录数据库,现在想使用新的用户名来连接数据库,碰到数据连接不上的情况. 把这些记录下来,以备后用 1.首先,创建用户 CREATE USER 'xiazhenx ...

  4. vue使用vue-video-player在直播中的应用

    文档地址:https://github.com/savokiss/vue-videojs-demo live demo地址:https://github.com/savokiss/vue-videoj ...

  5. 台达VFD-B变频器调试

    一.变频器上电调试 变频器安装完成后,断开变频器的输出,在没通电前先使用数字表的二极管档对变频器的输入输出进行测量,确保无短路情况,然后接通变频器工作电源,(注意变频器标定的工作电源电压与外部输入电压 ...

  6. python 10

    不想写了,用一下强大的copy功能吧!! (转自:我的同桌)

  7. s21day15 python笔记

    s21day15 python笔记 一.内容回顾及补充 回顾 补充 range / xrange(python2与python3的区别六) python2: xrange:不会在内存中立即创建,而是在 ...

  8. centos 7 中安装 mysql 5.7

    centos 7 中安装 mysql 5.7 环境说明: 查看centos的版本:cat /etc/redhat-release 安装和配置步骤: 下载 mysql 源安装包: sudo curl - ...

  9. 让Entity Framework不再私闯sys.databases

    这里的“私闯sys.databases”是指Entity Framework默认发起的查询:SELECT Count(*) FROM sys.databases WHERE [name]=N'数据库名 ...

  10. AGC002 F - Leftmost Ball

    貌似哪里讲过这题..总之当时掉线了(理解能力又差水平又低选手的日常).. 看看题目,应该是DP. 尝试了几次换状态,毫无思路.那我们就来继续挖掘性质吧...为了更直观,我们令第i个出现的球颜色就是i( ...