Centos7源码部署apache/httpd服务
httpd:是一个提供网站服务的程序
监听端口:80
环境准备:
Linux CentOS7.3系统
使用一台服务端,一台客户端即可;
一、安装httpd
1:安装
[root@localhost ~]# systemctl stop firewalld
[root@localhost ~]# setensorce 0
[root@localhost ~]# rpm -e httpd –nodeps #卸载系统自带的httpd
[root@localhost ~]# mkdir /media/cdrom #创建挂载点文件夹
[root@localhost ~]# mount /dev/cdrom /media/cdrom #挂载光盘
[root@localhost ~]# yum -y install gcc* apr-devel apr-util-devel pcre-devel #安装开发包
[root@localhost ~]# tar zxvf httpd-2.4.25.tar.gz #解压缩包
[root@localhost ~]# cd httpd-2.4.25
[root@localhost httpd-2.4.25]# ./configure --prefix=/usr/local/httpd --enable-so --enable-rewrite --enable-charset-lite --enable-cgi
注释:
--prefix:制定程序的安装目录
--enable-so:启用动态加载模块DSO的支持,使httpd具备进一步扩展功能的能力
--enable-rewrite:启用网页地址重写功能,用于网站优化
--enable-charset-lite:启动字符集支持,以便支持使用各种字符集编码的网页
--enable-cgi:启用cgi脚本程序支持,扩展网站的应用访问能力
[root@localhost httpd-2.4.25]# make && make install
[root@localhost httpd-2.4.25]# ls /usr/local/httpd
[root@localhost httpd-2.4.25]# /usr/local/httpd/bin/apachectl start
[root@localhost httpd-2.4.25]# netstat -anpt |grep httpd
[root@localhost httpd-2.4.25]# /usr/local/httpd/bin/apachectl stop
[root@localhost httpd-2.4.25]# netstat -anpt |grep httpd
2:优化执行路径
[root@localhost httpd-2.4.25]# ln -s /usr/local/httpd/bin/* /usr/local/bin/
[root@localhost httpd-2.4.25]# ls -l /usr/local/bin/httpd /usr/local/bin/apachectl
#查看软连接
[root@localhost httpd-2.4.25]# httpd -v
[root@localhost httpd-2.4.25]# apachectl start
[root@localhost httpd-2.4.25]# netstat -anpt |grep httpd
[root@localhost httpd-2.4.25]# apachectl stop
[root@localhost httpd-2.4.25]# netstat -anpt |grep httpd
3:添加httpd系统服务
使用chkconfig添加为系统服务
[root@localhost httpd-2.4.25]# cp /usr/local/httpd/bin/apachectl /etc/init.d/httpd #复制配置文件
[root@localhost httpd-2.4.25]# vi /etc/init.d/httpd //编辑配置文件
添加:
#!/bin/sh
#chkconfig:35 85 21
#description:httpd server
[root@localhost httpd-2.4.25]# chkconfig --add httpd #加入系统服务,开机启动
[root@localhost httpd-2.4.25]# chkconfig --list httpd
[root@localhost httpd-2.4.25]# service httpd start #启动httpd
二、httpd服务器的基本配置
1:确定网站的名称、ip地址和域名
2:配置并启动httpd
[root@localhost ~]# vim /usr/local/httpd/conf/httpd.conf
修改(前面的数字是行号):
ServerName www.bdqn.com ##200行
[root@localhost ~]# apachectl -t #检测配置文件语法
2:启动httpd服务
[root@localhost ~]# systemctl start httpd #启动httpd
[root@localhost ~]# netstat -anpt | grep httpd
3:部署网页
[root@localhost ~]# vim /usr/local/httpd/htdocs/index.html #编辑主页
<html><body><h1>It works!</h1></body></html>
[root@localhost ~]# service httpd restart #重启httpd服务
4:测试
打开网站
http://192.168.10.101
5:查看站点访问情况
[root@localhost ~]# tail /usr/local/httpd/logs/access_log
[root@localhost ~]# tail /usr/local/httpd/logs/error_log
三、httpd.conf配置文件解释
1:全局配置项
|
[root@localhost ~]# vim /usr/local/httpd/conf/httpd.conf ServerRoot "/usr/local/httpd" Listen 80 #监听端口(默认80) User daemon #用户 (默认daemon) Group daemon #用户组(默认daemon) ServerAdmin you@example.com #邮箱地址 ServerName www.bdqn.com #网站域名 DocumentRoot "/usr/local/httpd/htdocs" #网页存储位置 DirectoryIndex index.html #默认主页 ErrorLog "logs/error_log" #错误日志文件存储位置 LogLevel warn #日志级别 CustomLog "logs/access_log" common #正常访问日志
Include conf/extra/proxy-html.conf #虚拟主机路径
|
2:区域配置项
|
[root@localhost ~]# vim /usr/local/httpd/conf/httpd.conf <Directory /> #根目录 AllowOverride none Require all denied </Directory>
<Directory "/usr/local/httpd/htdocs"> #限制路径 Options Indexes FollowSymLinks AllowOverride None Require all granted #允许所有主机访问还可以拒绝所有人访问 </Directory>
|
Centos7源码部署apache/httpd服务的更多相关文章
- InfluxDB源码阅读之httpd服务
操作系统 : CentOS7.3.1611_x64 go语言版本:1.8.3 linux/amd64 InfluxDB版本:1.1.0 服务模块介绍 源码路径: github.com/influxda ...
- Centos7源码安装Apache和PHP
源码安装Apache 安装需要的依赖 yum -y install gcc autoconf automake make pcre pcre-devel openssl openssl-devel# ...
- centos7源码安装Apache及Tomcat
源码安装Apache (1) 一.通过 https://apr.apache.org/ 下载 APR 和 APR-util 通过 http://httpd.apache.org/download.c ...
- CentOS7 实战源码部署apache网站服务器
简介:实战演练apache网站服务器的搭建 Apache简介: Apache软件基金会的一个开源免费的网页服务器,也是目前世界上使用最广泛的一种web server , apache最出名的是它跨平台 ...
- centos7 源码部署LNMP
一.环境 系统环境:centos 7.4 64位 Nginx:1.7.9 MySQL: 5.7.20 (二进制包) PHP:5.6.37 二.Ngin 安装 Nginx部署 yum install ...
- Centos7源码部署Redis3.2.9
目录 一.环境准备 二.安装 三.测试 四.编写启动脚本 一.环境准备 [Redis-Server] 主机名 = host-1 系统 = centos-7.3 地址 = 1.1.1.1 软件 = re ...
- linux下源码安装apache服务
1.搭建静态网站是,我们只需要搭建apache服务即可满足要求. 例如:如果我再客户端游览器输入地址,他会找到192.168.1.100这个服务器,然后根据端口会找到apache服务器.apache他 ...
- Linux学习日记——源码编译Apache
[本文为笔者在学习Linux 下的软件安装时,尝试使用源码安装Apache 的过程,事后进行一个小小的总结,发现错误望指正.] 一.典型的源码编译安装软件的过程包括以下3步: 1) 运行 config ...
- 烂泥:源码安装apache
本文由秀依林枫提供友情赞助,首发于烂泥行天下. 最近要开始学习nagios监控方面的知识了,但是nagios与apache结合的比较紧密,所以本篇文章就先把apache的源码安装学习下. 我们现在分以 ...
随机推荐
- 解决 android push framework.jar 不生效的问题
. . . . . 在 Android 采用 ART 虚拟机后,为了提高运行时效率,在编译期间会将 jar 包中的 dex 文件编译为 odex.vdex 等文件.而这些文件并不存放在 framewo ...
- PAT-2019年冬季考试-甲级 7-3 Summit (25分) (邻接矩阵存储,直接暴力)
7-3 Summit (25分) A summit (峰会) is a meeting of heads of state or government. Arranging the rest ar ...
- PHP防止sql语句注入终极解决方案(包含pdo各种操作使用实例)
PHP防止sql语句注入终极解决方案完美解决方案就是使用拥有Prepared Statement机制(预处理sql)的PDO //先做个实验 先不用预处理sql写法<pre><?ph ...
- java AES-256加解密解决方法
看文件操作即可: 链接:https://pan.baidu.com/s/1dQ_-cZitxbG31JVmRi-trg 提取码:89p4 复制这段内容后打开百度网盘手机App,操作更方便哦
- 洛谷P5022 旅行 题解
前面几个代码都是部分分代码,最后一个才是AC了的,所以最后一个有详细注释 安利一发自己的Blog 这是提高组真题,233有点欧拉回路的感觉. 题目大意: 一个 连通 图,双向边 ,无重边 , 访问图中 ...
- 一个基于tcp的socket简单对话小例子
首先我们需要写连个py文件,一个server,一个client. import socket sk = socket.socket() # sk.bind(('ip',port)) sk.bind(( ...
- C++ Primer中文第四版
C++ Primer中文第四版 在简书上发现有挂羊头卖狗肉的,发的plus,而且压缩包还得付钱获取密码,我直接去github搜到了第四版,在此分享一下. 格式:pdf 书签目录:有 下载地址: ...
- Android apk逆向:反编译,回编译,签名,打包。
Android apk逆向:反编译,回编译,签名,打包流程. 第一步: apk 反编译. 1) 打开命令行窗口,输入java -version, 检测当前java版本,若版本较低, 则下载JAVA S ...
- Latex中如何设置字体颜色(三种方式)
1.直接使用定义好的颜色 \usepackage{color} \textcolor{red/blue/green/black/white/cyan/magenta/yellow}{text} 其中t ...
- CentOS7安装Grafana(Yum)
一.概述 Grafana是一个跨平台的开源的分析和可视化工具,可以通过将采集的数据查询然后可视化的展示,并及时通知. 其特点: 丰富的可视化显示插件,包括热图.折线图.饼图,表格等等. 多数据源,支持 ...