ORA-00265: instance recovery required, cannot set ARCHIVELOG mode
症状:
我打开后归档命令报告运行错误ORA-00265
SQL> alter database archivelog;
alter database archivelog
*
ERROR at line 1:
ORA-00265: instance recovery required, cannot set ARCHIVELOG mode
问题分析:
从如上错误我们能够看到是由于datafile,controlfile,redolog中的SCN号不一致导致无法开启归档,那么导致该问题的解决办法是由于我重新启动数据库到mount的时候採用的是startup force mount;由于这个命令实际上是做了两步操作。分别例如以下:
1、shutdown abort ---强制关闭数据库
2、startup mount
既然我们隐含的做了shutdown abort操作之后。也就意味着datafile。controlfile。redolog这里面的SCN号肯定不一致,须要在open数据库的过程中做recover,因为他们的SCN号不一致,所以会导致无法在mount状态下开启archivelog,例如以下:
SQL> startup mount force;
ORACLE instance started.
Total System Global Area 2505338880 bytes
Fixed Size 2255832 bytes
Variable Size 620758056 bytes
Database Buffers 1862270976 bytes
Redo Buffers 20054016 bytes
Database mounted.
SQL> alter database archivelog;
alter database archivelog
*
ERROR at line 1:
ORA-00265: instance recovery required, cannot set ARCHIVELOG mode
问题解决的方法:
针对该问题。最简单的解决的方法是,将数据库open,这个时候会进行recover操作。完毕之后再进行shutdown immediate后启动到statup mount就能够开启归档了。具体见例如以下:
SQL> alter database open;
Database altered.
####recover日志信息例如以下
alter database open
Beginning crash recovery of 1 threads
parallel recovery started with 3 processes
Started redo scan
Completed redo scan
read 1522 KB redo, 175 data blocks need recovery
Started redo application at
Thread 1: logseq 7, block 10941
Recovery of Online Redo Log: Thread 1 Group 1 Seq 7 Reading mem 0
Mem# 0: /DBData/woo2/redo01.log
Completed redo application of 0.44MB
Completed crash recovery at
Thread 1: logseq 7, block 13985, scn 991198
175 data blocks read, 175 data blocks written, 1522 redo k-bytes read
Wed Sep 03 22:39:35 2014
Thread 1 advanced to log sequence 8 (thread open)
Thread 1 opened at log sequence 8
Current log# 2 seq# 8 mem# 0: /DBData/woo2/redo02.log
Successful open of redo thread 1
MTTR advisory is disabled because FAST_START_MTTR_TARGET is not set
Wed Sep 03 22:39:35 2014
SMON: enabling cache recovery
[13499] Successfully onlined Undo Tablespace 2.
Undo initialization finished serial:0 start:3565124 end:3565194 diff:70 (0 seconds)
Verifying file header compatibility for 11g tablespace encryption..
Verifying 11g file header compatibility for tablespace encryption completed
SMON: enabling tx recovery
Database Characterset is AL32UTF8
No Resource Manager plan active
replication_dependency_tracking turned off (no async multimaster replication found)
Starting background process QMNC
Wed Sep 03 22:39:36 2014
QMNC started with pid=23, OS id=16119
Completed: alter database open
Wed Sep 03 22:39:37 2014
db_recovery_file_dest_size of 4182 MB is 0.00% used. This is a
user-specified limit on the amount of space that will be used by this
database for recovery-related files, and does not reflect the amount of
space available in the underlying filesystem or ASM diskgroup.
Wed Sep 03 22:39:37 2014
Starting background process CJQ0
Wed Sep 03 22:39:37 2014
CJQ0 started with pid=24, OS id=16134
Starting background process SMCO
Wed Sep 03 22:39:43 2014
SMCO started with pid=30, OS id=16149
#####immediate关闭数据库,又一次开启归档,就可以。
SQL> shutdown immediate
Database closed.
Database dismounted.
ORACLE instance shut down.
SQL> startup mount;
ORACLE instance started.
Total System Global Area 2505338880 bytes
Fixed Size 2255832 bytes
Variable Size 620758056 bytes
Database Buffers 1862270976 bytes
Redo Buffers 20054016 bytes
Database mounted.
SQL> alter database archivelog;
Database altered.
SQL> alter database open;
Database altered.
SQL>
###打开归档alert日志信息例如以下
ALTER DATABASE MOUNT
Successful mount of redo thread 1, with mount id 3606990310
Database mounted in Exclusive Mode
Lost write protection disabled
Completed: ALTER DATABASE MOUNT
Wed Sep 03 22:45:06 2014
alter database archivelog
Completed: alter database archivelog
alter database open
Wed Sep 03 22:45:12 2014
LGWR: STARTING ARCH PROCESSES
Wed Sep 03 22:45:12 2014
ARC0 started with pid=20, OS id=16867
ARC0: Archival started
LGWR: STARTING ARCH PROCESSES COMPLETE
ARC0: STARTING ARCH PROCESSES
Wed Sep 03 22:45:13 2014
ARC1 started with pid=21, OS id=16871
Wed Sep 03 22:45:13 2014
ARC2 started with pid=22, OS id=16873
Wed Sep 03 22:45:13 2014
ARC3 started with pid=23, OS id=16875
ARC1: Archival started
ARC2: Archival started
ARC1: Becoming the \
版权声明:本文博客原创文章。博客,未经同意,不得转载。
ORA-00265: instance recovery required, cannot set ARCHIVELOG mode的更多相关文章
- 【小错误】ORA-00265: instance recovery required, cannot set ARCHIVELOG mode
1.错误描述:今天在起归档的时候报一下错误: SQL> alter database archivelog; alter database archivelog * ERROR at line ...
- 【小错误】起归档是遇到ORA-00265: instance recovery required, cannot set ARCHIVELOG mode
今天在起归档时遇到ORA-00265: instance recovery required, cannot set ARCHIVELOG mode的错误 从错误我们能够看到是由于datafile,c ...
- ORA-00265: instance recovery required, cannot set ARCHIVELOG
OS: Oracle Linux Server release 5.7 DB: Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - ...
- An AnnotationConfiguration instance is required to use
An AnnotationConfiguration instance is required to use <mapping class="jebe7282/study/hibern ...
- 物理DG主备库切换时遇到ORA-16139: media recovery required错误
在物理DG主备库切换时遇到ORA-16139: media recovery required错误 SQL> ALTER DATABASE COMMIT TO SWITCHOVER TO PRI ...
- 整合SSH三大框架用注解时报An AnnotationConfiguration instance is required to use
Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 's ...
- org.hibernate.MappingException: An AnnotationConfiguration instance is required to use <mapping clas
在Hibernate中使用annotation出现错误.如题目所示. HibernateSessionFactory类中: // private static Configuration co ...
- SMON进程、PMON进程、LGWR/ARCH
SMON 进程:system monitor instance monitor 系统监控.实例监控进程 说明及作用:在实例关闭时,会清理临时段,整理空闲空间free space; 实例非正常关闭后,启 ...
- Oracle corrupt block(坏块) 详解
转自:http://blog.csdn.net/tianlesoftware/article/details/5024966 一. 坏块说明 1.1 相关链接 在看坏块之前,先看几个相关的链接,在后面 ...
随机推荐
- 正确lua简单的扩展,可以加速相关C++数据。
很早的时候,我有一件事纠结.如果,我在这里C++打开界面脚本.使用C++其中一个目标,和.我的程序有很多不同的lua虚拟机.每个虚拟机与一个关联C++对象,它是多线程,那么如何快速应利用这个好时机lu ...
- android代码签名和混乱的包装
研究了一下android的apk困惑签名和代码包装,假设没有混乱包.然后apk人们可以直接查看源代码反编译出来,尽管混乱包或能看懂.但不是那么容易理解,要求在至少一些时间 假设不混淆,反编译后的代码例 ...
- hdu4758 Walk Through Squares (AC自己主动机+DP)
Walk Through Squares Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others ...
- ubuntu12.04 残疾人游客
为了防止陌生人登录你的ubuntu系统.例如,下面的方法,可以采用禁用 游客登录. sudo vi /etc/lightdm/lightdm.conf 在 lightdm.conf 文件末尾加入上 a ...
- 如何使用Maven创建web工程(详细步骤)
使用eclipse插件创建一个web project 首先创建一个Maven的Project例如以下图 我们勾选上Create a simple project (不使用骨架) 这里的Packing ...
- HDU 4901 The Romantic Hero(二维dp)
题目大意:给你n个数字,然后分成两份,前边的一份里面的元素进行异或,后面的一份里面的元素进行与.分的时候依照给的先后数序取数,后面的里面的全部的元素的下标一定比前面的大.问你有多上种放元素的方法能够使 ...
- LeetCodeOJ. Maximum Depth of Binary Tree
见问题: https://oj.leetcode.com/problems/maximum-depth-of-binary-tree/ 主题概述 Given a binary tree, find i ...
- freemarker定义自己的标记(三)-nested说明
freemarker定义自己的标记 1.nested指令 是可选的,能够在<#macro>和</#macro>之间使用在不论什么位置和随意次数 2.演示样例说明 <#ma ...
- 零基Github Page个人博客建立教程无限的自由流动
本文介绍了什么是Github Page.以及如何使用Github Page搭建一个免费的.无限流量的个人博客并绑定独立域名. 一.前言 1.1 为什么要用Github Page搭建博客 借用阮一峰老大 ...
- ScrollView 嵌套ListView 幻灯冲突,和显示不全
import android.content.Context; import android.util.AttributeSet; import android.widget.ListView; /* ...