一、Linux防火墙基础

1.1 ptables的表、链结构

1.1.1 Linux包过滤防火墙概述

netfilter

位于Linux内核中的包过滤功能体系

称为Linux防火墙的"内核态"

iptables

位于/sbiniptables,用来管理防火墙规则的工具

称为Linux防火墙的"用户态"

上述2种称呼都可以表示Linux防火墙

1.2 数据包控制的匹配流程



数据包到达防火墙时,规则表之间的优先顺序:

raw > mangle > nat > filter

1.2.1 四表

raw表∶ 确定是否对该数据包进行状态跟踪。包含两个规则链, OUTPUT、PREROUTING。

mangle表∶修改数据包内容,用来做流量整形的,给数据包设置标记。包含五个规则链,INPUT、oUTPUT、FORWARD、PRERoUTTNG、PosTRou TING。

nat表∶ 负责网络地址转换,用来修改数据包中的源、目标IP地址或端口。包含三个规则链, oUTPUT、PRERoUTING、PoSTRoUTING。

filter表;负责过滤数据包, 确定是否放行该数据包(过滤)。 包含三个规则锌链,INPUT、FORWARD、OUTPUT。

1.2.2 五链

INPUT∶ 处理入站数据包,匹配目标IP为本机的数据包。

OUTPUT∶处理出站数据包,一般不在此锌上,做配置。

FORWARD∶ 处理转发数据包,匹配流经本机的数据包。

PREROUTING链∶ 在进行路由选择前处理数据包,用来修改目的地址,用来做DNAT。相当于把内网服务器的工P和端口映射到路由器的外网IP和端口上。

POSTROUTING链∶ 在进行路由选择后处理数据包,用来修改源地址,用来做SNAT。相当于内网通过路由器NAT转换功能实现内网主机通过一个公网工iP地址上网。

1.2.3 四表五链总结

规则表的作用∶容纳各种规则链

规则链的作用∶容纳各种防火墙规则

总结∶表里有链,链里有规则

1.2.4 规则链之间的匹配顺序

1)主机型防火墙∶

入站数据(来自外界的数据包,且目标地址是防火墙本机)∶ PREROUTING --> INPUT --> 本机的应用程序

出站数据(从防火墙本机向外部地址发送的数据包)∶ 本机的应用程序 --> OUTPUT --> POSTROUTING网络型防火墙∶

转发数据(需要经过防火墙转发的数据包)∶ PREROUTING --> FORWARD --> POSTROUTING

1.2.5 规则链内的匹配顺序∶

自上向下按顺序依次进行检查,找到相匹配的规则即停 止 (LoG策略例外, 表示记录相关日志)

若在该链内找不到相匹配的规则,则按该链的默认策略处理(未修改的状况下,默认策略为允许)

二、编写防火墙规则

准备工作:

1.iptables的安装

CentOS 7默认使用firewalld防火墙,没有安装 iptables,若想使用iptables防火墙。必须先关闭firewalld防火墙,再安装 iptables

systemctl stop firewalld.service #关闭防火墙

systemctl disable firewalld.service #设为开机不自启

yum -y install iptables iptables-services #安装iptables

systemctl start iptables. Service #开启服务

2.1 基本语法、控制类型

2.1.1 iptables防火墙的配置方法∶

使用iptables 命令行。

使用system-config-firewall

2.1.2 iptables 命令行配置方法∶

命令格式

iptables [-t 表名 ] 管理选项 [ 链名 ] [ 匹配条件 ] [-j 控制类型 ]



注意事项:

不指定表名时,默认指filter表

不指定链名时,默认指表内的所有链

除非设置链的默认策略,否则必须指定匹配条件

控制类型使用大写字母,其余均为小写

2.1.3 常用的控制类型∶

ACCEPT∶允许数据包通过。

DROP∶直接丢弃数据包,不给出任何回应信息。

REJECT∶ 拒绝数据包通过,会给数据发送端一个响应信息。 SNAT∶修改数据包的源地址。 DNAT∶修改数据包的目的地址。

MASQUERADE∶伪装成一个非固定公网IP地址。

LOG∶ 在/var/log/messages文件中记录日志信息,然后将数据包传递给下一条规则。LOG只是一种辅助动作,并没有真正处理数据包。

2.1.4 常用的管理选项∶

-A ∶ 在指定链的末尾追加 (–append)一条新的规则

-I ∶ 在指定链的开头插入(–insert)一条新的规则, 未指定序号时默认作为第一条规则

-R ∶ 修改、替换(–replace)指定链中的某一条规则,可指定规则序号或具体内容

-P ∶设置指定链的默认策略(–policy)

-D ∶ 删除 (–delete)指定链中的某一条规则, 可指定规则序号或具体内容

-F ∶ 清空(–flush)指定链中的所有规则,若未指定链名,则清空表中的所有链

-L∶列出 (–list)指定链中所有的规则,若未指定链名,则列出表中的所有链

-n ∶ 使用数字形式(–numeric)显示输出结果,如显示 IP 地址而不是主机名

-v ∶ 显示详细信息,包括每条规则的匹配包数量和匹配字节数

–line-numbers∶ 查看规则时,显示规则的序号

2.2 添加、查看、删除规则

2.2.1 添加新的规则∶

iptables -t filter -A INPUT -p icmp -j REJECT 禁止ping通本主机(有响应)

iptables -t filter -A INPUT -p icmp -j DROP 禁止ping通本主机(无响应)

iptables -I INPUT 2 -p tcp--dport 22 -jACCEPT

2.2.2 查看规则列表∶

iptables [-t 表名 ]-n -L[ 链名][--line-numbers]

或

iptables -[vn]L #注意∶不可以合写为 -Ln

iptables -n -L --line-numbers

2.2.3 设置默认策略∶

iptlables [-t 表名 ] -P <链名><控制类型>

iptables -P INPUT DROp iptables -P FORWARD DROp

2.2.4 删除规则∶

iptables -D INPUT 2

iptables -t filter -D INPUT -p icmp -jREJECT

一般在生产环境中设置网络型防火墙、主机型防火墙时都要设置默认规则为DROP,并设置白名单

注意∶

若规则列表中有多条相同的规则时, 按内容匹配只删除的序号最小的一条

按号码匹配删除时, 确保规则号码小于等于已有规则数,否则报错

按内容匹配删数时, 确保规则存在, 否则报错

2.2.5 清空规则∶

iptables 【-t 表名】 -F 【链名】

iptables -F INPUT

iptables -F

注意:

-F 仅仅是清空链中的规则,并不影响 -P 设置的默认规则,默认规则需要手动进行修改

-P 设置了DROP后,使用-F 一定要小心

防止把允许远程连接的相关规则清除后导致无法远程连接主机,此情况如果没有保存规则可重启主机解决

如果不写表名和链名,默认清空filter表中所有链里的所有规则

2.3 规则的匹配条件

2.3.1 通用匹配

可直接使用,不依赖于其他条件或扩展,包括网络协议、IP地址、网络接口等条件。

协议匹配∶ -p 协议名

地址匹配∶ -s 源地址、-d 目的地址 #可以是IP、网段、域名、空(任何地址)

接口匹配∶ -i 入站网卡、-o 出站网卡

iptables -A FORWARD !-p icmp -j ACCEPT

iptables -A INPUT -s 192.168.80.11 -j DROP

iptables -I INPUT -i ens33 -s 192.168.80.0/24 -j DROP

2.3.2 隐含匹配

要求以特定的协议匹配作为前提,包括端口、TCP标记、ICMP类型等条件。

端口匹配∶ --sport 源端口、--dport 目的端口

可以是个别端口、端口范围

–sport 1000 匹配源端 口是1000的数据包

–sport 1000:3000 匹配源端 口是1000-3000的数据包

–sport : 3000 匹配源端 口是3000及以下的数据包

–sport 1000: 匹配源端 口是1000及以上的数据包

注意∶ --sport 和 --dport 必须配合 -p <协议类型> 使用

iptables -A INPUT -p tcp --dport 20:21 -j ACCEPT

iptables-I FORWARD -d 192.168.80.0/24 -p tcp --dport 24500:24600 -j DROP

2.3.4 TCP标记匹配∶ --tcp-flags TCP标记

iptables -I INPUT -i ens33 -p tcp --tcp-flags SYN,RST,ACK SYN -jACCEPT

丢弃SYN请求包,放行其他包

2.3.5 ICMP类型匹配∶–icmp-type ICMP类型

可以是字符串、数字代码

"Echo-Request"(代码为 8)表示 请求

"Echo-Reply"(代码为 0)表示 回显

"Destination-Unreachable"(代码为 3)表示 目标不可达

关于其它可用的 ICMP 协议类型,可以执行"iptables -p icmp -h"命令,查看帮助信息

iptables -A INPUT -p icmp --icmp-type 8 -j DROP #禁止其它主机ping 本机

iptables -A INPUT -p icmp --icmp-type 0 -j ACCEPT #允许本机ping 其它主机

iptables -A INPUT -p icmp --icmp-type 3 -j ACCEPT #当本机ping 不通其它主机时提示目标不可达

此时其它主机需要配置关于icmp协议的控制类型为 REJECT

iptables -A INPUT-p icmp -j REJECT

2.3.6 显式匹配

要求以"-m 扩展模块"的形式明确指出类型,包括多端口、MAC地址、IP范围、数据包状态等条件。

多端口匹配∶

-m multiport --sport 源端口列表

-m multiport --dport 目的端口列表

iptables -A INPUT -p tcp -m multiport --dport 80,22,21,20,53 -i ACCEPT

iptables -A INPUT -p udp -m multiport --dport 53 -j ACCEPT

2.3.7 IP范围匹配∶ -m iprange --src-range IP范围

iptables -A FORWARD -p udp -m iprange--src-range 192.168.80.100-192.168.80.200-j DROP

禁止转发源地址位于192.168.80.100-192.168.80.200的udp数据包

2.3.6=8 MAC地址匹配∶-m mac --mac-source MAC地址

iptables -A FORWARD -m mac --mac-source xx:xx:xx:xx:xX:xx-j DROP

禁止来自某MAC 地址的数据包通过本机转发

2.3.8 状态匹配∶-m state_–state 连接状态

常见的连接状态∶

NEW ∶与任何连接无关的,还没开始连接

ESTABLISHED ∶响应请求或者已建立连接的,连接态

RELATED ∶ 与已有连接有相关性的(如FTP 主被动模式的数据连接),衍生态,一般与ESTABLISHED 配合使用

INVALID ∶ 不能被识别属于哪个连接或没有任何状态

iptables -A FORWARD -m state --state NEW -p tcp !--syn -j DROP

禁止转发与正常 TCP 连接无关的非–syn 请求数据包(如伪造的网络攻击数据包)

iptables -I INPUT -p tcp -m multiport --dport 80, 22,21,20,53 -j ACCEPT

iptables -A INPUT -p udp -m multiport --dport 53 -j ACCEPT

iptables -A INPUT -p tcp -m state --state ESTABLISHED, RELATED -j ACCEPT

linux中的防火墙netfilter iptables的更多相关文章

  1. Linux中的防火墙(Netfilter、Iptables、Firewalld)

    目录 Netfilter Iptables iptables做本地端口转发 Firewalld Netfilter Netfilter是Linux 2.4内核引入的全新的包过滤引擎,位于Linux内核 ...

  2. Linux中的防火墙

    firewalld 一.防火墙安全概述 firewalld支持命令行也支持GUI设置,相对于iptables,firewalld配置更加的方便.在底层的命令都是iptables, firewalld ...

  3. Linux中的防火墙----iptables

    防火墙,它是一种位于内部网络与外部网络之间的网络安全系统.一项信息安全的防护系统,依照特定的规则,允许或是限制传输的数据通过. 防火墙根据主要的功能可分为网络层防火墙.应用层防火墙.数据库防火墙. 网 ...

  4. Linux中在防火墙中开启80端口的例子

    最近自己在学习Linux.搭建一个LNMP环境.在测试时一切都好.然后重启Linux后.再次访问网站无法打开.最终原因是在防火墙中没有加入 80 端口的规则.具体方法如下: 在CentOS下配置ipt ...

  5. Linux centos修改防火墙为iptables

    防火墙配置 CentOS 7默认使用的是firewall作为防火墙,这里改为iptables防火墙.  firewall操作: # service firewalld status; #查看防火墙状态 ...

  6. linux日常管理-防火墙netfilter工具-iptables-1

    防火墙的名字叫 netfilter 工具/命令叫iptables 命令:iptables 选项: -t   指定表 -A 在最上面增加一条规则 -I 在最下面增加一条规则 -D 删除一条规则 -A-I ...

  7. 在linux中关闭防火墙

    1) 重启后生效 开启: chkconfig iptables on 关闭: chkconfig iptables off 2) 即时生效,重启后失效 开启: service iptables sta ...

  8. linux日常管理-防火墙netfilter工具-iptables-2

    分别是包的数量:26  包的字节:1320  处理方式 tcp协议  opt in out  源ip 目标ip 到80端口的行为. 处理行为处理有REJECT外 还有DROP ACCEPT.分别是看一 ...

  9. linux日常管理-防火墙netfilter工具-iptables-3

    可以指定chain链的总开关 把链的关掉,针对端口开放,更加安全,但是不建议这么做 实例:filter表INPUT链.INPUT策略改成DROP. 把192.168.0.0/24网段开通22端口.对所 ...

随机推荐

  1. vscode 配置 Pug Compile Hero Pro 插件步骤

    这个随笔主要介绍 vscode 配置 Pug Compile Hero Pro 插件的步骤,实现快速使用less 以及 scss 等的编程语言 第一步 当然是安装我们的插件啦! 在插件商店里 搜 Sa ...

  2. JVM到底是什么呢

    在我们运行和调试Java程序的时候,经常会提到一个JVM的概念.那JVM到底是什么呢? JVM是Java程序的运行环境,它同时也是一个操作系统的一个应用程序.一个进程,因此他也有他自己的运行生命周期, ...

  3. 配置tomcat虚拟主机

    实例说明 本实例介绍如何配置tomcat的虚拟主机. 关键技术 关于server.xml中host这个元素,只有在设置虚拟主机是才会修改.虚拟主机是一种在一个Web服务器上服务多个域名的机制,对这个域 ...

  4. python导入模块--案例

    1 导入模块 1.1 问题 本案例要求先编写一个star模块,主要要求如下: 建立工作目录 ~/bin/ 创建模块文件 ~/bin/star.py 模块中创建pstar函数,实现打印50个星号的功能 ...

  5. ExtJs4学习(五)最基本的Ext类

    Ext类是ExtJs中最常见.最基础的一个类,它是一个全局对象,封装了所有类.单例和 Sencha 库所提供的实用方法. 大多数用户界面组件在一个较低的层次嵌套在命名空间中, 但是提供的许多常见的实用 ...

  6. svn创建新分支报错:svn: E155015: Aborting commit: XXX remains in conflict

    用diea在对svn创建新分支的时候报错,错误为 svn: E155015: Aborting commit: XXX remains in conflict 百度和查阅资料后得知,此错误为分支被拉取 ...

  7. python 正则表达式 初级

    举例: 1.匹配hello world key = r"<h1>hello world<h1>" #源文本 p1 = r"<h1>.+ ...

  8. Spring常见异常说明

    文章要点 Spring bean 的声明方式 Spring bean 的注入规则 Spring bean 的依赖查找规则 Spring bean 的名称定义方式和默认名称规则 XXX required ...

  9. git常用命令自己梳理总结

    一.新建代码库 # git-init - 创建一个空的 Git 存储库或重新初始化一个现有的存储库 $ git init # 在本地新建一个repo,进入一个项目目录,执行git init,会初始化一 ...

  10. ESP32-http server笔记

    基于ESP-IDF4.1 #include <esp_wifi.h> #include <esp_event.h> #include <esp_log.h> #in ...