ORA-245: In RAC environment from 11.2 onwards Backup Or Snapshot controlfile needs to be in shared location (Doc ID 1472171.1)
巡检时遇到错误如下:
alert日志:
Wed Dec 19 01:00:29 2018
Errors in file /oracle/base/diag/rdbms/usap/usap1/trace/usap1_ora_7078838.trc:
ORA-00245: control file backup failed; target is likely on a local file system
Wed Dec 19 03:12:31 2018
ALTER SYSTEM ARCHIVE LOG
/oracle/base/diag/rdbms/usap/usap1/trace/usap1_ora_7078838.trc 的信息如下:
Trace file /oracle/base/diag/rdbms/usap/usap1/trace/usap1_ora_6357166.trc
Oracle Database 11g Enterprise Edition Release 11.2.0.4.0 - 64bit Production
With the Partitioning, Real Application Clusters, Automatic Storage Management, OLAP,
Data Mining and Real Application Testing options
ORACLE_HOME = /oracle/product/11.2.0.4
System name: AIX
Node name: jnpd-usap-dbrac-01
Release: 1
Version: 7
Machine: 00FB769F4C00
Instance name: usap1
Redo thread mounted by this instance: 1
Oracle process number: 92
Unix process pid: 6357166, image: oracle@jnpd-usap-dbrac-01 (TNS V1-V3)
*** 2019-01-18 03:13:18.387
*** SESSION ID:(7637.2713) 2019-01-18 03:13:18.387
*** CLIENT ID:() 2019-01-18 03:13:18.387
*** SERVICE NAME:(SYS$USERS) 2019-01-18 03:13:18.387
*** MODULE NAME:(rman@jnpd-usap-dbrac-01 (TNS V1-V3)) 2019-01-18 03:13:18.387
*** ACTION NAME:(0000012 STARTED114) 2019-01-18 03:13:18.387
ORA-00245: control file backup failed; target is likely on a local file system
===================================================================================================================
下面为官方文档:
ORA-245: In RAC environment from 11.2 onwards Backup Or Snapshot controlfile needs to be in shared location (Doc ID 1472171.1)

APPLIES TO:Oracle Database - Enterprise Edition - Version 11.2.0.1.0 and later From 11gR2 onwards, the controlfile backup happens without holding the controlfile enqueue. For non-RAC database, this doesn't change anything. But for RAC database, due to the changes made to the controlfile backup mechanism in 11gR2, any instance in the cluster may write to the snapshot controlfile. Due to this snapshot controlfile need to be visible to all instances. 从11 gR2开始,控制文件备份将在不持有控制文件队列的情况下进行。对于非RAC数据库,这不会改变任何事情。但是对于RAC数据库,由于对11 gR2中的控制文件备份机制所做的更改,集群中的任何实例都可以写入快照控制文件。因此,快照控制文件需要对所有实例都是可见的。
The snapshot controlfile MUST be accessible by all nodes of a RAC database, if the snapshot controlfile does not reside on a shared device error will be raised at the time of RMAN backup while taking snapshot of controlfile. This applies to backing up controlfile using sqlplus / having autobackup of controlfile configured on non
shared location. ORA-245 error message description DESCRIPTION1. In RAC environment controlfile autobackup fails with ora-0245 Autobackup of controlfile in RMAN is failing with error:
RMAN-571: =========================================================== RMAN-569: =============== ERROR MESSAGE STACK FOLLOWS =============== RMAN-571: =========================================================== RMAN-3009: failure of Control File and SPFILE Autobackup command on ORA_DISK_1 channel at 10/27/2010 12:13:31 ORA-245: control file backup operation failed 2. In RAC environment, backup controlfile to non shared location fails SQL> ALTER DATABASE BACKUP CONTROLFILE TO '/home/rac1122/test/control.bk' REUSE
* ERROR at line 1: ORA-245: control file backup operation failed 3. In RAC environment backing up standby controlfile to non shared location fails SQL> alter database create standby controlfile as '/home/oracle/renostdbycntrl.ctl'; alter database create standby controlfile as 4. In RAC environment copy current controlfile to '${DB_BACKUP_DIR}/rac_tnctv_control.bak'; channel ch1: starting datafile copy
copying current control file RMAN-571: =========================================================== RMAN-569: =============== ERROR MESSAGE STACK FOLLOWS =============== RMAN-571: =========================================================== RMAN-3009: failure of backup command on 10/07/2011 11:36:42 channel at ch1 ORA-245: control file backup operation failed 5. In RAC environment, Rman backup fails if snapshot controlfile is not in shared location. RMAN-00571: ========================================================
RMAN-00569: ============ ERROR MESSAGE STACK FOLLOWS ============= RMAN-00571: ========================================================= RMAN-03009: failure of resync command on default channel at 03/13/2012 10:19:41 ORA-00245: control file backup operation failed 6. In RAC environment, with NO RMAN activity, but controlfile autobackup is being created by database structure change. I.e., adding datafiles or a resize of datafiles with autoextend. Alert.log shows: 2016-12-30 23:46:10.244000 +00:00
Errors in file /ora01/app/oracle/diag/rdbms/persprop/persprop5/trace/persprop5_m000_24118.trc: ORA-19624: operation failed, retry possible ORA-19504: failed to create file "/orabck/uhilsfmt/persprop1/rman/c-3364950485-20161230-00.cf" ORA-27040: file create error, unable to create file SVR4 Error: 2: No such file or directory Additional information: 1 OCCURRENCEOnly affect Real application Cluster (RAC), 11.2 onward. SYMPTOMSIn RAC environment any form of controlfile backup may fail with ORA-0245 if the location of the Snapshot Controlfile is not a shared location. The backup of the controlfile actualy makes a backup of the SNAPSHOT controlfile. The Snapshot controlfile is created when the controlfile is about to be backed up. The Snapshot controlfile is a read-consistent copy of the controlfile. NOTE: There is another issue in which this error occurs when the backup location is not shared, see RMAN BACKUP TO LOCAL DEVICE WITH SNAPSHOT ON SHARED FAILS ORA-00245 (Doc ID 1516654.1)
According to bug 18073805 (closed as not a bug), ORA-00227 can also be raised from "alter database backup controlfile to <file>" when the location of the file is not shared. WORKAROUNDSOLUTION: This is a RAC specific 'configuration' issue and the correct configuration is as described below It is changed behaviour which requires that the snapshot controlfile in a RAC environment, is on a shared location. 1. Check the snapshot controlfile location: RMAN> show snapshot controlfile name; 2. Configure the snapshot controlfile to a shared disk: RMAN> CONFIGURE SNAPSHOT CONTROLFILE NAME TO '<shared_disk>/snapcf_<DBNAME>.f';
Or in case of ASM use RMAN> CONFIGURE SNAPSHOT CONTROLFILE NAME TO '+<DiskGroup>/snapcf_<DBNAME>.f';
PATCHESNA HISTORY02-07-2012 created and Published alert 07-12-2015 updated REFERENCESBUG:12311429 - ALTER DATABASE BACKUP CONTROLFILE FAILS WITH ORA-245 BUG:17824928 - ORA-00245 ERROR RMAN BACKUP WITH SNAPSHOT ON SHARED FAILS BUG:10263733 - SNAPSHOT CONTROLFILE USED BY RMAN MUST RESIDE ON SHARED DEVICE FOR RAC DATABASE |
ORA-245: In RAC environment from 11.2 onwards Backup Or Snapshot controlfile needs to be in shared location (Doc ID 1472171.1)的更多相关文章
- 模拟生产搭建Standby RAC实验环境(11.2.0.4 DG)
模拟生产搭建Standby RAC实验环境(11.2.0.4 DG) 环境:RHEL 6.5 + Oracle 11.2.0.4 GI.DB 1.需求背景介绍 2.准备工作 3.主库配置 4.备库配置 ...
- Data Guard Physical Standby - RAC Primary to RAC Standby 使用第二个网络 (Doc ID 1349977.1)
Data Guard Physical Standby - RAC Primary to RAC Standby using a second network (Doc ID 1349977.1) A ...
- 使用Data Guard迁移到RAC (Doc ID 273015.1)
Migrating to RAC using Data Guard (Doc ID 273015.1) APPLIES TO: Oracle Database Cloud Exadata Servic ...
- 11.2 Data Guard Physical Standby Switchover Best Practices using SQL*Plus (Doc ID 1304939.1)
11.2 Data Guard Physical Standby Switchover Best Practices using SQL*Plus (Doc ID 1304939.1) APPLIES ...
- 如何将RAC数据库的 RMAN Disk 备份 Restore 到另一个节点上的单个实例 (Doc ID 415579.1)
HowTo Restore RMAN Disk backups of RAC Database to Single Instance On Another Node (Doc ID 415579.1) ...
- Differences Between Enterprise, Standard and Standard One Editions on Oracle 11.2 (Doc ID 1084132.1)
标准版不允许并行.分区.闪回.各种缓存等大数据量必须特性,如此限制,oracle摆明了只卖企业版,买标准版不如mysql(如果不熟悉postgresql的话). Oracle企业版1 CPU 20w起 ...
- Configuring Oracle E-Business Suite Integrated SOA Gateway Release 12.1.2 and Release 12.1.3 in a Multinode Environment (Doc ID 1081100.1)
Configuring Oracle E-Business Suite Integrated SOA Gateway Release 12.1.2 and Release 12.1.3 in a Mu ...
- ORA-0245
经常有客户报错ORA-0245 1.11.2 rac环境, rman存在snap控制文件路径,默认是文件系统[非共享,导致备份控制文件报错] 解决方法:将snap路径配置到ASM磁盘组共享路径[nfs ...
- centos部署oracle rac单实例11.2.0.3数据库(使用asm磁盘)
部署oracle rac单实例数据库,需要安装grid和datavase两部分,所以首先创建两个用户oracle和grid,因为不能使用root用户进行安装,在安装之前首先需要修改一些系统参数和安装一 ...
随机推荐
- Windows安装diango框架<一>
下一篇:使用Django创建网站项目<二> python工具安装 python下载:https://www.python.org/downloads/windows/(我的版本3.7.0) ...
- 【开发工具之Spring Tool Suite】6、用Spring Tool Suite简化你的开发
如果你是一个喜欢用spring的人,你可能会在欣赏spring的强大功能外,对其各样的配置比较郁闷,尤其是相差较大的版本在配置文件方面会存在差异,当然你可以去花不少的时间去网上查找相关的资料,当你准备 ...
- Why does the C# compiler translate this != comparison as if it were a > comparison?
Question: I have by pure chance discovered that the C# compiler turns this method: static bool IsNot ...
- MVC中的HtmlHelper详解
熟悉MVC开发的朋友都应该知道在MVC中,每一个Controller都对应一个View,并且CS文件和对应的ASPX文件也被分离了,更重要的是不再有服务器端控件在工具箱中,不再是代码后至了.MVC中的 ...
- PHP7.27: object
http://www.devshed.com/c/a/PHP/PHP-Services-Layers-Data-Mappers/ https://stackoverflow.com/questions ...
- php服务器代理解决浏览器跨越问题
详见代码 <?php $url = $_SERVER["QUERY_STRING"]; switch ($_SERVER['REQUEST_METHOD']) { case ...
- git 查看/修改用户名、密码
用户名和邮箱地址的作用 用户名和邮箱地址是本地git客户端的一个变量,不随git库而改变. 每次commit都会用用户名和邮箱纪录. github的contributions统计就是按邮箱来统计的. ...
- python练习:http协议介绍
一.HTTP协议 HTTP是Hyper Text Transfer Protocol(超文本传输协议)的缩写.它的发展是万维网协会(World Wide Web Consortium)和Interne ...
- 腾讯云部署golang flow流程,vue.js+nginx+mysql+node.js
这次总算把js-ojus/flow的ui部署到腾讯云上,比较吐槽的就是,为啥这么复杂,vue.js前后端分离,比golang编写的部署方面复杂几万倍.真是浪费人生啊. golang+sqlite写的东 ...
- 安装mysql(macos系统)
1.到官网下载,直接百度"mysql"即可找到 2.双击安装包,一路安装即可 3.然后进到系统设置 4.接下来 输入coho的用户密码 设置root用户的密码 切换root用户,v ...