Symptoms

If you experience an ungraceful shutdown of the database (for example, because of a power outage), you may experience these symptoms:

  • The VMware VirtualCenter Server service fails to start.
  • ODBC connection to the database tests successfully with the specified user.
  • The vpxd.log file (located at C:\Documents and Settings\All Users\Application Data\VMware\VirtualCenter\logs) contains entries similar to:

    [02896 error 'App'] ODBC error: (28000) - [Microsoft][SQL Native Client][SQL Server]Login failed for user 'vmware_user'.
    [02896 error 'App'] Error getting configuration info from the database
    [02896 error 'App'] [Vpxd::ServerApp::Init] Init failed: VpxdVdb::InitVdb::GetInstance(), false, false)
    [02896 error 'App'] Failed to intialize VMware VirtualCenter. Shutting down...
    [02896 info 'App'] Forcing shutdown of VMware VirtualCenter now

Cause

This is a rare issue that occurs if a password is corrupted by an ungraceful shutdown (for example, due to a power outage). With a graceful shutdown, Windows saves everything that was in cache to disk, but when an operating system shuts down unexpectedly, settings can be lost or corrupted. The password can get corrupted if the registry is being accessed at the time of the outage.

This issue occurs even if:

  • The integrity of the database has been verified.
  • The SQL permissions have been verified and set properly.
  • The connection information (including password) is present and correct in the registry key:
    • 32-bit operating systems: HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VirtualCenter\DB
    • 64-bit operating systems: HKEY_LOCAL_MACHINE\SOFTWARE\wow6432node\VMware, Inc.\VMware VirtualCenter\DB

Resolution

To resolve this issue, you must change the password.

To change the password:

  1. Open a command prompt. For more information, see Opening a command or shell prompt (1003892).
  2. Change to the directory containing the VMware VirtualCenter Server service executable vpxd.exe (typically located at C:\Program Files\VMware\Infrastructure\VirtualCenter Server). If vpxd.exe is not at that path:

    1. Click Start > Run, type services.msc, and click OK.
    2. Right-click the VMware VirtualCenter Server Service and click Properties. The path to vpxd.exe is on the General tab.
  3. When you have verified the location of vpxd.exe, run this command in the appropriate directory to change the password in the registry:

    vpxd -p

  4. To start the VMware VirtualCenter Server service, right-click VMware VirtualCenter Server service and click Start.

Additional Information

Note: With vCenter Server 4.1, the vCenter Server system must have a 64-bit DSN. Using a 32-bit DSN on vCenter Server 4.1 may result in a similar issue outlined in the above symptoms. For more information, see the ESX and vCenter Server Installation Guide for vCenter Server 4.1.

For related information, see Starting VMware VirtualCenter Server service when using SQL authentication fails with the error: Login Failure, Failed to connect to database (2015824).

See Also

Request a Product Feature

To request a new product feature or to provide feedback on a VMware product, please visit the Request a Product Feature page.

Feedback

 
source   http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1017688

VMware VirtualCenter Server service fails to start with the vpxd.log error: ODBC error: (28000) (1017688)的更多相关文章

  1. VMware vCenter Server安装图解教程

    安装说明: 1.安装VMware vCenter Server的主机操作系统为:Windows Server 2008 R2 2.在Windows Server 2008 R2中需要预先安装好SQL ...

  2. Microsoft SQL Server 2005 Service fails to start

    今天碰到一雷死人的事情,在Windows Server 2012 R2上安装SQL SERVER 2005标准版过程中一直遇到"The SQL Server service failed t ...

  3. VMWare ESX Server

    VMWare ESX Server 4.1 全套下载 [转自:http://www.awolf.net/content/hack/vmware-esx-server-4-1-all-download. ...

  4. VMware GSX Server 3.2.1 Build 19281免费下载

    VMware GSX Server 3.2.1 Build 19281免费下载 评论2   字号:大中小 订阅 VMware官方下载: For Windows 版系统:http://download3 ...

  5. VMware vCenter Server 6.5安装

    实验环境: 数据中心操作系统 :  Windows server 2008 R2(建议配置8G内存) 数据中心安装包版本: VMware vCenter Server 6.5 数据中心数据库:     ...

  6. 如何安全的将VMware vCenter Server使用的SQL Server Express数据库平滑升级到完整版

    背景: 由于建设初期使用的vSphere vCenter for Windows版,其中安装自动化过程中会使用SQL Server Express的免费版数据库进行基础环境构建.而此时随着业务量的增加 ...

  7. The SQL Server Service Broker for the current database is not enabled

    把一个数据恢复至另一个服务器上,出现了一个异常: The SQL Server Service Broker for the current database is not enabled, and ...

  8. DELL R710服务器可以安装的VMWare ESX Server 4.1 全套下载带注册码

    随着R710的停产,R720随之面世,但DELL R720服务器只支持vmware esxi5.0以上,DELL客户经理给了一套系统安装后序列号无法解决,还是用4.1好了,却又发现怎么都无法安装.按网 ...

  9. 警告: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to

    警告: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 警告: [SetPro ...

随机推荐

  1. 3.06课·········C#语言基础

    Main函数: static void Main(string [] args){ }程序代码需要写在Main函数的花括号内. 一.输出:Console.WriteLine("这是我的第一个 ...

  2. Data Structure Graph: strong connectivity

    如果为undirected graph就是dfs或者bfs,如果都能visit则为连通O(V+E). 如果为directed graph就先dfs或者bfs,再reverse direct,再dfs或 ...

  3. 0423 hashlib模块、logging模块、configparse模块、collections模块

    一.hashlib模块补充 1,密文验证 import hashlib #引入模块 m =hashlib.md5() # 创建了一个md5算法的对象 m.update(b') print(m.hexd ...

  4. _CRT_SECURE_NO_WARNINGS

    在新版编程器的编译过程中我们常常会遇到一些过时或者不安全的函数 举一个简单的例子: 很多带"_s"后缀的函数是为了让原版函数更安全,传入一个和参数有关的大小值,避免引用到不存在的元 ...

  5. Win7打开新的文件夹总会以新窗口的形式打开

    首先可以在 组织-->文件夹和搜索选项   中设置“在同一窗口中打开每个文件夹” 如果设置后不起作用还可以 管理员方式执行以下两条命令 在开始菜单-运行中输入regsvr32 "%Sy ...

  6. Python 变量(赋值,数据类型,数据类型转换)

    一.python 变量赋值方式有三种: 1.直接赋值:age = 28 2.多个变量赋值 age, sex = 28, 1  #每个变量都必须要有个对应的值 3.特殊形式的赋值(链式赋值)  a = ...

  7. Node教程

    本人的博客写了node的教程,从零开始,一步一步的通过例子讲解,希望喜欢的同学给我的github上加颗星,谢谢! github地址:https://github.com/manlili/node_le ...

  8. 【LeetCode】删除链表的倒数第N个节点

    给定一个链表,删除链表的倒数第 n 个节点,并且返回链表的头结点. 示例: 给定一个链表: 1->2->3->4->5, 和 n = 2. 当删除了倒数第二个节点后,链表变为 ...

  9. mysql日志总结

    1.mysql慢查询设置 log-slow-queries=/alidata/mysql-log/mysql-slow.loglong_query_time = 1log-queries-not-us ...

  10. Shiro-自定义realm

    Shiro自定义 realm package com.zhen.realm; import org.apache.shiro.authc.AuthenticationException; import ...