centos 6.10源码安装mysql5.5.62实验
查看系统版本
[root@ABC ~]# cat /etc/redhat-release
CentOS release 6.10 (Final)
下载mysql5.5.62源码包,解压后安装
tar –zxf mysql-5.5.62.tar.gz -C /usr/local/src
根据提示安装必要的依赖库文件
yum install -y gcc gcc-c++ ncurses-devel git cmake
预编译规划
Mysql软件安装目录/usr/local/mysql;mysql数据目录为/usr/local/mysql/data;
Mysql错误日志文件保存目录为/var/log/mysql/error.log,创建相应目录和用户并赋权
groupadd mysql&&useradd –r –g mysql –s /sbin/false
mkdir –p /usr/local/mysql/data&&chown –R mysql:mysql /usr/local/mysql
mkdir /var/log/mysql&&chown –R mysql:mysql /var/log/mysql
进入解压包目录,使用cmake预编译
cmake -DCMAKE_INSTALL_PREFIX=/usr/local/mysql -DMYSQL_DATADIR=/usr/local/mysql/data/ -DSYSCONFDIR=/etc -DDEFAULT_CHARSET=utf8 -DDEFAULT_COLLATION=utf8_general_ci -DMYSQL_UNIX_ADDR=/usr/local/mysql/mysql.sock -DMYSQL_TCP_PORT=3306 -DWITH_MYISAM_STORAGE_ENGINE=1 -DWITH_INNOBASE_STORAGE_ENGINE=1 -DWITH_MEMORY_STORAGE_ENGINE=1 -DWITH_READLINE=1
编译安装
make –j 4&& make install –j 4
进入安装目录执行操作
cd /usr/local/mysql
拷贝mysql服务脚本文件到系统目录
cp support-files/mysql.server /ect/init.d/mysqld
设置mysqld服务为开机自启动
chkconfig - -level 3 mysqld on
chkconfig - -list mysqld
启动mysql服务
service mysqld start
启动报错,无法正常启动
安装完5.5.62的mysql后,必需要先执行mysql_install_db才能执行后续操作
[root@ABC mysql]#/usr/local/mysql/ scripts/mysql_install_db --user=mysql --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data
/usr/local/mysql/bin/mysqladmin -u root password 'new-password'
/usr/local/mysql/bin/mysqladmin -u root -h 主机名 password 'new-password'
Alternatively you can run:
/usr/local/mysql/bin/mysql_secure_installation
which will also give you the option of removing the test
databases and anonymous user created by default. This is
strongly recommended for production servers.
See the manual for more instructions.
You can start the MySQL daemon with:
cd /usr/local/mysql ; /usr/local/mysql/bin/mysqld_safe &
You can test the MySQL daemon with mysql-test-run.pl
启动mysql服务
[root@ABC mysql]# service mysqld start
Starting MySQL SUCCESS!
修改环境变量,将mysql命令添加到系统中
PATH=$PATH:/usr/local/mysql/bin
要想使命令永久生效,需要将该命令添加到$HOME/.bashrc_profile文件末尾即可,
使用source $HOME/.bashrc_profile 让命令生效
安全初始化mysql
[root@ABC ~]# mysql_secure_installation
登陆mysql
[root@ABC ~]# mysql –u root –p password
查看端口和状态
[root@ABC mysql]# netstat -ntulp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 23441/mysqld
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 2195/sshd
tcp 0 0 :::80 :::* LISTEN 1744/httpd
tcp 0 0 :::22 :::* LISTEN 2195/sshd
udp 0 0 0.0.0.0:68 0.0.0.0:* 1231/dhclient
[root@ABC mysql]# ps -ef | grep mysql
root 23145 1991 0 18:34 pts/0 00:00:00 /bin/sh /usr/local/mysql/bin/mysqld_safe
mysql 23441 23145 0 18:34 pts/0 00:00:01 /usr/local/mysql/bin/mysqld --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data --plugin-dir=/usr/local/mysql/lib/plugin --user=mysql --log-error=/var/log/mysql/error.log --pid-file=ABC.pid --socket=/usr/local/mysql/mysql.sock --port=3306
root 23872 1991 0 19:36 pts/0 00:00:00 grep mysql
重启测试
[root@b mysql]# service mysqld restart
ERROR! MySQL server PID file could not be found!
无法启动,提示server PID无法找到关闭selinux防火墙并重启测试
[root@b mysql]# vim /etc/selinux/config
[root@b mysql]# reboot
[root@ABC ~]# service mysqld restart
Shutting down MySQL. SUCCESS!
Starting MySQL.. SUCCESS!
至此数据库安装成功。
centos 6.10源码安装mysql5.5.62实验的更多相关文章
- CentOS 6.5 源码安装MySQL5.6
1:下载安装cmake (mysql5.5以后是通过cmake来编译的) #http://download.csdn.net/detail/csxuedn/7976005 #wget http://w ...
- CentOS 6.5 源码安装MySQL5.6.26
1:下载安装cmake (mysql5.5以后是通过cmake来编译的) 2:创建mysql的安装目录及数据库存放目录 #mkdir /usr/mysql //安装my ...
- centos 6.4 源码安装php5.4 mysql5.5 apahce2
centos 6.4 源码安装php5.4 mysql5.5 apahce2 博客分类: php 参考:http://blog.csdn.net/simpleiseasy/article/deta ...
- CentOS 7下源码安装MySQL 5.7
网上说linux安装mysql服务分两种安装方法: ①源码安装,优点是安装包比较小,只有几十M左右,缺点是安装依赖的库多,安装编译时间长,安装步骤复杂容易出错: ②使用官方编译好的二进制文件安装,优点 ...
- lnmp之阿里云源码安装mysql5.7.17
mysql5.7.17一直号称世界上最好的mysql 那么就在阿里云主机linux安装它(采用的源码安装mysql5.7.17) 我在阿里云主机上安装它 连接阿里云主机 进入,跟我们自己装的虚拟机一毛 ...
- CentOS6.7源码安装MySQL5.6
1.源码安装MySQL5.6 # CentOS6操作系统安装完成后,默认会在/etc目录下存在一个my.cnf, # 强制卸载了mysql-libs之后,my.cnf就会消失 rpm -qa | gr ...
- CentOS6.5源码安装MySQL5.6.35
CentOS6.5源码安装MySQL5.6.35 一.卸载旧版本 1.使用下面的命令检查是否安装有mysql [root@localhost tools]# rpm -qa|grep -i mysql ...
- CentOS7 实战源码安装mysql5.7.17数据库服务器
CentOS7 实战源码安装mysql5.7.17数据库服务器 简介:实战演练mysql数据库服务器的搭建 mysql简介: mysql是一个开源的关系型数据库管理系统,现在是oracle公司旗下的 ...
- CentOS 源码安装MySQL5.7
一.安装方式源码安装,源码包名称mysql-boost-5.7.27.tar.gz,此版本包含boost库,在解压后的boost路径下.安装时,可以-DDOWNLOAD_BOOST=1 -DWITH_ ...
随机推荐
- 最少多少人说谎(dp)
https://ac.nowcoder.com/acm/contest/1168/H 题意:n个学生,邓志聪想知道这些学生的考试情况,于是一个一个叫这些学生叫去办公室问他们,但是有些学生并没有讲真话, ...
- HTTPS和HTTP的区别,http协议的特征
http协议传输的数据都是没有经过加密的,也就是明文,所以http用于传输数据并不安全.而https是是使用了ssl(secure socket layer)协议+http协议构成的可加密传输,身份认 ...
- CSS中:first-child伪类
使用 :first-child 伪类来选择作为某个元素的第一个子元素.这个特定伪类很容易遭到误解,所以有必要举例来说明.考虑以下标记: 如下: html: <div> <p>T ...
- div的edit和drag(点击div可编辑、删除、拖动)
1.可编辑: <div id="move" contentEditable="true">可编辑</div> 设置contentEdit ...
- 204-基于Xilinx Virtex-6 XC6VLX240T 和TI DSP TMS320C6678的信号处理板
基于Xilinx Virtex-6 XC6VLX240T 和TI DSP TMS320C6678的信号处理板 1.板卡概述 板卡由我公司自主研发,基于VPX架构,主体芯片为两片 TI DSP TMS ...
- 使用nginx配置二级域名
使用nginx配置二级域名 2018.11.21 11:51:17字数 613阅读 170 最近想把三个项目配在一个服务器上,于是想使用nginx配置二级域名实现. 1.域名添加解析 我的是阿里云的域 ...
- VB中的SSTab控件隐藏选项卡方法
请教下,VB中Sstab控件,如何隐藏选项卡呢? SSTab1.TabVisible(1) = False object.TabVisible(tab) [ = boolean ] tab 数值表达式 ...
- oracle 主键自增并获取自增id
1 创建表 /*第一步:创建表格*/ create table t_user( id int primary key, --主键,自增长 username varchar(20), password ...
- 移动端适配 rem
前置知识: 物理像素(physical pixel,device pixel) 物理像素(设备像素),显示设备中一个最微小的物理部件.每个像素可以根据操作系统设置自己的颜色和亮度. 设备独立像素(de ...
- C\C++下获取系统进程或线程ID(转)
在程序开发时有时需要获取线程和进程ID以分析程序运行 ()windows下获取进程或线程ID 通过调用系统提供的GetCurProcessId或GetNowThreadID来获取当前程序代码运行时的进 ...