本文转自:http://www.cnblogs.com/zhwl/p/3726003.html

一个小小的问题,让我折腾了一个上午,下午三点彻底解决了,分享一个给大家解决方法,尽管在测试服务器上,但是经验是值得总结和分享的.

ERROR: ORA-01034: ORACLE not available ORA-27101: shared memory realm does not exist 进程 ID: 0 会话 ID: 0 序列号: 0

---- 这个是现象。

SQL*Plus: Release 11.2.0.1.0 Production on 星期一 3月 18 15:30:38 2013

Copyright (c) 1982, 2010, Oracle.  All rights reserved.

ERROR: ORA-01031: insufficient privileges

请输入用户名:  sys as sysdba 输入口令: 已连接到空闲例程。

SQL> show parameter; ORA-01034: ORACLE not available 进程 ID: 0 会话 ID: 0 序列号: 0

SQL> select group#,sequence#,members,archived,status from v$log; select group#,sequence#,members,archived,status from v$log * 第 1 行出现错误: ORA-01034: ORACLE not available 进程 ID: 0 会话 ID: 0 序列号: 0 -----

这个过程中我参考很多资料,无法解决

SQL> startup open hstestdb ORACLE 例程已经启动。

Total System Global Area 6847938560 bytes Fixed Size                  2188768 bytes Variable Size            3422554656 bytes Database Buffers         3405774848 bytes Redo Buffers               17420288 bytes 数据库装载完毕。 ORA-03113: 通信通道的文件结尾 进程 ID: 2984 会话 ID: 5 序列号: 3

-----

还是报ORA-03113: 通信通道的文件结尾,究竟什么原因?

SQL> startup open hstestdb ORACLE 例程已经启动。

Total System Global Area 6847938560 bytes Fixed Size                  2188768 bytes Variable Size            3422554656 bytes Database Buffers         3405774848 bytes Redo Buffers               17420288 bytes 数据库装载完毕。 ORA-03113: 通信通道的文件结尾 进程 ID: 2984 会话 ID: 5 序列号: 3

SQL> exit 从 Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production With the Partitioning, OLAP, Data Mining and Real Application Testing options 断 开

C:\Documents and Settings\Administrator>set oracle_sid=hstestdb

C:\Documents and Settings\Administrator>sqlplus "/as sysdba

SQL*Plus: Release 11.2.0.1.0 Production on 星期一 3月 18 15:37:02 2013

Copyright (c) 1982, 2010, Oracle.  All rights reserved.

ERROR: ORA-01031: insufficient privileges

请输入用户名:  sys as  sysdba 输入口令: 已连接到空闲例程。

SQL> stop SP2-0042: 未知命令 "stop" - 其余行忽略。 SQL> shutdown immediate; ORA-01034: ORACLE not available ORA-27101: shared memory realm does not exist SQL> startup mount; ORACLE 例程已经启动。

Total System Global Area 6847938560 bytes Fixed Size                  2188768 bytes Variable Size            3422554656 bytes Database Buffers         3405774848 bytes Redo Buffers               17420288 bytes 数据库装载完毕。 SQL> select * from v$log;

GROUP#    THREAD#  SEQUENCE#      BYTES  BLOCKSIZE    MEMBERS ARC ---------- ---------- ---------- ---------- ---------- ---------- --- STATUS           FIRST_CHANGE# FIRST_TIME     NEXT_CHANGE# NEXT_TIME ---------------- ------------- -------------- ------------ --------------          1          1       3823   52428800        512          1 NO CURRENT               34344047 12-3月 -13       2.8147E+14

3          1       3822   52428800        512          1 NO INACTIVE              34327500 12-3月 -13         34344047 12-3月 -13

2          1       3821   52428800        512          1 NO INACTIVE              34324562 12-3月 -13         34327500 12-3月 -13

SQL> alter database open; alter database open * 第 1 行出现错误: ORA-03113: 通信通道的文件结尾 进程 ID: 2592 会话 ID: 5 序列号: 7

SQL> alter database archivelog; ERROR: ORA-03114: 未连接到 ORACLE

SQL> select * from v$log; ERROR: ORA-03114: 未连接到 ORACLE

SQL> conn sys/sys as sysdba 已连接到空闲例程。 SQL> select * from v$log; select * from v$log * 第 1 行出现错误: ORA-01034: ORACLE not available 进程 ID: 0 会话 ID: 0 序列号: 0

SQL> archive log list; ORA-01012: not logged on SQL> exit 已断开连接

C:\Documents and Settings\Administrator>lsnrctl status

LSNRCTL for 64-bit Windows: Version 11.2.0.1.0 - Production on 18-3月 -2013 15:4 4:24

Copyright (c) 1991, 2010, Oracle.  All rights reserved.

正在连接到 (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=hserptest)(PORT=1521))) LISTENER 的 STATUS ------------------------ 别名                      LISTENER 版本                      TNSLSNR for 64-bit Windows: Version 11.2.0.1.0 - Produ ction 启动日期                  18-3月 -2013 15:30:27 正常运行时间              0 天 0 小时 14 分 0 秒 跟踪级别                  off 安全性                    ON: Local OS Authentication SNMP                      OFF 监听程序参数文件          D:\app\Administrator\product\11.2.0\dbhome_1\network\a dmin\listener.ora 监听程序日志文件          d:\app\administrator\diag\tnslsnr\hserptest\listener\a lert\log.xml 监听端点概要...   (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=hserptest)(PORT=1521)))   (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC1521ipc))) 服务摘要.. 服务 "CLRExtProc" 包含 1 个实例。   实例 "CLRExtProc", 状态 UNKNOWN, 包含此服务的 2 个处理程序... 服务 "hstestdb" 包含 1 个实例。   实例 "hstestdb", 状态 UNKNOWN, 包含此服务的 1 个处理程序... 命令执行成功

C:\Documents and Settings\Administrator>sqlplus "/as sysdba"

SQL*Plus: Release 11.2.0.1.0 Production on 星期一 3月 18 15:45:23 2013

Copyright (c) 1982, 2010, Oracle.  All rights reserved.

ERROR: ORA-01031: insufficient privileges

请输入用户名:  sys/sys as sysdba 已连接到空闲例程。

SQL> select *  from v$log; select *  from v$log * 第 1 行出现错误: ORA-01034: ORACLE not available 进程 ID: 0 会话 ID: 0 序列号: 0

SQL> alter  database open resetlog; alter  database open resetlog * 第 1 行出现错误: ORA-01034: ORACLE not available 进程 ID: 0 会话 ID: 0 序列号: 0

SQL> alter  database open resetlogs; alter  database open resetlogs * 第 1 行出现错误: ORA-01034: ORACLE not available 进程 ID: 0 会话 ID: 0 序列号: 0

SQL> shutdown immedate; SP2-0717: 非法的 SHUTDOWN 选项 SQL> shutdown immediate ORA-01034: ORACLE not available ORA-27101: shared memory realm does not exist SQL> startup mount; ORACLE 例程已经启动。

Total System Global Area 6847938560 bytes Fixed Size                  2188768 bytes Variable Size            3422554656 bytes Database Buffers         3405774848 bytes Redo Buffers               17420288 bytes 数据库装载完毕。
SQL> alter database open resetlogs; alter database open resetlogs * 第 1 行出现错误: ORA-01139: RESETLOGS 选项仅在不完全数据库恢复后有效

SQL> select * from v$log;

GROUP#    THREAD#  SEQUENCE#      BYTES  BLOCKSIZE    MEMBERS ARC ---------- ---------- ---------- ---------- ---------- ---------- --- STATUS           FIRST_CHANGE# FIRST_TIME     NEXT_CHANGE# NEXT_TIME ---------------- ------------- -------------- ------------ --------------          1          1       3823   52428800        512          1 NO CURRENT               34344047 12-3月 -13       2.8147E+14

3          1       3822   52428800        512          1 NO INACTIVE              34327500 12-3月 -13         34344047 12-3月 -13

2          1       3821   52428800        512          1 NO INACTIVE              34324562 12-3月 -13         34327500 12-3月 -13

SQL> alter database open resetlogs; alter database open resetlogs * 第 1 行出现错误: ORA-01139: RESETLOGS 选项仅在不完全数据库恢复后有效

SQL> SQL> recover database until time '2013-03-01 12:12:12'; 完成介质恢复。

---

我恢复3月1日的 SQL> alter database open resetlogs;

数据库已更改。

SQL> shutdown 数据库已经关闭。 已经卸载数据库。 ORACLE 例程已经关闭。 SQL> startup ORACLE 例程已经启动。

Total System Global Area 6847938560 bytes Fixed Size                  2188768 bytes Variable Size            3422554656 bytes Database Buffers         3405774848 bytes Redo Buffers               17420288 bytes 数据库装载完毕。 数据库已经打开。 SQL>

--到目前为止,问题解决。

[转]ORA-01034: ORACLE not available如何解决的更多相关文章

  1. oracle错误(ORA:12154 ORA:01034 和 ORA:27101 ORA-18008 ORA-01081)

    按照正常操作流程,启动项目,发现项目报错,原因是连接不上oracle数据库, PLSQL连接时报错,错误码  ORA:12154 无法解析指定的连接标识符 第一次,遇到这个错误,在网上找了资料都是需要 ...

  2. Oracle导入中文乱码解决办法

    Oracle导入中文乱码解决办法 一.确保各个客户端字符集的编码同服务器字符集编码一致 1-       确定sqlplus字符集编码,如果是windows设置环境变量. 2-       确保Sec ...

  3. Oracle OCI-22053:溢出错误解决方法

    原文 Oracle OCI-22053:溢出错误解决方法 Oracle 数值数据类型最多可存储 38 个字节的精度.当将 Oracle 数值转换为公共语言运行库数据类型时,小数点后边的位数可能过多,这 ...

  4. 经历:asp.net oracle 部署问题以及解决方法

    原文:[原创]经历:asp.net oracle 部署问题以及解决方法 精简的美丽...... 一.环境    开发环境        win7 64bit         Vs2010       ...

  5. 升级时针对Source oracle home 不存在解决办法

    针对于oracle升级从11.2.0.4升级至12.1.0.1,遇到的问题解决. 运行/oracle/app/product/12.1.0.1/dbhome_1/bin/dbua 后 在选择数据库ho ...

  6. 导出oracle 到 mysql的解决办法

    导出oracle 到 mysql的解决办法 使用sqluldr2 命令如下sqluldr2 USER=weibh/1234@dydb file=c:\1.txt sql=sql.sql   FORMA ...

  7. Asp.Net 应用程序在IIS发布后无法连接oracle数据库问题的解决方法

    asp.net程序编写完成后,发布到IIS,经常出现的一个问题是连接不上Oracle数据库,具体表现为Oracle的本地NET服务配置成功:用 pl/sql 等工具也可以连接上数据库,但是通过浏览器中 ...

  8. ORA-01034: ORACLE not available如何解决

    一个小小的问题,让我折腾了一个上午,下午三点彻底解决了,分享一个给大家解决方法,尽管在测试服务器上,但是经验是值得总结和分享的. ERROR:ORA-01034: ORACLE not availab ...

  9. 本机连接虚拟机Oracle时报错的解决办法

    虚拟机安装了Oracle服务器(桌面类)和客户端,里面使用plsql连接自己没有问题. 在本机连接虚拟机没有成功.虚拟机的地址是192.168.126.132,已经确认本机能ping通虚拟机. 先是报 ...

随机推荐

  1. 如何去除My97 DatePicker控件上右键弹出官网的链接 - 如何debug混淆过的代码

    概述 http://my97.net/是一个web浏览器的日期选择控件,非常好用,做得非常棒,各种API等事件等都很方便,但是使用了4.8beta3之后,在控件上面右击会出现官网链接 ,这个是PM以及 ...

  2. 安装配置php5.4 win2003

    php php-5.4.38 1.下载 http://windows.php.net/downloads/releases/php-5.4.38-Win32-VC9-x86.zip 解压到 D:\we ...

  3. CSS常用样式(四)之animation

    上篇CSS常用样式(三)这篇博文中已经介绍过了CSS中具有动画效果的transition.transform,今天来大概说说CSS中的animation.animation的加入会使得动画效果更加乐观 ...

  4. HTML标签的嵌套

    随着时间的推移,我们学习html的基础知识有了大概的了解.而我发现,平时在写html文档的时候,发现不太清楚标签之间的嵌套规则,经常是想到什么标签就用那些,然而发现有时的标签嵌套却是错误的.通过网上找 ...

  5. iOS 3DES加密解密(一行代码搞定)

    3DES(或称为Triple DES)是三重数据加密算法(TDEA,Triple Data Encryption Algorithm)块密码的通称.它相当于是对每个数据块应用三次DES加密算法.由于计 ...

  6. 通过ABAP的标准功能,寻找源代码中的字符串

    程序名称: *ABAP_SOURCE_SCAN 查找 作用:通过这个标准程序,可以在系统的源代码中进行字符串的查找!

  7. 【C语言】C语言函数

    目录: 1. [函数注意点] 2. [函数目的] 3. [函数格式] 4. [函数定义前需明确的条件] 5. [函数的形参.实参] 6. [函数返回值注意点] 7. [为什么要return] 8. [ ...

  8. iOS开发UINavigation——导航控制器UINavigationController

    iOS开发UINavigation系列一——导航栏UINavigtionBar摘要iOS中的导航条可以附着于导航控制器之中使用,也可以在controller中单独使用,这篇博客,主要讨论有关导航栏的使 ...

  9. iOS开发--Swift 最近项目开发中遇到的一些小问题与解决方法

    1, Swift 修改导航栏颜色 self.navigationController?.navigationBar.barTintColor 2, Swift button 属性设置时直接进行初始化 ...

  10. 安卓开发NDK环境搭建

    第一步preferences - android - NDK 第二步 输入ndk文件所在目录 第三步 创建文件名(右击项目,阿 androidtool - add native sppuort)