Kooboo CMS的安装步骤

来自Kooboo document
跳转到: 导航, 搜索
http://www.microsoft.com/web/gallery/install.aspx?appid=KoobooCMS

Kooboo CMS的安装过程是一个普通MVC站点在IIS上的架设过程,没有额外的配置步骤。

目录

[隐藏] 

在IIS6上安装Kooboo CMS


  1. 从http://kooboo.codeplex.com下载最新版本的Kooboo CMS安装包解压到C:\Kooboo CMS
  2. 打开IIS6控制台,创建一个新的应用程序池。命名为:Kooboo CMS Pool
  3. 在IIS6控制台,创建一个新的站点,站点主目录指向C:\Kooboo CMS。应用程序池选择步骤1创建的应用程序池Kooboo CMS Pool。
  4. 添加通配符映射。在“主目录”选项卡中找到“配置”按钮,单击添加通配符映射。在弹出的窗口中,单击“插入”,在“可执行文件”的输入框中输入:%WINDIR%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll ,去掉“确认文件是否存在”的选中状态。
  5. 设置站点的目录权限。Kooboo CMS要求当前的站点运行用户具有对Cms_Data目录的读写权限。

在IIS7上安装Kooboo CMS


  1. 从http://kooboo.codeplex.com下载最新版本的Kooboo CMS安装包解压到C:\Kooboo CMS
  2. 打开IIS7控制台,创建一个应用程序池。.NET框架版本选择“.NET Framework v4.0.30319” ,通道模式选择“集成”模式,命名为Kooboo CMS Pool。
  3. 在IIS7控制台,创建一个新站点。站点目录指向C:\Kooboo CMS,应用程序池使用刚刚创建的Kooboo CMS Pool。
  4. 设置站点的目录权限。Kooboo CMS要求当前的站点运行用户具有对Cms_Data目录的读写权限。

通过Web platform installer安装Kooboo CMS


Kooboo CMS已发布到Windows Web App Gallery http://www.microsoft.com/web/gallery/kooboocms.aspx ,支持用户从Web platform installer和WebMatrix安装Kooboo CMS。通过这两种工具安装Kooboo CMS只要求用户按要求输入相关的IIS站点设置,并且不需要站点目录下的读写权限已经自动设置。

安装的常见问题


  • 站点运行时出现配置错误,提示:Parser Error Message: Could not load file or assembly 'Kooboo.CMS.Web' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded. 这种情况,通常是在IIS中使用了错误了.NET Framework版本。请检查是否正确设置使用.NET 4。
  • 在站点运行过程中,如果出现文件无法删除或抛出类似IOException的异常,请检查当前IIS用户是否有对Cms_Data目录的读写。如果不确定,请在Cms_Data目录上设置“Everyone”具有“读写权限”。

切换内容数据库


Kooboo CMS目前提供对XML,MongoDB,SQL Server,SQLCe以及MySQL数据的支持。默认使用XML文件存储的方式,在多数据情况下,我们建议开发人员在开发时使用XML存储,等到部署时再整站点导入到生产环境。

切换数据库的步骤很简单,通常的步骤包括:

  1. 从http://kooboo.codeplex.com 下载Content_Providers.zip,解压找到相应的数据库目录的支持文件。
  2. 导出已经创建好的站点。
  3. 把数据库目录下的文件全部拷贝到Kooboo CMS的BIN目录下。
  4. 修改相应的连接串配置文件(MongoDB.config,SqlServer.config,MySQL.config)。
  5. 重新创建或导入站点。

切换数据库常见的问题

  1. 数据丢失
    切换为无结构的数据库(MongoDB)后,如果站点没有重新导入,站点运行不会出错,但是内容数据将会丢失。
  2. 提示Invalid object name
    切换为有结构数据库(SQLServer,SQLCe,MySQL)后,如果站点没有重新导入,在运行时会出现找不到数据表的错误。因为有结构数据库,需要重新导入站点来重建数据表和导入数据。

个人工具
名字空间
变换
操作
搜索

  • 本页面最后修订于2012年2月8日 (星期三) 03:17。
  • 此页面已被浏览过1,553次。

Kooboo CMS的安装步骤的更多相关文章

  1. Kooboo CMS技术文档之二:Kooboo CMS的安装步骤

    在IIS上安装Kooboo CMS Kooboo CMS安装之后 安装的常见问题 1. 在IIS上安装Kooboo CMS Kooboo CMS部署到正式环境相当简单,安装过程是一个普通MVC站点在I ...

  2. Kooboo CMS技术文档之五:站点配置管理

    站点关系 管理站点间的关系,站点可以有子站点,子站点继承父站点的部分配置数据,同时子站点还可以根据需要,本地化由父站点继承而来的数据.通过继承和本地化,可以让子站点在用最小的改动代价,来完成一个与父站 ...

  3. Kooboo CMS技术文档之一:Kooboo CMS技术背景

    语言平台 依赖注入方案 存储模型 1. 语言平台 Kooboo CMS基于.NET Framework 4.x,.NET Framework 4.x的一些技术特性成为站点开发人员使用Kooboo CM ...

  4. Kooboo CMS技术文档之三:切换数据存储方式

    切换数据存储方式包括以下几种: 将文本内容存储在SqlServer.MySQL.MongoDB等数据库中 将站点配置信息存储在数据库中 将后台用户信息存储在数据库中 将会员信息存储在数据库中 将图片. ...

  5. Kooboo CMS 无聊随笔 (1)

    因为公司的框架不开源,但是自己一直都有研究框架的兴趣,所以拿了一个开源的框架过来,而这个开源的框架就是Kooboo CMS.首先我无法用言语来形容我对这个CMS的赞美之词了,总之大家知道一点,这个CM ...

  6. Kooboo CMS - 之后台注册用户流程方法。

    今天决定写一篇好一点的文章,吼吼!首先我们必须找到这个文件,这个文件是UsersController.cs,我们找到和添加新用户有关的方法,如下代码: public virtual ActionRes ...

  7. CentOS 6.4 32位系统 LAMP(Apache+MySQL+PHP)安装步骤

    先来解释一下,什么是 LAMP.正如标题所言,LAMP 实际上就是 Linux.Apache.MySQL.PHP 四个名称的缩写,当然最后一个 “P” 还有其他说法是 Perl 或者 Python.不 ...

  8. Kooboo CMS技术文档之四:Kooboo CMS的站点组成部分

    Kooboo CMS本着功能独立分离的原则,将站点分为三部分组成:用户管理,站点管理和内容数据库管理.各个功能之间既可独立使用,也可以容易组成在一起形成一个完整的系统. 用户管理 管理整个系统内的用户 ...

  9. 如何搭建SVN服务器,详细安装步骤。

    SVN服务器端安装 下载: VisualSVN是一款图形化svn服务器.官网 http://www.visualsvn.com/server/ 下载地址: http://www.visualsvn.c ...

随机推荐

  1. EXTJS 3.0 资料 控件之 combo 用法

    EXTJS combo 控件: 1.先定义store //年款 var comboData_ReleasYear = [ ['], ['], ['], ['] ]; 2.定义combo控件 { lay ...

  2. Spring AOP进行日志记录

    在java开发中日志的管理有很多种.我一般会使用过滤器,或者是Spring的拦截器进行日志的处理.如果是用过滤器比较简单,只要对所有的.do提交进行拦截,然后获取action的提交路径就可以获取对每个 ...

  3. 【BZOJ 1088】 [SCOI2005]扫雷Mine

    Description 相信大家都玩过扫雷的游戏.那是在一个n*m的矩阵里面有一些雷,要你根据一些信息找出雷来.万圣节到了,“余”人国流行起了一种简单的扫雷游戏,这个游戏规则和扫雷一样,如果某个格子没 ...

  4. 【BZOJ 2730】 [HNOI2012]矿场搭建

    Description 煤矿工地可以看成是由隧道连接挖煤点组成的无向图.为安全起见,希望在工地发生事故时所有挖煤点的工人都能有一条出路逃到救援出口处.于是矿主决定在某些挖煤点设立救援出口,使得无论哪一 ...

  5. Ubuntu 设置root用户登录

    由于 Ubuntu 是基于 Debian 的 linux 操作系统,在默认的情况下,是没有超级用户(superuser, root)的,但有些系统操作必须有超级用户的权限才能进行,如手动释放内存等.  ...

  6. JQuery 知识点

    1:animate 动画效果 $(function () { $(".sidebar-nav a").mouseover(function () { $(this).animate ...

  7. [转载]WCF序列化65536大小限制的问题

    错误: The formatter threw an exception while trying to deserialize the message: There was an error whi ...

  8. linux下执行 ls,cat等一些命令报出 -bash: /bin/cat: Cannot allocate memory 有没解决的方法

    环境变量配置出错了cd -- 进入用户目录vim .bash_profile删除以前PATH这一行,把下面的粘帖进去PATH=$PATH:$HOME/bin:/root:/root/snapshot/ ...

  9. python参考手册--第2章词汇和语法约定

    1.续行符\ 三引号.().{}.[]中的内容不需要续行符 2.空格缩进 优选空格作为缩进,不要用tab,这是因为不同操作系统下tab对应的空格不一样,而python是通过严格的空格来控制语句块的. ...

  10. Python SyntaxError: Non-ASCII character '\xe5'

    error: SyntaxError: Non-ASCII character '\xe5' in file D:\worklife\workshop\myCrawler\src\mainDriver ...