想自己安装nginx,又不相用到root用户。

非root用户下(本文为用户bdctool)来ngnix安装,要依赖pcre库、zlib库等,

1、 下载依赖包:下载地址 pcre(www.pcre.org),zlib(www.zlib.org),openssl(www.openssl.org)

2、不用依赖包,先安装一下试试

[bdctool@localhost setup]$ tar  -zxvf nginx-1.12.2.tar.gz

[bdctool@localhost setup]$ ./configure  --with-http_stub_status_module --prefix=/opt/aspire/product/bdctool/nginx

报错

./configure: error: the HTTP rewrite module requires the PCRE library.
You can either disable the module by using
--without-http_rewrite_module
option, or install the PCRE library into the
system, or build the PCRE library
statically from the source with nginx by
using --with-pcre=<path> option.

3、还是安装一下pcre吧

[bdctool@localhost setup]$ unzip  pcre-8.10.zip

[bdctool@localhost setup]$ cd  pcre-8.10

[bdctool@localhost pcre-8.10]$ ./configure   
--prefix=/opt/aspire/product/bdctool/nginx/zzw_other/pcre-8.10 (自定义目录)

[bdctool@localhost pcre-8.10]$ make

[bdctool@localhost pcre-8.10]$ make install

4、再来安装nginx,首先./configure

[bdctool@localhost nginx-1.12.2]$./configure  --with-http_stub_status_module 
--prefix=/opt/aspire/product/bdctool/nginx 
--with-pcre=/opt/aspire/product/bdctool/nginx/zzw_other/pcre-8.10

注意:上面命令--prefix=路径为nginx想要安装到的目录, --with-pcre=路径为pcre安装到的目录。

.....................
checking for openat(),
fstatat() ... found
checking for getaddrinfo() ... found
checking for zlib
library ... found
creating objs/Makefile

Configuration summary
  + using PCRE library:
/opt/aspire/product/bdctool/nginx/zzw_other/pcre-8.10
 
+ OpenSSL library is not used  
--- OpenSSL  可选
  + using system zlib library    ---
其实是要依赖zlib包的,但系统已安装,所以没有额外安装,如果系统没安装,要自行如pcre一样安装一下,并且在configure时加
--with-zlib=(自行安装的zlib的目录)

nginx path prefix:
"/opt/aspire/product/bdctool/nginx"
  nginx binary file:
"/opt/aspire/product/bdctool/nginx/sbin/nginx"
  nginx modules path:
"/opt/aspire/product/bdctool/nginx/modules"
  nginx configuration prefix:
"/opt/aspire/product/bdctool/nginx/conf"
  nginx configuration file:
"/opt/aspire/product/bdctool/nginx/conf/nginx.conf"
  nginx pid file:
"/opt/aspire/product/bdctool/nginx/logs/nginx.pid"
  nginx error log file:
"/opt/aspire/product/bdctool/nginx/logs/error.log"
  nginx http access log
file: "/opt/aspire/product/bdctool/nginx/logs/access.log"
  nginx http client
request body temporary files: "client_body_temp"
  nginx http proxy temporary
files: "proxy_temp"
  nginx http fastcgi temporary files: "fastcgi_temp"
 
nginx http uwsgi temporary files: "uwsgi_temp"
  nginx http scgi temporary
files: "scgi_temp"

没什么大问题

4、再进行make

[bdctool@localhost nginx-1.12.2]$ make
make -f
objs/Makefile
make[1]: Entering directory
`/opt/aspire/product/bdctool/setup/nginx-1.12.2'
cd
/opt/aspire/product/bdctool/nginx/zzw_other/pcre-8.10 \
        && if
[ -f Makefile ]; then make distclean; fi \
        && CC="cc"
CFLAGS="-O2 -fomit-frame-pointer -pipe " \
        ./configure
--disable-shared
/bin/sh: line 2: ./configure: 没有那个文件或目录
make[1]: ***
[/opt/aspire/product/bdctool/nginx/zzw_other/pcre-8.10/Makefile] 错误
127
make[1]: Leaving directory
`/opt/aspire/product/bdctool/setup/nginx-1.12.2'
make: *** [build] 错误
2

出问题了,make报错。

参考《http://www.cnblogs.com/yayagepei/articles/1884462.html》的解决方法
,原来是--with-pcre=让你设置到源码目录,而不是编译安装后的目录;同样的道理, --with-zlib=也是解压后的源码目录,而不是zlib编译安装后的目录!!!!。这点与apache的编译还有点不同。用./configure 
-help 可以看配置参数帮助

5、修改
--with-pcre=后的路径为pcre的解压后的源路径,重新./configure

[bdctool@localhost nginx-1.12.2]$./configure  --with-http_stub_status_module 
--prefix=/opt/aspire/product/bdctool/nginx 
--with-pcre=/opt/aspire/product/bdctool/setup/pcre-8.10

6、重新make

[bdctool@localhost nginx-1.12.2]$ make

成功了,没出问题

7、最后make install

[bdctool@localhost nginx-1.12.2]$ make 
install

完成,没出问题

8、不改配置,试着启动一下

[bdctool@localhost sbin]$ ./nginx
nginx: [emerg]
bind() to 0.0.0.0:80 failed (13: Permission denied)

启动不了的,因为非root用户启动不了1024以下端口,具体解决方法见 http://www.cnblogs.com/zzw-zyba/p/8575428.html

9、修改一下nginx.conf监听端口为1024以上端口,重新启动nginx,成功。

参考《http://www.runoob.com/linux/nginx-install-setup.html》

 
 
 

zzw原创_非root用户下安装nginx的更多相关文章

  1. zzw原创_非root用户启动apache的问题解决(非root用户启动apache的1024以下端口)

    场景:普通用户编译的apache,要在该用户下启动1024端口以下的apache端口 1.假设普通用户为sims20,用该用户编译 安装了一个apache,安装路径为/opt/aspire/produ ...

  2. zzw原创_非root安装fastDFS

    zzw原创_非root安装fastDFS fastDFS 想要非root安装,没找到资料,分析了一下安装脚本,原来作者是留了安装路径的,但没有放出来. 1.解包 [bdc@svr001 setup]$ ...

  3. linux非root用户下安装软件,搭建生产环境

    之前的用实验室的服务器,因为某些原因,使用的用户没有root权限.linux的非root用户很多软件无法安装,非常的不方便.我的方法是使用brew来代替系统的包管理工具.brew是最先用在mac上的包 ...

  4. CentOS6非root用户下安装及配置CDH5.3.0

    #install lsb packagesudo yum install -y redhat-lsb #install net-tools package sudo yum install -y ne ...

  5. Linux下非root用户如何安装软件

    Linux下非root用户如何安装软件 从windows转移到Linux的用户最开始总会有各种不适,因为这种不适最终放弃linux的不在少数.对于这类人只能说可惜,还没有领略到linux的美好就过早放 ...

  6. [转载]Linux下非root用户如何安装软件

    [转载]Linux下非root用户如何安装软件 来源:https://tlanyan.me/work-with-linux-without-root-permission/ 这是本人遇到的实际问题,之 ...

  7. ubuntu下非root用户下获得使用wireshark的权限

    在非root用户下不能使用wireshark用来抓包,所以需要进行以下操作: sudo groupadd wireshark sudo chgrp wireshark /usr/bin/dumpcap ...

  8. 8、非root权限下安装perl以及perl模块

    转载:http://www.cnblogs.com/nkwy2012/p/6418669.html 转载自http://www.zilhua.com 在本博客中,所有的软件安装都在服务器上,且无roo ...

  9. 非root模式下安装mysql php小记

    假设你的home目录为/home/work mysql-server 安装 1. 下载mysql.tar.gz wget http://dev.mysql.com/get/Downloads/MySQ ...

随机推荐

  1. Linux基础命令---top显示进程信息

    top top指令用来显示Linux的进程信息,这是一个动态显示的过程.top提供运行系统的动态实时视图.它可以显示系统摘要信息以及当前由Linux内核管理的任务列表.所显示的系统摘要信息的类型以及为 ...

  2. nodejs笔记之流(stream)

    nodejs的stream有四种流类型: 可读:Readable可写:Writable可读可写:Duplex操作被写入数据,然后读出结果:Transform常用事件:data:有数据可读时触发end: ...

  3. Qt QGraphicsItem要点 积累

    1.在创建QGraphicsItem子类的时候,想要实现自己绘图,一般是重新实现boundingRect()和paint()函数,如果不重新实现shape(),基类的实现将会退而使用 bounding ...

  4. python:循环定义、赋值多个变量

    exec函数,可以循环定义.赋值多个变量 exec ("temp%s=1"%1)   这段代码的意思是,让exec执行temp1=1.字符串里面的%s由‘1’代替了. 我们在外面再 ...

  5. Redis查漏补缺:最易错过的技术要点大扫盲

    考虑到绝大部分写业务的程序员在实际开发中使用Redis时,只会Setvalue和Getvalue两个操作,对Redis整体缺乏一个认知.又恰逢笔者有同事下周要去培训Redis,所以笔者斗胆以Redis ...

  6. oracle 表空间管理相关(原创)

    通过以下几步基本可以查看表空间情况以及处理表空间不足问题. ASM相关 查看asm空间 select group_number,name,total_mb,free_mb from v$asm_dis ...

  7. 解决docker主机配置了DaoCloud.io的加速后重启失败问题Failed to start Docker Application Container Engine

    问题说明 正常运行的docker主机配置了DaoCloud.io加速后重启报如下错 解决过程 问题原因: 重新配置加速器后发现,daocloud的配置信息是写在/etc/docker/daemon.j ...

  8. java中‘\'和'/'的区别

    斜杠“/”表示地址路径的下一级目录:反斜杠“\”表示转义字符,例如:要做制表,可以输入:\t:做换行:\n等.如果要输出反斜杠“\”也需要用转义字符:“\\”    在java中后台给前台传的时候如果 ...

  9. SpringBoot Tomcat启动报错

    中间的桥梁就是下面这个依赖 <dependency> <groupId>org.slf4j</groupId> <artifactId>jcl-over ...

  10. JS实现打开本地文件或文件夹 ActiveXObject

    IE浏览器打开C盘,测试可用. 如果浏览器报错提示:ActiveXObject is not defined Internet 选项 -> 安全 - >安全级别,调低级别 function ...