禅道——Linux服务器部署禅道
前言
2019年6月14日 22:01:24 看看时间我知道,我离猝死依然不远~
禅道是什么 | 禅道是专业的研发项目管理软件
禅道的官网 | https://www.zentao.net/
禅道开源版 | https://www.zentao.net/download/80137.html
视频教程 | https://www.zentao.net/video/linux-zbox-install-79983.html
步骤
我是为了美和正义而诞生的无聊的句子~
查看服务器版本
getconf LONG_BIT

64位返回64 32位返回32
选择对应版本禅道

上传到服务器
你可以选择下载后通过scrt或者其他远程连接工具上传,也可以直接wget下载
cd /opt/
wget http://dl.cnezsoft.com/zentao/11.5/ZenTaoPMS.11.5.stable.zbox_old.64.tar.gz

Linux一键安装包
必须直接解压到/opt目录下
解压文件
tar -zxvf ZenTaoPMS.11.5.stable.zbox_old.64.tar.gz
上传的可通过-C来将文件解压到指定目录
tar -zxvf ZenTaoPMS.11.5.stable.zbox_old.64.tar.gz -C /opt
帮助命令
[root@izuf63g0jydq42k49eo7zcz ~]# /opt/zbox/zbox -h
Usage: zbox.php {start|stop|restart|status}
Options:
-h --help Show help.
-ap --aport Apache port, default 80.
-mp --mport Mysql port, default 3306.
修改端口
因为我原有的是lnmp环境,为了防止端口冲突,所以这里修改下端口!
[root@izuf63g0jydq42k49eo7zcz zbox]# /opt/zbox/zbox -ap 8284
[root@izuf63g0jydq42k49eo7zcz zbox]# /opt/zbox/zbox -mp 8285
启动服务
[root@izuf63g0jydq42k49eo7zcz zbox]# /opt/zbox/zbox start
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:8284
no listening sockets available, shutting down
AH00015: Unable to open logs
Start Apache fail. You can see the log /opt/zbox/logs/apache_error.log
Start Mysql success
设置开机自启
进入到系统服务目录
cd /lib/systemd/system
创建服务文件
vi chandao.service
[Unit]
Description=chandao
After=network.target
[Service]
Type=forking
ExecStart=/opt/zbox/zbox start
ExecReload=/opt/zbox/zbox restart
ExecStop=/opt/zbox/zbox stop
PrivateTmp=true
[Install]
WantedBy=multi-user.target
修改文件权限
chmod -R 754 chandao.service
加入开机自启
systemctl enable chandao.service

访问地址
默认账户密码为 admin 和123456
http://<ip或者域名>:8284/zentao/user-login.html


禅道——Linux服务器部署禅道的更多相关文章
- linux服务器部署tomcat和Nginx
项目需要,申请了三台测试机器,好在测试机里面光秃秃的什么都没有,我就可以好好的学习一把玩一把了!接下来以图文的形式讲一下我所碰到的坑以及小小的收获吧! 一.准备工作 首先你得有一台可以玩的linux服 ...
- Linux服务器部署系列之八—Sendmail篇
Sendmail是目前Linux系统下面用得最广的邮件系统之一,虽然它存在一些不足,不过,目前还是有不少公司在使用它.对它的学习,也能让我们更深的了解邮件系统的运作.下面我们就来看看sendmail邮 ...
- Linux服务器部署系列之七—OpenLDAP篇
LDAP(轻量级目录访问服务),通过配置这个服务,我们也可以在linux下面使用目录的形式管理用户,就像windows下面的AD一样,方便我们管理.下面我们就一起来配置openldap服务.本文运行环 ...
- Linux服务器部署系列之一—Apache篇(下)
接上篇 linux服务器部署系列之一—Apache篇(上) 四.管理日志文件 Apache日志分为访问日志和错误日志两种: 1)访问日志 用于记录客户端的访问信息,文件名默认为access_lo ...
- Linux服务器部署系列之二—MySQL篇
MySQL是linux环境中使用最广泛的数据库之一,著名的“LAMP黄金组合”就要用到MySQL.关于MySQL的优点及作用,我就不多讲了,网上很多这样的文章. 今天我们要谈的是MySQL服务器的部署 ...
- 如何在linux服务器部署Rstudio server,配置ODBC远程访问win 服务器上的SQL server
如何在linux服务器部署Rstudio server,配置ODBC后通过RODBC包远程访问SQL server 背景介绍:之前写过一篇文章,提到近期要部署Rstudio server(搭建数据分析 ...
- Linux服务器部署.Net Core笔记:目录
目录 Linux服务器部署.Net Core笔记:一.开启ssh服务 Linux服务器部署.Net Core笔记:二.安装FTP Linux服务器部署.Net Core笔记:三.安装.NetC ...
- 2019-08-28 redhat linux如何部署禅道服务器(一键安装包)
linux一键安装包内置了XXD.apache, php, mysql这些应用程序,不需要再单独安装部署. linux一键安装包分为32位和64位两个包,请大家根据操作系统的情况下载相应的包. 一.准 ...
- #阿里云#云服务器部署可道云(KodExplorer)
前言:在做一些项目的时候,经常有一些文档交流,修改之后的文档在QQ或微信上发来发去,还要下载,很是不爽,有一个挺有用的东西叫做KodExplorer可道云. kodexplorer可道云是目前国内有代 ...
随机推荐
- Biorhythms(poj 1006)
Description 人生来就有三个生理周期,分别为体力.感情和智力周期,它们的周期长度为23天.28天和33天.每一个周期中有一天是高峰.在高峰这天,人会在相应的方面表现出色.例如,智力周期的高峰 ...
- localStorag的一点见解
dot方法对localStorag方法进行键值操作 设值 localStorage.hello = 'world'; localStorage.zhangsan = 'lisi'; 取值: var v ...
- msp430项目编程46
msp430综合项目---监控系统46 1.电路工作原理 2.代码(显示部分) 3.代码(功能实现) 4.项目总结
- Yii 安装学习
(1)打开yii官方网站: http://www.yiichina.com (2)点击下载,跳转到下载页面: (3)找到从归档文件安装,新手学习,使用[ Yii2的基本应用程序模板]: (4)下载解压 ...
- asp.net MVC最简单的增删查改!(详)
折腾了两天搞出来,但原理性的东西还不是很懂,废话不多说上图上代码 然后右键models,新建一个数据模型 注意我添加命名为lianxi 添加后如上 接下来在controllers添加控制器还有在Vie ...
- hdu4848 求到达每个点总时间最短(sum[d[i]])。
开始的时候是暴力dfs+剪枝,怎么也不行.后来参考他人思想: 先求出每个点之间的最短路(这样预处理之后的搜索就可以判重返回了),截肢还是关键:1最优性剪枝(尽量最优:目前的状态+预计还有的最小时间&g ...
- bzoj 4457: 游戏任务
4457: 游戏任务 Time Limit: 10 Sec Memory Limit: 64 MBSubmit: 128 Solved: 71[Submit][Status][Discuss] D ...
- Junit4 断言新方法
话不多少说,直接上代码 package ASSERTTEST; import org.junit.Assert; import org.hamcrest.*;import org.junit.Test ...
- UICollectionView 使用 介绍
1.1. Collection View 全家福: UICollectionView, UITableView, NSCollectionView n 不直接等效于NSCollectionView ...
- 基于centos 创建一个stress镜像
最近需要学习docker的Cgroups机制,需要用到stress进行测试,前期工作就是自己创建一个stress镜像. 新建一个 Dockerfile 文件 [vagrant@localhost ~] ...