日志名称:          Application
来源:            Apache Service
日期:            2014/3/12 14:43:21
事件 ID:         3299
任务类别:          无
级别:            错误
关键字:           经典
用户:            暂缺
计算机:           USER-20140106PI
描述:
The Apache service named  reported the following error:
>>> Unable to open logs     .
事件 Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Apache Service" />
    <EventID Qualifiers="0">3299</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-03-12T06:43:21.000000000Z" />
    <EventRecordID>28004</EventRecordID>
    <Channel>Application</Channel>
    <Computer>USER-20140106PI</Computer>
    <Security />
  </System>
  <EventData>
    <Data>The Apache service named</Data>
    <Data>
    </Data>
    <Data>reported the following error:
&gt;&gt;&gt;</Data>
    <Data>Unable to open logs</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

日志名称:          Application
来源:            Apache Service
日期:            2014/3/12 14:43:21
事件 ID:         3299
任务类别:          无
级别:            错误
关键字:           经典
用户:            暂缺
计算机:           USER-20140106PI
描述:
The Apache service named  reported the following error:
>>> no listening sockets available, shutting down     .
事件 Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Apache Service" />
    <EventID Qualifiers="0">3299</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-03-12T06:43:21.000000000Z" />
    <EventRecordID>28003</EventRecordID>
    <Channel>Application</Channel>
    <Computer>USER-20140106PI</Computer>
    <Security />
  </System>
  <EventData>
    <Data>The Apache service named</Data>
    <Data>
    </Data>
    <Data>reported the following error:
&gt;&gt;&gt;</Data>
    <Data>no listening sockets available, shutting down</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

日志名称:          Application
来源:            Apache Service
日期:            2014/3/12 14:43:21
事件 ID:         3299
任务类别:          无
级别:            错误
关键字:           经典
用户:            暂缺
计算机:           USER-20140106PI
描述:
The Apache service named  reported the following error:
>>> (OS 10048)通常每个套接字地址(协议/网络地址/端口)只允许使用一次。  : make_sock: could not bind to address 0.0.0.0:80     .
事件 Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Apache Service" />
    <EventID Qualifiers="0">3299</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2014-03-12T06:43:21.000000000Z" />
    <EventRecordID>28002</EventRecordID>
    <Channel>Application</Channel>
    <Computer>USER-20140106PI</Computer>
    <Security />
  </System>
  <EventData>
    <Data>The Apache service named</Data>
    <Data>
    </Data>
    <Data>reported the following error:
&gt;&gt;&gt;</Data>
    <Data>(OS 10048)通常每个套接字地址(协议/网络地址/端口)只允许使用一次。  : make_sock: could not bind to address 0.0.0.0:80</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

很难从给出的信息中发现有用的东西,
让你不知道是哪出了问题,幸好通常你不会是第一个碰到这个问题的人,又幸好有度娘。
 
今天一开机,Apache就不能启动了,结果在Event Viewer中看到说: Unable to open logs
不知道是什么意思。
 
经过一番搜索,才知道,如果Apache默认的80端口被占用才会报这个错,
 
解决的办法很简单:
用netstat -ano查看Local Address中Listening 80的应用的PID, 去任务管理器中找到对应的进程,关闭此进程即可。
 
我这边发现的进程居然是一个叫skype的进程占了,也不知道它监听80端口干嘛,看起来有点古怪。

Apache不能启动: Unable to open logs的更多相关文章

  1. 【转】Windows10下80端口被PID为4的System占用导致Apache无法启动的分析与解决方案

    昨天刚更新了Windows10,总体上来说效果还是蛮不错的,然而今天在开启Apache服务器的时候却发现,Apache莫名其妙的打不开了,起初以为是权限的问题,于是使用管理员身份的控制台去调用命令ne ...

  2. linux下apache无法启动之(httpd not running, trying to st)

    这突然接手的服务器,本来是没什么事的,可是因为机房的问题,需要将服务器迁回来,结果可想而知,关机重启了,其中有一台估计诚心给我过不去,待配置好ip并重启了服务后,发现apache无法正常启动了! 先还 ...

  3. Win10下80端口被System占用导致Apache无法启动

    Windows10下80端口被PID为4的System占用导致Apache无法启动的分析与解决方案 方法/步骤     最近更新了Windows10,总体上来说效果还是蛮不错的,然而今天在开启Apac ...

  4. org.apache.jasper.JasperException: Unable to compile class for JSP

    项目启动时报错 : The method getJspApplicationContext(ServletContext) is undefined for the type JspFactory S ...

  5. 80端口未占用,apache无法启动解决办法

    网上很多关于apache无法启动的原因,新手遇到最多的是80端口被占用. 今天为了解决apache和tomcat端口共存问题,修改了httpd.conf的配置,由于增加位置没有做明显标识,重启apac ...

  6. apache无法启动报错No space left on device

    apache无法启动报错No space left on device 故障现象:apache无法启动ipcs信号量很多 # service httpd startStarting httpd : [ ...

  7. zookeeper无法启动"Unable to load database on disk

    QuorumPeerMain,ResourceManager都没有起来 resourcemanager.log如下 2018-09-28 23:17:02,787 FATAL org.apache.h ...

  8. maven web报错:org.apache.jasper.JasperException: Unable to compile class for JSP

    原博文地址:https://blog.csdn.net/ken1583096683/article/details/80837281 maven web项目启动没问题,访问页面就报错:org.apac ...

  9. apache服务器启动时提示httpd: apr_sockaddr_info_get() failed for

    apache服务器启动时提示httpd: apr_sockaddr_info_get() failed for 在RedHat Linux 5 与 CentOS 5服务器上配置好apache后,启动或 ...

随机推荐

  1. java es 骤合操作

    ElasticSearch java API - 聚合查询 以球员信息为例,player索引的player type包含5个字段,姓名,年龄,薪水,球队,场上位置.index的mapping为: &q ...

  2. Gradle项目构建(1)——Gradle的由来

    一.项目自动构建介绍 作为Java的开发者对eclipse都非常熟悉,其实eclipse就是居于ant来构建项目的,我们先来看看为什么需要自动化构建项目. 1.为什么我们要自动化构建项目 可以假设我们 ...

  3. {Linux} boot仅剩余XX字节

    1. 查看已安装的linux-image各版本 dpkg --get-selections |grep linux-image   2. 查看我们当前使用的是哪一个版本: uname -a    3. ...

  4. CF Gym 100187B A Lot of Joy (古典概型)

    题意:给两个一样的只含有26个小写字母的字符串,然后两个分别做一下排列,问如果对应位置的字母相等那么就愉悦值就加一,问愉悦值的期望是多少? 题解:只考虑两个序列相对的位置,那么就相当于固定一个位置,另 ...

  5. 2017年团体程序设计天梯赛 - 大区赛 L3-3

    题意:有向图找哈密顿回路 比赛的时候剪枝只剪了vis 状压没剪对 反而只拿17分... 比赛结束后还去看了一发这个NP问题的QB(快速回溯法...但是对于本题好像大材小用...) 上网看了一个神犇的写 ...

  6. JsonPath 语法 与 XPath 对比

    JsonPath 语法 与 XPath 对比   XPath JSONPath Description / $ the root object/element . @ the current obje ...

  7. java HashMap 内存泄漏

    import java.util.HashMap; import java.util.Map; public class HashMapOver { public static void main(S ...

  8. Mybatis中关于OGNL表达式冲突

    注意设计表字段不能用bor  xor  and  band  eq  neq  lt  gt  lte  gte  shl  shr  ushr

  9. PAT (Basic Level) Practise (中文)- 1008. 数组元素循环右移问题 (20)

    一个数组A中存有N(N>0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(M>=0)个位置,即将A中的数据由(A0A1……AN-1)变换为(AN-M …… AN-1 A0  ...

  10. Java(面试题):字符串截取

    在Java中,字符串“abcd”与字符串“ab你好”的长度是一样,都是四个字符. 但对应的字节数不同,一个汉字占两个字节. 定义一个方法,按照指定的字节数来取子串. 如:对于“ab你好”,如果取三个字 ...