zk启动报错

解决办法,进入zkdata目录删除version-2下面的所有文件

参考:

https://issues.apache.org/jira/browse/ZOOKEEPER-1546

[hadoop@slave1 bin]$ cat zookeeper.out
2017-09-06 20:38:53,468 [myid:] - INFO [main:QuorumPeerConfig@134] - Reading configuration from: /usr/local/zookeeper/zookeeper-3.4.10/bin/../conf/zoo.cfg
2017-09-06 20:38:53,486 [myid:] - INFO [main:QuorumPeer$QuorumServer@167] - Resolved hostname: slave3 to address: slave3/192.168.1.198
2017-09-06 20:38:53,487 [myid:] - INFO [main:QuorumPeer$QuorumServer@167] - Resolved hostname: slave2 to address: slave2/192.168.1.197
2017-09-06 20:38:53,487 [myid:] - INFO [main:QuorumPeer$QuorumServer@167] - Resolved hostname: slave1 to address: slave1/192.168.1.196
2017-09-06 20:38:53,487 [myid:] - INFO [main:QuorumPeerConfig@396] - Defaulting to majority quorums
2017-09-06 20:38:53,490 [myid:1] - INFO [main:DatadirCleanupManager@78] - autopurge.snapRetainCount set to 3
2017-09-06 20:38:53,490 [myid:1] - INFO [main:DatadirCleanupManager@79] - autopurge.purgeInterval set to 0
2017-09-06 20:38:53,490 [myid:1] - INFO [main:DatadirCleanupManager@101] - Purge task is not scheduled.
2017-09-06 20:38:53,501 [myid:1] - INFO [main:QuorumPeerMain@127] - Starting quorum peer
2017-09-06 20:38:53,509 [myid:1] - INFO [main:NIOServerCnxnFactory@89] - binding to port 0.0.0.0/0.0.0.0:2181
2017-09-06 20:38:53,526 [myid:1] - INFO [main:QuorumPeer@1134] - minSessionTimeout set to -1
2017-09-06 20:38:53,526 [myid:1] - INFO [main:QuorumPeer@1145] - maxSessionTimeout set to -1
2017-09-06 20:38:53,526 [myid:1] - INFO [main:QuorumPeer@1419] - QuorumPeer communication is not secured!
2017-09-06 20:38:53,526 [myid:1] - INFO [main:QuorumPeer@1448] - quorum.cnxn.threads.size set to 20
2017-09-06 20:38:53,529 [myid:1] - INFO [main:FileSnap@83] - Reading snapshot /home/hadoop/zookeeper/zkdata/version-2/snapshot.400000000
2017-09-06 20:38:53,890 [myid:1] - ERROR [main:Util@239] - Last transaction was partial.
2017-09-06 20:38:53,896 [myid:1] - ERROR [main:QuorumPeer@648] - Unable to load database on disk
java.io.IOException: The current epoch, 12, is older than the last zxid, 81604378626
at org.apache.zookeeper.server.quorum.QuorumPeer.loadDataBase(QuorumPeer.java:630)
at org.apache.zookeeper.server.quorum.QuorumPeer.start(QuorumPeer.java:591)
at org.apache.zookeeper.server.quorum.QuorumPeerMain.runFromConfig(QuorumPeerMain.java:164)
at org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPeerMain.java:111)
at org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:78)
2017-09-06 20:38:53,899 [myid:1] - ERROR [main:QuorumPeerMain@89] - Unexpected exception, exiting abnormally
java.lang.RuntimeException: Unable to run quorum server
at org.apache.zookeeper.server.quorum.QuorumPeer.loadDataBase(QuorumPeer.java:649)
at org.apache.zookeeper.server.quorum.QuorumPeer.start(QuorumPeer.java:591)
at org.apache.zookeeper.server.quorum.QuorumPeerMain.runFromConfig(QuorumPeerMain.java:164)
at org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPeerMain.java:111)
at org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:78)
Caused by: java.io.IOException: The current epoch, 12, is older than the last zxid, 81604378626
at org.apache.zookeeper.server.quorum.QuorumPeer.loadDataBase(QuorumPeer.java:630)
... 4 more

zookeeper启动错误 ---- Unable to load database on disk的更多相关文章

  1. zookeeper无法启动"Unable to load database on disk"

    自己的虚拟机集群.一次强制关机后,发现slave2的zookeeper起不来了 http://blog.csdn.net/ashic/article/details/47088299 下午5点29:5 ...

  2. zookeeper无法启动"Unable to load database on disk

    QuorumPeerMain,ResourceManager都没有起来 resourcemanager.log如下 2018-09-28 23:17:02,787 FATAL org.apache.h ...

  3. Linux x64 Hadoop-2.4.1配置-解决错误Unable to load native-hadoop library for your platform

    网上配置hadoop的教程一堆,各不尽相同,但没有一个是完整系统的. 下面给出遇到的错误的解决方法,相信能解决很多人的问题. 错误:Exception in thread "main&quo ...

  4. zookeeper启动错误 transaction type: 2 error: KeeperErrorCode = NoNode for /hbase

    hbase伪分布式,与zookeeper同一台机器的时候,运行一段时间,启动zookeeper的时候,日志中有如下错误,导致无法启动zookeeper java.io.IOException: Fai ...

  5. 忘记导入struts2-xxx-plugin-x.x.x.jar导致服务器启动报Unable to load configuration.Caused by: Parent package is not defined: xxx-default

    今天做的一个Struts2+MyFaces(JSF)+Spring的应用,为了使用JSF,我的struts.xml中使用了如下代码 <package name="jsf" e ...

  6. Zookeeper 启动错误

    启动后日志如下 : 2016-09-14 05:51:19,449 [myid:1] - INFO [QuorumPeer[myid=1]/0:0:0:0:0:0:0:0:2181:FastLeade ...

  7. Eclipse的SVN插件提示:验证验证位置时发生错误:"Unable to load default SVN Client“解决

    这个原因是你的机器上没有 JAVAHL 这个包, 这个是另外的一个开源组件, 所以, 在trigis的svn插件发行版里面没有这个东西,下载装上就是, 这个包在不同的系统上, 有不同的情况...详情见 ...

  8. zookeeper启动入口

    最近正在研究zookeeper,一些心得记录一下,如有错误,还请大神指正. zookeeper下载地址:http://zookeeper.apache.org/releases.html,百度一下就能 ...

  9. zookeeper源码学习一——zookeeper启动

    最近正在研究zookeeper,一些心得记录一下,如有错误,还请大神指正. zookeeper下载地址:http://zookeeper.apache.org/releases.html,百度一下就能 ...

随机推荐

  1. (转)myeclipse工程 junit不能运行 ClassNotFoundException

    博文转自:http://www.cnblogs.com/java-zone/articles/2730722.html myeclipse工程   junit不能运行 1 2 3 4 5 6 7 8 ...

  2. MAP的get与containskey

    前提是:Map可以出现在k与v的映射中,v为null的情况, 所以containsKey出现更加必要. map.get(key)是得到的key所对应的value值. map.contains(key) ...

  3. Redis安装 java中的连接 序列化 反序列化

    安装路径 /webapp/redis/redis- #启动redis /webapp/redis/redis-/src/redis-server & #关闭redis /webapp/redi ...

  4. Java并发容器--ConcurrentHashMap

    引子 1.不安全:大家都知道HashMap不是线程安全的,在多线程环境下,对HashMap进行put操作会导致死循环.是因为多线程会导致Entry链表形成环形数据结构,这样Entry的next节点将永 ...

  5. 关于each()、find()、filter()遍历节点的操作方法

    关于each().find().filter()遍历节点的操作方法 each语法: each(fn)  ; 返回值:jQuery fn:代表对于每个匹配元素所要执行的函数 each()方法共有三种形式 ...

  6. WinForm Control.Invoke&Control.BeginInvoke异步操作控件实例

    参考:http://www.cnblogs.com/yuyijq/archive/2010/01/11/1643802.html 效果图: 实例(实验)代码: using System; using ...

  7. Centos下zabbix部署(二)agent安装并设置监控

    1.配置zabbix源 rpm -ivh http://repo.zabbix.com/zabbix/3.0/rhel/7/x86_64/zabbix-release-3.0-1.el7.noarch ...

  8. hdu 1598(最小生成树)

    find the most comfortable road Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K ...

  9. Android 之 AlarmManager(定时器) 的介绍和使用

    AlarmManager 包含的主要方法: // 取消已经注册的与参数匹配的定时器 void cancel(PendingIntent operation) //注册一个新的延迟定时器void set ...

  10. 有关时间限制使用和软件注册的设计(delphi)

    http://blog.sina.com.cn/s/blog_693cf1cf0100oyus.html procedure TForm1.form1create(Sender: TObject);v ...