#



# Some examples:



#ErrorDocument 500 "The server made a boo boo."



#ErrorDocument 404 /missing.html



#ErrorDocument 404 "/cgi-bin/missing_handler.pl"



#ErrorDocument 402
http://www.example.com/subscription_info.html



#



 



#



# MaxRanges: Maximum number of Ranges in a request before



# returning the entire resource, or one of the special



# values 'default', 'none' or 'unlimited'.



# Default setting is to accept 200 Ranges.



#MaxRanges unlimited



 



#



# EnableMMAP and EnableSendfile: On systems that support
it, 



# memory-mapping or the sendfile syscall may be used to
deliver



# files.  This usually improves server
performance, but must



# be turned off when serving from
networked-mounted 



# filesystems or if support for these functions is otherwise



# broken on your system.



# Defaults: EnableMMAP On, EnableSendfile Off



#



#EnableMMAP off



EnableSendfile



off



 



# AcceptFilter: On Windows, none uses accept() rather than
AcceptEx() and



# will not recycle sockets between connections. This is useful for
network



# adapters with broken driver support, as well as some virtual
network



# providers such as vpn drivers, or spam, virus or spyware
filters.



AcceptFilter



http none



AcceptFilter



https none



 



# Supplemental configuration



#



# The configuration files in the conf/extra/ directory can
be 



# included to add extra features or to modify the default
configuration of 



# the server, or you may simply copy their contents here and change
as 



# necessary.



 



# Server-pool management (MPM specific)



#Include conf/extra/httpd-mpm.conf



 



# Multi-language error messages



#Include conf/extra/httpd-multilang-errordoc.conf



 



# Fancy directory listings



Include



conf/extra/httpd-autoindex.conf



 



# Language settings



#Include conf/extra/httpd-languages.conf



 



# User home directories



#Include conf/extra/httpd-userdir.conf



 



# Real-time info on requests and configuration



#Include conf/extra/httpd-info.conf



 



# Virtual hosts



#Include conf/extra/httpd-vhosts.conf



 



# Local access to the Apache HTTP Server Manual



#Include conf/extra/httpd-manual.conf



 



# Distributed authoring and versioning (WebDAV)



#Include conf/extra/httpd-dav.conf



 



# Various default settings



#Include conf/extra/httpd-default.conf



 



# Configure mod_proxy_html to understand HTML4/XHTML1







proxy_html_module>



Include



conf/extra/proxy-html.conf







 



# Secure (SSL/TLS) connections



#Include conf/extra/httpd-ssl.conf



#



# Note: The following must must be present to support



#      
starting without SSL on platforms with no /dev/random
equivalent



#      
but a statically compiled-in mod_ssl.



#







ssl_module>



SSLRandomSeed



startup builtin



SSLRandomSeed



connect builtin







#



# uncomment out the below to deal with user agents that
deliberately



# violate open standards by misusing DNT (DNT *must* be a
specific



# end-user choice)



#



#



#BrowserMatch "MSIE 10.0;" bad_DNT



#



#



#RequestHeader unset DNT env=bad_DNT



#



 



 



#IncludeOptional "c:/wamp/vhosts/*"



Include



"c:/wamp/alias/*"

如何解决wamp中apache外部IP访问问题的更多相关文章

  1. SQL Server不能通过外部IP访问,解决方法

    SQL Server不能通过外部IP访问,解决方法   版本:SQL server 2008 express with tools   打开配置管理器,开启 TCP,右键属性设置TCP端口:   设置 ...

  2. 解决mysql中只能通过localhost访问不能通过ip访问的问题

    解决mysql中只能通过localhost访问不能通过ip访问的问题 原因是没开权限 SELECT * FROM USER WHERE USER='root'; grant all privilege ...

  3. Apache禁止ip访问

    网站突然让禁止ip访问,于是就通过配置Apache达到了想要的效果. 我们网站用的是Apache+tomcat集群,所以需要配置虚拟主机,虚拟主机我在这里就不说了,不明白的上网搜搜吧,这里只说禁止ip ...

  4. linux服务器NAT后无法在内网通过外部IP访问内部服务的问题

    场景一: 将外网访问192.168.100.10的80端口转发到192.168.75.5:8000端口. # iptables -t nat -A PREROUTING -d 192.168.100. ...

  5. CentOS7上解决tomcat不能被外部浏览访问的问题?

    在linux上开启的tomcat使用浏览器访问不了.主要原因在于防火墙的存在,导致的端口无法访问. CentOS7使用firewall而不是iptables.所以解决这类问题可以通过添加firewal ...

  6. apache禁止IP访问网站

    参考资料: http://www.cnblogs.com/zhuangge/archive/2011/04/13/2014892.html 先引用一下上面资料的内容: 用apache搭建的WEB服务器 ...

  7. Apache 禁用IP 访问 和 HTTP 跳转 HTTPS

    如果需要 禁用IP 访问并且 需要 HTTP 跳转到 HTTPS <VirtualHost *:80> ServerName xxx.xxx.com RewriteEngine On Re ...

  8. 解决wamp的Apache服务器不能重启

    由于工作需要,现在开始研究PHP语言.刚开始搭建服务器环境就困难重重啊.首先看了下配置说明,很复杂很复杂(超级想念Visual Studio).然后问了下群里的老鸟,他们都是安装WAMPServer环 ...

  9. 解决xmapp中Apache端口号占用问题

    [原]解决 "安装xmapp后Apache不能正常启动" 问题 小伙伴们安装xmapp后发现Apache不能正常开启,下面给出了不同情况的解决办法,可以分为以下几种情况分析问题: ...

随机推荐

  1. Java 反编译工具下载

    反编译,通俗来讲,就是将.java 文件经过编译生成的 .class 文件还原.注意这里的还原不等于 .java 文件.因为Java编译器在编译.java 文件的时候,会对代码进行一些处理. 那么接下 ...

  2. js获取样式、currentStyle和getComputedStyle的兼容写法

    currentStyle获取计算后的样式,也叫当前样式.最终样式.优点:可以获取元素的最终样式,包括浏览器的默认值,而不像style只能获取行间样式,所以更常用到.注意:不能获取复合样式如backgr ...

  3. js遍历 子节点 子元素

    Js 节点 子元素 属性 方法 // 添加子节点前 删除所有子节点 var usernameEle = document.getElementById("username"); v ...

  4. C程序设计语言(第二版)--- 习题选

    1. 解: 2. 解: 3. (分析的好有条理啊!) 4. 解:

  5. Python day 3 (3)

    一:判断语句: 1  if 语句 : 2  或者if 语句 : else : 3  或者if 语句 : elif 语句 : else : 4注意:的使用,缩进一般用4个空格来完成. 二:input 语 ...

  6. Python之旅本地环境搭建

    刚开始学习Python, 之后将会把Python相关的一些学习在此记录下来 . 毋庸置疑 ,我们需要先搭建本地开发环境, 为之后的Python开发做准备 ,这篇文章 ,将环境的搭建记录下来 第一步: ...

  7. opacity的背景透明&background中rgba的背景色透明

    近期使用css实现了一个loading旋转加载的图片效果,类似gif动画 过程中,需要透明背景,但是图片不要透明 只要背景透明!只要背景透明!只要背景透明! 这里对透明模糊了,两种写法,模糊了 A: ...

  8. Spring框架入门之开发环境搭建(MyEclipse2017平台)

    基于MyEclipse2017平台搭建Spring开发环境,这里MyEclipse已将Spring集成好了,我们只需要做一简单配置即可 一.环境配置 OS:Windows7 64位 IDE工具:MyE ...

  9. shader程序员需要注意的优化Tips

    在写shader的时候,其实一些写法对于其执行影响非常大,而且由于gpu和cpu在架构上的不同,代码的优化思想也不一样,最近一直在写几个shader,为了性能问题,查阅了很多资料,把一些tips总结下 ...

  10. 生成器&迭代器

    通过列表生成式,我们可以快速创建一个列表,但是受到内存的限制,列表容量是有限的,而且一个包含100万个元素的列表不仅占用很大的存储空间,如果我们仅仅需要访问当前几个元素,那后面绝大多数元素占用的空间都 ...