oracle@WWJD-DB1:~> $ORACLE_HOME/bin/srvctl start database -d ndscdb
PRCR-1079 : Failed to start resource ora.ndscdb.db
CRS-5017: The resource action "ora.ndscdb.db start" encountered the following error:
ORA-00443: background process "LMD1" did not start
. For details refer to "(:CLSN00107:)" in "/oracle/app/grid/diag/crs/WWJD-db1/crs/trace/crsd_oraagent_oracle.trc". CRS-2674: Start of 'ora.ndscdb.db' on 'WWJD-db1' failed
CRS-2632: There are no more servers to try to place resource 'ora.ndscdb.db' on that would satisfy its placement policy
--alert.log
Starting background process LMD1
2019-01-28T01:29:19.181299-08:00
Process startup failed, error stack:
2019-01-28T01:29:19.181569-08:00
Errors in file /oracle/app/oracle/diag/rdbms/ndscdb/NDSCDB1/trace/NDSCDB1_psp0_148992.trc:
ORA-27300: OS system dependent operation:fork failed with status: 11
ORA-27301: OS failure message: Resource temporarily unavailable
ORA-27302: failure occurred at: skgpspawn3
2019-01-28T01:29:19.181989-08:00
* Load Monitor used for high load check
* New Low - High Load Threshold Range = [61440 - 81920]
2019-01-28T01:29:19.184921-08:00
LMS0 started with pid=24, OS id=149071 at elevated (RT) priority
2019-01-28T01:29:19.186634-08:00
LMS2 started with pid=26, OS id=149075 at elevated (RT) priority
2019-01-28T01:29:19.187214-08:00
LMS1 started with pid=25, OS id=149073 at elevated (RT) priority
2019-01-28T01:29:19.187425-08:00
LMS3 started with pid=27, OS id=149077 at elevated (RT) priority
2019-01-28T01:29:20.180278-08:00
Process LMD1 died, see its trace file
2019-01-28T01:29:20.182144-08:00
USER (ospid: 148922): terminating the instance due to error 443
2019-01-28T01:29:21.228555-08:00
Instance terminated by USER, pid = 148922
--trace
oracle@WWJD-DB1:~> more /oracle/app/oracle/diag/rdbms/ndscdb/NDSCDB1/trace/NDSCDB1_psp0_148992.trc
Trace file /oracle/app/oracle/diag/rdbms/ndscdb/NDSCDB1/trace/NDSCDB1_psp0_148992.trc
Oracle Database 12c Enterprise Edition Release 12.2.0.1.0 - 64bit Production
Build label: RDBMS_12.2.0.1.0_LINUX.X64_170125
ORACLE_HOME: /oracle/app/oracle/product/12.2.0/db_1
System name: Linux
Node name: WWJD-DB1
Release: 4.4.162-94.69-default
Version: #1 SMP Mon Nov 5 18:58:52 UTC 2018 (9e06c56)
Machine: x86_64
Instance name: NDSCDB1
Redo thread mounted by this instance: 0 <none>
Oracle process number: 4
Unix process pid: 148992, image: oracle@WWJD-DB1 (PSP0) *** 2019-01-28T01:29:17.870458-08:00
*** CLIENT ID:() 2019-01-28T01:29:17.870482-08:00
*** SERVICE NAME:() 2019-01-28T01:29:17.870488-08:00
*** MODULE NAME:() 2019-01-28T01:29:17.870493-08:00
*** ACTION NAME:() 2019-01-28T01:29:17.870501-08:00
*** CLIENT DRIVER:() 2019-01-28T01:29:17.870506-08:00 [kji_attach][LMON !running, !call kjual]
*** SESSION ID:(2065.45615) 2019-01-28T01:29:19.181339-08:00
*** SERVICE NAME:() 2019-01-28T01:29:19.181353-08:00 *** 2019-01-28T01:29:19.181318-08:00
Process startup failed, error stack:
ORA-27300: OS system dependent operation:fork failed with status: 11
ORA-27301: OS failure message: Resource temporarily unavailable
ORA-27302: failure occurred at: skgpspawn3
OS - DIAGNOSTICS
----------------
loadavg : 0.32 0.51 0.63
Memory (Avail / Total) = 497616.35M / 515669.59M
Swap (Avail / Total) = 65536.00M / 65536.00M
Max user processes limits(s / h) = 65536 / 65536
----------------
oracle@WWJD-DB1:~>
  • 诊断 ORA-27300 ORA-27301 ORA-27302 错误 (文档 ID 2179478.1)
  • ORA-27300 OS system dependent operation:fork failed with status: 11 (文档 ID 392006.1)
  • 在 Unix AIX,HP-UX,Linux,Solaris 和 MS Windows 操作系统上安装和配置 Oracle 数据库(RDBMS)的要求的快速参考(12.1/12.2) (文档 ID 2226599.1)
--Oracle要求
Shell limits Soft File Descriptors 最少 1024
Hard File Descriptors 最少 65536
Soft FILE size -1 (Unlimited)
Soft CPU time -1 (Unlimited)
Soft DATA segment -1 (Unlimited)
Soft STACK size -1 (Unlimited)
Number of processes (Soft) 最少 2047
Number of processes (Hard) 最少 16384
maxuprocs 16384 oracle@WWJD-DB1:~> cat /etc/security/limits.conf
grid soft nproc 2047
grid hard nproc 16384
grid soft nofile 1024
grid hard nofile 65536
grid soft stack 10240
grid hard stack 32768 oracle soft nproc 2047
oracle hard nproc 16384
oracle soft nofile 1024
oracle hard nofile 65536
oracle soft stack 10240
oracle hard stack 32768 # End of file
* - nofile 102400
* - nproc 148270
#Oracle recommended value for memlock is set to 3145728 for user oracle
oracle hard memlock 3145728
#Oracle recommended value for memlock is set to 3145728 for user oracle
oracle soft memlock 3145728
oracle@WWJD-DB1:~> ulimit -a
core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
scheduling priority (-e) 0
file size (blocks, -f) unlimited
pending signals (-i) 2062592
max locked memory (kbytes, -l) 3145728
max memory size (kbytes, -m) unlimited
open files (-n) 1024
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority (-r) 0
stack size (kbytes, -s) 10240
cpu time (seconds, -t) unlimited
max user processes (-u) 2047
virtual memory (kbytes, -v) unlimited
file locks (-x) unlimited
oracle@WWJD-DB1:~>

后来发现是由于在SUSE 12sp3上存在的问题,或者说是在Linux上会存在的问题,参考MOS

1.Database And ASM Instance Ora-27300 OS System Dependent Operation Fork Failed With Status 11 (文档 ID 2331884.1)
2.SLES 12: Database Startup Error with ORA-27300 ORA-27301 ORA-27303 While Starting using Srvctl (文档 ID 2340986.1)

可以看https://www.cnblogs.com/wwjd365/p/10370797.html

最终的解决方案是需要修改OS层的参数

ORA-27300 ORA-27301 ORA-27302 skgpspawn3 CRS-2674的更多相关文章

  1. Oracle启动中,spfile.ora、init<SID>.ora、spfile<SID>.ora 这三个文件正确的先后顺序是什么?

    Oracle启动中,spfile.ora.init<SID>.ora.spfile<SID>.ora 这三个文件正确的先后顺序是什么? 解答:启动数据库,使用startup命令 ...

  2. oracle--本地网络配置tnsnames.ora和监听器listener.ora

    文件tnsnames.ora 是给orcl客户端使用 配置本地网络服务:(客户端) 第一种使用暴力方式直接操作: 修改:C:\app\Administrator\product\11.2.0\dbho ...

  3. Oracle的tnsnames.ora配置(PLSQL Developer)

    首先打开tnsnames.ora的存放目录,一般为D:\app\Administrator\product\11.2.0\client_1\network\admin,就看安装具体位置了. 步骤阅读 ...

  4. listener.ora/sqlnet.ora/tnsnames.ora配置文件详解

    oracle网络配置 三个配置文件 listener.ora.sqlnet.ora.tnsnames.ora ,都是放在$ORACLE_HOME/network/admin目录下. 英文说明: The ...

  5. Oracle的sqlnet.ora与password文件试验

    先看有没有sqlnet.ora [oracle@localhost ~]$ cd $ORACLE_HOME[oracle@localhost dbhome_1]$ cd network[oracle@ ...

  6. 转载《Oracle的tnsnames.ora配置(PLSQL Developer)》

    源地址:https://www.cnblogs.com/qq3245792286/p/6212617.html. 首先打开tnsnames.ora的存放目录,一般为D:\app\Administrat ...

  7. [转帖]sqlnet.ora常用参数

    sqlnet.ora常用参数 注﹕在修改sqlnet.ora文件之后重新启动监听﹐修改才能生效﹗﹗﹗ oracle网络设置主要包括三个文件,sqlnet.ora\ lisnter.ora\ tnsna ...

  8. PLSQL连接ORACLE配置字符串简介 oracle网络配置 三个配置文件 listener.ora、sqlnet.ora、tnsnames.ora原理解释

    PLSQL连接ORACLE配置字符串简介 oracle网络配置 三个配置文件 listener.ora.sqlnet.ora.tnsnames.ora原理解释 oracle网络配置三个配置文件 lis ...

  9. oracle安装完成后目录中不论有没有tnsnames.ora和listener.ora文件 PLSQL都能连上的问题解决方法

    今天遇到这个问题了,发现listener.ora文件和tnsnames.ora文件在Net Work文件夹下没有,正常情况下安装完oracle或者是oracle Client是会有的,但是在Net M ...

  10. oracle: listener.ora 、sqlnet.ora 、tnsnames.ora的配置及例子

    1.解决问题:TNS或者数据库不能登录.      最简单有效方法:使用oracle系统提供的工具 netca 配置(把原来的删除掉重新配置)     $netca  2.然而,仍有疑问:如何指定'l ...

随机推荐

  1. 关于 win10 系统中 Anaconda3 中修改 Jupyter Notebook 默认启动目录

    目标: 修改Anaconda3中自带的Jupyter Notebook默认启动目录. 步骤:     1.提前创建好你想要启动位置文件夹.     2.寻找配置文件,"jupyter_not ...

  2. MongoDB 及 scrapy 应用

    0 1.Scrapy 使用 MongoDB https://doc.scrapy.org/en/latest/topics/item-pipeline.html#write-items-to-mong ...

  3. Python-读文件

    用python读一个文件,我们一般采用  open('文件名字')这里的文件名可以说完整路径也可以是相对路径(要读取的文件和和代码放在一起) f = open('data.txt')此时我们只是打开了 ...

  4. [nodemon] clean exit - waiting for changes before restart

    出现上述日志信息,程序就不能往下运行了. 原因:node程序在初始化的时候就报错了,仔细debug吧...

  5. Android Studio帮助文档的安装及智能提示设置

    初次使用Android Studio,发现其智能提示不能像Visual Studio一样显示系统方法等的详细用途描述.经查找资料,问题原因是未安装SDK Document. 解决办法如下: 1.打开如 ...

  6. org.hibernate.exception.SQLGrammarException: could not extract ResultSet &&&&&Incorrect syntax near '@P0'.

    这个故障的原因比较多: 1.如数据库中的字段和类中的字段类型不一致: 2.数据库dialect不够具体 myeclispe自动生成的是  org.hibernate.dialect.SQLServer ...

  7. Linux下的文件切割和文件合并

    linux下文件分割可以通过split命令来实现,可以指定按行数分割和按大小分割两种模式.Linux下文件合并可以通过cat命令来实现. 在Linux下用split进行文件分割: ①:指定分割后文件行 ...

  8. CentOS7.0安装Nginx 1.7.4

    一.安装准备 首先由于nginx的一些模块依赖一些lib库,所以在安装nginx之前,必须先安装这些lib库,这些依赖库主要有g++.gcc.openssl-devel.pcre-devel和zlib ...

  9. linux权限字母的含义

    无 --- 只能列出文件 r-- 访问文件 r-x 创建和删除文件 rwx

  10. 如何使用mybatis插入数据之前就具生成id值

    SelectKey在Mybatis中是为了解决Insert数据时不支持主键自动生成的问题,该功能可以很随意的设置生成主键的方式. 不管SelectKey有多好,尽量不要遇到这种情况吧,毕竟很麻烦. k ...