Zabbix安装 Grafana安装
每天学习一点点 编程PDF电子书免费下载: http://www.shitanlife.com/code
前提: 先需要安装好 lamp环境。
官方文档: https://www.zabbix.com/documentation/3.4/zh/manual/installation/install
1)安装
1.Zabbix server
1) 下载源代码归档,解压
tar -zxvf zabbix-3.4.3.tar.gz
2) 创建用户账户:zabbix-server
3) 创建Zabbix数据库,导入数据库内容,数据库脚本在源码目录里面有,需要按顺序进行导入(mysql)
4) 配置源代码,进入源码目录
./configure --enable-server --with-mysql --with-net-snmp
5) 安装组件
make install
6) 查看和编辑配置文件
/usr/local/etc/zabbix_server.conf
指定数据库名称,用户名和密码
7) 启动
zabbix_server
2.Zabbix_agent
1) 下载源代码归档,解压
tar -zxvf zabbix-3.4.3.tar.gz
2) 创建用户账户zabbix-agent
3) 配置源代码,安装,进入源码目录
./configure --enable-agent
4) 安装组件
make install
5) 查看和编辑配置文件
/usr/local/etc/zabbix_agentd.conf
指定Zabbix server的 IP地址
1.Hostname
主机名,必须唯一,区分大小写。Hostname必须和zabbix web上配置的一直,否则zabbix主动监控无法正常工作。
2.Server
zabbix server的ip地址,多个ip使用逗号分隔
3.SourceIP
zabbix对外连接的出口IP地址
6) 启动
su - zabbix-agent
zabbix_agentd
2)前端设置
参考:http://www.cnblogs.com/yyhh/archive/2015/09/08/4792830.html
前端地址: http://192.168.102.116/zabbix Admin / zabbix
登录成功后,设置语言 Administrator-User,点击某个用户,选择中文语言;
如果没有中文选项,则需要修改源码了。3.4版本已经默认开启了中文支持,可以选择
配置-主机-创建主机(创建尽量从原始主机拷贝,因为已经配置了监控项的)
3)根据官方文档安装时报错:
1. MySQL library not found (参考 http://blog.csdn.net/wellto/article/details/31794829)
ln -s /usr/lib64/mysql/libmysqlclient.so.16.0.0 /usr/lib/libmysqlclient.so
2.Unable to use libevent (libevent check failed) (参考: http://www.cnblogs.com/kunhu/p/3632225.html)
yum -y install libevent-devel
3. 192.168.102.116/10051/zabbix-server
配置文件:
/usr/local/etc/zabbix_server.conf
/usr/local/etc/zabbix_agentd.conf
zabbix_get -s 192.168.102.116 -p 10050 -k"net.tcp.service[ftp]"
4. Resource interpreted as Stylesheet but transferred with MIME type text/plain
zabbix 源码修改 /var/www/html/zabbix/include/classes/html/pageheader 去掉 <!DOCTYPE html>输出
这个错误可能在某些服务器上出现,也可能不出现,样式问题
4)其他
停止服务:
killall zabbix_server 杀掉所有进程
启动: zabbix_server
zabbix_agentd
卸载:
1.找到相关sbin,删除掉
2.找到相关目录及文件,删除掉
3.杀进程
三、Grafana安装
在ZabbixServer服务器上,安装Grafana 参考: http://docs.grafana.org/installation/rpm/
service grafana-server start(默认是sqlite数据库)
grafana安装:
1.yum install https://s3-us-west-2.amazonaws.com/grafana-releases/release/grafana-4.5.2-1.x86_64.rpm
(rpm安装方式: rpm -Uvh grafana-4.5.2-1.x86_64.rpm)
配置文件: /etc/grafana/grafana.ini
日志:/var/log/grafana/grafana.log
源码安装目录: /usr/share/grafana
默认sqlite数据库: /var/lib/grafana/grafana.db
配置文件修改:
http_addr 这个放开,默认空,允许所有地址访问;如果配置了某个域名或IP,就只允许该配置的地址访问
port 端口
1.安装grafana-zabbix插件
官方安装方式:grafana-cli plugins install alexanderzobnin-zabbix-app
http://192.168.102.116:3001
2.启动,设置开机启动
service grafana-server start
chkconfig grafana-server on
3.数据源界面配置:
1.先需要开启插件(界面找)
2.参考网上文档配置
每天学习一点点 编程PDF电子书免费下载: http://www.shitanlife.com/code
参考:http://www.cnblogs.com/yyhh/archive/2015/09/08/4792830.html#l10
Zabbix安装 Grafana安装的更多相关文章
- grafana安装使用及与zabbix集成
grafana简介Grafana是一个完全开源的度量分析与可视化平台,可对来自各种各种数据源的数据进行查询.分析.可视化处理以及配置告警. Grafana支持的数据源:官方:Graphite,Infl ...
- ubuntn18 docker zabbix+grafana安装和使用
在ubuntu docker inflxudb(安装 使用 备份 还原 以及python编码) telegraf Grafana我采用telegraf采集数据, 本文计划采用zabbix来才采集数据, ...
- Centos 7.3 安装Grafana 6.0
grafana简介 Grafana是一个完全开源的度量分析与可视化平台,可对来自各种各种数据源的数据进行查询.分析.可视化处理以及配置告警. Grafana支持的数据源: 官方:Graphite,In ...
- Grafana安装配置介绍
一.Grafana介绍 Grafana是一个可视化面板(Dashboard),有着非常漂亮的图表和布局展示,功能齐全的度量仪表盘和图形编辑器,支持Graphite.zabbix.InfluxDB.Pr ...
- Centos 7安装Grafana 4及结合Zabbix3.2实现可视化监控图形
上一篇介绍了如何在Centos 7环境下安装zabbix监控,本章继续介绍在Centos 7环境下安装Grafana,并结合Zabbix实现可视化监控图形! 简介: Grafana 是 Graphit ...
- Centos下载安装grafana
grafana的官网下载:https://grafana.com/grafana/download 一.安装服务端图像呈现组件 # yum install -y fontconfig freetype ...
- zabbix 3.0 安装 ubuntu环境
zabbix 3.0 安装 标签(空格分隔): 开发 [TOC] 下载deb # wget http://repo.zabbix.com/zabbix/3.0/ubuntu/pool/main/z/z ...
- 日志分析 第七章 安装grafana
grafana依赖mysql存储数据,首先需要安装mysql 安装mysql 解压 # groupadd mysql # useradd -s /sbin/nologin -g mysql mysql ...
- zabbix之2安装编译/基本功能实现
1.安装方式: rpm或者编译都可,rpm可以直接用yum安装. rpm安装的话,根据文件名进行选择即可. 编译的话,不同参数对应不同的组件. 编译安装zabbix:同时安装server和agent, ...
随机推荐
- RocketMQ的broker启动失败解决
RocketMQ的broker用如下命令启动: nohup sh bin/mqbroker -n localhost:9876 & 使用jps查看,系统非常卡顿,broker的名字也未显示.使 ...
- kubernetes系列(一)安装和配置
谈到kubernetes(或者说k8s)不得不提到云计算.虚拟化以及容器技术,相关介绍网上一大堆,不再赘述.而kubernetes的出现就是为了高效的管理云端运行的docker容器. 环境 docke ...
- C#语句 分支语句 if --- else ---
语句是指程序命令,都是按照顺序执行的.语句在程序中的执行顺序称为“控制流”或“执行流”. 根据程序对运行时所收到的输入的响应,在程序每次运行时控制流可能有所不同. 注意,语句间的标点符号必须是英文标点 ...
- 【Java并发编程】21、线程池ThreadPoolExecutor源码解析
一.前言 JUC这部分还有线程池这一块没有分析,需要抓紧时间分析,下面开始ThreadPoolExecutor,其是线程池的基础,分析完了这个类会简化之后的分析,线程池可以解决两个不同问题:由于减少了 ...
- html页面边框的简单设置方法
<!DOCTYPE html> <html> <head> <meta charset="UTF-8"> <title> ...
- 使用普通用户执行 docker
CentOS 版本 7.4,Docker 版本 docker-1.13 及以下 ll /var/run/docker.sock srw-rw----. 1 root root 0 May 25 14: ...
- [VUE ERROR] Duplicate keys detected: 'tab-user'. This may cause an update error.
错误消息如图: 如果你看到此错误消息,则说明 v-for 指令的 key值 重复了,只需修改你的 key值 让其不会重复即可.
- selenium win7+selenium2.0+python环境搭建
win7+selenium2.0+python环境搭建 by:授客 QQ:1033553122 步骤1:下载python 担心最新版的支持不太好,这里我下载的是python 2.7(selenium之 ...
- loadrunner 脚本开发-字符串编码转换
字符串编码转换 by:授客 QQ:1033553122 相关函数 lr_convert_string_encoding函数 功能:字符串编码转换 原型: int lr_convert_string ...
- (后端)Java跨域过滤器
private FilterConfig config = null; @Override public void init(FilterConfig config) throws ServletEx ...