云服务器 linux文件系统异常an error occurren during the file system check导致服务器启动失败
云服务器 linux文件系统异常an error occurren during the file system check导致服务器启动失败
文件系统宕机,重启后报错,无法启动
处理流程:
1.编辑/etc/fstab将文件系统挂载去掉
# vim /etc/fstab
#/dev/xvdb /data ext3 defaults 1 2
#/dev/xvdc /data1 ext3 defaults 0 0
2.重启进入系统,对两个分区进行fsck修复检测(建议使用screen,避免中途被打断)
# screen -S xvdc
# fsck -y /dev/xvdc
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
/dev/xvdc: recovering journal
/dev/xvdc has gone 510 days without being checked, check forced.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
/dev/xvdc: ***** FILE SYSTEM WAS MODIFIED *****
/dev/xvdc: 425/32768000 files (68.5% non-contiguous), 4265913/131072000 blocks
# fsck -y /dev/xvdb
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
/dev/xvdb contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes
Free blocks count wrong for group #2637 (10474, counted=14592).
Fix? yes
Free blocks count wrong for group #2638 (9318, counted=10345).
Fix? yes
Free blocks count wrong for group #2639 (11172, counted=12429).
Fix? yes
Free blocks count wrong for group #2640 (8375, counted=8887).
Fix? yes
Free blocks count wrong (22177812, counted=22268375).
Fix? yes
Inode bitmap differences: -19694041 -19709957 -19718159
Fix? yes
Free inodes count wrong for group #2404 (7638, counted=7639).
Fix? yes
Free inodes count wrong for group #2406 (8104, counted=8105).
Fix? yes
Free inodes count wrong for group #2407 (8088, counted=8089).
Fix? yes
Free inodes count wrong (32383813, counted=32383816).
Fix? yes
/dev/xvdb: ***** FILE SYSTEM WAS MODIFIED *****
/dev/xvdb: 384184/32768000 files (63.4% non-contiguous), 108803625/131072000 blocks
3.检测完磁盘以后打开挂载,并重新挂载,重启系统
# cat /etc/fstab
#
# /etc/fstab
# Created by anaconda on Thu Aug 14 21:16:42 2014
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=94e4e384-0ace-437f-bc96-057dd64f42ee / ext4 defaults,barrier=0 1 1
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/xvdb /data ext3 defaults 1 2
/dev/xvdc /data1 ext3 defaults 0 0
# ll /data
total 0
# ll /data1
total 0
# mount /dev/xvdb /data
# mount /dev/xvdc /data1
重启系统
# reboot
云服务器 linux文件系统异常an error occurren during the file system check导致服务器启动失败的更多相关文章
- redhat系统服务器重启后提示An error occurred during the file system check.
问题描述 浪潮一台NF8480M3外观红灯报警,鉴于无法登陆带外,只能对服务器进行断电重启操作 问题现象 重启后进入开机过程并报错,报错如下内容及图片如下所示,正常来说进入此界面后直接输入root密码 ...
- linux系统重启后提示An error occurred during the file system check.
一.问题描述 生产环境中一台浪潮NF8480M3外观红灯报警,鉴于无法登陆带外管理口,只能对服务器进行断电重启操作 二.问题现象 重启后进入开机过程并报错,正常来说进入此界面后直接输入root密码即可 ...
- an error occurred during the file system check错误的解决
[root@GIT ~]# fsck -A /dev/mapper/VolGroup-lv_root 下面的选择,一路Y就行了,最后reboot,问题解决!
- an error occured during the file system check
打开虚拟机的时候,报错: 出错原因: 我之前修改了/etc/fstab文件, 原先/etc/fstab文件中有一行是这样的: LABEL=/i01 /u01 ...
- error occurred during the file system check
fsck -c 然后一路:y reboot 问题解决!!!
- VMware中CentOS6.5启动出现An error occurred during the file system check
- Error:/etc/fstab:Read-only file system错误的解决办法
1.挂载60T存储,设置开机自动挂载,UUID编号配置错误导致系统无法启动 2.根据提示进入维护状态,输入root密码,进入fstab删除UUID等内容,结果报错 Error:/etc/fst ...
- 解决 docker 报错: Error starting daemon: error initializing graphdriver: backing file system is unsupported for this graph driver
CentOS 7.5 x64下 sudo yum install docker -y systemctl enable docker systemctl start docker 发现启动失败 jou ...
- 报错解决——linux下执行sh出现异常"syntax error: unexpected end of file"
有时我们在linux下执行一个sh文件,会报错“SYNTAX ERROR:UNEXPECTED END OF FILE”,这个现象主要是工作的系统环境改变造成的. 若最初脚本中是在windows下,使 ...
随机推荐
- Java8的Stream流(一) --- 基础用法
Java8中的Stream Stream使用一种类似用SQL语句从数据库查询数据的直观方式来提供一种对Java集合运算和表达的高阶抽象. Stream的特性及优点: 无存储. Stream不是一种数据 ...
- 面试 -- fragment生命周期
Android 3.0 (Api 11)引入: Fragment具有重用,易适配(平板和手机之间的)优点: 依赖Activity,生命周期受到Activity的生命周期影响: fragment生命周期 ...
- Ubuntu16.04创建electronic-wechat启动器图标
步骤 将最新的electronic-wechat二进制包,下载解压,并移动到/opt/下面.sudo cp -r electronic-wechat/ /opt/electronic-wechat/ ...
- CF724F Uniformly Branched Trees
CF724F Uniformly Branched Trees 有根树可以统计.无根树难以统计.因为可以换根. 所以不让换根:只要两个无根树在重心位置不同构,就一定不同构 每个本质不同的树在重心位置统 ...
- 1: java开发_""和null的区别
原文地址:http://www.cnblogs.com/hongten/archive/2012/11/08/java_null.html 在代码中: 1 //name可以为"", ...
- quartz 关闭不断输出的batch acquisition of 0 triggers ?
转: spring整合quartz定时器的项目中,如何关闭不断输出的batch acquisition of 0 triggers ? 不断输出的batch acquisition of 0 trig ...
- Css的前世今生
Css的基础知识扫盲 作者:尹正杰 版权声明:原创作品,谢绝转载!否则将追究法律责任. HTML的用法没有什么技巧,就是死记硬背,当然你不需要都记下来,能记住20个常用的标签基本上就OK了,其他不常用 ...
- spring整合redis-----ShardedJedisPool实现
redis是一个非常优秀的缓存框架,良好的api,强悍的性能,是现在非常非常火的缓存框架.下面来介绍一下spring中是如何整合redis的 分析: 需要引入依赖 需要配置连接池,就是一个xml文件, ...
- CentOS 使用 Xfce 桌面并通过 xrdp 登录
基础环境 CentOS 7.1 最小化安装 安装步骤 以下步骤,均通过ssh连接到主机进行操作. 安装桌面支持 首先安装桌面支持 yum groupinstall "Server with ...
- (cx_Oracle.DatabaseError) DPI-1047: 64-bit Oracle Client library cannot be loaded: "libclntsh.so: cannot open shared object file: No such file or directory"
打开https://oracle.github.io/odpi/doc/installation.html 官方相关如下 Oracle Instant Client RPM¶ To run ODPI- ...