SSAS IIS 发布
http://www.cnblogs.com/zhangzt/p/4046259.html
-->

2、在D盘新建一个olap文件,把上述的isapi内的所有东西全部copy进去。

3、在IIS中新建一个应用程序池,名称为olap,托管模式选择经典,如下设置

4、在IIS默认网站下新建一虚拟目录,名称为olap,物理路径选择第二步新建的d:\olap的文件夹,具体操作如下图


5、在虚拟目录OLAP上点右键,选择"转换为应用程序",然后对应的应用程序池选择第三步创建的olap模式,具体如下图


6、在OLAP的功能视图区,双击"处理程序映射"

7、右键,选择“添加脚本映射”,选中刚所建虚拟目录下的msmdpump.dll文件,确定即可。会出现是否允许ISAP拓展,点击是即可,具体如下图


8、配置IIS身份验证,在功能视图中,双击“身份验证”,出现如下对话框


9、上面是启用匿名身份验证的,其他都是禁用的。右击匿名身份验证,选择编辑,出现如下对话框:

点击设置输入相应的用户名和密码,特别注意:这里的用户名必须是可以访问SQLSERVER的。如果多维数据库带有实例名的话,比如.\sqlserver2008切记要修改msmdpump.ini文件,打开msmdpump.ini文件,修改对应的ServerName为.\sqlserver2008即可。

测试配置是否成功 1、在多维分析引擎里面输入:http://ip地址:端口号/IIS站点名称/msmdpump.dll 即可,例如:本机IP地址:192.168.156.139 端口:80 IIS站点名称:olap 访问如下:http://192.168.156.139/olap/msmdpump.dll


2、在EXCEL里面连接Cube配置如下:打开Excel,点击数据,来自其他分析数据源,输入访问的 http://192.168.156.139/olap/msmdpump.dll 连接即可,具体如下图


选择对应的多维数据库和对应的Cube即可

其他说明:如果在使用EXCE连接的时候报 XML分析在第1行、第9列处失败:禁用DTD这个错误话。 在应用程序池,选择之前创建的OLAP应用程序池,点击高级设置,启用32bit位应用程序:选择true 即可

PS: 分享IIS6、IIS5配置SSAS通过HTTP远程连接详细解决方案,详情参考以下附件 http://www.flybi.net/article/64
2 个评论
相关问题
- ssis+ssas+ssrs各个之间什么关系,如何联系?
- BIEE安装后重启后http://localhost:7001/analytics 不可访问
- BIEE跨库连接查询
- 有没有合适的支持SSAS的第三方工具
- 如何验证Cognos是否安装成功,如何使用Cognos连接数据库?
- IIS7发布SSAS错误
- SSIS 的 64 位版本中不支持 Excel 连接管理器 的解决方法?
- ssrs使用ssas cube数据集作为数据源,使用日历控件出错
- 会话变量初始化块无法选择连接池
- Cognos的开发流程是什么,是最先配置数据源然后在建Cube,最后进行报表的实现操作吗?
- Cognos 连接Oracle中 Jar驱动如何进行选择解决方案分享
SSAS IIS 发布的更多相关文章
- IIS发布站点错误收集(持续更新)
本文主要收集IIS在发布站点过程中遇到的错误,并提供解决办法.并亲测可行.如果您也在使用IIS发布站点的过程中遇到了一些问题,欢迎留言提问. (1.) HTTP错误500.21-Internal Se ...
- IIS发布网站
IIS发布网站几个问题 1.部署步骤:http://jingyan.baidu.com/article/3065b3b6e5becdbecff8a4d5.html Win7下IIS报503Servic ...
- C# 通过WebService方式 IIS发布网站 上传文件到服务器
应用场景:要将本地的文件 上传到服务器的虚拟机上 网络环境:公司局域网(如下图中第二种) 开发环境:VS2010 服务器环境:WinServer2008 虚拟机环境:WinServer2008 ...
- IIS发布报错
IIS发布报错一般原因 ISAPI和CGI限制作为IIS与ASP.NET的连接桥梁
- 通过IIS发布站点和VS2012自带发布网站
vs2012通过IIS发布站点 http://jingyan.baidu.com/article/0964eca2d7beeb8285f536bd.html 用VS2012自带发布网站 http:// ...
- IIS发布网站后局域网其他用户不能访问问题(转)
如果本机能正常访问,而局域网其他用户不能访问,那么判断的结果很可能是防火墙问题. 解决方法: 既然问题出在Windows7或Windows Server 2008 R2的防火墙上,那么我们可以有以下两 ...
- IIS发布网站,浏览网站时候,出现 试图加载格式不正确的程序。
异常来自HRESULT:0x8007000B 缘由:在64位操作系统下IIS发布32位的项目,报“项目依赖的dll无法读取,试图加载格式不正确的程序”错误. 原因:程序集之间的通讯要么全是64位环境下 ...
- IIS发布网站浏览之后看到的是文件目录 & Internal Server Error 处理程序“ExtensionlessUrlHandler-ISAPI-4.0_64bit”在其模块列表中有一个错误模块“IsapiModule” 解决方法 & App_global.asax.pduxejp_.dll”--“拒绝访问。 ”
Q:IIS发布网站浏览之后看到的是文件目录 A:它出现了一个说到.NET4.0 更高框架什么的错误,所以我将 .NTE CRL版本由4.0改为2.0了,改为2.0后就出现了只能浏览文件目录了.改为4. ...
- 这里主要展示在Win7下怎么用IIS发布局域网站
首先对IIS做一个简要的介绍: IIS(InternetInformationServices)互联网信息服务的简称.本质是一种Web(网页)服务组件,其中包含Web.FTP和SMTP三大服务器,分别 ...
随机推荐
- poj 2096 Collecting Bugs 【概率DP】【逆向递推求期望】
Collecting Bugs Time Limit: 10000MS Memory Limit: 64000K Total Submissions: 3523 Accepted: 1740 ...
- iphone开发之获取网卡的MAC地址和IP地址
本文转载至 http://blog.csdn.net/arthurchenjs/article/details/6358489 这是获取网卡的硬件地址的代码,如果无法编译通过,记得把下面的这几个头文件 ...
- UIWebview加载H5界面侧滑返回上一级
一.UIWebview的发现 问题发现:当UIWebview王深层次点击的时候,返回时需要webView执行goBack方法一级一级返回,这样看到的webView只是在该界面执行刷新,并看不到类似iO ...
- 如何查看apache配置文件路径
我是用https://lamp.sh/安装的,apache配置文件位置在:/usr/local/apache/conf/httpd.conf如果是直接安装的apache,配置文件应该在:/etc/ht ...
- 安装pymysqlpool并使用(待补充)
pip3 install PyMysqlPool 第一个错,提示没有装c++ 14.0,下载安装报下一个错 error: Setup script exited with error: Microso ...
- python -- redis连接与使用
前面我们简单介绍了redis nosql数据库,现在我们在python里面来使用redis. 一.python连接redis 在python中,要操作redis,目前主要是通过一个python-red ...
- centos下安装nodejs及websocket
软件环境: VMware Workstation CentOS 6.5 NodeJS v0.12.5 安装过程: Step 1.确认服务器有nodejs编译及依赖相关软件,如果没有可通过运行以下命令安 ...
- codeforces 之 Little Pigs and Wolves
B-Little Pigs and Wolvestime limit per test2 secondsmemory limit per test256 megabytesinputstandard ...
- 1.1 BASIC PROGRAMMING MODEL(算法 Algorithms 第4版)
1.1.1 private static void exercise111() { StdOut.println("1.1.1:"); StdOut.println((0+15)/ ...
- laravel基础课程---14、表单验证(lavarel如何进行表单验证)
laravel基础课程---14.表单验证(lavarel如何进行表单验证) 一.总结 一句话总结: lavarel的验证的功能比tp要[简单]且[强大]很多 直接控制器中:添加[规则数组]和[修改提 ...
