经过实践,weblogic节点管理器的作用主要有两点:

1、可通过weblogic控制台远程控制被管server启停。

2、可以自动重启被管server的进程,并且对spring框架提供比直接启动更快的重启速度。

配置步骤:

在管理电脑上:

在weblogic控制台中建立代表被管电脑的machine以及被管电脑上的被管server,把被管server添加到machine中,把machine的监听
协议设为“普通”。

在被管电脑上:

一、修改D:\Oracle\Middleware\wlserver_10.3\common\bin\commEnv.cmd脚本:
1、WL_USE_X86DLL改为false,WL_USE_IA64DLL改为true,表示使用64位库;
2、JAVA_USE_64BIT改为true;
3、JAVA_HOME改为“C:\Program Files\Java\jdk1.7.0_80”,即用户自己安的jdk1.7而非weblogic默认安装的jdk1.6;
4、下面的是java虚拟机在各种不同情况下的默认内存分配,Xms是最小值,Xmx是最大值,MaxPermSize是jdk占用内存,被管

server的实际内存可以在以后通过脚本覆盖设置,这里的配置主要用在了管理server上;(对于32位系统内存要限制在2GB,64位系统

则没有此限制,)

二、在D:\Oracle\Middleware\wlserver_10.3\server\bin下找到startNodeManager.cmd,把它复制到D:\Oracle\Middleware
\user_projects\domains\base_domain\bin\nodemanager下,并修改之:
1、将NODEMGR_HOME改为“D:\Oracle\Middleware\user_projects\domains\base_domain\bin\nodemanager”
2、在“if not "%COHERENCE_HOME%" == "" set JAVA_OPTIONS=-Dcoherence.home=%COHERENCE_HOME% %JAVA_OPTIONS%”行下添

加一行“set JAVA_OPTIONS="%JAVA_OPTIONS% -Dweblogic.nodemanager.sslHostNameVerificationEnabled=false"”,表示忽略

ssl的主机名验证。

三、修改D:\Oracle\Middleware\user_projects\domains\base_domain\bin\startWebLogic.cmd脚本:
在“set SERVER_CLASS=com.oracle.classloader.launch.Launcher”行下面添加一行“JAVA_OPTIONS="${JAVA_OPTIONS} -

Dweblogic.security.SSL.ignoreHostnameVerification=true"”,再添加一行“export JAVA_OPTIONS”。

四、执行startNodeManager.cmd,发现命令行窗口一闪而过启动失败:
1、在目录下生成了nodemanager.log日志文件,其中记录“Native version is enabled but nodemanager native library

could not be loaded”,意思是nodemanager 的库与系统默认库有冲突。
2、在目录下建立nodemanager.properties文件写入一行“NativeVersionEnabled=false”解决库冲突问题,写入一

行“SecureListener=false”说明使用“普通”模式不使用ssl协议。

五、再次执行startNodeManager.cmd,出现“ Plain socket listener started on port 5556”表示节点管理器启动成功:
在“Configuration settings:”和“Domain name mappings:”之间的内容都可以写在nodemanager.properties文件中作为配置

选项,其中“:”和“\”前面要加“\”进行转义。

六、在目录下添加nodemanager.domains文件:
其中写入:“base_domain=D\:\\Oracle\\Middleware\\user_projects\\domains\\base_domain”指明被管电脑上这个域的位置

。

七、重启节点管理器,在管理电脑的weblogic控制台中启动被管电脑上的被管server,显示“FAILED”:
1、此时在被管电脑的D:\Oracle\Middleware\user_projects\domains\base_domain\servers\sservername\logs下可以看到被管server的启动日志(.out

文件),记录了“错误: 找不到或无法加载主类 Files\Java\jdk1.7.0_80\bin;C:\Program”
2、这是因为windows2012把环境变量中的Program Files给拆开了理解,此时在环境变量中找到JAVA_HOME项,把Program Files改

为“PROGRA~1”

八、重复执行第七步,被管server启动成功。

20151208_使用windows2012配置weblogic节点管理器的更多相关文章

  1. 配置weblogic nodemanager管理器

    [内容提示]:看了一场皇族对阵OMG的比赛,失落 .皇族又输了..  可爱的UZI...   我承认我是逗比,看了3天节点管理器才明白点东西 .笨笨 .. 废话不多说,上图!所有的故意围绕一张图开始了 ...

  2. weblogic11g 节点管理器 nodemanager

    Weblogic 节点管理器  nodemanager 一.Weblogic  规划 : Server名称 端口 ip 备注 xyyadmin 7001 10.10.54.74 管理server ap ...

  3. 在控制台启动服务器时出现:对于服务器soa1_wls, 与计算机oim1相关联的节点管理器无法访问。

    问题:在控制台启动服务器时出现:对于服务器soa1_wls, 与计算机oim1相关联的节点管理器无法访问.原因:nodemanager没有启起来解决方法: 一.对于managedServer于admi ...

  4. 转:对于服务器AdminServer, 与计算机Machine-0相关联的节点管理器无法访问

    控制台启动server时报"对于服务器server-1与计算机machin<!--StartFragment -->对于服务器AdminServer, 与计算机Machine-0 ...

  5. 对于服务器AdminServer, 与计算机Machine-0相关联的节点管理器无法访问

    控制台启动server时报"对于服务器server-1与计算机machin<!--StartFragment -->对于服务器AdminServer, 与计算机Machine-0 ...

  6. 使用 WLST 和节点管理器来管理服务器

    使用节点管理器启动计算机上的服务器 WLST 可以连接至在任何计算机上运行的节点管理器,并能够在此计算机上启动一个或多个 WebLogic Server 实例.要通过此技术使用 WLST 和节点管理器 ...

  7. [置顶] Weblogic节点管理

    配置节点管理之后能方便管理,可以在控制台启动停止被管服务器,一般配置步骤:创建受管服务器,创建machine,屏蔽SSL主机名验证,修改nodemanager.properties,启动nodeman ...

  8. 解决在Spring整合Hibernate配置tx事务管理器出现错误的问题

    问题描述: Error occured processing XML 'org/aopalliance/intercept/MethodInterceptor'. See Error Log for ...

  9. TaskTracker节点上的内存管理器

    Hadoop平台的最大优势就是充分地利用了廉价的PC机,这也就使得集群中的工作节点存在一个重要的问题——节点所在的PC机内存资源有限(这里所说的工作节点指的是TaskTracker节点),执行任务时常 ...

随机推荐

  1. Node.js 手册查询-1-核心模块方法

    Node.js 学习手册 标签(空格分隔): node.js 模块 核心模块 核心模块是被编译成二进制代码,引用的时候只需require表示符即可 os 系统基本信息 os模块可提供操作系统的一些基本 ...

  2. 原生javascript封装ajax和jsonp

    在我们请求数据时,完成页面跨域,利用原生JS封装的ajax和jsonp: <!DOCTYPE html> <html lang="en"> <head ...

  3. [LintCode] Reverse Nodes in k-Group 每k个一组翻转链表

    Given a linked list, reverse the nodes of a linked list k at a time and return its modified list. If ...

  4. E: dpkg 被中断,您必须手工运行 sudo dpkg --configure -a 解决此问题。

    学习 : http://blog.csdn.net/darennet/article/details/9009361 http://www.uedsc.com/dpkg-sudo-dpkg-confi ...

  5. Logistic Regression Vs Decision Trees Vs SVM: Part I

    Classification is one of the major problems that we solve while working on standard business problem ...

  6. wamp虚拟主机的配置 .

    开发环境:WAMP 实例一,Apaceh配置localhost虚拟主机步骤 1,用记事本打开apache目录下httpd文件(如:D:\wamp\bin\apache\apache2.2.8\conf ...

  7. c#中的math类

    http://wenku.baidu.com/link?url=TliiVtdB8IeO3wiM9mVSD-3wLZcLum7dsXlEZgSKawo6x-qvE_G3VL_yDa3ZQ_9ZFlGG ...

  8. Web安全学习笔记之一

    浏览器基本策略:同源策略 同源策略规定:不同域的客户端脚本在没有明确授权的情况下,不能读写对方的资源. 同域与不同域:如http://www.text.com与https://www.text.com ...

  9. 无法删除DLL文件解决方法(转)

    手动解决dll文件无法删除的终极方法 手动解决dll文件无法删除的终极方法 相信大家都遇见过:在删除一些软件的时候弹出某某文件正在运行或磁盘写保护不能删除这样的报错提示吧.而常常删除不掉的都一些后缀为 ...

  10. js中获取键盘事件【转】

    <script type="text/javascript" language=JavaScript charset="UTF-8"> 2 docu ...