启动问题(如The server quit without updating PID file)请查看最后的附录进行解决

作者:晨星1032

一、MySQL国内镜像下载

二、国内镜像相关站点

只列取部分(其他相关软件可进入站点进行下载)

三、Centos7安装MySQL5.7

1. 下载并解压至/usr/local

镜像站下载(以版本mysql-5.7.31-linux-glibc2.12-x86_64为例)

wget http://mirrors.ustc.edu.cn/mysql-ftp/Downloads/MySQL-5.7/mysql-5.7.31-linux-glibc2.12-x86_64.tar.gz

解压至/usr/local

tar -xvf mysql-5.7.31-linux-glibc2.12-x86_64.tar.gz -C /usr/local/

重命名

cd /usr/local
mv mysql-5.7.31-linux-glibc2.12-x86_64/ mysql

2. 配置信息

新建my.cnf

mkdir -p /usr/local/mysql/etc
vi /usr/local/mysql/etc/my.cnf

在my.cnf中填入以下内容

[mysqld]
user=mysql
server-id=1
port = 3306
character_set_server=utf8mb4 datadir=/mnt/mysql/mysql_data
tmpdir=/mnt/mysql/mysql_tmp # 日志
log-error=/mnt/mysql/log-error.txt default-storage-engine=INNODB join_buffer_size = 512M
tmp_table_size = 1G
max_allowed_packet = 64M
# 365
interactive_timeout = 31536000
# 24.86
wait_timeout = 2147483
read_buffer_size = 128M
read_rnd_buffer_size = 256M
sort_buffer_size = 256M
key_buffer_size=512M
back_log=500
flush_time=0
open_files_limit=4161
table_definition_cache=1400
binlog_row_event_max_size=16M # 最大连接数
max_connections=1000
max_connect_errors = 1000 # 线程缓存大小
thread_cache_size=500 # 日志缓冲刷新的频繁程度
innodb_flush_log_at_trx_commit=2
innodb_buffer_pool_size=2G
innodb_log_file_size=512M
innodb_log_buffer_size=256M
innodb_thread_concurrency=32
innodb_autoextend_increment=64
innodb_buffer_pool_instances=8
innodb_concurrency_tickets=5000
innodb_old_blocks_time=1000
innodb_open_files=300
innodb_stats_on_metadata=0
innodb_file_per_table=1
innodb_checksum_algorithm=0
innodb_lock_wait_timeout = 50 # 瓶颈位
query_cache_size = 0 slow-query-log=1
long_query_time=10 lower_case_table_names=1
table_open_cache=4096 autocommit = 1
skip_name_resolve = 1
transaction_isolation = READ-COMMITTED
explicit_defaults_for_timestamp = 1 # Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0

注:

  1. my.cnf配置文件的位置在:/usr/local/mysql/etc/

  2. 启动错误日志在:/mnt/mysql/log-error.txt

  3. MySQL的wait_timeout连接已经修改为最大值,不会出现相关超时问题

3. 用户及用户组管理(提高安全)

新建组和用户

groupadd mysql
useradd -g mysql mysql -s /usr/sbin/nologin

创建数据目录(与my.cnf一致)

mkdir -p /mnt/mysql/mysql_data
mkdir -p /mnt/mysql/mysql_tmp

添加权限

chmod 644 /usr/local/mysql/etc/my.cnf
chmod 750 /mnt/mysql/mysql_data
chmod 750 /mnt/mysql/mysql_tmp chown -R mysql:mysql /usr/local/mysql
chown -R mysql:mysql /mnt/mysql/mysql_data
chown -R mysql:mysql /mnt/mysql/mysql_tmp

其他权限设置

touch /var/log/mariadb/mariadb.log
chown -R mysql:mysql /var/lib/mysql
chown -R mysql:mysql /var/log/mariadb/mariadb.log

4. 初始化数据库

进入目录

cd /usr/local/mysql/

初始化数据

./bin/mysqld --initialize

若有错误发生

  1. message:error while loading shared libraries: libnuma.so.1: cannot open shared object file: No such file or directory

    solution:yum -y install numactl.x86_64

  2. message: error while loading shared libraries: libaio.so.1: cannot open shared object file: No such file or directory

    solution:yum -y install libaio

5. 启动数据库

启动
/usr/local/mysql/support-files/mysql.server start 停止
/usr/local/mysql/support-files/mysql.server stop 重启
/usr/local/mysql/support-files/mysql.server restart

若启动有错误发生

如:The server quit without updating PID file (/mnt/mysql/mysql_data/xx.pid)

!!首先查看启动错误日志信息:/mnt/mysql/log-error.txt

根据启动日志进行排查问题(直接百度一般都没啥用,切记根据日志进行定点查问题)

以及/var/log/mariadb/mariadb.log的日志

6. 默认密码修改

(1)先停止mysql服务

/usr/local/mysql/support-files/mysql.server stop

# 并查看进程,若有则kill
ps -ef|grep mysqld

​ 结果如图所示

(2)启动 mysql 进入无需授权模式

./bin/mysqld --defaults-file=/usr/local/mysql/etc/my.cnf --skip-grant-tables --console

(3)新开一个窗口,并进入mysql目录下,执行以下命令连上数据库

./bin/mysql

(4)执行相关sql命令

-- 切换库
use mysql;
-- 更新密码为123456
update user set authentication_string=password("123456"),host = '%', password_expired='N' where user="root"; -- 查询结果
select user, authentication_string, host, password_expired from user; FLUSH PRIVILEGES;
exit

7. 防火墙开放端口设置

开放端口

firewall-cmd --zone=public --add-port=3306/tcp --permanent
firewall-cmd --reload

或者直接关闭防火墙(本地推荐)

# 启动
systemctl start firewalld
# 关闭
systemctl stop firewalld
# 查看状态
systemctl status firewalld # 开机禁用
systemctl disable firewalld
# 开机启用
systemctl enable firewalld

作者:晨星1032

附:启动问题排查

如:The server quit without updating PID file (/mnt/mysql/mysql_data/xx.pid)

!!首先查看启动错误日志信息:/mnt/mysql/log-error.txt

  1. 添加日志方法:
# 修改my.cnf配置文件,增加以下内容
log-error=/mnt/mysql/log-error.txt
  1. 同时对以下文件增加权限
touch /var/log/mariadb/mariadb.log
chown -R mysql:mysql /var/lib/mysql
chown -R mysql:mysql /var/log/mariadb/mariadb.log

然后根据启动日志进行排查问题(直接百度一般都没啥用,切记根据日志进行定点查问题)

或者/var/log/mariadb/mariadb.log的日志

若仍解决不了,可根据本文过程重新安装

重装MySQL过程数据库迁移注意点以及数据恢复,请看下篇内容!

MySQL下载地址与Centos7安装MySQL以及启动问题排查的更多相关文章

  1. linux mysql下载地址

    linux mysql下载地址: https://dev.mysql.com/downloads/mysql/5.7.html#downloads

  2. CentOS7安装MYSQL。

    参考这个文章(网页已存到本地):http://www.cnblogs.com/starof/p/4680083.html 安装完成后,本地登录MYSQL没有问题. 现在主要是在windows下用ora ...

  3. yum CentOS7安装mysql

    配置阿里云yum源 [root@bogon ~]# cd /etc/yum.repos.d/ [root@bogon yum.repos.d]# mkdir repo_bak [root@bogon ...

  4. [CentOs7]安装mysql(2)

    摘要 之前安装过一次mysql,最后配置,发现在本地无法连接,重启服务的时候一直卡在那里不动,感觉是安装的过程出问题,最后没办法还是卸载了,然后重新安装一下. [CentOs7]安装mysql Mys ...

  5. centos7安装mysql(yum)

    centos7安装mysql(yum) ----安装环境----依赖安装----检查mysql是否已安装----安装----验证是否添加成功----选择要启用的mysql版本----通过Yum安装my ...

  6. centos7安装Mysql爬坑记录

    centos7安装Mysql爬坑记录   查看是否已安装 使用下列命令查看是否已经安装过mysql/mariadb/PostgreSQL 如果未安装,不返回任何结果(ECS的centos镜像默认未安装 ...

  7. CentOS7 安装 MySQL Cluster 7.6.7

    引用自:http://lemonlone.com/posts/mysql-ndb-cluster-install/ 仅做备份和配置文件更改 1.先在VMware中安装 CentOS-7-x86_64- ...

  8. Centos7 安装mysql服务器并开启远程访问功能

    大二的暑假,波波老师送了一个华为云的服务器给我作测试用,这是我程序员生涯里第一次以root身份拥有一台真实的云服务器 而之前学习的linux知识在这时也派上了用场,自己的物理机用的是ubuntu系统, ...

  9. CentOS7安装mysql提示“No package mysql-server available.”

    针对centos7安装mysql,提示"No package mysql-server available."错误,解决方法如下: Centos 7 comes with Mari ...

随机推荐

  1. django-mdeditor支持七牛云存储图片

    由于django-mdeditor官方插件没有支持第三方存储,所以,我们只能进行修改源码的方式实现了. 本次改写即使替换了其文件,不使用七牛云也是无关紧要的,因为在存储时,去settings.py中判 ...

  2. hive中笛卡尔积的优化

    由于一个业务,必须要进行笛卡尔积,但是速度太慢了,left join时左表大概4万条数据,右表大概 3000多条数据,这样大概就是一亿多条数据, 这在大数据领域其实不算很大的数据量,但是hive中跑的 ...

  3. 【探索之路】机器人篇(3)-给mwRobot建立模型

    在创建一个mwRobot_description程序包那一节中,我们添加了依赖roscpp  rospy std_msgs 和 urdf , 现在我们再添加一个xacro依赖. 如何添加依赖? 打开程 ...

  4. git fork , git pull request那回事

    git fork 原理 相当于你在原项目的主分支上又建立了一个分支,你可以在该分支上任意修改,如果想将你的修改合并到原项目中时,可以pull request,这样原项目的作者就可以将你修改的东西合并到 ...

  5. maxmemory-policy

    maxmemory-policy 配置的策略 noeviction: 不删除策略, 达到最大内存限制时, 如果需要更多内存, 直接返回错误信息.(默认值) allkeys-lru: 所有key通用; ...

  6. docker安装(yum方式)

    1. 更新现有的yum 包:sudo yum update 2.添加Docker源: 2.1首先创建docker.repo: touch /etc/yum.repos.d/docker.repo [d ...

  7. 【Flutter】功能型组件之跨组件状态共享

    前言   在Flutter开发中,状态管理是一个永恒的话题.   一般的原则是:如果状态是组件私有的,则应该由组件自己管理:如果状态要跨组件共享,则该状态应该由各个组件共同的父元素来管理.   对于组 ...

  8. requests +httprunne r

    1.get 请求和 post 请求的区别是什么?  2.requests 模拟 get 请求时,有哪两种方式让响应的结果不是乱码?(直接代码描述)  3.requests 库中的 post 方法,参数 ...

  9. library cache pin解决方法

    library cache pin大部分都是因为编译存储过程造成的 查找造成问题的数据库对象(一般为存储过程) SELECT * FROM v$session_wait WHERE event = ' ...

  10. SAP中使用FTP服务

    SAP中简单的FTP技术实现基本上如下几个步骤: 1.SM59建立FTP的RFC destination. 可以通过执行SAP的标准程序RSFTP005,自动创建两个名为SAPFTP何SAPFTPA的 ...