在 CentOS7 上安装 MongoDB

1 通过 SecureCRT 连接至 CentOS7 服务器;

2 进入到 /usr/local/ 目录:
 cd /usr/local

3 在当前目录下创建 tools 目录:
 mkdir -p tools

4 进入到 tools 目录中:
 cd tools

5 下载与 CentOS 系统匹配的 mongodb-linux-x86_64-rhel70-3.2.4.tgz 文件:
 wget https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-rhel70-3.2.4.tgz

6 解压缩 mongodb-linux-x86_64-rhel70-3.2.4.tgz 文件:
 tar -zxvf mongodb-linux-x86_64-rhel70-3.2.4.tgz
 解压完成后得到 mongodb-linux-x86_64-rhel70-3.2.4 文件夹及其所属的文件;

7 重命名 mongodb-linux-x86_64-rhel70-3.2.4 文件为 mongodb3.2.4:
 mv mongodb-linux-x86_64-rhel70-3.2.4 mongodb3.2.4

8 返回到上一级目录,并创建 mongodb 目录:
 cd ../
 mkdir -p mongodb

9 将 mongodb3.2.4 文件从 /usr/local/tools 目录中移动到 /usr/local/mongodb 目录中:
 mv tools/mongodb3.2.4/ mongodb/

10 进入到 /usr/local/mongodb/mongodb3.2.4 目录中:
 cd mongodb/mongodb3.2.4

11 在 /usr/local/mongodb/mongodb3.2.4/bin/ 目录中创建一个存放日志的目录:
 mkdir -p data/test/logs

12 在 /usr/local/mongodb/mongodb3.2.4/bin/ 目录中创建一个存放数据文件的目录:
 mkdir -p data/test/db

13 进入 bin 目录中:
 cd bin/

14 创建配置文件 mongodb.conf:
 vi mongodb.conf
 
 在 mongodb.conf 写入如下内容:
  # idae - MongoDB config start - 2016-05-02

# 设置数据文件的存放目录
  dbpath = /usr/local/mongodb/mongodb3.2.4/bin/data/test/db

# 设置日志文件的存放目录及其日志文件名
  logpath = /usr/local/mongodb/mongodb3.2.4/bin/data/test/logs/mongodb.log

# 设置端口号(默认的端口号是 27017)
  port = 27017

# 设置为以守护进程的方式运行,即在后台运行
  fork = true

# nohttpinterface = true
  nohttpinterface = true
  # idae - MongoDB config end - 2016-05-02
 
 按英文状态下的“:wq”保存并退出;
 
 参数解释: 
  --dbpath 数据库路径(数据文件)
  --logpath 日志文件路径
  --master 指定为主机器
  --slave 指定为从机器
  --source 指定主机器的IP地址
  --pologSize 指定日志文件大小不超过64M.因为resync是非常操作量大且耗时,最好通过设置一个足够大的oplogSize来避免resync(默认的 oplog大小是空闲磁盘大小的5%)。
  --logappend 日志文件末尾添加,即使用追加的方式写日志
  --journal 启用日志
  --port 启用端口号
  --fork 在后台运行
  --only 指定只复制哪一个数据库
  --slavedelay 指从复制检测的时间间隔
  --auth 是否需要验证权限登录(用户名和密码)
  --syncdelay 数据写入硬盘的时间(秒),0是不等待,直接写入
  --notablescan 不允许表扫描
  --maxConns 最大的并发连接数,默认2000  
  --pidfilepath 指定进程文件,不指定则不产生进程文件
  --bind_ip 绑定IP,绑定后只能绑定的IP访问服务

15 启动 mongodb 服务:
 15.1 以自定义的 mongodb 配置文件方式启动:
  ./mongod --config mongodb.conf
 15.2 以修复模式启动 mongodb:
  ./mongod --repair -f mongodb.conf
 15.3 以参数式启动:
  ./mongod /usr/local/mongodb/mongodb3.2.4/bin/mongod --dbpath=/usr/local/mongodb/mongodb3.2.4/bin/data/test/db --logpath=/usr/local/mongodb/mongodb3.2.4/bin/data/test/logs/mongodb.log --fork
 如果报如下错误:
   ERROR: child process failed, exited with error number 1
 很可能是 mongodb.conf 中配置的路径不一致问题;
 如果报如下错误:
   ERROR: child process failed, exited with error number 100
 很可能是没有正常关闭导致的,那么可以删除 mongod.lock 文件

15 查看 mongodb 进程:
 ps aux |grep mongodb

16 查看 mongodb 服务的运行日志:
 tail -200f /usr/local/mongodb/mongodb3.2.4/bin/data/test/logs/mongodb.log

17 检查端口是否已被启动:
 netstat -lanp | grep 27017

18 杀死 mongodb 进程,即可关闭 mongodb 服务:
 kill -15 PID
 PID 可以通过步骤 16 查看到

19 如果出现如下情况
 warning: Failed to connect to 127.0.0.1:27017, reason: errno:111 Connection refused

可以采用如下两种方式解决:
 18.1 若数据库出现如上不能连接的原因,可能是data目录下的mongod.lock文件问题,可以用如下命令修复:
  ./bin/mongod --repair
 18.2 或者直接删除mongod.lock
  rm -f /usr/local/mongodb/data/db/mongod.lock  
 然后再启动 mongodb 服务:
  ./mongod --config mongodb.conf
 如果以上两部依然解决不掉,则是路径文件,我们可以删除 /usr/local/mongodb/mongodb3.2.4/bin/data 目录及其子目录,并采用绝对路径的方式:
  ./mongod /usr/local/mongodb/mongodb3.2.4/bin/mongod --dbpath=/usr/local/mongodb/mongodb3.2.4/bin/data/test/db --logpath=/usr/local/mongodb/mongodb3.2.4/bin/data/test/logs/mongodb.log --fork

20 将 mongodb 服务加入到自启动文件中:
 vi /etc/rc.local 
 在文件末尾追加如下命令:
  /usr/local/mongodb/mongodb3.2.4/bin/mongod --config mongodb.conf
 保存并退出:
  :wq!

21 客户端常用命令:
 db.version(); # 查看 mongodb 的版本
 use test; # 进入到指定的数据中,这里是 test 数据库

22 在 /usr/local/mongodb/mongodb3.2.4/bin/ 目录中,键入如下命令,打开一个 mongodb 的客户端程序,即打开一个 mongodb 的 shell 客户端,这个 shell 客户端同时也是一个 JavaScript 编辑器,即可用输入任何的 JavaScript 脚本:
 ./mongo
 默认连接至 test 数据库

23 在浏览器中输入 IP:27017,如:
 http://101.201.212.129:27017/
 可以查看 MongoDB 的版本信息;

(转)在 CentOS7 上安装 MongoDB的更多相关文章

  1. 在 CentOS7 上安装 MongoDB

    在 CentOS7 上安装 MongoDB 1 通过 SecureCRT 连接至 CentOS7 服务器: 2 进入到 /usr/local/ 目录: cd /usr/local 3 在当前目录下创建 ...

  2. 在CentOS7上安装JDK1.8

    在CentOS7上安装JDK1.8 1 通过 SecureCRT 连接到阿里云 CentOS7 服务器: 2 进入到目录 /usr/local/ 中: cd /usr/local/ 3 创建目录 to ...

  3. 在centos7上安装Jenkins

    在centos7上安装Jenkins 安装 添加yum repos,然后安装 sudo wget -O /etc/yum.repos.d/jenkins.repo http://pkg.jenkins ...

  4. 在 CentOS7 上安装 zookeeper-3.4.9 服务

    在 CentOS7 上安装 zookeeper-3.4.9 服务 1.创建 /usr/local/services/zookeeper 文件夹: mkdir -p /usr/local/service ...

  5. 在 CentOS7 上安装 MySQL5.7

    在 CentOS7 上安装 MySQL5.7 1 通过 SecureCRT 连接到阿里云 CentOS7 服务器: 2 进入到目录 /usr/local/ 中: cd /usr/local/ 3 创建 ...

  6. 在 CentOS7 上安装 Tomcat9

    在 CentOS7 上安装 Tomcat9 1 通过 SecureCRT 连接到阿里云 CentOS7 服务器: 2 进入到目录 /usr/local/ 中: cd /usr/local/ 3 创建目 ...

  7. 如何在CentOS/RHEL & Fedora上安装MongoDB 3.2

    MongoDB(名称取自"huMONGOus")是一个有着全面灵活的索引支持和丰富的查询的数据库.MongoDB通过GridFS提供强大的媒体存储.点击这里获取MongoDB的更多 ...

  8. Ubuntu上安装MongoDB(译)

    add by zhj:直接从第四步开始就可以了,而且安装好MongoDB后会自动启动的,不必自己去执行启动命令 原文:https://docs.mongodb.com/manual/tutorial/ ...

  9. 在Centos7上安装漏洞扫描软件Nessus

    本文摘要:简单叙述了在Centos7上安装Nessus扫描器的过程   Nessus 是目前全世界最多人使用的系统漏洞扫描与分析软件,Nessus的用户界面是基于Web界面来访问Nessus漏洞扫描器 ...

随机推荐

  1. [Elixir002]节点启动后自动连接其它节点

    问题: 如何指定一个节点在启动后自动连接到别的节点上? 这个我们要使用到sys.config,这是erlang的配置文件,这个文件一般都是$ROOT/releases/Vsn下 1. 首先我们要先启动 ...

  2. Hadoopd 单元测试-MPUnit

    Apache 版: 官网:http://mrunit.apache.org 教程:https://cwiki.apache.org/confluence/display/MRUNIT/MRUnit+T ...

  3. C# winform截图、web Cropper图片剪切、上传

    今天又来一弹,写了个小功能,windows 桌面截图,web剪切图片上传的功能. 废话不多说,直接上图: 1.winform 截屏功能 图1 主窗体 点击全屏截图,就已经全屏截图了,截图后,图片保存在 ...

  4. sqlhelper写调用存储过程方法

    public static object Proc(string ProcName, SqlParameter[] parm) { conn.Open(); //最后一个参数为输出参数 parm[pa ...

  5. Spring Boot 学习系列(06)—采用log4j2记录日志

    此文已由作者易国强授权网易云社区发布. 欢迎访问网易云社区,了解更多网易技术产品运营经验. 为什么选择log4j2 log4j2相比于log4j1.x和logback来说,具有更快的执行速度.同时也支 ...

  6. BASE64编码乱码问题的浅层分析与解释

    本文由作者朱臻授权网易云社区发布. 1问题案例 曾在开发过程中,我们遇到了BASE64编码乱码的问题,该问题的场景如下: 当web前端,将带有中文字符的字符串base64编码后,传到后端.当后端将数据 ...

  7. php实现循环链表

    <?php /** * php实现链表 * Date: 2018/5/18 * Time: 下午5:59 */ class Node { public $nodeId = 0; public $ ...

  8. 自注意力机制(Self-attention Mechanism)——自然语言处理(NLP)

    近年来,注意力(Attention)机制被广泛应用到基于深度学习的自然语言处理(NLP)各个任务中.随着注意力机制的深入研究,各式各样的attention被研究者们提出.在2017年6月google机 ...

  9. Web Api 内部数据思考 和 利用http缓存优化 Api

    在上篇<Web Api 端点设计 与 Oauth>后,接着我们思考Web Api 的内部数据: 其他文章:<API接口安全加强设计方法> 第一  实际使用应该返回怎样的数据 ? ...

  10. 蹭你wifi后 我竟然干了这样的事

    前言:故事发生在前两天,我们去参观工业园区内一家电商公司. 去参观他们公司的时候,我说要用下无线网,他们技术说密码就是他们的网站域名,我一脸懵逼表示我不知道域名,然后对方接过我手机给我连上了他们wif ...