在 CentOS7 上安装 MongoDB
在 CentOS7 上安装 MongoDB
1 通过 SecureCRT 连接至 CentOS7 服务器;
2 进入到 /usr/local/ 目录:
cd /usr/local
3 在当前目录下创建 tools 目录:
mkdir -p tools
4 进入到 tools 目录中:
cd tools
5 下载与 CentOS 系统匹配的 mongodb-linux-x86_64-rhel70-3.2.4.tgz 文件:
wget https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-rhel70-3.2.4.tgz
6 解压缩 mongodb-linux-x86_64-rhel70-3.2.4.tgz 文件:
tar -zxvf mongodb-linux-x86_64-rhel70-3.2.4.tgz
解压完成后得到 mongodb-linux-x86_64-rhel70-3.2.4 文件夹及其所属的文件;
7 重命名 mongodb-linux-x86_64-rhel70-3.2.4 文件为 mongodb3.2.4:
mv mongodb-linux-x86_64-rhel70-3.2.4 mongodb3.2.4
8 返回到上一级目录,并创建 mongodb 目录:
cd ../
mkdir -p mongodb
9 将 mongodb3.2.4 文件从 /usr/local/tools 目录中移动到 /usr/local/mongodb 目录中:
mv tools/mongodb3.2.4/ mongodb/
10 进入到 /usr/local/mongodb/mongodb3.2.4 目录中:
cd mongodb/mongodb3.2.4
11 在 /usr/local/mongodb/mongodb3.2.4/bin/ 目录中创建一个存放日志的目录:
mkdir -p data/test/logs
12 在 /usr/local/mongodb/mongodb3.2.4/bin/ 目录中创建一个存放数据文件的目录:
mkdir -p data/test/db
13 进入 bin 目录中:
cd bin/
14 创建配置文件 mongodb.conf:
vi mongodb.conf
在 mongodb.conf 写入如下内容:
# idae - MongoDB config start - 2016-05-02
# 设置数据文件的存放目录
dbpath = /usr/local/mongodb/mongodb3.2.4/bin/data/test/db
# 设置日志文件的存放目录及其日志文件名
logpath = /usr/local/mongodb/mongodb3.2.4/bin/data/test/logs/mongodb.log
# 设置端口号(默认的端口号是 27017)
port = 27017
# 设置为以守护进程的方式运行,即在后台运行
fork = true
# nohttpinterface = true
nohttpinterface = true
# idae - MongoDB config end - 2016-05-02
按英文状态下的“:wq”保存并退出;
参数解释:
--dbpath 数据库路径(数据文件)
--logpath 日志文件路径
--master 指定为主机器
--slave 指定为从机器
--source 指定主机器的IP地址
--pologSize 指定日志文件大小不超过64M.因为resync是非常操作量大且耗时,最好通过设置一个足够大的oplogSize来避免resync(默认的 oplog大小是空闲磁盘大小的5%)。
--logappend 日志文件末尾添加,即使用追加的方式写日志
--journal 启用日志
--port 启用端口号
--fork 在后台运行
--only 指定只复制哪一个数据库
--slavedelay 指从复制检测的时间间隔
--auth 是否需要验证权限登录(用户名和密码)
--syncdelay 数据写入硬盘的时间(秒),0是不等待,直接写入
--notablescan 不允许表扫描
--maxConns 最大的并发连接数,默认2000
--pidfilepath 指定进程文件,不指定则不产生进程文件
--bind_ip 绑定IP,绑定后只能绑定的IP访问服务
15 启动 mongodb 服务:
15.1 以自定义的 mongodb 配置文件方式启动:
./mongod --config mongodb.conf
15.2 以修复模式启动 mongodb:
./mongod --repair -f mongodb.conf
15.3 以参数式启动:
./mongod /usr/local/mongodb/mongodb3.2.4/bin/mongod --dbpath=/usr/local/mongodb/mongodb3.2.4/bin/data/test/db --logpath=/usr/local/mongodb/mongodb3.2.4/bin/data/test/logs/mongodb.log --fork
如果报如下错误:
ERROR: child process failed, exited with error number 1
很可能是 mongodb.conf 中配置的路径不一致问题;
如果报如下错误:
ERROR: child process failed, exited with error number 100
很可能是没有正常关闭导致的,那么可以删除 mongod.lock 文件
15 查看 mongodb 进程:
ps aux |grep mongodb
16 查看 mongodb 服务的运行日志:
tail -200f /usr/local/mongodb/mongodb3.2.4/bin/data/test/logs/mongodb.log
17 检查端口是否已被启动:
netstat -lanp | grep 27017
18 杀死 mongodb 进程,即可关闭 mongodb 服务:
kill -15 PID
PID 可以通过步骤 16 查看到
19 如果出现如下情况
warning: Failed to connect to 127.0.0.1:27017, reason: errno:111 Connection refused
可以采用如下两种方式解决:
18.1 若数据库出现如上不能连接的原因,可能是data目录下的mongod.lock文件问题,可以用如下命令修复:
./bin/mongod --repair
18.2 或者直接删除mongod.lock
rm -f /usr/local/mongodb/data/db/mongod.lock
然后再启动 mongodb 服务:
./mongod --config mongodb.conf
如果以上两部依然解决不掉,则是路径文件,我们可以删除 /usr/local/mongodb/mongodb3.2.4/bin/data 目录及其子目录,并采用绝对路径的方式:
./mongod /usr/local/mongodb/mongodb3.2.4/bin/mongod --dbpath=/usr/local/mongodb/mongodb3.2.4/bin/data/test/db --logpath=/usr/local/mongodb/mongodb3.2.4/bin/data/test/logs/mongodb.log --fork
20 将 mongodb 服务加入到自启动文件中:
vi /etc/rc.local
在文件末尾追加如下命令:
/usr/local/mongodb/mongodb3.2.4/bin/mongod --config mongodb.conf
保存并退出:
:wq!
21 客户端常用命令:
db.version(); # 查看 mongodb 的版本
use test; # 进入到指定的数据中,这里是 test 数据库
22 在 /usr/local/mongodb/mongodb3.2.4/bin/ 目录中,键入如下命令,打开一个 mongodb 的客户端程序,即打开一个 mongodb 的 shell 客户端,这个 shell 客户端同时也是一个 JavaScript 编辑器,即可用输入任何的 JavaScript 脚本:
./mongo
默认连接至 test 数据库
23 在浏览器中输入 IP:27017,如:
http://101.201.212.129:27017/
可以查看 MongoDB 的版本信息;
在 CentOS7 上安装 MongoDB的更多相关文章
- (转)在 CentOS7 上安装 MongoDB
在 CentOS7 上安装 MongoDB 1 通过 SecureCRT 连接至 CentOS7 服务器: 2 进入到 /usr/local/ 目录: cd /usr/local 3 在当前目录下创建 ...
- 在CentOS7上安装JDK1.8
在CentOS7上安装JDK1.8 1 通过 SecureCRT 连接到阿里云 CentOS7 服务器: 2 进入到目录 /usr/local/ 中: cd /usr/local/ 3 创建目录 to ...
- 在centos7上安装Jenkins
在centos7上安装Jenkins 安装 添加yum repos,然后安装 sudo wget -O /etc/yum.repos.d/jenkins.repo http://pkg.jenkins ...
- 在 CentOS7 上安装 zookeeper-3.4.9 服务
在 CentOS7 上安装 zookeeper-3.4.9 服务 1.创建 /usr/local/services/zookeeper 文件夹: mkdir -p /usr/local/service ...
- 在 CentOS7 上安装 MySQL5.7
在 CentOS7 上安装 MySQL5.7 1 通过 SecureCRT 连接到阿里云 CentOS7 服务器: 2 进入到目录 /usr/local/ 中: cd /usr/local/ 3 创建 ...
- 在 CentOS7 上安装 Tomcat9
在 CentOS7 上安装 Tomcat9 1 通过 SecureCRT 连接到阿里云 CentOS7 服务器: 2 进入到目录 /usr/local/ 中: cd /usr/local/ 3 创建目 ...
- 如何在CentOS/RHEL & Fedora上安装MongoDB 3.2
MongoDB(名称取自"huMONGOus")是一个有着全面灵活的索引支持和丰富的查询的数据库.MongoDB通过GridFS提供强大的媒体存储.点击这里获取MongoDB的更多 ...
- Ubuntu上安装MongoDB(译)
add by zhj:直接从第四步开始就可以了,而且安装好MongoDB后会自动启动的,不必自己去执行启动命令 原文:https://docs.mongodb.com/manual/tutorial/ ...
- 在Centos7上安装漏洞扫描软件Nessus
本文摘要:简单叙述了在Centos7上安装Nessus扫描器的过程 Nessus 是目前全世界最多人使用的系统漏洞扫描与分析软件,Nessus的用户界面是基于Web界面来访问Nessus漏洞扫描器 ...
随机推荐
- 【转】java中注解的使用与实例
原文:http://www.cnblogs.com/pepcod/archive/2013/02/20/2918719.html java 注解,从名字上看是注释,解释.但功能却不仅仅是注释那么简单. ...
- IDDD 实现领域驱动设计-SOA、REST 和六边形架构
上一篇:<IDDD 实现领域驱动设计-架构之经典分层> 阅读目录: SOA-面向服务架构 REST 与 RESTful 资源(Resources) 状态(State) 六边形架构 DDD ...
- mysql表名查询sql
select table_schema,table_name,engine from information_schema.tables where table_schema not in('info ...
- android 在使用ViewAnimationUtils.createCircularReveal()无法兼容低版本的情况下,另行实现圆形scale动画
ViewAnimationUtils.createCircularReveal()的简介: ViewAnimationUtils.createCircularReveal()是安卓5.0才引入的,快速 ...
- vue+node开发手机端h5页面开发遇到的坑
项目进行中...随时更新 这里记录了一些手机端调试的方式 一 css 1.文字超过span宽度显示...(单行文字) .topWrap .introduce span { padding: 0 17p ...
- Node.js、express、mongodb 实现分页查询、条件搜索
前言 在上一篇Node.js.express.mongodb 入门(基于easyui datagrid增删改查) 的基础上实现了分页查询.带条件搜索. 实现效果 1.列表第一页. 2.列表第二页 3. ...
- 汽车之家一道SQL 面试题,大家闲来无事都来敲一敲
写在前面 上周去汽车之家面试,拿到这个SQL笔试题顿时感觉到有些陌生,因为好长时间不写SQL语句了,当时只写了表设计,示例数据和SQL语句都没写出来. 汽车之家应该用的SQL Server, 编程题一 ...
- 微信扫码支付+Asp.Net MVC
这里的扫码支付指的是PC网站上面使用微信支付,也就是官方的模式二,网站是Asp.net MVC,整理如下.(demo在最下方) 一.准备工作 使用的微信API中的统一下单方法,关键的参数是‘公众账号I ...
- JavaScriptSerializer 序列化json 时间格式
利用JavaScriptSerializer 序列化json 时间格式,得到的DateTime值值显示为“/Date(700000+0500)/”形式的JSON字符串,显然要进行转换 1.利用字符串直 ...
- 第一篇:Entity Framework 简介
先从ORM说起吧,很多年前,由于.NET的开源组件不像现在这样发达,更别说一个开源的ORM框架,出于项目需要,以及当时OOP兴起(总不至于,在项目里面全是SQL语句),就自己开始写ORM框架.要开发O ...