Docker磁盘&内存&CPU资源实战
#查看帮助
docker run --help
docker update --help #配置容器使用cpu /内存大小--privileged 给与容器特权
docker run -itd --privileged --name=precious --cpuset-cpus=0-0 -m 512m centos7-ssh
#查看容器的内存/cpu
docker inspect 558bd2ec40fd|more|grep -iE "cpu|Memory"
#updata 参数:在线扩容/缩容功能
docker update --cpuset-cpus=0-1 -m 1024m 558bd2ec40fd
docker update --cpuset-cpus=0-0 -m 516m 558bd2ec40fd #滚动查看容器内存/cpu 使用状态: --no-stream(静态显示)
docker stats 558bd2ec40fd --no-stream
docker stats 558bd2ec40fd --no-stream|awk '{print $2,$3,$4}'
docker stats 558bd2ec40fd --no-stream|awk 'NR>1 {print "CPU:"$2}'




OPTIONS='--storage-opt overlay2.size=40G'
DOCKER_STORAGE_OPTIONS="--storage-driver overlay2 "

OPTIONS='--storage-opt overlay2.size=40G'

--storage-opt overlay2.size=40G


mkfs.xfs -f /dev/sdb

mkdir -p /data/
mount -o uquota,prjquota /dev/sdb /data/

xfs_quota -x -c 'limit bsoft=10M bhard=10M precious' /data
xfs_quota -x -c 'report' /data/

chmod o+w /data/ -R
su precious
cd /data/
dd测试语法:创建空文件(输入或输出)
dd if=[STDIN] of=[STDOUT]

mkdir -p /data/docker/
mkdir -p /data/docker-engine
cd /var/lib/
mv docker docker.bak
mv docker /data/
ln -s /data/docker/ .
ln -s /data/docker-engine/ .


#z找到ExecStart部分,在此行末尾添加 --graph=你的目录:
--graph=/data/docker

systemctl restart docker时会报错,重新加载下即可
systemctl daemon-reload
systemctl restart docker
再次docker indo查看,发现目录已改变

systemctl restart docker
ps -ef|grep docker
docker run -itd centos7-ssh
docker exec 容器ID df -h


--storage-opt overlay2.size=10G


/dev/sdb /data/ xfs defaults,uquota,prjpuota 0 0
/dev/sdb /data/ xfs defaults,uquota,prjquota 0 0


Docker磁盘&内存&CPU资源实战的更多相关文章
- Docker技术入门与实战 第二版-学习笔记-5-容器-命令及限制内存与cpu资源
1.启动容器 启动容器有两种方式: 基于镜像新建一个容器并启动 将在终止状态(stopped)的容器重新启动 1)新建并启动——docker run 比如在启动ubuntu:14.04容器,并输出“H ...
- docker容器资源限制:限制容器对内存/CPU的访问
目录 一.系统环境 二.前言 三.docker对于CPU和内存的限制 3.1 限制容器对内存的访问 3.2 限制容器对CPU的访问 一.系统环境 服务器版本 docker软件版本 CPU架构 Cent ...
- 如何使用 Docker 来限制 CPU、内存和 IO等资源?
如何使用 Docker 来限制 CPU.内存和 IO等资源?http://www.sohu.com/a/165506573_609513
- docker的memory和cpu资源限制
这里仅针对docker本身,不涉及任何编排工具compose或者k8s等. 按照惯例,官文撸起来. 重要的部分是一些选项,用来限制资源大小. Memory Most of these options ...
- 服务器为什么这么慢?耗尽了CPU、RAM和磁盘I/O资源
机器运行缓慢通常是由于消耗了太多系统特定的资源.系统的主要资源包括CPU.RAM.磁盘I/O以及网络.过度使用这些资源的任何一种都会让系统陷入困境.不过,如果能登录到系统之中,可以借助大量工具确定问题 ...
- Docker CPU 资源限制——CPU分片功能测试
之前的一篇随笔——Docker CPU 资源限制 中介绍了针对COU的某个或某几个核的控制,今天介绍下CPU分片功能,即CPU占比. 测试步骤 1.下载CPU测试image.agileek/cpuse ...
- Docker CPU 资源限制——CPU固定核功能测试
Docker使用Linux cgroup来实现资源的限制,对于CPU的限制有两种方法: 1.cpuset CPU Set限定容器使用某个固定的CPU核.使用默认的libcontainer引擎时,可以通 ...
- SSD磁盘,CPU居高不下,高并发的情况下,是不是mysql解析器耗费的cpu资源高?
你看看我做的实验,这个user表是300多W纪录,普通磁盘下,消耗时间最多的是Copy to tmp table 0.81秒,当然在ssd下,这个可以减少很多很多的,第二高就是sending data ...
- 内存和CPU资源控制
数据库系统的资源是指内存和CPU(处理器)资源,拥有资源的多寡,决定了数据查询的性能.当一个SQL Server实例上,拥有多个独立的工作负载(workload)时,使用资源管理器(Resource ...
- docker容器内存和CPU使用限制
docker容器内存和CPU使用限制 示例如下 sudo docker run --name seckill0 -p 8080:8080 -m 1024M --cpus=0.2 -d seckill: ...
随机推荐
- 国内可用的GPT4镜像站
我做了个镜像站,GPT4的费用目前太贵了. 虽然做了个低价的月费,但基本上亏本在做,接口的实际费用高出太多. 运行了1个月,每天有几十人在用吧. 有兴趣的可以收藏一下 GPT4的验明正身的问题&quo ...
- DHorse v1.2.1 发布,基于k8s的发布平台
综述 DHorse是一个简单易用.以应用为中心的云原生DevOps系统,具有持续集成.持续部署.微服务治理等功能,无需安装依赖Docker.Maven.Node等环境即可发布Java.Vue.Reac ...
- Web网页音视频通话之Webrtc相关操作(一)
目录 打开摄像头/关闭摄像头 静音/解除静音 打开视频/关闭视频 截图且下载 打开摄像头/关闭摄像头 效果图 HTML <!DOCTYPE html> <html lang=&quo ...
- Maven-Could not calculate build plan错误解决方法
报错如图: 报错情况: 可以创建简单的maven项目例子,但是无法创建web的maven项目 解决方法: 1.安装maven插件后,c盘下会生成.m2文件夹 .m2\repository\org\ap ...
- Go 语言的 nil 能比较自己吗
nil 是什么? 可以看看官方的描述,在 buildin/buildin.go 里: // nil is a predeclared identifier representing the zero ...
- Nginx获取用户真实IP
Nginx获取用户真实IP地址 本人在一次项目中,使用Nginx需要获取到用户IP,本来可以很常规的获取的,可现实往往不常规,项目是前后端分离的,部署时,前端使用了Nginx进行了代理并转发,后端也使 ...
- boinc使用笔记
安装 yum install -y epel-release yum install -y boinc-client boinc-manager 启动 在图形界面开启终端 boinc boincmgr
- jsp中的一些问题
jsp里的${pageContext.request.contextPath} 在JSP中,${pageContext.request.contextPath}是一个EL表达式(Expression ...
- 聊聊 RocketMQ 名字服务
NameServer 是专为 RocketMQ 设计的轻量级名字服务,它的源码非常精简,八个类 ,少于1000行代码. 这篇文章, 笔者会从基础概念.Broker发送心跳包.NameServer 维护 ...
- CAP 7.2 版本发布通告
前言 今天,我们很高兴宣布 CAP 发布 7.2 版本正式版,我们在这个版本中主要致力于 Dashboard 对 k8s 服务发现的支持. 从 7.1 版本以来,我们发布了4个小版本,在这些版本中我们 ...