问题如下

将某一pv加入vg

vgextend cl /dev/xvdb1

然后进入fdisk将xvdb1分区删掉,重新创建pv

使用lvdisplay报警告

[root@localhost ~]# lvdisplay
WARNING: Device /dev/xvdb1 has size of 6291456 sectors which is smaller than corresponding PV size of 20969472 sectors. Was device resized?
One or more devices used as PVs in VG cl have changed sizes.

使用其他命令检查也会报错

[root@localhost ~]# vgscan
Reading volume groups from cache.
WARNING: Device for PV fNjF3j-gTVO-fkOV-2Cfe-MxSg-6uFo-v6hlZJ not found or rejected by a filter.
Found volume group "cl" using metadata type lvm2
[root@localhost ~]# vgck
Couldn't find device with uuid fNjF3j-gTVO-fkOV-2Cfe-MxSg-6uFo-v6hlZJ.
The volume group is missing 1 physical volumes.

[root@localhost ~]# pvdisplay
WARNING: Device for PV fNjF3j-gTVO-fkOV-2Cfe-MxSg-6uFo-v6hlZJ not found or rejected by a filter.
--- Physical volume ---
PV Name /dev/xvda2
VG Name cl
PV Size 99.80 GiB / not usable 3.00 MiB
Allocatable yes (but full)
PE Size 4.00 MiB
Total PE 25549
Free PE 0
Allocated PE 25549
PV UUID beHW5L-tqXd-TwBF-ddfm-ouJn-OQbk-gYznOz

--- Physical volume ---
PV Name [unknown]    #这里显示未知说明有问题
VG Name cl
PV Size 10.00 GiB / not usable 3.00 MiB
Allocatable yes
PE Size 4.00 MiB
Total PE 2559
Free PE 2559
Allocated PE 0
PV UUID fNjF3j-gTVO-fkOV-2Cfe-MxSg-6uFo-v6hlZJ

解决方法如下

先尝试根据系统命令看一下有没有合适的命令

从lvdisplay那里我们可以推测,vg有问题

所以我们来看一下vg开头的命令有哪些

可以看到vgck,vgscan都可以用来检查vg,其中vgremove和vgreduce和删除东西有关,所以我们重点关注这两个命令

经分析vgremove 是用来直接删掉vg的,所以我们试着来看一下vgreduce

[root@localhost ~]# vgreduce --help
vgreduce: Remove physical volume(s) from a volume group

vgreduce
[-a|--all]
[-A|--autobackup y|n]
[--commandprofile ProfileName]
[-d|--debug]
[-h|--help]
[--mirrorsonly]
[--removemissing]
[--reportformat {basic|json}]
[-f|--force]
[-t|--test]
[-v|--verbose]
[--version]
VolumeGroupName
[PhysicalVolumePath...]

我们尝试用removemissing选项

再看一下,已经恢复正常了

添加一个pv到vg后,误删新加入的pv,报 pv * not found or rejected by a filter的更多相关文章

  1. 向PE文件中添加一个Section

    背景 之前说过直接向类HelloWorld.exe的可执行文件添加一个MessageBox弹窗, 但有时候, 需要添加的内容太多了, 因为数据与代码一起插入, 以至于可执行文件本身没有足够的空闲空间存 ...

  2. SQL Server 2005中的分区表(五):添加一个分区(转)

    所谓天下大事,分久必合,合久必分,对于分区表而言也一样.前面我们介绍过如何删除(合并)分区表中的一个分区,下面我们介绍一下如何为分区表添加一个分区. 为分区表添加一个分区,这种情况是时常会 发生的.比 ...

  3. SQL Server 2005中的分区表(五):添加一个分区

    所谓天下大事,分久必合,合久必分,对于分区表而言也一样.前面我们介绍过如何删除(合并)分区表中的一个分区,下面我们介绍一下如何为分区表添加一个分区. 为分区表添加一个分区,这种情况是时常会 发生的.比 ...

  4. Linux 在添加一个新账号后却没有权限怎么办

    当添加一个新账号后,我们可能会发现新账号sudo 时会报告不在sudoers中,使用su -s时输入密码后也会认证失败 上网搜索大部分都要求修改/etc/sudoers中的内容,但修改这个文件必须需要 ...

  5. SharePoint 自定义的列表页面中添加javascript的一个 For循环语句后,该页面就打不开了。

    一个sharepoint 2013的普通的列表的自定义新建页面,我在其中新添加几行javascript代码后页面就打不开了.如图所示: 真是一言不合,友谊的页面说打不开就打不开啊.后来慢慢比对发现是因 ...

  6. linux采用模块方法,添加一个新的设备

    该文转载自:http://rangercyh.blog.51cto.com/1444712/521244 系统调用是操作系统内核和应用程序之间的接口,而设备驱动程序是操作系统内核和机器硬件之间的接口. ...

  7. 012.Adding a New Field --【添加一个新字段】

    Adding a New Field 添加一个新字段 2016-10-14 3 分钟阅读时长 作者 By Rick Anderson In this section you'll use Entity ...

  8. Mysql学习(一)添加一个新的用户并用golang操作Mysql

    Mysql添加一个新的用户并赋予权限 添加一个自己的用户到mysql 首先我们需要先用root用户登录mysql,但是刚安装完没有密码,我们先跳过密码 ailumiyana@ailumiyana:~/ ...

  9. RK平台Android4.4 添加一个新的遥控器支持以及添加特殊按键【转】

    本文转载自:http://blog.csdn.net/coding__madman/article/details/52904063 版权声明:本文为博主原创文章,未经博主允许不得转载. 瑞芯微平台 ...

随机推荐

  1. Tampermonkey脚本属性

    新建脚本属性: // ==UserScript== // @name New Userscript 脚本名 // @namespace http://tampermonkey.net/ 脚本主页 // ...

  2. 浅谈Final

    Java关键字final有“这是无法改变的”或者“终态的”含义,final可以修饰非抽象类.非抽象类成员方法和变量. final类不能被继承,没有子类,final类中的方法默认是final的.fina ...

  3. VC.重定向标准输出到文件(父进程方式)

    1.libxml2 使用过程中,有时 libxml2里面会报一些错误信息,在 控制台的程序中 这些信息看起来比较乱,不易观察,我想将这些信息重定向到 文件中 1.1.本进程内:试着 将标准输出,标准错 ...

  4. jRazor

    引擎渲染速度竞赛 条数据 × 次渲染测试 建议在高版本的浏览器上进行测试,避免浏览器停止响应 测试环境: 开始测试»  

  5. DOMContentLoaded方法

    document.addEventListener('DOMContentLoaded',function(){ alert("SSDD") },false);

  6. itchat和wordcloud对微信好友的签名进行画像

    获取好友列表的时候,返回的json信息中还看到了有个性签名的信息,脑洞一开,把大家的个性签名都抓下来,看看高频词语,还做了个词云. # coding:utf-8 import itchat # 先登录 ...

  7. httpd常见配置

    httpd常见配置 配置文件 /etc/httpd/conf/httpd.conf    主配置文件 /etc/httpd/conf.d/*.conf  辅助配置文件 配置文件语法检查及重新加载配置文 ...

  8. flask项目部署

    1.安装 安装ssh 新版本安装位 apt/apt-get 老版本为 apt-get 安装以后 ifconfig查看当前的ip地址 如果网络不在同一个ip段 将网络模式设置为桥接 安装pip3 sud ...

  9. Jboss解决只能通过localhost访问而不能使用IP访问项目的问题

    之前项目都是前后端完全分离,很少使用到后端语言的开发工具,最近使用intellij+Jboss进行项目部署开发,初始用发现项目启动后只能使用localhost进行项目访问,IP地址访问则提示页面404 ...

  10. Fedora 23 U盘启动出现“Failed to load ldlinux.c32”解决

    利用UltraISO制作了Fedora 23的U盘启动,开机F12键USB启动时出现 Failed to load ldlinux.c32 Boot failed: please change dis ...