(一)C#WebService服务在Windows7的部署 

一、在控制面板,程序与卸载中安装IIS组件。

二、IIS无法显示WebService的.asmx文件。解决办法:注:(这里可以不用考虑,直接参考:后面节:遭遇“HTTP 错误 500.19 无法访问请求的页面,因为该页的相关配置数据无效。”)

1、如果你是先安装的vs后再安装的IIS的话先注册一下IIS:

命令行转到目录:C:\Windows\Microsoft.NET\Framework\v2.0.50727 下执行命令:使用VS的命令行,输入命令:aspnet_regiis -i,重新注册.net环境。

2、如果命令行运行提示出错,可尝试用管理员身份运行(win7)。

更新完后,IIS配置的应用程序池的.NetFramework版本为v4.0。

三、进入IIS管理器选择建立或选择一个网站,再右键添加虚拟目录,将物理路径指向你的WebService工程,完成后选择虚拟目录右键执行“转为应用程序”操作,浏览:http://localhost/虚拟目录的别名/Service.asmx,页面显示调用的方法。

四、部署IIS

1、添加站点

2、添加虚拟目录

3、转换为应用程序

4、点击确定。

5、修改“默认文档”.

6、添加 *.asmx文件

7、选中webservice 应用程序,点击右侧的浏览即可。

五、设置URL地址

1、去除.asxm后缀也能调用,例如:

正常的调用方法为:http://localhost/WebServiceServer/WebService1.asmx

要改为:http://localhost/WebServiceServer/WebService1?wsdl

(1)    在webservice服务创建时,添加Global.asax全局文件。

(2)    打开Global.asax文件,添加代码:

protected void Application_BeginRequest(object sender, EventArgs e)

{

string path = Request.Url.ToString();

path = Request.Url.LocalPath.ToString();

if (!path.Contains("/WebService1.asmx"))

{

if (path.Contains("/WebService1"))

{

Context.RewritePath(path.Replace("/WebService1", "/WebService1.asmx"));

}

}

}

六、新建站点

1、

2、

3、

4、

参考资料:

1、http://blog.sina.com.cn/s/blog_6abb49260100lc8z.html

2、http://www.doc88.com/p-418980892612.html

3、http://q.cnblogs.com/q/54872/

4、http://blog.sina.com.cn/s/blog_585657900100036h.html

转自:https://www.cnblogs.com/czhelp/p/3980614.html

(二)遭遇“HTTP 错误 500.19 无法访问请求的页面,因为该页的相关配置数据无效。”

解决方法:

控制面板-->程序和功能-->打开或关闭windows功能-->角色

的这里,如果还未安装“web服务器(IIS)”,则选择“添加”。

如果已经安装了,则选择“web服务器(IIS)”-->添加角色服务。

选择“应用程序开发(已安装)”-->“ASP.NET”。注:勾选这个就可以了

win7下为

查看网页错误,请看这篇文章https://www.cnblogs.com/liushui-sky/p/10522361.html

另其他类似错误一:

HTTP Error 500.19 - Internal Server Error
配置错误: 不能在此路径中使用此配置节。如果在父级别上锁定了该节,便会出现这种情况。锁定是默认设置的 (overrideModeDefault="Deny"),或者是通过包含 overrideMode="Deny" 或旧有的 allowOverride="false" 的位置标记明确设置的。

出现这个错误是因为 IIS 7 采用了更安全的 web.config 管理机制,默认情况下会锁住配置项不允许更改。要取消锁定可以运行命令行 %windir%\system32\inetsrv\appcmd unlock config -section:system.webServer/handlers 。其中的 handlers 是错误信息中红字显示的节点名称。

如果modules也被锁定,可以运行%windir%\system32\inetsrv\appcmd unlock config -section:system.webServer/modules

另外,如果使用Asp.net的朋友,在安装IIS7的时候一定记得勾选Asp.net,默认不选,也会出现类似的错误信息

另其他类似错误二:

HTTP 错误 500.19 - Internal Server Error
无法访问请求的页面,因为该页的相关配置数据无效。

详细错误信息模块 IIS Web Core 
通知 BeginRequest 
处理程序 尚未确定 
错误代码 0x80070005 
配置错误 由于权限不足而无法读取配置文件

原文件夹,右击选择它的属性,打开“安全”选项卡,看到“组或用户 名”,单击“编辑”按钮添加一个新的用户名“Everyone”,然后更改它的权限,将第二个权限“修改”设置为允许就可以了。

转自:https://www.cnblogs.com/delphinet/archive/2010/03/25/1694960.html

(三)IIS网站本机可以访问,局域网其他机器无法访问

  1. 【开始】打开【控制面板】,选择【WINDOWS 防火墙】,进入

  2. 在防火墙界面,选择左侧边栏的【高级设置】

     
  3. 在弹出的高级安全Windows防火墙界面中,选择左侧边栏的【入站规则】,然后在右侧边栏选择【新建规则】

  4. 在弹出的窗口中完成如下操作:

    1.选择【端口】,下一步;

    2.选择【TCP】以及【特定本地端口】,填入要开放的端口号(或开放所有端口,可以以逗号分隔多个端口),下一步;

    3.【允许连接】,下一步;

    4. 网络类型全部勾选,下一步;

    5.【名称】中填入自定义名称,如:IIS 【完成】。

    END

注意事项

  • 在防火墙完全关闭的情况下,此法无效,无需设置开放端口

注:最简单的办法就是关闭防火墙就可以了。

转自:https://jingyan.baidu.com/article/335530da89540a19cb41c3cb.html

C#WebService服务在Windows7的部署的更多相关文章

  1. WCF技术剖析之二十: 服务在WCF体系中是如何被描述的?

    原文:WCF技术剖析之二十: 服务在WCF体系中是如何被描述的? 任何一个程序都需要运行于一个确定的进程中,进程是一个容器,其中包含程序实例运行所需的资源.同理,一个WCF服务的监听与执行同样需要通过 ...

  2. 关于IDEA,多服务运行 Services -> Run Dashboard 部分服务添加变灰色,限制使用5个启动类,重启之后需要重新添加,服务在 Run Dashboard 中的显示排序问题,不显示 Services(Run Dashboard)

    我的IDEA版本为最新版本 变灰色的原因就是因为右键删除了那个启动的主配置类,然后就会显示灰色,再次打开这个醒目,就不会在Run Dashboard中显示这个主配置类了 解决方法 如果你要 调整这些服 ...

  3. .net core 和 WPF 开发升讯威在线客服系统【私有化部署免费版】发布

    希望 .net 和 WPF 技术时至今日,还能有一些存在感. 这个项目源于2015年前后,当时开发的初版,我使用了 ASP.NET MVC 做为后端,数据库使用原生 ADO.NET 进行操作.WPF ...

  4. WebService的创建发布及部署

    1.打开win7的IIS功能: http://jingyan.baidu.com/article/2a138328ae4b85074b134f55.html 2.IIS注册Frameworkt4.0 ...

  5. Solr服务在Linux上的搭建

    一.系统环境 注:欢迎大家转载,非商业用途请在醒目位置注明本文链接和作者名dijia478即可,商业用途请联系本人dijia478@163.com. CentOS-6.7-i386-bin-DVD1 ...

  6. windows7下部署tomcat

    需要准备的软件: 1.JDK 安装程序 2.Tomcat 安装程序 JDK安装步骤: 安装方式:使用安装程序进行安装.使用JDK文件夹,免安装,以下步骤使用的是文件夹免安装,只需配置环境变量 配置环境 ...

  7. Solr服务在Linux上的搭建详细教程

    一.系统环境 注:欢迎大家转载,非商业用途请在醒目位置注明本文链接和作者名dijia478即可,商业用途请联系本人dijia478@163.com. CentOS-6.7-i386-bin-DVD1 ...

  8. 如何把asp.net上的服务在iis调试

    1,在iis上部署一个应用,路径指向工程目录 2,在vs2012(其他版本没试过,10都很久没用不记得了)中打开网站,选择本地iis 3,在你想调试的地方设置断点,F5,搞定!

  9. 没有技术说明文档的开源都是耍流氓:微软Roslyn编译即服务在CIIP中具体应用(上)

    前段时间我发布了 github开源:企业级应用快速开发框架CIIP WEB+WIN+移动端,很多园友们都表示支持并与我探讨相关技术问题,上篇中我也承诺会写相关的技术文章,本篇就来介绍一下建模模块中使用 ...

随机推荐

  1. [Codeforces394B]Very Beautiful Number(逆推)

    退役了吗? 退役了…… 但是以后也许还不会一下子离开OI吧 因为我真的很喜欢OI啊 只是实力不如人 为了考上一个学OI的高中 要努力啊! [本题] 一道很好的题目了(刷CF题看到的) 和394A一样, ...

  2. PAT Basic 1026

    1026 程序运行时间 (15 分) 要获得一个 C 语言程序的运行时间,常用的方法是调用头文件 time.h,其中提供了 clock() 函数,可以捕捉从程序开始运行到 clock() 被调用时所耗 ...

  3. sqlserver数据类型转换

    Insert into [Cet.4] Select CONVERT(VARCHAR(20),CONVERT(DECIMAL(20,7),F1)) FROM Sheet1$ 我从外部导入了一个学号表, ...

  4. jmeter接口测试实例5-文件上传

    Jmeter实例5:文件上传 添加http协议.添加IP.路径.方法.选择files upload文件名称tab,输入绝对路径,参数名称,运行: 上传成功

  5. SDWebImage 加载一些大的图片的时候导致程序崩溃

    在  UIImage+MultiFormat这个类里面添加如下压缩方法, +(UIImage *)compressImageWith:(UIImage *)image { float imageWid ...

  6. nodeJs --- web服务器创建

    一.下载nodeJs http://nodejs.cn/download/ 根据自己的情况选择下载 然后在命令行中输入 node -v 看是否安装成功 (下载node时,会把npm包处理工具一起下) ...

  7. CentOS7+Hadoop2.7.2(HA高可用+Federation联邦)+Hive1.2.1+Spark2.1.0 完全分布式集群安装

    1 2 2.1 2.2 2.3 2.4 2.5 2.6 2.7 2.8 2.9 2.9.1 2.9.2 2.9.2.1 2.9.2.2 2.9.3 2.9.3.1 2.9.3.2 2.9.3.3 2. ...

  8. 每天一个linux命令(4):mkdir

    1.命令简介 mkdir (Make Directory 创建目录): 若指定目录不存在则创建目录.在创建目录时,要求创建目录的用户具有写权限,并应保证新建的目录没有重名. 2.用法 用法:mkdir ...

  9. 【MVP时间】5节课助你破解物联网硬件接入难点

    视频播放链接:https://mvp.aliyun.com/topic/10?spm=5176.8961170.detail.18.31a3yK4zyK4zUc 1.会上网的鸡,有啥不一样? http ...

  10. Ubuntu 16.04常用快捷键

    注意:在Linux下Win键就是Super键 启动器 Win(长按) 打开启动器,显示快捷键 Win + Tab 通过启动器切换应用程序 Win + 1到9 与点击启动器上的图标效果一样 Win + ...