Oracle 11gR2通过Memory创建动态参数文件后,通过SPFILE启动,提示

ORA-32004: obsolete or deprecated parameter(s) specified for RDBMS instance

原因是因为参数文件里面含有弃用(deprecated )的参数,重新编辑删除它们即可。

操作提示

SQL> create spfile from memory;

File created.

SQL> startup force;
ORA-32004: obsolete or deprecated parameter(s) specified for RDBMS instance
ORACLE instance started. Total System Global Area 830930944 bytes
Fixed Size    2232920 bytes
Variable Size   629149096 bytes
Database Buffers    197132288 bytes
Redo Buffers   2416640 bytes
Database mounted.
Database opened.

解决方案

查询日志,显示哪些参数被弃用。

Deprecated system parameters with specified values:
background_dump_dest
user_dump_dest

生成静态参数文件

SQL> create pfile from spfile;

File created.

进行编辑

[oracle@henry dbs]$ vim initPROD1.ora

删除里面有弃用标记的两行参数

*.user_dump_dest='/u01/app/oracle/diag/rdbms/prod1/PROD1/trace'#Deprecate parameter
*.background_dump_dest='/u01/app/oracle/diag/rdbms/prod1/PROD1/trace'#Deprecate parameter

通过静态参数文件创建SPFILE

[oracle@henry dbs]$ sqlplus / as sysdba

SQL*Plus: Release 11.2.0.3.0 Production on Tue May 28 00:20:31 2019

Copyright (c) 1982, 2011, Oracle.  All rights reserved.

Connected to an idle instance.

SQL> create spfile from pfile;

File created.

启动数据库(默认使用SPFILE),将不再有的ORA-32004错误。

SQL> startup
ORACLE instance started. Total System Global Area 830930944 bytes
Fixed Size    2232920 bytes
Variable Size   629149096 bytes
Database Buffers    197132288 bytes
Redo Buffers   2416640 bytes
Database mounted.
Database opened.

官方DETAILS

Error Text, Cause and Action from Message File/s for ORA-32004

Versions 11.2, 12.1

Error:  ORA-32004 obsolete or deprecated parameter(s) specified for %s instance
-------------------------------------------------------
Cause: Obsolete or deprecated parameters
for this instance type were
specified in the SPFILE or the PFILE on the server side.
Action: See alert log for a list of parameters
that are obsolete or deprecated.
Remove them from the SPFILE or the server side PFILE.
Versions 9.2, 10.1, 10.2, 11.1

Error:  ORA-32004 obsolete and/or deprecated parameter(s) specified
--------------------------------------------------------
Cause: One or more obsolete and/or parameters
were specified in the SPFILE or
the PFILE on the server side.
Action: See alert log for a list of parameters
that are obsolete. or deprecated.
Remove them from the SPFILE or the server side PFILE.

OERR: ORA-32004 "obsolete or deprecated parameter(s) specified for %s instance"的更多相关文章

  1. RAC ORA-32004: obsolete or deprecated parameter(s) specified for RDBMS instance

    重启RAC时发现32004,后来才发现DG已经不存在了standby_archive_dest还在生效中,而background_dump_dest和user_dump_dest并没在pfile中出现 ...

  2. 手动建库时一个小错误:ORA-32004: obsolete or deprecated parameter(s) specified for RDBMS instance

    此前执行了CREATE SPFILE FROM MEMORY.  重新使用SPFILE启动时,出错如下: SYS@ bys3>startup ORA-32004: obsolete or dep ...

  3. ORA-32004: obsolete or deprecated parameter(s) specified for RDBMS instance

    1.启动报错SQL> startupORA-32004: obsolete or deprecated parameter(s) specified for RDBMS instanceORAC ...

  4. ORA-32004: obsolete and/or deprecated parameter(s) specified

    如果在启动数据库时遇到ORA-32004: obsolete and/or deprecated parameter(s) specified 错误,这个是因为数据库里面设置了过时或不推荐使用的参数, ...

  5. oracle 错误码查看命令oerr ora及常用错误码总结--不断更新

    oracle 错误码查看命令oerr ora及常用错误码总结--不断更新 1.ORA-00907: 缺失右括号 我自己的问题出在 字段的default 和 not null 顺序反了,defalut ...

  6. ORA-32004

    今天在启动数据库的过程中,收到以下错误: SQL> startup ORA: obsolete or deprecated parameter(s) specified for RDBMS in ...

  7. ORA-32004 的错误处理

    启动数据库时,收到了ORA-32004 的错误,错误多是一些过时且在当前版本中不在使用的参数,如果碰到类似的错误,只需要将其 reset即可. SQL> startup;ORA-32004: o ...

  8. oracle数据库升级dbua操作阻塞解决方法(解决ORA-32004报错)

    操作环境 1.SuSE11sp3操作系统 2.oracle 11.2.0.3版本升级到11.2.0.4版本 问题现象   oracle 11.2.0.3版本升级到11.2.0.4版本时执行dbua命令 ...

  9. oracle--数据库扩容后出现ORA-27102

    一,问题描述 Connected to an idle instance. SQL> startup nomount ORA: obsolete or deprecated parameter( ...

随机推荐

  1. windows2016_x64搭建ELK(datasource->filebeat->logstash->elasticsearch->kibana)

    windows2016_x64搭建ELK(datasource->filebeat->logstash->elasticsearch->kibana) 本文示例日志程序基于as ...

  2. 纪中21日c组模拟赛

    AWSL  AWSL  AWSL  AWSL AWSL  AWSL  AWSL  AWSL AWSL  AWSL  AWSL  AWSL AWSL  AWSL  AWSL  AWSL 题解传送 T1  ...

  3. 白面系列 docker

    在讲docker之前,首先区分2个概念,容器和虚拟机. 容器: 虚拟机: 简单来说,容器虚拟化操作系统:虚拟机虚拟化硬件. 容器粒度更小更灵活:虚拟机包含资源更多更大. docker就是用来做容器化的 ...

  4. MacOs使用CleanMyMac X清除可清除空间

    写在前面 本文介绍如何使用CleanMyMac X清除可清除的空间 可以看到,可清除的空间达到了125.79GB,虽然说不影响系统的使用,但是在使用时间机器进行备份的时候,仍然会将可清除空间当成备份的 ...

  5. Codeforces Round #592 (Div. 2) D - Paint the Tree

    题目链接:https://codeforces.com/contest/1244/problem/D 题意:给你一个树,让你把树上的每个节点染成三种颜色,使得任意三个互相相邻的节点颜色都不一样(意思是 ...

  6. A Bug's Life____并查集

    English preparation: falsify     伪造:篡改:歪曲:证明...虚假 the sexual behavior of a rare species of bugs. 一种稀 ...

  7. 网络中的 TCP/IP

    TCP/IP OSI的“实现”:TCP/IP OSI七层模型 TCP/IP概念层模型 功能 TCP/IP协议族 应用层 应用层 文件传输.电子邮件.文件服务.虚拟终端 FTP,HTTP,SMTP,SN ...

  8. VMware安装centos7与配置网络

    自己想搭建个虚机学习下k8s,使用VMware安装centos7,上不了网,折腾了很久才连上.发现网上很多教程都是错误的或者不明确的,这边写下自己的配置记录 首先安装centos7系统就不赘述了,这边 ...

  9. archlinux install.txt

    ++++++ 注意事项+++ +++++++++++++++++++++++++++ 强烈建议新手移步 Arch Wiki > 新手指南 经验者请参阅 Arch Wiki > 安装指南 若 ...

  10. Python之路Day08

    文件操作 open() -- 打开 open通过Python控制操作系统打开文件 f=open('文件路径',mode='r',encoding='utf-8') mode -- 不写就默认是r f ...