centos-7安装redis服务
一、Redis下载
在centOS里通过wget下载redis
wget http://download.redis.io/releases/redis-4.0.11.tar.gz 具体版本下载地址可以去redis官网查看
Redis下载地址:https://redis.io/download
二、安装
1、进入/usr/local/redis目录下,解压redis安装文件
cp -a /down/redis-4.0.11.tar.gz /usr/local/redis/
cd /usr/local/redis
tar -xzvf redis-4.0.11.tar.gz

2、进入解压后的文件目录,之后直接编译即可(redis安装相对简单)
cd redis-4.0.11
make

3、复制redis-server 和 redis-cli到redis文件夹
cp /usr/local/redis/redis-4.0.11/src/redis-server /usr/local/redis/
cp /usr/local/redis/redis-4.0.11/src/redis-cli /usr/local/redis/
4、复制redis的配置文件
cp /usr/local/redis/redis-4.0.11/redis.conf /usr/local/redis
5、编辑配置文件
cd /usr/local/redis
vim redis.conf
编辑以下几项:
① 注释 bind 127.0.0.1 项。
默认的bind 接口是127.0.0.1,也就是本地回环地址。
这样的话,访问redis服务只能通过本机的客户端连接,而无法通过远程连接 ② 保护模式protected-mode yes 改为 protected-mode no。
Protected-mode 是为了禁止公网访问redis cache,加强redis安全的。
它为yes有两个条件需要满足:没有bind IP 和 没有设置访问密码。
如果为yes,则只能够通过lookback ip(127.0.0.1)访问Redis cache,
如果从外网访问,则会返回相应的错误信息 ③ 默认为不守护进程模式,把daemonize no 改为daemonize yes
daemonize 设置yes或者no区别
daemonize:yes:redis采用的是单进程多线程的模式。当redis.conf中选项daemonize设置成yes时,代表开启守护进程模式。
在该模式下,redis会在后台运行,并将进程pid号写入至redis.conf选项pidfile设置的文件中,此时redis将一直运行,除非手动kill该进程。
daemonize:no: 当daemonize选项设置成no时,当前界面将进入redis的命令行界面,exit强制退出或者关闭连接工具(putty,xshell等)都会导致redis进程退出。 ④ 将 requirepass foobared前的“#”去掉,并重置密码。格式为requirepass mypassword123
6、编辑redis开机启动redis脚本并给脚本赋予权限
vim /etc/init.d/redis
编辑之后赋予权限:
chmod 755 /etc/init.d/redis
在/etc/init.d/redis文件中写如下代码【该脚本在设置密码或者未设置密码时通用】
#!/bin/sh # chkconfig: 2345 80 90
# description: Start and Stop redis
# PATH=/usr/local/bin:/sbin:/usr/bin:/bin
REDISPORT=6379 #端口
EXEC=/usr/local/redis/redis-server #redis-server路径
REDIS_CLI=/usr/local/redis/redis-cli #redis_cli路径
PIDFILE=/var/run/redis_$REDISPORT.pid
CONF="/usr/local/redis/redis.conf" #redis.conf路径
AUTH="mypassword123" #密码信息 case "$1" in
start)
if [ -f $PIDFILE ]
then
echo "$PIDFILE exists, process is already running or crashed"
else
echo "Starting Redis server..."
$EXEC $CONF
fi
if [ "$?"="0" ]
then
echo "Redis is running..."
fi
;;
stop)
if [ ! -f $PIDFILE ]
then
echo "$PIDFILE does not exist, process is not running"
else
PID=$(cat $PIDFILE)
echo "Stopping ..." if [ -z $AUTH ]
then
$REDIS_CLI -p $REDISPORT SHUTDOWN
else
$REDIS_CLI -a $AUTH -p $REDISPORT SHUTDOWN
fi while [ -x ${PIDFILE} ]
do
echo "Waiting for Redis to shutdown ..."
sleep 1
done
echo "Redis stopped"
fi
;;
restart|force-reload)
${0} stop
${0} start
;;
*)
echo "Usage: /etc/init.d/redis {start|stop|restart|force-reload}" >&2
exit 1
esac
7、添加开机启动服务
在rc.local增加启动代码就可以了。
vim /etc/rc.local
在里面加上 service redis star

8、给Redis启动注册系统服务
chkconfig --add redis
9、测试redis服务开启关闭
service redis start
service redis stop
检查开启是否成功:
ps -ef|grep redis
10、创建redis命令软连接
ln -s /usr/local/redis/redis-cli /usr/bin/redis
注意:因为redis登录时加了密码验证,所以用redis时需要加 ‘auth 密码’
centos-7安装redis服务的更多相关文章
- Centos 7 安装redis,修改配置文件不生效、外网不能访问。
前提: 在用Centos 7 安装 redis 时,遇上一下几个问题 ,记录下 . 1.修改配置文件,按官网步骤启动,不生效. 2.外网无法访问redis. 步骤: 1.打开centos 虚拟机 ,按 ...
- window 安装redis服务、卸载redis服务和启动redis服务
1.安装redis服务 redis-install.bat 1 echo install redis-server23 D:\redis\redis-server.exe --service-inst ...
- window如何安装redis服务、卸载redis服务和启动redis服务
window如何安装redis服务.卸载redis服务和启动redis服务 一.总结 一句话总结:github上下载,解压,命令行运行(redis-server.exe redis.windows.c ...
- win7 安装redis服务
Redis官方是不支持windows的,只是 Microsoft Open Tech group 在 GitHub上开发了一个Win64的版本,项目地址是: https://github.com/MS ...
- Windows下安装Redis服务及安装PHP的Redis扩展
Redis是一个开源的使用ANSI C语言编写.遵守BSD协议.支持网络.可基于内存亦可持久化的日志型.Key-Value数据库,并提供多种语言的API. 它通常被称为数据结构服务器,因为值(valu ...
- 在 CentOS 上安装 vsftp 服务
在 CentOS 上安装 vsftp 服务 1.查看当前 CentOS 服务器是否已安装了 vsftpd 服务: rpm -q vsftpd 如果打印如下类似的信息则表明已安装 vsftpd 服务: ...
- 【转】window 安装redis服务、卸载redis服务和启动redis服务
1.安装redis服务 redis-install.bat 1 echo install redis-server23 D:\redis\redis-server.exe --service-inst ...
- centos 下安装redis 通过shell脚本
#! /bin/bash echo -e "开始安装redis服务\n" download_url=http://download.redis.io/releases/redi ...
- Linux(Centos)之安装Redis及注意事项
1.redis简单说明 a.在前面我简单的说过redis封装成共用类的实现,地址如下:http://www.cnblogs.com/hanyinglong/p/Redis.html. b.redis是 ...
- 虚拟机centOS中安装Redis,主机Redis Destop Manager不能访问虚拟机Redis server的解决方案
今天在学些redis的时候碰到个问题,发现主机Redis Destop Manager不能访问虚拟机Redis server的解决方案,找了一些网上的资料,原因可能有两个,整理记录下来: 1. Red ...
随机推荐
- App云测试服务对比
前言: 我们都知道在测试移动app时最耗时的是在各种测试设备进行测试, 因为不论是安卓还是iOS都已经碎片化了.而云测试看似是解决这一问题的有效途径.因此选择哪种云测试平台来协助测试人员进行各种测试就 ...
- 【读书笔记】Linux内核设计与实现(第十八章)
18.1 准备开始 需要: 1.一个确定的bug.但是,大部分bug通常都不是行为可靠定义明确的. 2.一个藏匿bug的内核版本. 18.2 内核中的bug bug发作时的症状: 明白无误的错误代码( ...
- Linux换源
Linux换源 前言 最近学校的ipv6坏了,导致从deepin本身获取的源速度极慢,笔者实在忍无可忍,随后在同学指导下换了清华大学ipv4的源 步骤 sudo gedit /etc/apt/sour ...
- Oracle DROPtable以及Truncate table 的简单测试
1. 一个用户库 有一个业务表比较大 大小是 49g 表的行数为:121546147 一亿两千万行 制作一个虚拟机的快照测试一下 drop table 和 truncate table的性能差距 2. ...
- [专贴]Xshell 以及 shell 的快捷键
Ctrl + a 切换到命令行开始Ctrl + e 切换到命令行末尾Ctrl + l 清除屏幕内容Ctrl + u 清除光标之前的内容Ctrl + k 清除光标之后的内容Ctrl + h 类似于退格键 ...
- Python模块-pandas
目录 数据读取 数据探索 数据清洗 数据清洗 类型转换 缺失值 重复值 值替换 修改表结构 新增列 删除列 删除行 修改列名 数据分组(数值变量) 数据分列(分类变量) 设置索引 排序 数据筛选/切片 ...
- Android studio Gradle编译错误: Unable to tunnel through proxy. Proxy returns "HTTP/1.1 400 Bad Reques
两种处理方法: 1.修改distributionUrl链接 gradle-wrapper.properties文件 distributionUrl=https\://services.gradle.o ...
- 修改docker镜像和容器的存放路径
默认情况下,镜像和容器存放的路径是/var/lib/docker. 要修改这个设置很简单,把指定的目录软链到这个目录,或者将一个单独的分区挂载到这个目录,或者直接修改docker启动参数. 查看使用帮 ...
- PostgreSQL(一)教程 -----从头开始
一.安装 自然,在你能开始使用PostgreSQL之前, 你必须安装它.PostgreSQL很有可能已经安装到你的节点上了, 因为它可能包含在你的操作系统的发布里, 或者是系统管理员已经安装了它.如果 ...
- Eclipse 报 "The builder launch configuration could not be found" 错误
Eclipse 报 "The builder launch configuration could not be found" 错误的解决办法 标签: eclipseEclipse ...