LINUX安装好后无法访问网络
LINUX安装好后无法访问网络
在虚拟机安装好新的LINUX系统后,ping www.baidu.com ,发现无法ping通。
键入ifconfig查询配置:
|
eno16777728: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 |
|
ether 00:0c:29:3e:ad:2d txqueuelen 1000 (Ethernet) |
|
RX packets 0 bytes 0 (0.0 B) |
|
RX errors 0 dropped 0 overruns 0 frame 0 |
|
TX packets 0 bytes 0 (0.0 B) |
|
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 |
|
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536 |
|
inet 127.0.0.1 netmask 255.0.0.0 |
|
inet6 ::1 prefixlen 128 scopeid 0x10<host> |
|
loop txqueuelen 0 (Local Loopback) |
|
RX packets 942 bytes 79580 (77.7 KiB) |
|
RX errors 0 dropped 0 overruns 0 frame 0 |
|
TX packets 942 bytes 79580 (77.7 KiB) |
|
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 |
得到本机的网卡是eno16777728
然后,重启网卡服务:service network restart
再次查询:ifconfig,发现依旧如上所示,并且无法访问网络。
修改网卡配置: root模式下vim /etc/sysconfig/network-scripts/ifcfg-eno16777728(最后的数字不一定一致,不要照搬,根据查询出来的配置信息灵活替换),然后将文件里最后一项的ONBOOT=no在插入模式中修改为yes并保存退出,以后计算机自动启动网卡。
现在手动启动网卡服务ifup eno16777736
重新键入ifconfig:
|
eno16777728: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 |
|
inet 192.168.81.134 netmask 255.255.255.0 broadcast 192.168.81.255 |
|
inet6 fe80::20c:29ff:fe3e:ad2d prefixlen 64 scopeid 0x20<link> |
|
ether 00:0c:29:3e:ad:2d txqueuelen 1000 (Ethernet) |
|
RX packets 125 bytes 14963 (14.6 KiB) |
|
RX errors 0 dropped 0 overruns 0 frame 0 |
|
TX packets 147 bytes 15265 (14.9 KiB) |
|
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 |
|
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536 |
|
inet 127.0.0.1 netmask 255.0.0.0 |
|
inet6 ::1 prefixlen 128 scopeid 0x10<host> |
|
loop txqueuelen 0 (Local Loopback) |
|
RX packets 946 bytes 80000 (78.1 KiB) |
|
RX errors 0 dropped 0 overruns 0 frame 0 |
|
TX packets 946 bytes 80000 (78.1 KiB) |
|
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 |
问题解决,网卡服务成功启动,并且后续不需要每次都手动启动网卡服务
本文参照:http://114193107.blog.51cto.com/3025337/1676433
LINUX安装好后无法访问网络的更多相关文章
- Linux安装Tomcat外部不能访问
Linux安装Tomcat后本地可以正常访问,可是这时Tomcat还不能被外界访问需要在Linux默认防护墙上打开8080端口 打开 /etc/sysconfig/iptables [root@loc ...
- linux安装mysql后root无法登录 sql 无法登录
linux安装mysql后root无法登录 问题:[root@localhost mysql]# mysql -u root -pEnter password: ERROR 1045 (28000): ...
- linux安装MySQL后输入mysql显示 ERROR 2002 (HY000): Can't connect to local MySQL server through socket
我是小白,大佬勿喷 *** linux安装MySQL后输入mysql显示 ERROR 2002 (HY000): Can't connect to local MySQL server through ...
- linux安装tomcat后启动报错Cannot find ./catalina.sh的解决方法
linux安装tomcat后启动报错: Cannot find ./catalina.shThe file is absent or does not have execute permissionT ...
- widows10 安装1803 版本后不能访问网络上的机器解决方法
安装Windows10 1803 版本后,发现网络上的机器好多不见了. 使用 ping 可以ping 通,但是访问网络共享提示下面错误. 这个原因是1803 中没有安装 SMB1.0 协议.因为 S ...
- linux tomcat启动后无法访问
先是按网上资料先下载安装包,然后上传到linux,启动后发现8080端口并未被占用.查了很多资料,不知道神马原因了.最后用yum安装后就可以访问了. 教程如下: 本教程介绍在CentOS 7服务器上使 ...
- linux安装vsftpd后无法登陆
安装完成后在主机上登陆时,不管是输入用户,还是匿名都无法登陆 经过检查,发现是因为/etc/hosts.deny禁止了所有ip访问 将hosts.deny中的all:all删除,或者在/etc/hos ...
- 关于阿里云服务器Linux安装Tomcat后,外网不能访问解决方案
这里需要提及三个方面的问题 第一个方面:Linux上启动防火墙的问题 当下比较流行的Linux镜像是CentOS,所以防火墙也随之变成了firewall,那么怎么操作这个防火墙呢? #停止fi ...
- 安装docker后,VMware网络无法访问了,VMware重置网络设置
1.vmware虚拟机处于关闭状态 2.vmware程序->edit(编辑)-->左下角 "Restore Default"恢复默认设置 [恢复]完成后 ...
随机推荐
- ORACLE分页SQL
1,使用rownum SELECT * FROM ( SELECT A.*, ROWNUM RN FROM (SELECT * FROM TABLE_NAME) A ) 2,使用between SEL ...
- Android JNI和NDK的关系
转自:http://blog.csdn.net/elfylin/article/details/6121466 1.什么JNI Java Native Interface(JNI)标准是java平台的 ...
- ListView中CheckBox错乱解决
思路: ListView在复用的时候会出现很多问题,CheckBox状态会出现错乱,解决思路: 1.使用Map集合的键值对的形式来存放position位置上CheckBox的状态 2.监听CheckB ...
- [原创]在Debian9上配置NAS
序言 此教程安装的都是最新版本的.由于是当NAS让它非常稳定的运行,所以能不安装的软件尽量不要安装. 一.准备工作 1. 更新系统 没啥,就他喵想用个最新的. apt update && ...
- ansible使用8-Best Practices
Content Organization production # inventory file for production servers stage # inventory file for s ...
- IDEA 打包jar
1.ctrl+shift+alt+s 弹出项目设置窗口,点击Artifacts页签,点+号,选择jar Empty.修改jar name,将右侧需要打包进去的资源拖到左侧,记住Output direc ...
- element-ui打包的坑爹之处 !!!必看三遍!!!
最近笔者打包element-ui出现如下问题: ERROR in static/js/0.4cad92088cb8dc6e7afd.js from UglifyJs Unexpected token: ...
- win2008 配置TLS1.2
配置TLS1.2 提供两种方法, 选择其中一种就行了 1.手动设置 找到HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProv ...
- nginx配置https服务器
方法一 1.创建证书 #cd /usr/local/nginx/conf #openssl genrsa -des3 -out server.key 1024 #openssl req -new -k ...
- Node.js-ReferenceError: _filename is not defined
简直不要被坑得太惨!!!你能?看出来这前面是两根下划线!两根下划线!两根下划线!太尴尬了~找了半天原因居然是这个!