1.进入 mysql:

/usr/local/mysql/bin/mysql -u root -p

2.使用 mysql库 :

use mysql;

3.查看用户表 :

SELECT `Host`,`User` FROM user;

4.更新用户表 :

UPDATE user SET `Host` = '%' WHERE `User` = 'root' LIMIT 1;

5.强制刷新权限 :

flush privileges;

完成以上步骤即可远程连接数据库了,上边关键的一句是

UPDATE user SET `Host` = '%' WHERE `User` = 'root' LIMIT 1;

其中%的意思是允许所有的ip远程访问,如果需要指定具体的某个ip就写上具体的ip即可

说明:在服务器本地登录mysql的话是使用如下命令:mysql -h127.0.0.1 -uroot -p,不能使用这个命令:mysql -hlocalhost -uroot -p

因为上面更新用户表是把地址为localhost的root用户地址给改称%了,所以没法再使用localhost地址登录本地了,不过可以使用127.0.0.1这个地址。

另外还可以把其他多余的账号信息删除,只保留俩账号,均为root,只不过地址一个是%,另一个是127.0.0.1.

这样一来,既可以使用root账号远程登录mysql,也能使用root用户本地登录mysql.

需要防火墙放行3306端口。

注意不是修改mysql配置文件my.cnf文件中的参数bind-address,该配置文件保持默认即可

创建数据库,账号和密码

create database paydb;  # 创建数据库:paydb

create user payuser identified by 'EDRCRFT44434^^&$#$@WWS';  # 创建账号和密码,账号:payuser,密码:EDRCRFT44434^^&$#$@WWS

grant all on paydb.* to 'payuser'@'localhost' identified by 'EDRCRFT44434^^&$#$@WWS' with grant option; # 授权账号和密码只能从本机访问这个数据库

flush privileges; # 刷新权限

配置mysql允许远程访问的更多相关文章

  1. 配置 Mysql 支持远程访问 并取消域名解析以提高链接速度

    1 配置远程访问 1.1 修改 my.cnf [mysqld] 段 bind-address = 0.0.0.0 //支持所有 ipv4 1.2 建立远程访问用户 mysql> grant al ...

  2. Linux下配置Mysql允许远程访问

    操作非常简单,就5步骤,如下: 1.进入 mysql: ? 1 /usr/local/mysql/bin/mysql -u root -p 2.使用 mysql库 : ? 1 use mysql; 3 ...

  3. Linux 配置mysql 免安装版。

    二.Linux配置 mysql ? 1.linux配置mysql(要求全部使用免安装版) 5.1.从官网下载mysql5.tar.gz 5.2.使用xftp把mysql的压缩包上传到服务器上 5.3. ...

  4. 配置mysql远程访问权限,大家可能掉过的那些坑~

    1 作为互联网技术从业人 或者粗暴点说:作为一个程序猿.测试从业者 如果没掉过一些坑,都不好意思说自己混过技术圈     2 今天重点讲:mysql开启远程访问权限的那些坑- 对于mysql开启远程访 ...

  5. CentOS和Windows下配置MySQL远程访问的教程

    CentOS和Windows下配置MySQL远程访问的教程   一.前言 由于实验在云服务器上跑的结果不是很理想.所以,现在切换到局域网服务器.因此,需要重新配置 Windows 服务器和 CentO ...

  6. 【Linux】- Ubuntu 配置mysql远程访问

    ubuntu上安装mysql非常简单只需要几条命令就可以完成. sudo apt-get install mysql-server   安装过程中会提示设置密码什么的,注意设置了不要忘了,安装完成之后 ...

  7. Docker中配置MySQL并实现远程访问

    Docker配置MySQL容器 拉取MySQL镜像 docker pull mysql:5.6 有可能会因为网络问题失败,重复尝试. 创建容器 docker run -d --name selfdef ...

  8. linux安装和配置 mysql、redis 过程中遇到的问题记录

    linux下部署mysql和redis网上的教程很多,这里记录一下我部署.配置的过程中遇到的一些问题和解决办法. mysql ①安装完成后启动的时候报错 Starting MySQL.The serv ...

  9. CentOS 7.2 安装配置mysql主从服务器

    MySQL官方压缩包安装: 1:下载mysql官方版本,此处以目前最新版本5.7.14为例,下载的64位版本文件为: mysql-5.7.14-linux-glibc2.5-x86_64.tar 2: ...

随机推荐

  1. POJ 1474

    半平面交模板 #include <iostream> #include <cstdio> #include <cstring> #include <algor ...

  2. android发送get请求时报错

    异常信息: java.lang.RuntimeException: Unable to start activity ComponentInfo{com.synology.synologycloud/ ...

  3. 通俗编程——白话NIO之Buffer

    Buffer简单介绍 Buffer意为缓冲区.其本质上就是是一块可写入数据,然后能够从中读取数据的内存区域.通过该种方式有助于降低系统开销和提高外设效率.对于缓冲区我们早有所了解,比方在C中标准I/O ...

  4. web.xml配置编码过滤器解决中文乱码问题

    为了防止前端传入的中文数据出现乱码问题,使用Spring提供的编码过滤器来统一编码. 要使用编码过滤器,只需要在web.xml中添加如下代码: <filter> <filter-na ...

  5. beisen

    #include <stdio.h> #include <pthread.h> #include <windows.h> #define N 100 #define ...

  6. Linux - 设置光盘,开机自动挂载。

    设置光盘,开机自动挂载. 挂载, 在linux操作系统中, 挂载是指将一个设备(通常是存储设备)挂接到一个已存在的目录上. 我们要访问存储设备中的文件,必须将文件所在的分区挂载到一个已存在的目录上, ...

  7. 【Codeforces 258A】 Game With Sticks

    [题目链接] http://codeforces.com/contest/451/problem/A [算法] 若n和m中的最小值是奇数,则先手胜,否则后手胜 [代码] #include<bit ...

  8. NSKeyedUnarchiver归档

    把自定义的类对象编码到NSData中 NSData *data = [NSKeyedArchiver archivedDataWithRootObject:bc];//归档,bc是一个自定义的类对象, ...

  9. TYVJ 1941 BZOJ3038 上帝造题的七分钟2 并查集+树状数组

    背景 XLk觉得<上帝造题的七分钟>不太过瘾,于是有了第二部. 描述 "第一分钟,X说,要有数列,于是便给定了一个正整数数列. 第二分钟,L说,要能修改,于是便有了对一段数中每个 ...

  10. Tomcat修改默认根目录

    tomcat7默认的程序发布路径为tomcat/webapps/ROOT/下面 修改Tomcat配置文件server.xml <Host name="localhost" a ...