本文由秀依林枫提供友情赞助,首发于烂泥行天下。

以前有关NFS的文章,我们介绍的都是NFS的使用挂载等等。这篇文章我们介绍有关NFS作为存储使用。

既然本篇文章的主题是有关NFS的,我们还是先把NFS服务器搭建完毕。具体搭建过程可参考《烂泥:NFS存储与VSphere配合使用》,这篇文章。

在此有关NFS配置文件/etc/exports中的几个参数,我们需要先介绍下:

ro 该主机对该共享目录有只读权限。

rw 该主机对该共享目录有读写权限,需要配合no_root_squash参数使用。

root_squash 该参数为缺省参数,客户机用root用户访问该共享文件夹时,将root用户映射成匿名用户即nobody用户不具有对目录具有创建和删除操作。

no_root_squash 客户机用root访问该共享文件夹时,不映射root用户。即具有root用户所有权限,具有对目录具有创建和删除操作。

all_squash 客户机上的任何用户访问该共享目录时都映射成匿名用户。

anonuid 将客户机上的用户映射成指定的本地用户ID的用户。

anongid 将客户机上的用户映射成属于指定的本地用户组ID。

sync 资料同步写入到内存与硬盘中。

async 资料会先暂存于内存中,而非直接写入硬盘。

Insecure 允许从这台机器过来的非授权访问。

因为NFS是做存储使用的,所以我们必须为共享文件配置读写以及root用户权限,同时考虑到数据的安全的问题,建议还需要配置同步权限。具体配置权限如下:

通过上图,我们可以看到NFS共享目录/nfs,具有root用户权限,同时具有可读写、同步的权限。而NFS共享目录/home/datasoft/soft/iso/目录,只具有可读权限。为什么会是这样,我们会在下面就行讲解。

我们现在先来测试下,NFS共享目录的权限。

登录KVM服务器挂载NFS共享目录。如下:

通过上图。我们可以看到NFS的/nfs目录挂载到KVM服务器的/nfs目录下,/home/datasoft/soft/iso/目录挂载到NFS的/nfs目录下。

下面我们开始测试各自挂载目录的权限,如下:

通过以上两张图可以看出,我们对在KVM服务器上对NFS共享目录/nfs的操作都会在NFS服务器上/nfs进行同步,而且我们也具有相应的读写、创建、删除权限。

通过上图我们可以看到,我们在KVM服务器上对NFS共享目录/home/datasoft/soft/iso/只具有读权限权限,而没有创建和删除权限。这个也可以和我们在设置的权限相对应。

注意NFS共享目录/home/datasoft/soft/iso/尽管有读写权限,但是因为没有加入no_root_squash参数,默认使用root_squash参数。尽管已经给出rw参数,但是由于不具有root用户权限,所以没有创建和删除权限。

以上有关NFS共享目录权限测试完毕后,我们现在就开始配置NFS与KVM进行集成。

有关KVM与NFS存储我们分为图形界面方式和命令行方式。

我们首先来介绍命令行方式,现在把KVM的VM的硬盘创建到NFS服务器上,通过如下命令:

qemu-img create -f qcow2 /nfs/nfs.img 20G

ifconfig eth0|grep "inet addr"|awk '{print $2}'|cut -d: -f2

创建完毕后,我们现在登陆NFS服务器查看刚刚生成的文件。如下:

通过上图我们可以看到,现在KVM的VM硬盘已经存在NFS服务器上。

现在我们开始创建VM,使用如下命令:

virt-install -n nfs -r 2048 --os-type=linux --vcpus=1 -c /iso/CentOS-6.5-i386-minimal.iso --disk path=/nfs/nfs.img,format=qcow2,bus=ide --boot cdrom,menu=on -b br0 --vnc --vnclisten=0.0.0.0 --vncport=5993

但是此时会发现系统,提示如下的错误信息:

ERROR 内部错误 Process exited while reading console log output: char device redirected to /dev/pts/1

qemu-kvm: -drive file=/nfs/nfs.img,if=none,id=drive-ide0-0-0,format=qcow2,cache=none: could not open disk image /nfs/nfs.img: Permission denied

经过多次实验,如果把VM的硬盘文件权限修改为777,就不会报错。如下:

但是这种方法你可以看到,这对VM的安全性很低的。

经过查询资料发现,我们只需要把/etc/libvirt/qemu.conf文件中有关用户和用户组的注释去掉即可,这样就不需要修改有关VM的配置。qemu.conf 是libvirt对QEMU的驱动的配置文件,包括VNC、SPICE等和连接它们时采用的权限认证方式的配置,也包括内存大页、SELinux、Cgroups等相关配置。

如下:vi /etc/libvirt/qemu.conf

修改完毕后要重启qemu。如下:

/etc/init.d/libvirtd restart

然后再次创建虚拟机,如下:

系统没有报错,说明现在可以正式安装VM。

现在通过VNC客户端,进行系统安装,如下:

以上是有关命令行下的配置,说实话命令行下配置还是比较简单的。下面我来介绍下如何在图形界面下使用NFS存储,图形界面下需要建立相应的存储池。

注意为了更好的实验效果,我现在把KVM服务器上所有关NFS挂载已经卸载。

启动KVM虚拟机管理virt-manager,如下:

现在我们为KVM创建存储池,如下:

在这个界面中,类型一定要注意,选择netfs:网络导出的目录。

在这个界面中“目标路径”填写KVM服务器中你需要挂载点。我现在需要把NFS的镜像文件权限挂载到/iso目录下。

“主机名”中填写NFS服务器。

“源路径”中填写NFS共享的目录。

这个界面是我们用来存储镜像文件的存储池。下面创建VM硬盘的存储池,利用上边同样的方法,如下:

VM硬盘的存储池创建完毕后,此时并没有创建VM的硬盘文件。现在开始创建VM的硬盘文件,如下:

VM的硬盘文件创建完毕后,我们就可以新建虚拟机。如下:

在ISO镜像中,我们可以选择在前面创建的镜像文件存储池。

在VM的硬盘我们,可以选择前面创建的硬盘文件。

启动VM,开始进行安装系统。

现在看看KVM服务器上NFS挂载情况。如下:

df –h

通过上图我们可以发现,其实命令行和图形界面配置的都是一样的。

以上就是有关,NFS作为存储与KVM进行集成时的相关配置方法以及注意点。

烂泥:NFS做存储与KVM集成的更多相关文章

  1. 基于NFS共享存储实现KVM虚拟机动态迁移

    基于NFS共享存储实现KVM虚拟机动态迁移 一:配置环境 二:安装相关的依赖包 三:实现NFS共享存储 四:KVM机配置相同的步骤 五:安装KVM01安装虚拟机 六:实现迁移  实验初始配置:所有主机 ...

  2. [k8s]k8s配置nfs做后端存储&配置多nginx共享存储&&statefulset配置

    所有节点安装nfs yum install nfs-utils rpcbind -y mkdir -p /ifs/kubernetes echo "/ifs/kubernetes 192.1 ...

  3. 基于本地存储的kvm虚拟机在线迁移

    基于本地存储的kvm虚拟机在线迁移 kvm虚拟机迁移分为4种(1)热迁移基于共享存储(2)热迁移基于本地存储(3)冷迁移基于共享存储(4)冷迁移基于本地存储 这里介绍的是基于本地存储的热迁移 动态块迁 ...

  4. Linux架构之NFS共享存储1

    第35章 NFS共享存储 35.1 NFS基本概述 NFS是Network File System的缩写及网络文件系统.NFS主要功能是通过局域网络让不同的主机系统之间可以共享文件或目录. 常见的文件 ...

  5. NFS 共享存储实战

    目录 NFS 共享存储实战 一.NFS概述 二.NFS部署 部署NFS客户端backup和web01 统一web.nfs.backup的用户权限 代码部署步骤 三.NFS配置详解 NFS存储小结 四. ...

  6. 09 . Kubernetes之pv、pvc及使用nfs网络存储应用

    PV,PVC概述 PV的全称是: PersistentVolume (持久化卷),是对底层的共享存储的一种抽象,PV由管理员进行创建和配置,它和具体的底层的共享存储技术的实现方式有关,比如Ceph.G ...

  7. NFS 共享存储

    目录 环境准备 NFS服务端 NFS客户端 部署时常见报错 httpd服务 NFS 共享存储的坑 环境准备 主机名 WanIP(Wide Area Network) LanIP(Local Area ...

  8. 生产场景NFS共享存储优化及实战

    生产场景NFS共享存储优化: 1.硬件:sas/ssd磁盘,买多块,raid0/raid10,网卡好 2.NFS服务器端优化加all_squash,async /backup/NFS 192.168. ...

  9. Linux之nginx反向代理+三台web+nfs共享存储实现集群配置

    作业四:nginx反向代理+三台web+nfs共享存储实现集群配置 在各个web服务器上挂载nfs [root@localhost nginx]# mount -t nfs 192.168.152.1 ...

随机推荐

  1. servlet基本原理(手动创建动态资源+工具开发动态资源)

    一.手动开发动态资源 1 静态资源和动态资源的区别 静态资源: 当用户多次访问这个资源,资源的源代码永远不会改变的资源. 动态资源:当用户多次访问这个资源,资源的源代码可能会发送改变. <scr ...

  2. Java集合源码分析(六)TreeSet<E>

    TreeSet简介 TreeSet 是一个有序的集合,它的作用是提供有序的Set集合.它继承于AbstractSet抽象类,实现了NavigableSet<E>, Cloneable, j ...

  3. TestNG官方文档中文版(3)-testng.xml

    TestNG的官方文档的中文翻译版第3章,原文请见 http://testng.org/doc/documentation-main.html 3 - testng.xml 调用TestNG由几种不同 ...

  4. percona server 5.7.16正式发布

    继2016年10月12日mysql 5.7.16发布后,percona server 5.7.16终于于11月29日发布了,这是最新版本的5.7系列,可从https://www.percona.com ...

  5. ENVI【遥感图像预处理之图像的几何校正】

    ---恢复内容开始--- 一.图像几何校正的概述 1.几何校正方法: 1)利用卫星自带的地理定位文件进行几何校正.主菜单>>>Map>>Georeference传感器的名 ...

  6. localForage——轻松实现 Web 离线存储

    Web 应用程序有离线功能,如保存大量数据集和二进制文件.你甚至可以做缓存 MP3 文件这样的事情.浏览器技术可以保存离线数据和大量的储存.但问题是,如何选择合适技术,如何方便灵活的实现. 如果你需要 ...

  7. C语言一级指针与二级指针

    指针的概念 指针就是地址, 利用这个地址可以找到指定的数据 指针就是地址, 那么在使用的时候, 常常会简单的说 指针变量为指针 指针变量就是存储地址的变量 int *p1;// 申请了一个变量, 即在 ...

  8. CoreDataManager-OC版-兼容iOS10以前的版本

    头文件: #import <Foundation/Foundation.h> #import <CoreData/CoreData.h> /** CoreData管理器 */ ...

  9. OC中.pch文件的解释

      在IOS开发的项目中有一个Prefix.pch,.pch文件是什么?  Prefix.pch:扩展名.pch表示"precompiled header",这是一个你工程要用到的 ...

  10. 2016最新CocoaPods安装和错误解决 + 自己的经验

    p.p1 { margin: 0.0px 0.0px 0.0px 0.0px; font: 20.0px Times; color: #333333; background-color: #fffff ...