1、如果需要使用zabbix自带的SMTP发送邮件,需要在安装前升级系统的curl到7.20版本以上
2、zabbix对接PHP 7.1版本,因为PHP 7.1类型强化,会在安装完成zabbix,登录之后monitor页面显示:
 A non well formed numeric value encountered [zabbix.php: → require_once() → ZBase->run() → ZBase->processRequest() → CView->getOutput() → include() → make_status_of_zbx() → CFrontendSetup->checkRequirements() → CFrontendSetup->checkPhpMemoryLimit() → str2mem() in include/func.inc.php:]
A non well formed numeric value encountered [zabbix.php: → require_once() → ZBase->run() → ZBase->processRequest() → CView->getOutput() → include() → make_status_of_zbx() → CFrontendSetup->checkRequirements() → CFrontendSetup->checkPhpPostMaxSize() → str2mem() in include/func.inc.php:]
A non well formed numeric value encountered [zabbix.php: → require_once() → ZBase->run() → ZBase->processRequest() → CView->getOutput() → include() → make_status_of_zbx() → CFrontendSetup->checkRequirements() → CFrontendSetup->checkPhpUploadMaxFilesize() → str2mem() in include/func.inc.php:]
解决方案:
sed -i '/$last = strtolower(substr($val, -1));/a$val = substr($val,0,-1);' /home/www/zabbix/include/func.inc.php
/home/www/zabbix/include/func.inc.php文件路径各根据各http服务不同有所差异。
3、zabbix 3.0版本之后,使用自定义脚本发送邮件时,需要手动传递脚本参数
{ALERT.SENDTO}    收件人:对应用户邮箱
{ALERT.SUBJECT}   邮件主题:问题状态+对应的trigger名称 
  
{ALERT.MESSAGE}  邮件正文:action中配置的邮件内容
以上参数按照顺序分别对应自定义脚本中的$1,$2,$3
4、使用自定义脚本发送的邮件,接收到的邮件正文为附件
该问题原因是由windws和linux文本格式导致,需要使用dos2unix将邮件内容进行转换
 #!/bin/bash

 echo "$3" > /tmp/zabbix_alert_message
/usr/bin/dos2unix -k /tmp/zabbix_alert_message
/bin/mail -s "$2" $ < /tmp/zabbix_alert_message
中转文件/tmp/zabbix_alert_message,需要事先创建,并更属主属组为zabbix,否则zabbix服务器以zabbix用户身份执行自定义脚本时,无权限访问该中转文件,导致格式转换失败
5、执行remote command时需要做的事情:
  •   agent端打开remote command支持
 [root@localhost ~]# grep -i remote /etc/zabbix/zabbix_agentd.conf
### Option: EnableRemoteCommands
# Whether remote commands from Zabbix server are allowed.
EnableRemoteCommands=
1为开启,0为关闭,默认为0
  • 配置远程命令时,若该命令需要使用root身份执行,在命令前增加sudo命令。

 
  • 在客户端,使用visudo编辑sudo的配置文件,给zabbix用户增加sudo权限,并关闭tty登录限制新增下面两行:
 zabbix  ALL=(ALL)       NOPASSWD: /etc/rc.d/init.d/httpd restart        #增加权限
Defaults:zabbix !requiretty #关闭TTY登录限制 若为关闭tty登录限制,无法成功使用sudo命令,可在visudo中打开sudo使用日志:
Defaults logfile=/var/sudo.log
Defaults !syslog [root@localhost ~]# more /var/sudo.log
6月 :: : zabbix : sorry, you must have a tty to run sudo ; TTY=unknown
; PWD=/ ; USER=root ; COMMAND=/etc/rc.d/init.d/httpd restart

Zabbix 3.2.6使用注意事项的更多相关文章

  1. zabbix接口调用注意事项--Python

    不知道该怎么写,但是明显得写点什么,担心时间长了,忘记,再回顾时又要重新摸索一遍 一.Request:post params: 1. 第一层的参数处理: 第一层的参数设置为变量 2. 其他层参数格式不 ...

  2. Linux zabbix 配置注意事项

    发现php-fpm启动之后,找不到 php-fpm.pid文件??? vi php-fpm.conf 去掉里面那个 pid = run/php-fpm.pid 前面的分号然后再启动php-fpm才能自 ...

  3. LNMP+zabbix分布式监控搭建及版本升级

    LNMP+zabbix分布式监控搭建需要组件:gcc gcc-c++ openssl* pcre pcre-devel gd gd-devel libjpeg-devel libpng-devel l ...

  4. 自定义key解决zabbix端口监听取值不准确的问题

         今天有一个朋友问到我一个关于zabbix监控tcp端口的问题,明明端口在监听,但是通过net.tcp,listen取值取到的却是0. 经过简单的goole发现这已经是一个历史悠久的问题: 问 ...

  5. 第2章Zabbix基础进阶

    p.MsoNormal,li.MsoNormal,div.MsoNormal { margin: 0cm; margin-bottom: .0001pt; text-align: justify; t ...

  6. 自动化监控利器-Zabbix深入配置和使用

    1.  配置流程 Zabbix完整的监控配置流程可以简单描述为: Host groups(主机组)→Hosts(主机)→Applications(监控项组)→Items(监控项)→Triggers(触 ...

  7. Zabbix实战-简易教程--动作(Actions)--自动发现

    一.概述 Zabbix提供了有效和非常灵活的网络自动发现功能. 设置网络发现后你可以: 加快Zabbix部署(自动添加主机.添加模板) 简化管理(自动删除主机.删除模板.禁用主机) 无需过多管理就能在 ...

  8. Zabbix实战-简易教程(3)--DB安装和表分区

    一.DB安装环境 主机角色 主机IP VIP 操作系统版本 软件版本 DB Master A 192.168.1.97 (主从) CentOS 6.5 64bit mysql-5.6.21 DB Sl ...

  9. centos7之zabbix邮件报警(短信报警)

    前言 前面我们介绍了zabbix的基本linux和window及SNMP流量的简单监控,我们知道作为运维人员,需要7x24小时待命,但是我们不可能时时刻刻都坐在电脑旁边查看监控上的各个主机状态,所以我 ...

随机推荐

  1. tableau extension 调研

    概述 最近调研了一下 tableau extensions 的实现,有一些心得,记录下来,供以后开发时参考,相信对其他人也有用. 总的来说,写 tableau extensions 还是挺简单的,只是 ...

  2. c# Selenium ExpectedConditions 不存在

    Selenium中的显示等待指的是,等待某一元素出现或者等待页面加载完成后,才执行下一步.需要用到WebDriverWait类. 例如: , , )); var element = wait.Unti ...

  3. IDEA工具上传项目报:Push rejected: Push to origin/master was rejected

    原文:https://blog.csdn.net/a137151062/article/details/78820806 解决方案如下: 1.切换到自己项目所在的目录,右键选择GIT BASH Her ...

  4. GPL,BSD,Apache三个开源协定的大体联系及区别

    开源许可证GPL.BSD.MIT.Mozilla.Apache和LGPL的区别 以下是上述协议的简单介绍: BSD开源协议 BSD开源协议是一个给于使用者很大自由的协议.基本上使用者可以"为 ...

  5. 使用URLOS 五分钟安装rTorrent (轻量级优秀BT/PT客户端)

    rTorrent是一个非常简洁.优秀.非常轻量的BT客户端,它使用ncurses库以C++编写,将 rTorrent 用在安装有 GNU Screen 和 Secure Shell 的低端系统上作为远 ...

  6. 安卓的一些UI美化框架的使用

    目录 一.前言 二.Android-Bootstrap 三.Sweet Alert Dialog 四.ExplosionField 一.前言 在这里记录一些用到过的觉得还算不错的UI第三方开源美化框架 ...

  7. Leetcode之广度优先搜索(BFS)专题-279. 完全平方数(Perfect Squares)

    Leetcode之广度优先搜索(BFS)专题-279. 完全平方数(Perfect Squares) BFS入门详解:Leetcode之广度优先搜索(BFS)专题-429. N叉树的层序遍历(N-ar ...

  8. 【Linux开发】linux设备驱动归纳总结(十二):简单的数码相框

    linux设备驱动归纳总结(十二):简单的数码相框 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx ...

  9. sqlalchemy链接数据库

    from sqlalchemy import create_engine HOSTNAME = '127.0.0.1' PORT = 3306 DATABASE = 'first_sqlalchemy ...

  10. gulp时发生错误---------const { Math, Object } = primordials;

    [问题描述] 执行完npm install后,对前台页面进行gulp操作时,报如下错误: const { Math, Object } = primordials; [错误日志] ***@**** M ...