使用背景

线上物理备份任务是在从库上进行的,xtrabackup会在备份binlog的时候执行flush logs,relay-log会rotate到新的一个文件号,导致sql thread线程应用完之后无法自动删除

这时候就可以引入purge_relay_logs做成执行计划自动清理relay log

安装

yum install -y  mha4mysql-node-0.56-0.el6.noarch

需要的权限

RELOAD, SUPER

使用

#Ansible:  purge mysql relay log from mha node
* */ * * * /usr/bin/purge_relay_logs --disable_relay_log_purge --user=purge_relay --password='' --port= --host=127.0.0.1 &>/tmp/mysql_purge_relay.log

可以通过ansible批量对已有的从库加一下

思路就是先获取所有的从库元数据到列表对象中,然后遍历更新inventory及调用写好的playbook,主脚本如

cat mysql_purge_relay.py
# -*_ coding: utf-8 -*-
import json
import os f = 'port_ip_role'
inf = open(f, 'r')
port_ip_role=json.load(inf)
#port_ip_role={"6666,10.1.1.1": "Slave","6667,10.1.1.2": "Slave"} for k,v in port_ip_role.items():
if v=='Slave':
port_ip=k.split(',')
port,ip =port_ip[0],port_ip[1]
os.system('echo "[slave_host]\n{0}">inventory.cfg'.format(ip))
ansible_cmd='ansible-playbook main.yaml --extra-vars="port={0} slave_host={1}"'.format(port,ip)
print ansible_cmd
os.system(ansible_cmd)

main.yaml

- hosts: slave_host
remote_user: root
vars:
vars_files:
- vars.yaml
roles:
- { role: purge_relay, tags: purge_relay }

purge_relay/tasks/main.yaml

- name: check if install
shell: which purge_relay_logs
register: status
ignore_errors: yes - name: check if exists /usr/bin/purge_relay_logs
shell: ls /usr/bin/purge_relay_logs
register: pstatus
ignore_errors: yes - name: check if cron on port
shell: crontab -l|grep purge_relay_logs|grep {{port}}
register: cronstatus
ignore_errors: yes - name: make soft link if not exists /usr/bin/purge_relay_logs
shell: ln -s `which purge_relay_logs` /usr/bin/purge_relay_logs
when: "{{ status.rc }} == 0 and {{ pstatus.rc }} !=0" - name: install mha4mysql-node-0.56 远程yum安装
yum: name=https://raw.githubusercontent.com/yyueshui/mysql-master-ha-rpm/master/mha4mysql-node-0.56-0.el6.noarch.rpm
when: "{{ status.rc }} != 0" - name: purge mysql relay log cronjob
cron: hour="*/2"
name="{{port}} purge mysql relay log from mha node"
user="root"
job="/usr/bin/purge_relay_logs --disable_relay_log_purge --user={{purge_relay_user}} --password='{{purge_relay_password}}' --port={{port}} --host=127.0.0.1 &>/tmp/mysql_purge_relay.log"
#when: "{{ cronstatus.rc }} != 0" #- name: Removes job from crontab
# cron:
# name: "purge mysql relay log from mha node"
# state: absent
# when: "{{ status.rc }} == 0"

补充

如果在运行purge_relay_logs 报错为

-- ::: purge_relay_logs script started.
install_driver(mysql) failed: Can't load '/usr/local/lib64/perl5/auto/DBD/mysql/mysql.so' for module DBD::mysql: libmysqlclient.so.18: cannot open shared object file: No such file or directory at /usr/lib64/perl5/DynaLoader.pm line 200.
at (eval ) line
Compilation failed in require at (eval ) line .
Perhaps a required shared library or dll isn't installed where expected
at /usr/bin/purge_relay_logs line

解决方法为

ln -s /home/mysql/mysql/lib/libmysqlclient.so. /usr/lib64/

注:由于Mariadb 和mysql的参数有些出入,所以在Mariadb上执行会报参数不存在的错误,可以自行修改perl脚本修正

通过 purge_relay_logs 自动清理relaylog的更多相关文章

  1. wordpress自动清理评论回收站

    有时wordpress的垃圾评论实在让人心烦,杂草难除根,footprint吹又生.如果你有心情的话会一个个把垃圾评论放入回收站,但是时间一长,回收站里的东西越堆越多,你可以点击回收站,然后再点一下e ...

  2. 自动清理SQLServerErrorLog错误日志避免太大

    问题描述:开启SQLServer自动备份后,备份文件越来越多,有没有及时清理,导致服务器空间不足,备份出错,以至于出现几个G的ErrorLog文件,影响系统的登录管理. 解决办法:定期清理SQLSer ...

  3. Tomcat8.5.24日志自动清理(maxDays)功能探究

    前言 测试人员反馈tomcat目录下的日志占用空间很大,需要自动清理.接到这个反馈时,想象着应该是一个很简单的功能,tomcat应该已经实现了日志的自动清理功能.于是乎,我先到网上查询了如何自动清除t ...

  4. hive 中间会话临时文件自动清理脚本

    hive在运行过程中,我们经常会发现 hdfs /tmp/hive/hive or hdfs 目录占用空间巨大,我这里已经清理过了所以,相对较小.但是初次使用hive的用户,一定会发现 随着时间的推移 ...

  5. zookeeper3.4.6配置实现自动清理日志【转】

    在使用zookeeper过程中,我们知道,会有dataDir和dataLogDir两个目录,分别用于snapshot和事务日志的输出(默认情况下只有dataDir目录,snapshot和事务日志都保存 ...

  6. CentOS7的/tmp目录自动清理规则

    CentOS6以下系统(含)使用watchtmp + cron来实现定时清理临时文件的效果,这点在CentOS7发生了变化. 在CentOS7下,系统使用systemd管理易变与临时文件,与之相关的系 ...

  7. 自动清理MySQL binlog日志

    开启MySQL binlog日志的服务器,如果不设置自动清理日志,默认binlog日志一直保留着,时间一长,服务器磁盘空间被binlog日志占满,导致MySQL数据库出错. 使用下面方法可以安全清理b ...

  8. zookeeper3.4.6配置实现自动清理日志

    在使用zookeeper过程中,我们知道,会有dataDir和dataLogDir两个目录,分别用于snapshot和事务日志的输出(默认情况下只有dataDir目录,snapshot和事务日志都保存 ...

  9. IIS日志自动清理

    IIS在运行的过程中日志会不停地增长,若iis的网站被频繁的调用或不当的调用,则会产生很多日志.我在系统运维的时候曾出现过20G的系统盘,由于合作商开发的程序有问题,每几百微秒调用一次web服务,短期 ...

随机推荐

  1. Unity结合Flask实现排行榜功能

    业余做的小游戏,排行榜本来是用PlayerPrefs存储在本地,现在想将数据放在服务器上.因为功能很简单,就选择了小巧玲珑的Flask来实现. 闲话少叙.首先考虑URL的设计.排行榜无非是一堆分数sc ...

  2. EF写统计

    EF的特性是,你from的第一个表为主表,接下来的所有表以左联或者内联或者交叉连接的方式去显示,不会出现右联, 在编写的时候,可以先确定个数据源,然后对这个数据源进行数据的统计, 例如SQL: -- ...

  3. 【洛谷2216】[HAOI2007] 理想的正方形(二维RMQ)

    点此看题面 大致题意: 求出一个矩阵中所有\(n*n\)正方形中极差的最小值. 另一种做法 听说这题可以用单调队列去做,但是我写了一个二维\(RMQ\). 二维\(RMQ\) \(RMQ\)相信大家都 ...

  4. PMP(第六版)中的沟通方法总结与对比

  5. python_34_文件操作3

    f=open('yesterday',encoding='utf-8') print(f.tell())#文件句柄所在指针指向的位置,即光标在哪里(按字符计数) f.readline()#读一行 pr ...

  6. 洛谷P1220 关路灯【区间dp】

    题目:https://www.luogu.org/problemnew/show/P1220 题意:给定n盏灯的位置和功率,初始时站在第c盏处. 关灯不需要时间,走的速度是1单位/秒.问把所有的灯关掉 ...

  7. jsp引用servlet生成的验证码代码演示

    此演示代码主要包括以下三部分:1.checkCode.java:用于生成验证码2.checkCodeServler3.check.jsp 验证 下面是checkCode.java的内容: 复制代码代码 ...

  8. flask-bootstrap

    pip install bootstarp 使用bower安装bootstrap的命令是: bash$ bower install bootstrap不过问题出在如何安装bower上. 官方网站上这样 ...

  9. AB test学习笔记

    AB Test 介绍: https://vwo.com/ab-testing/ AB Test 的意义: 数据分析告诉我们要不要去做一件事情,ab 实验反馈告诉我们我们做得好不好,哪里有问题,以及衡量 ...

  10. 闯越自动签到demo版补充说明

    demo代码:https://www.cnblogs.com/canmeng/p/11000548.html 定位出错是由于cookie 我重新登录账号过,cookies的值就变了 当时没注意cook ...