MySql数据主从同步配置
由于需要配置MySQL的主从同步配置,现将配置过程记录下,已被以后不时之需
MySql数据主从同步
1.1. 同步介绍
Mysql的 主从同步 是一个异步的复制过程,从一个 Master复制到另一个 Slave上。在 Master 与 Slave 之间的实现整个复制过程主要由三个线程来完成,其中两个线程(Sql线程和IO线程)在 Slave 端,另外一个线程(IO线程)在 Master 端。
要实现 MySQL 的 主从同步 ,首先必须打开 Master 端的BinaryLog(mysql-bin)功能,否则无法实现。因为整个复制过程实际上就是Slave从Master端获取该日志然后再在自己身上完全顺序的执行日志中所记录的各种操作。打开 MySQL 的 Binary Log 可以通过在启动 MySQL Server 的过程中使用 “—log-bin” 参数选项,或者在 my.cnf 配置文件中的 mysqld 参数组([mysqld]标识后的参数部分)增加 “log-bin” 参数项。
1.2. Mysql主从服务器配置
主服务器IP:192.168.1.60
从服务IP:192.168.1.61
Linux:centOS
Mysql版本:5.1.58
以下配置皆在此服务上进行配置
一、主数据库操作
查看主库服务器的my.cnf配置文件,根据mysql安装包、版本不同,相关的路径和配置文件路径会大致不一样,不过大多情况下是一样的。该文件在 etc/目录下。Mysql服务也提供了对不同服务器配置使用不同的配置文件,要使用它们的时候,只需用它们任一一个替换上面的my.cnf文件即可。注:替换文件名必须为my.cnf。
cnf配置文件一般会有四个,可以根据命令 # ll /usr/share/mysql/*.cnf 查看;
my-small.cnf 内存少于或等于64M,只提供很少的的数据库服务;
my-medium.cnf 内存在32M--64M之间而且和其他服务一起使用,例如web;
my-large.cnf 内存有512M主要提供数据库服务;
my-huge.cnf 内存有1G到2G,主要提供数据库服务;
my-innodb-heavy-4G.cnf 内存有4G,主要提供较大负载数据库服务(一般服务器都使用这个);
可以根据服务器配置的不同选择不同的cnf配置文件。
1、 配置my.cnf文件
采用系统默认的etc/my.cnf配置文件进行配置,对主服务器进行配置主要需要在配置文件中添加以下几项(在添加的时候要确保它们不在文件中存在,因为如选择上面几种不同的配置文件,配置里的内容会不一样,如果没有相应的项,需要添加)。
用vi etc/my.cnf打开文件,对文件进行修改,在[mysqld]下面进行添加修改:
Server-id = 1 #这是数据库ID,此ID是唯一的,主库默认为1,其他从库以此ID进行递增,ID值不能重复,否则会同步出错;
log-bin = mysql-bin 二进制日志文件,此项为必填项,否则不能同步数据;
binlog-do-db = testcreate #需要同步的数据库,如果需要同步多个数据库;
则继续添加此项。
binlog-do-db = testcreate1
binlog-do-db = testcreate2
binlog-ignore-db = mysql 不需要同步的数据库;
至此主服务器配置my.cnf配置完成,保存退出文件。
现在对Mysql服务器进行重启:#servicemysqld restart 如果重启失败,则证明配置文件错误,需重新检查。
建议:对my.cnf修改之前最好对其进行备份,以免配置文件修改失败不能及时重启服务器。
2、 配置完成后需要建立同步用的数据库账户
主库需要提供一个账户让从库对起连接并同步,用命令mysql服务器
mysql>grantreplication slave on *.* to ‘testcreate’@’192.168.1.61’ identified by ‘123456’;
说明:’testcreate’:同步的数据库;
‘192.168.1.61’:同步的数据库地址;
‘123456’ :同步的数据库密码,在从库配置时需要设置。
3、显示主库信息
mysql>showmaster status;
执行上述命令显示:
看到上述信息则表示主库建立成功。
4、备份数据库(如果从服务器也为新建库,则不需要此操作)
备份数据库的方法有很多种:如果在同一局域网可以直接复制数据库,也可以用工具直接进行数据导入。
复制数据库用打包的方法:
# cd/data 转到存放Mysql数据库的路径下
# tarcvfz testcreate.tar.gz db/
再从数据库中进行复制解压
# cd/data
# scp192.168.1.61:/data/testcreate.tar.gz
#tarxvfz testcreate.tar.gz
数据复制完毕;
二、 从库配置
从服务器的配置基本与主库配置差不多,选择的从库服务器为:192.168.1.61
1. 配置从库服务my.cnf文件
# vietc/my.cnf 对其进行如下修改:
Server-id = 2 #这里ID改为2 因为主库为1;
log-bin = mysql-bin 必填项,用于数据同步;
master-host = 192.168.1.60 主库IP;
master-user = test 同步用的账户;
master-password = 123456 同步账户密码,主库时的设置;
master-port = 3306 同步数据库的端口号。
2. 重启从库服务器
#service mysqld restart
如果重启失败则配置文件有问题,需重新检查配置。
3. 调整复制过来的数据库的权限(如果有从主库复制过来的数据库)
主库复制过来的数据库权限都为root权限,需要修改为mysql权限
#chown–R mysql:mysql /var/lib/mysql
如果从库是新建的库就不需要进行此步骤
4. 显示从服务器状态
进行mysql服务器:
mysql>showslave status\G; 显示如图:

如果slave_io_running和slave_sql_running都为yes则表示从服务器配置成功。
如果遇到关于position相关的错误,就需要再手动设置以下File/Postion的信息
mysql>Changemaster to master_host = ‘192.168.1.60’
master_user= ‘test’
master_password=’123456’
master_log_file=’mysql-bin.000001’, 主库的文件信息
master_log_pos=’106’;主库的Position信息
三、 主从服务器测试
在主服务器和从服务器建立同样的数据库:testCreate 表为:test,字段为ID,name
往主服务器添加数据

此时从服务器192.168.1.61中testcreate数据库显示为

表示主从服务器同步成功。
四、 常见问题
在配置成服务器时,从库不能进行修改操作,即从库只有读的权限,如果修改了从库数据库,则会造成同步失败:如发现失败,用showslave status\G;查看从服务器的状态信息
如果出现slave_IO_Running:为NO时,则表示从数据库连接失败
Last_Error:会显示出出错日志信息

出现此问题主要是事物回滚问题,解决方法有:
1、
mysql>slave stop; 停止从服务
mysql>set GLOBAL SQL_SLAVE_SKIP_COUNTER=1;
mysql>slave start; 启动从服务
2、手动重设从服务器
mysql>Changemaster to
master_host= ‘192.168.1.60’
master_user= ‘test’
master_password=’123456’
master_log_file=’mysql-bin.000001’; 主库的文件信息
master_log_pos=’106’;主库的Position信息
到此Mysql主从服务配置完毕
在主服务器中,主要是以写数据为主,建议用InnoDB数据引擎,在读方面用Mysql中的MyISAM引擎读的效率很不错。
MyIsAM引擎支持全文索引,但不支持事务,而InnoDB恰好相反!
MySql数据主从同步配置的更多相关文章
- Linux下MySQL数据库主从同步配置
说明: 操作系统:CentOS 5.x 64位 MySQL数据库版本:mysql-5.5.35 MySQL主服务器:192.168.21.128 MySQL从服务器:192.168.21.129 准备 ...
- Docker Mysql数据库主从同步配置方法
一.背景 最近在做内部平台架构上的部署调整,顺便玩了一下数据库的主从同步,特此记录一下操作- 二.具体操作 1.先建立数据存放目录(-/test/mysql_test/) --mysql --mast ...
- CentOS7安装配置MariaDB(mysql)数据主从同步
CentOS7安装MariaDB并配置主从同步 环境声明: 防火墙firewalld及SElinux均为关闭状态 主库节点:192.168.0.63 从库节点:192.168.0.64 配置主库节点: ...
- MySQL数据库主从同步配置
主服务器必须打开开二进制日志. 主要是修改配置文件 , 一般在 linux 下安装的 mysql 配置文件是 my.cnf, 在 windwos 下是 my.ini, 修改主服务器配置文件 serve ...
- 简单的MySQL数据库主从同步配置
Master配置: 代码如下 复制代码 log-bin = mysql-binserver-id = 1binlog-do-db = powerdns #要同步的数据库 Master新增slave账号 ...
- mysql 之 主从同步(单向同步和双向同步)
一. 实验环境部署 主服务器(MySQL-01) IP: 192.168.8.241 端口3306 ,操作系统:Centos6.5 64位 从服务器(MySQL-02) IP: 192.168. ...
- MySQL 主主同步配置和主从配置步骤
★预备知识 : 1.双机热备 对于双机热备这一概念,我搜索了很多资料,最后,还是按照大多数资料所讲分成广义与狭义两种意义来说. 从广义上讲,就是对于重要的服务,使用两台服务器,互相备份,共同执行同一服 ...
- MySQL数据库主从同步安装与配置总结
MySQL的主从同步是一个很成熟的架构,优点为: ①在从服务器可以执行查询工作(即我们常说的读功能),降低主服务器压力: ②在从主服务器进行备份,避免备份期间影响主服务器服务: ③当主服务器出现问题时 ...
- Docker Mysql主从同步配置搭建
Docker Mysql主从同步配置搭建 建立目录 在虚拟机中建立目录,例如路径/home/mysql/master/data,目录结构如下: Linux中 新建文件夹命令:mkdir 文件夹名 返回 ...
随机推荐
- thinkcmf,thinksns,thinkphp,onethink三者是什么关系?
thinksns 是基于tp的老版本二开的 thinkcmf 是网友基于tp开发的cmf thinkphp 是顶想的框架 onethink 是顶想基于tp开发的cmf 官方目前只有ThinkPHP和O ...
- Chrome 里的请求报错 " Provisional headers are shown"
之所以会出现这个警告,是因为去获取该资源的请求其实并(还)没有真的发生; 背景:提交表单,按钮点击<button>标签,触发事件,ajax发送请求,服务器返回信息; <button& ...
- C# 通过 probing 指定 dll 寻找文件夹
在很大的项目开发,会发现项目引用的 dll 会很多,我想要按照不同的功能,将不同的 dll 放在不同的文件夹 简单的方法是通过修改 App.config 文件指定文件夹,如将文件移动到 abc\12 ...
- ZR 8.31
ZR8.31 题目链接:http://www.zhengruioi.com/contest/388 版权原因,不放题面 A 首先,排序肯定要根据工作经验排序,因为这样便于选择 之后,如果两个人工作经验 ...
- Laravel -- Excel 导入(import) (v2.1.0)
原博客地址 https://www.jianshu.com/p/7287ebdc77bb Install (安装) //> composer.json 中 require中添加如下: " ...
- luoguP2679 子串
luoguP2679 子串 个人感觉\(noip\)系列中挺好的一道DP题目. 题面有点难理解. 我们设\(f_{i,j,k,0/1}\)表示\(A\)串前\(i\)个字符,匹配\(B\)串前\(j\ ...
- Python 序列求和
#基于Python2.7 多数OJ题库的第一题便是A+B,A+B+C此类求和问题,之前初学Python时是这么做的: while True: try: a,b,c=raw_input().split( ...
- IDEA比较实用的插件之翻译插件(Translation)
插件名称:Translation 安装步骤:Mac 2019.2的IDEA安装步骤如下 InteIIij IDEA --> Preference --> Other Setting --& ...
- python类中的一些神奇方法
__str__:用于在print(对象)时,直接打印__str__的返回值 class Animal: def __init__(self, name): self.name = name def _ ...
- 微服务实战——微服务架构选型SpringCloud / Dubbo / K8S比较(一)
## 说在前面 大概是三年前,因一些原因公司原项目最初为单体结构部署,所有业务模块都在一个项目里面,而后随着业务的不断膨胀以及模块之间的耦合,导致后面增加或修改一些简单业务时的成本都会变的极大.新入职 ...