1. 今天重启squid的时候发现,squid启动后,status 一会就stop了
whoami@blackman:~/script/AutoProxy-master/main/server$ sudo service squid3 start
squid3 start/running, process 19021
whoami@blackman:~/script/AutoProxy-master/main/server$ sudo service squid3 status
squid3 start/running, process 19154
whoami@blackman:~/script/AutoProxy-master/main/server$ sudo service squid3 status
squid3 stop/waiting

点击并拖拽以移动

  1. 通过查看日志文件发现是了异常,提示中建议运行squid -z来检查swap 目录
FATAL:  Failed to verify one of the swap directories, Check cache.log
for details. Run 'squid -z' to create swap directories
if needed, or if running Squid for the first time.
Squid Cache (Version 3.3.8): Terminated abnormally.
CPU Usage: 0.016 seconds = 0.009 user + 0.007 sys
Maximum Resident Size: 73008 KB
Page faults with physical i/o: 0

点击并拖拽以移动

  1. 通过查看squid -z发现是因为权限的问题,导致缓存文件无法写入
whoami@blackman:~/script/AutoProxy-master/main/server$ /usr/sbin/squid3 -z
whoami@blackman:~/script/AutoProxy-master/main/server$ 2018/01/24 11:26:12 kid1| Creating missing swap directories
FATAL: Failed to make swap directory /var/cache/squid: (13) Permission denied
2018/01/24 11:26:15 kid1| Creating missing swap directories
FATAL: Failed to make swap directory /var/cache/squid: (13) Permission denied

点击并拖拽以移动

  1. 于是用sudo chmod 777 /var/cache/squid/就解决了,这里由于是局域网服务器,直接就是777,简单粗暴些。
whoami@blackman:~/script/AutoProxy-master/main/server$ sudo chmod 777 /var/cache/squid/
whoami@blackman:~/script/AutoProxy-master/main/server$ sudo /usr/sbin/squid3 -z
whoami@blackman:~/script/AutoProxy-master/main/server$ 2018/01/24 11:29:42 kid1| Creating missing swap directories
2018/01/24 11:29:42 kid1| /var/cache/squid exists
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/00
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/01
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/02
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/03
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/04
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/05
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/06
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/07
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/08
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/09
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/0A
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/0B
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/0C
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/0D
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/0E
2018/01/24 11:29:42 kid1| Making directories in /var/cache/squid/0F

点击并拖拽以移动

到这里就解决了。squid -z创建完swap 目录后,会停在那,我等了几分钟,等不急了,直接ctrl+c给他结束了。然后service squid3 start就正常了。

DEUBG手册:

  1. 出问题时先去翻日志文件,一般成熟的软件都有完善的日志记录,对定位异常非常有帮助 。

squid异常停止的排查步骤的更多相关文章

  1. 华为云数据库GaussDB(for Cassandra)揭秘第二期:内存异常增长的排查经历

    摘要:华为云数据库GaussDB(for Cassandra) 是一款基于计算存储分离架构,兼容Cassandra生态的云原生NoSQL数据库:它依靠共享存储池实现了强一致,保证数据的安全可靠. 本文 ...

  2. SQL SERVER 2014 Agent服务异常停止案例

    生产环境一数据库服务器(SQL Server 2014)的Agent服务突然停掉了,检查了错误日志,发现在"SQL Server Agent"里面没有"SQLServer ...

  3. php不解析的排查步骤

    php不解析的排查步骤:1. /usr/local/apache2/bin/apachectl -M 看一下有没有加载libphp5.so2. 查看配置文件中是否有 AddType applicati ...

  4. 在Windows平台下Qt的exe报错问题排查步骤

    在Windows平台下Qt的exe报错问题排查步骤 工具介绍: 1. Dependency Worker Dependency Worker是一个免费的用具用来扫描任何的32bit 或者64bit 的 ...

  5. Python3 tesseract加载chi_sim异常停止工作

    Python3 tesseract加载chi_sim异常停止工作 原因: chi_sim.traineddata 和 tesseract3.0.2 版本不一致: 解决方案: 下载tesseract3. ...

  6. 总结一下NDK crash排查步骤

    总结一下NDK crash排查步骤: 先在PC上跑通算法 用Visual Studio写算法的testbed,确保算法能跑通 抓log adb logcat -c; adb logcat > 1 ...

  7. Kafka 0.8 宕机问题排查步骤

    CPU 利用率高的排查方法 看看该机器的连接数是不是比其他机器多,监听的端口数:netstat -anlp | wc -l Kafka-0.8的停止和启动 启动: cd /usr/local/kafk ...

  8. Lodop简短问答客户反馈篇 及排查步骤 及注册相关

    A.http下打印图片正常,https下打印图片是××.(有的客户端可以,有的不可以)重置ie浏览器试试.客户反馈:(和ie浏览器的设置有关)intenet选项--高级里,我调整为和能打印出图片的电脑 ...

  9. Squid 启动/停止/重载配置文件 命令

    当你的 squid.conf 配置文档按照你的想法修改完以后,启动 squid 之旅就开始了. Squid安装设试命令: 1,初始化你在 squid.conf 里配置的 cache 目录 #/usr/ ...

随机推荐

  1. Local dimming algorithm in matlab

    LED局部背光算法的matlab仿真 最近公司接了华星光电(TCL)的一个项目LCD-BackLight-Local-Diming-Algorithm-IP ,由于没有实际的硬件,只能根据客户给的论文 ...

  2. 什么是OSI的第7层

    1.什么是Internet的第7层? 第7层是指Internet的7层OSI模型的顶层,也称为"应用程序层".这是数据处理的顶层,位于用户与之交互的软件应用程序的表面之下或幕后.例 ...

  3. k8s-生产环境部署django项目k8s-dashboard管理系统

    1. k8s-生产环境部署django项目k8s-dashboard管理系统 gitee地址: https://gitee.com/scajy/django-k8s-dashboard.git 部署架 ...

  4. 7.6、openstack网络拓扑

    1.openstack官方架构图: 2.openstack服务常用服务的端口号: mysql:3306 keystone:5000 memcache:11211 rabbitmq:5672 rabbi ...

  5. hdu 2159 二维完全背包

    Problem Description 最近xhd正在玩一款叫做FATE的游戏,为了得到极品装备,xhd在不停的杀怪做任务.久而久之xhd开始对杀怪产生的厌恶感,但又不得不通过杀怪来升完这最后一级.现 ...

  6. ESP32的Flash加密知识

    一.Flash 加密功能用于加密与 ESP32-S2 搭载使用的 SPI Flash 中的内容.启用 Flash 加密功能后,物理读取 SPI Flash 便无法恢复大部分 Flash 内容.通过明文 ...

  7. 315M、433M和2.4G笔记

    一.315M无线模块 315m无线模块广泛地运用在车辆监控.遥控.遥测.小型无线网络.无线抄表.门禁系统.小区传呼.工业数据采集系统.无线标签.身份识别.非接触RF智能卡.小型无线数据终端.安全防火系 ...

  8. FTP服务—三种登录类型的配置方法

    目录 一.部署 二.配置vsftpd 1.匿名用户登录配置 2.系统用户登录配置 3.虚拟用户登录配置 1. 创建虚拟用户名单文件 2. 生成虚拟用户口令认证文件 3. 创建FTP根目录及虚拟用户映射 ...

  9. java基础---设计模式(3)

    行为型模式 出处:http://blog.csdn.net/zhangerqing 行为型模式包括策略模式.模板方法模式.观察者模式.迭代子模式.责任链模式.命令模式.备忘录模式.状态模式.访问者模式 ...

  10. dev c++自动添加初始源代码

    1.打开 dec v++ 2.工具--编辑器属性 3."代码"选项卡,点击"缺省源" 7.选择"向项目初始源文件插入代码" 8.下面插入下面 ...