centos7 装机配置及 mysql 安装过程
打开网卡,使操作系统可以上网
1
ip add 查看网卡,lo是回环网卡可以忽略,ens33为实际网卡。
[root@localhost ~]# ip add
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: ens33: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 00:0c:29:57:b7:c0 brd ff:ff:ff:ff:ff:ff
inet 192.168.3.9/24 brd 192.168.3.255 scope global noprefixroute dynamic ens33
valid_lft 601734sec preferred_lft 601734sec
inet6 fe80::6b4e:2213:ded8:b6fc/64 scope link noprefixroute
valid_lft forever preferred_lft forever
2
vi /etc/sysconfig/network-scripts/ifcfg-ens33 //打开vi编辑器修改配置文件的内容
将 onboot=no 改为 onboot=yes (文件打开时处于命令模式,需要将光标移动到想要的地方按s进入插入模式,进行修改。修改完成后按Esc回到命令模式,输入“:wq”保存并退出vi ,或输入“:q!”不保存并推出vi)
TYPE=Ethernet
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=dhcp
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME=ens33
UUID=b8052e2f-c8d4-4ba5-860d-e1e2d60bd148
DEVICE=ens33
ONBOOT=yes
ZONE=public
~
~
~
~
~
~
~
Type :quit<Enter> to exit Vim
3
systemctl restart network.service //重启网络
配置 ssh 以允许远程访问
1
安装 ssh :yum install ssh
2
启动 ssh:
service sshd start
chkconfig sshd on
3
可以在 windows操作系统中使用 xshell工具访问centos
安装 mysql
可以参考 mysql 的文档:https://dev.mysql.com/doc/mysql-yum-repo-quick-guide/en/
1
下载rpm文件:wget http://repo.mysql.com/mysql80-community-release-el7-2.noarch.rpm
2
安装rpm文件:rpm -Uvh mysql80-community-release-el7-2.noarch.rpm
3
安装服务器(需要下载所有的安装文件,耗时较长):yum install -y mysql-community-server
4
启动 mysql :systemctl start mysqld.service(el7平台使用), service mysqld start(其他平台使用)。
配置 mysql
1
查看安装时生成的默认密码:grep 'temporary password' /var/log/mysqld.log
[root@localhost ~]# grep 'temporary password' /var/log/mysqld.log
2019-04-08T12:16:09.849530Z 1 [Note] A temporary password is generated for root@localhost: gvMa4jAqvr;+
2
使用临时的 root 密码登陆 mysql :mysql -uroot -p
3
修改 root 密码:ALTER USER 'root'@'localhost' IDENTIFIED BY 'MyNewPass4!'; (英文大小写 + 数字 + 特殊字符)
4
授权外网访问:GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY 'MyNewPass567!' WITH GRANT OPTION;
5
刷新授权:FLUSH PRIVILEGES;
配置防火墙
1
在防火墙中添加3306端口(这是 mysql 默认的安装端口):firewall-cmd --zone=public --add-port=3306/tcp --permanent
2
重启防火墙:firewall-cmd --reload
centos7 装机配置及 mysql 安装过程的更多相关文章
- centos7中配置java + mysql +jdk +使用jar部署项目
centos7中配置java + mysql +jdk +使用jar部署项目 思维导图 1. 配置JDK環境 1.1下载jdk安装包 Java Downloads | Oracle 1.2 将下载j ...
- MySQL安装过程net start mysql 启动失败 报“错误2,系统找不到文件”的解决办法
MySQL安装过程net start mysql 启动失败 报“错误2,系统找不到文件”的解决办法 错误2,系统找不到文件. 开始...运行... regedit 注册表项: HKEY_LOCAL_ ...
- mysql安装过程中出现错误ERROR 1820 (HY000): You must SET PASSWORD before executing this statement解决
mysql安装过程中出现错误ERROR 1820 (HY000): You must SET PASSWORD before executing this statement解决 最近新装好的my ...
- SVN CentOS7 下配置svn的安装及基础配置介绍
CentOS7 下配置svn的安装及基础配置介绍 by:授客 QQ:1033553122 目录 一. 二. 三. 四. 五. 六. 七. 一. 实践环境 CentOS 7操作系统(CentO ...
- ubuntu 的mysql 安装过程和无法远程的解决方案
ubuntu 的mysql 安装过程和无法远程的解决方案 安装完mysql-server启动mysqlroot@ubuntu:# /etc/init.d/mysql start (如果这个命令不可以, ...
- MySQL安装过程中对The error code is 2203的解决方案
MySQL安装过程中对The error code is 2203的解决方案 1.问题描述 Windows系统安装MySQL遇到The error code is 2203.,具体描述如下 The i ...
- win10 64位 mysql安装过程出现status显示failed
mysql安装过程出现status显示failed,如下图: 由于我的电脑是64位系统,这里需要升级一个插件,即32位 visual C++ 2013 and visual C++ redistri ...
- CentOS7 64位下MySQL安装与配置(YUM)
安装环境:腾讯云CentOS7 64位安装MySQL5.7 1.配置YUM源 在MySQL官网中下载YUM源rpm安装包:http://dev.mysql.com/downloads/repo/yum ...
- mysql安装过程mysql本地环境变量的配置
配置环境变量 前面步骤完成后安装好MySQL,为MySQL配置环境变量.MySQL默认安装在C:\Program Files下. 1)新建MYSQL_HOME变量,并配置:C:\Program Fil ...
随机推荐
- 云存储上传控件(cloud2)-Xproer.HttpUploader7
版权所有 2009-2016 荆门泽优软件有限公司 保留所有权利 官方网站:http://www.ncmem.com/ 产品首页:http://www.ncmem.com/webapp/cloud2/ ...
- Gym 100989L (DFS)
AbdelKader enjoys math. He feels very frustrated whenever he sees an incorrect equation and so he tr ...
- Replication--使用MSlogreader_history查看日志读起的延迟和事务命令
--======================================================================== MSlogreader_history 表存放本地 ...
- sonar安装问题记录
1.启动时日志中提示 Caused by: java.lang.RuntimeException: can not run elasticsearch as root 错误原因:因为安全问题elast ...
- xshell无法连接Ubuntu的解决办法
使用workstations14安装完Ubunu后,网络连接方式为NAT模式(N):用于共享主机的IP地址 此时想用xshell连接此虚拟机但是提示连接失败,但是宿主机和虚拟机互相都能ping通,且虚 ...
- sql添加列,删除列,修改列
有时候,当数据库里面有数据了,再到设计器里面删除列,就删不掉.只能用代码删除. alter table tableName drop column columnName 添加列 ) 修改列 ) --修 ...
- ManualResetEvent 线程通信
using System; using System.Threading; namespace ConsoleApp1 { class MyThread { Thread t = null; Manu ...
- [TJOI2007] 线段
因为每行必须走完才能到下一行,所以我们有两种决策: 1.最后留在线段左端点 2.最后留在线段右端点 这种存在状态转移且多决策的问题用动态规划来进行递推是最好不过的了. 所以我们设\(dp[i][0/1 ...
- centos下部署NFS
一. NFS简介 NFS---Network File System:主要功能是通过网络让不同的linux主机系统间可以彼此共享文件和目录.NFS客户端可以通过挂载的方式将NFS服务器端共 ...
- linux修改用户名
貌似只需要改红色的就行了,要保险就都改,比如阿里云服务器就要2个都改 ubuntu:修改 /etc/hostname 修改 /etc/hosts 比如:127.0 ...