centos7下yum安装MariaDB

CentOS 7下mysql下替换成MariaDB了。
MariaDB数据库管理系统是MySQL的一个分支,主要由开源社区在维护,采用GPL授权 许可 MariaDB的目的是完全兼容MySQL,包括API和命令行,使之能轻松成为MySQL的代替品。

使用yum快速安装

安装

# yum install -y mariadb-server
已加载插件:fastestmirror
Loading mirror speeds from cached hostfile
* base: mirrors.aliyun.com
* extras: mirrors.aliyun.com
* updates: mirror.bit.edu.cn
正在解决依赖关系
--> 正在检查事务
---> 软件包 mariadb-server.x86_64.1.5.5.64-.el7 将被 安装
--> 正在处理依赖关系 mariadb-libs(x86-) = :5.5.-.el7,它被软件包 :mariadb-server-5.5.-.el7.x86_64 需要
--> 正在处理依赖关系 mariadb(x86-) = :5.5.-.el7,它被软件包 :mariadb-server-5.5.-.el7.x86_64 需要
--> 正在处理依赖关系 perl-DBI,它被软件包 :mariadb-server-5.5.-.el7.x86_64 需要
--> 正在处理依赖关系 perl-DBD-MySQL,它被软件包 :mariadb-server-5.5.-.el7.x86_64 需要
--> 正在处理依赖关系 perl(Data::Dumper),它被软件包 :mariadb-server-5.5.-.el7.x86_64 需要
--> 正在处理依赖关系 perl(DBI),它被软件包 :mariadb-server-5.5.-.el7.x86_64 需要
--> 正在检查事务
---> 软件包 mariadb.x86_64.1.5.5.64-.el7 将被 安装
---> 软件包 mariadb-libs.x86_64.1.5.5.64-.el7 将被 安装
---> 软件包 perl-DBD-MySQL.x86_64.0.4.-.el7 将被 安装
---> 软件包 perl-DBI.x86_64.0.1.-.el7 将被 安装
--> 正在处理依赖关系 perl(RPC::PlServer) >= 0.2001,它被软件包 perl-DBI-1.627-.el7.x86_64 需要
--> 正在处理依赖关系 perl(RPC::PlClient) >= 0.2000,它被软件包 perl-DBI-1.627-.el7.x86_64 需要
---> 软件包 perl-Data-Dumper.x86_64.0.2.-.el7 将被 安装
--> 正在检查事务
---> 软件包 perl-PlRPC.noarch.0.0.-.el7 将被 安装
--> 正在处理依赖关系 perl(Net::Daemon) >= 0.13,它被软件包 perl-PlRPC-0.2020-.el7.noarch 需要
--> 正在处理依赖关系 perl(Net::Daemon::Test),它被软件包 perl-PlRPC-0.2020-.el7.noarch 需要
--> 正在处理依赖关系 perl(Net::Daemon::Log),它被软件包 perl-PlRPC-0.2020-.el7.noarch 需要
--> 正在处理依赖关系 perl(Compress::Zlib),它被软件包 perl-PlRPC-0.2020-.el7.noarch 需要
--> 正在检查事务
---> 软件包 perl-IO-Compress.noarch.0.2.-.el7 将被 安装
--> 正在处理依赖关系 perl(Compress::Raw::Zlib) >= 2.061,它被软件包 perl-IO-Compress-2.061-.el7.noarch 需要
--> 正在处理依赖关系 perl(Compress::Raw::Bzip2) >= 2.061,它被软件包 perl-IO-Compress-2.061-.el7.noarch 需要
---> 软件包 perl-Net-Daemon.noarch.0.0.-.el7 将被 安装
--> 正在检查事务
---> 软件包 perl-Compress-Raw-Bzip2.x86_64.0.2.-.el7 将被 安装
---> 软件包 perl-Compress-Raw-Zlib.x86_64.1.2.-.el7 将被 安装
--> 解决依赖关系完成
作为依赖被安装:
mariadb.x86_64 :5.5.-.el7 mariadb-libs.x86_64 :5.5.-.el7
perl-Compress-Raw-Bzip2.x86_64 :2.061-.el7 perl-Compress-Raw-Zlib.x86_64 :2.061-.el7
perl-DBD-MySQL.x86_64 :4.023-.el7 perl-DBI.x86_64 :1.627-.el7
perl-Data-Dumper.x86_64 :2.145-.el7 perl-IO-Compress.noarch :2.061-.el7
perl-Net-Daemon.noarch :0.48-.el7 perl-PlRPC.noarch :0.2020-.el7 完毕!

mariadb相关命令

yum install mariadb mariadb-server
systemctl start mariadb #启动mariadb
systemctl enable mariadb #设置开机自启动
systemctl stop mariadb #停止MariaDB
systemctl restart mariadb #重启MariaDB
mysql_secure_installation #设置root密码等相关
mysql -uroot -p #测试登录

修改root的密码

update mysql.user set password=PASSWORD('yhb123456') where user='root';
// 更新权限
flush privileges;

新建用户

// create user  '用户名'@'主机' identified by '密码'   如果只允许本机访问 @'localhost'  , 或者指定一个ip  @'192.xx.xx.xx' 或者使用通配: @'%'
create user 'read_visa'@'%' identified by '';

给用户分配权限

// grant 操作类型 on 数据库.表 to 用户@'主机'   数据库,表,主机都支持通配符 grant select, insert on *.* to  'read_visa'@'%'
// grant all on visa.* to 'read_visa'@'%'; // all 表示所有权限
grant select on visa.* to 'read_visa'@'%';

当我启动mariadb的时候出现了如下的错误

Failed to start mariadb.service: Unit not found.

出现这个的原因是机器上之前安装了mysql,删除掉就可以了。

1、查看mysql安装了哪些东西

# rpm -qa |grep -i mysql
mysql-community-common-5.7.-.el7.x86_64
mysql-community-client-5.7.-.el7.x86_64
mysql-community-libs-compat-5.7.-.el7.x86_64
mysql-community-libs-5.7.-.el7.x86_64
mysql-community-server-5.7.-.el7.x86_64

2、开始卸载

yum remove mysql-community-common-5.7.-.el7.x86_64
yum remove mysql-community-client-5.7.-.el7.x86_64
yum mysql-community-libs-compat-5.7.-.el7.x86_64
yum remove mysql-community-libs-5.7.-.el7.x86_64
yum remove mysql-community-server-5.7.-.el7.x86_64

3、查看是否卸载完成

# rpm -qa |grep -i mysql

4、查找mysql相关目录

# find / -name mysql
/usr/share/mysql

5、删除相关目录

# rm -rf /usr/share/mysql

6、删除/etc/my.cnf

# rm -rf /etc/my.cnf

7、删除/var/log/mysqld.log(如果不删除这个文件,会导致新安装的mysql无法生存新密码,导致无法登陆)

# rm -rf /var/log/mysqld.log

参考

【Centos7 完全卸载mysql】https://www.jianshu.com/p/ef58fb333cd6
【centos7 mariadb安装 MySql】https://www.jianshu.com/p/f55a31ae0cea

centos7安装MariaDB以及Failed to start mariadb.service: Unit not found的错误解决的更多相关文章

  1. CentOS 7出现Failed to start firewalld.service: Unit is masked的解决办法和firewalld 防火墙开关

    说明:刚刚使用systemctl start firewalld命令开启防火墙的时候,却开不成功,出现Failed to start firewalld.service: Unit is masked ...

  2. CentOS7安装MySQL报错,解决Failed to start mysqld.service: Unit not found

    当输入命令 ~]# systemctl start mysql.service 要启动MySQL数据库是却是这样的提示 Failed to start mysqld.service: Unit not ...

  3. CentOS7安装MySQL报错Failed to start mysqld.service: Unit not found解决办法

    1 ~]# systemctl start mysql.service 要启动MySQL数据库是却是这样的提示 1 ~]# Failed to start mysqld.service: Unit n ...

  4. CentOS7安装mysql后无法启动服务,提示Unit not found

    首发日期: 2018-01-30 现象: 在centOS7中启动MySQL数据库提示: Failed to start mysqld.service: Unit not found [明明已经安装了, ...

  5. centOS7中启动MySQL数据库提示: Failed to start mysqld.service: Unit not foundc

    现象: 在centOS7中启动MySQL数据库提示: Failed to start mysqld.service: Unit not found [明明已经安装了,为什么提示不存在呢?] 原因: 在 ...

  6. centos7 Failed to start firewalld.service: Unit is masked.

    centos7 启动防火墙失败:Failed to start firewalld.service: Unit is masked.   ---- 刚yum安装了iptables 解决: 执行”sys ...

  7. 安装tomcat出现failed to install tomcat8 service错误及解决方法

    failed to install tomcat8 service 如下图所示:     一.安装tomcat出现failed to install tomcat6 service错误及解决方法(转载 ...

  8. 【非原创】tomcat 安装时出现 Failed to install Tomcat7 service

    tomcat 安装时出现 Failed to install Tomcat7 service 今天在安装tomcat时提示 Failed to install Tomcat7 service了,花了大 ...

  9. docker安装完报错:Failed to start docker.service: Unit docker.service is masked

    执行 systemctl start docker 报错 Failed to start docker.service: Unit docker.service is masked. 解决 syste ...

随机推荐

  1. BigDecimal介绍及BigDecimal实现四舍五入

    BigDecimal介绍及BigDecimal实现四舍五入 BigDecimal是什么? 我们知道float最大精度是7-8位有效数字,而double的最大精度是16-17位有效数字,那么大于16位的 ...

  2. Html的总结(待完善)

    Html的总结(待完善) 框内文字 Placeholder 框内文字(例如:请输入密码) A标签 link 未点击的A标记 visited 点击过的A标签 hover 放置鼠标变颜色 active 点 ...

  3. 150多个Flutter组件详细介绍送给你

    迷茫是什么,迷茫就是大事干不了,小事不想干,能力配不上欲望,才华配不上梦想. 150+Flutter组件详细介绍地址:http://laomengit.com/ 前言 我在Flutter未正式发布之前 ...

  4. mysql & Tomcat使用问题记录

    mysql使用问题记录 1.mysql如何修改root密码 a.进入mysql安装目录b.登录 mysql -u root -pc.修改密码 mysql> SET PASSWORD FOR ro ...

  5. Codeforce219C-Color Stripe

    E. Color Stripe time limit per test 2 seconds memory limit per test 256 megabytes input standard inp ...

  6. 在Windows中安装OpenCV-Python |四

    目标 在本教程中 我们将学习在你的Windows系统中设置OpenCV-Python. 下面的步骤在装有Visual Studio 2010和Visual Studio 2012的Windows 7- ...

  7. 一、【Docker笔记】进入Docker世界

    ​ 我们平时判断一个电脑的性能主要看什么?磁盘读写?CPU的主频高低?还是内存的大小?可是作为个人使用者来说,这些参数高一些足够我们去使用了,可是对于一个大型系统甚至是超大型系统,当前的硬件是远远达不 ...

  8. spring-cloud-gateway动态路由

    概述 线上项目发布一般有以下几种方案: 停机发布 蓝绿部署 滚动部署 灰度发布 停机发布 这种发布一般在夜里或者进行大版本升级的时候发布,因为需要停机,所以现在大家都在研究 Devops 方案. 蓝绿 ...

  9. +load 和 +initialize

    APP 启动到执行 main 函数之前,程序就执行了很多代码. 执行顺序: 将程序依赖的动态链接库加载到内存 加载可执行文件中的所有符号,代码 runtime 解析被编译的符号代码 遍历所有的 cla ...

  10. 基于MVP模式实现四则运算器

    基于MVP模式四则运算器 来到新东家,项目的框架采用的是MVP模式,刚来公司的时候,项目经理给予分配小任务,首先熟悉MVP模式,而后普通的四则运算器的实现使用MVP分层.这里主要回顾当时做任务时候的对 ...