Cloudera Manager 安装集群遇到的坑
Cloudera Manager 安装集群遇到的坑
多次安装集群,但每次都不能顺利,都会遇到很多很多的坑,今天就过去踩过的坑简单的总结一下,希望已经踩了的和正在踩的童鞋能够借鉴一下,希望对你们能有所帮助。
一、Mysql的配置
1、卸载原有的mysql
查看目前安装的mysql
rpm -qa |grep mysql

卸载自带的mysql
yum -y remove mysql-libs-5.1.73-7.el6.x86_64
2、安装mysql
mysql的安装有三种方式:
- rpm包安装(本次就采用rmp包的安装方式进行演示)
- 源码安装(提供了源码安装的脚本)
- yum安装(虽然安装方便,但是不建议使用)
rpm包的方式安装mysql
#加压tar文件
tar -xvf mysql-5.6.26-1.linux_glibc2.5.x86_64.rpm-bundle.tar -C /files/mysql-rpm/
#安装rpm包
rpm -ivh /files/mysql-rpm/*.rpm
cp /usr/share/mysql/my-default.cnf /etc/my.cnf
#安装数据库
/usr/bin/mysql_install_db
#启动服务
service mysql start
#设置开机自启
chkconfig mysql on
#设置数据库密码
/usr/bin/mysqladmin -u root password '123456'
3、初始化数据库
mysql安装完了之后就是初始化数据库的过程,进去mysql库中
mysql -u root -p123456
执行一下的语句进行初始化建库
create database hive default charset utf8 collate utf8_general_ci;
create database hue default charset utf8 collate utf8_general_ci;
create database scm default charset utf8 collate utf8_general_ci;
create database amon default charset utf8 collate utf8_general_ci;
create database sentry default charset utf8 collate utf8_general_ci;
create database oozie default charset utf8 collate utf8_general_ci;
create database reports default charset utf8 collate utf8_general_ci;
grant all privileges on *.* to 'root'@'locolhost';
grant all on *.* to 'root'@'%' identified by '123456' with grant option;
grant all on *.* to 'root'@'hadoop' identified by '123456' with grant option;
flush privileges;
然后重启数据库就ok了
service mysql restart
重点说明一下:mysql的安装是前期准备工作的重要一步,不建议使用yum安装,我就是因为图省事,直接用yum安装了mysql,导致在创建cmf数据的时候总是报连不上mysql服务的错误(即执行/opt/cm-5.11.1/share/cmf/schema/scmpreparedatabase.sh mysql cmf -hhadoop -uroot -p123456 --scm-host hadoop scm scm scm 命令),最后只得卸载了yum安装的mysql重新用rmp包安装的。
二、启动cloudera-scm-server
在启动cloudera-scm-server的时候报如下的错误(启来30秒左右自动关闭,查看日志文件:/opt/cm-5.11.1/log/cloudera-scm-server/cloudera-scm-server.log)
Caused by: javax.persistence.PersistenceException: org.hibernate.exception.GenericJDBCException: Could not open connection
错误原因:
- 缺少mysql的驱动包,检查/opt/cm-5.11.1/share/cmf/lib目录下是否有mysql的驱动;
- 检查mysql是否启动;
- mysql本身的问题,只能卸载mysql重新安装(我就是这种方案解决的);
三、启动cloudera-scm-agent
在启动cloudera-scm-server的时候报如下的错误(启来30秒左右自动关闭,查看日志文件:/opt/cm-5.11.1/log/cloudera-scm-agent/cloudera-scm-agent.log)
ERROR Failed to connect to newly launched supervisor. Agent will exit
这种错误是因为主节点的uuid和从节点的一样,所以造成代理紊乱
错误原因:在主节点启动了agent后,再scp到其他节点,这样会把已经生成好的uuid带过去。所以必须等所有的agent节点都准备好之后,再启动agent
那遇到这种error如何处理:
- 删除/opt/cm-5.11.1/lib/cloudera-scm-agent目录下的所有文件(首先要保证server和agent服务都是关闭的)
- 删除mysql中cmf数据库
- 删除从节点中/opt/cm-5.11.1目录
重新复制到从节点
scp -r /opt/cm-5.11.1 root@hadoop001:/opt
创建cmf数据库,执行一下代码
/opt/cm-5.11.1/share/cmf/schema/scm_prepare_database.sh mysql cmf -hhadoop -uroot -p123456 --scm-host hadoop scm scm scm
重新启动server和agent就ok了
四、启动集群时报错
错误提示:

看服务的状态:
service cloudera-scm-agent status

以上错误的意思是:agent服务死了,但是pid文件换是存在
解决方法:进入到/opt/cm-5.11.1/run/cloudera-scm-agent目录下删除pid文件

五、hive分析运算时报错
错误提示:org.apache.hadoop.security.AccessControlException: Permission denied: user=root, access=WRITE, inode="/user":hdfs:supergroup:drwxr-xr-x

错误原因:我当前所在的用户的是root,root没有操作hdfs文件中/user的权限
当前文件的权限:

执行以下赋权限语句
sudo -u hdfs hadoop fs -chmod -R 777 /user
sudo -u hdfs 说明需要指定hdfs用户来执行赋权限的操作
Cloudera Manager 安装集群遇到的坑的更多相关文章
- Cloudera Manager安装之利用parcels方式安装单节点集群(包含最新稳定版本或指定版本的安装)(添加服务)(CentOS6.5)(四)
不多说,直接上干货! 福利 => 每天都推送 欢迎大家,关注微信扫码并加入我的4个微信公众号: 大数据躺过的坑 Java从入门到架构师 人工智能躺过的坑 ...
- Cloudera Manager安装之利用parcels方式(在线或离线)安装3或4节点集群(包含最新稳定版本或指定版本的安装)(添加服务)(Ubuntu14.04)(五)
前期博客 Cloudera Manager安装之Cloudera Manager 5.6.X安装(tar方式.rpm方式和yum方式) (Ubuntu14.04) (三) 如果大家,在启动的时候,比如 ...
- Cloudera Manager安装_搭建CDH集群
2017年2月22日, 星期三 Cloudera Manager安装_搭建CDH集群 cpu 内存16G 内存12G 内存8G 默认单核单线 CDH1_node9 Server || Agent ...
- Cloudera Manager安装之利用parcels方式安装3或4节点集群(包含最新稳定版本或指定版本的安装)(添加服务)(CentOS6.5)(五)
参考博客 Cloudera Manager安装之利用parcels方式安装单节点集群 Cloudera Manager安装之Cloudera Manager 5.3.X安装(三)(tar方式.rpm ...
- Cloudera Manager安装之Cloudera Manager 5.3.X安装(三)(tar方式、rpm方式和yum方式)
不多说,直接上干货! 福利每天都有 => =>=>=>=> 欢迎大家,关注微信扫码并加入我的4个微信公众号: 大数据躺过的坑 Java从入门到架构师 ...
- Cloudera Manager安装之时间服务器和时间客户端(二)
福利 => 每天都推送 欢迎大家,关注微信扫码并加入我的4个微信公众号: 大数据躺过的坑 Java从入门到架构师 人工智能躺过的坑 Java全栈大联盟 ...
- Cloudera Manager安装之Cloudera Manager安装前准备(Ubuntu14.04)(一)
其实,基本思路跟如下差不多,我就不多详细说了,贴出主要图. 博主,我是直接借鉴下面这位博主,来进行安装的!(灰常感谢他们!) 在线和离线安装Cloudera CDH 5.6.0 Cloudera M ...
- Cloudera Manager安装之时间服务器和时间客户端(Ubuntu14.04)(二)
第二步: Cloudera Manager安装之时间服务器和时间客户端(二) 找一台机器作为时间服务器 我这里,放到ubuntucmbigdata1这台机器! 注意,之前是已经做了集群时间同步了. 在 ...
- Cloudera Manager安装之Cloudera Manager安装前准备(CentOS6.5)(一)
Cloudera Manager安装前准备 (一)机器准备 192.168.80.148 clouderamanager01 (部署ClouderaManager-server和Mirror se ...
随机推荐
- 关于Unity3d的Quaternion.LookRotation的学习
首先,创建两个cube GameObject物件.Origin作为原点参考.Player是我们要实验的物件.如下图所示: 创建一个脚本Quat.cs,赋给Palyer cube.脚本如下: publi ...
- 【Git】创建一个空分支
1 创建一个分支 使用参数 --orphan,这个参数的主要作用有两个,一个是拷贝当前所在分支的所有文件,另一个是没有父结点,可以理解为没有历史记录,是一个完全独立背景干净的分支. 参考git的帮助文 ...
- 配置 Tomcat 服务 和 自启动
如果我们使用war 包进行部署项目的时候,需要把包放进Tomcat的目录下,为了使我们的服务能够在服务器重启的时候自动启动起来,我们需要把Tomcat设置成自起服务. 配置 Tomcat 服务 新建服 ...
- 021.5 IO流——字符流
###############基本功能写 FileWriter fw = new FileWriter("xxx.txt"); fw.write("哈喽"); ...
- java查找字符串里与指定字符串相同的个数
public class EmployeeDemo { //方法一: public int search(String str,String strRes) {//查找字符串里与指定字符串相同的个数 ...
- jq封装-无缝滚动效果
<!DOCTYPE html> <html> <head lang="en"> <meta charset="UTF-8&quo ...
- 【Webpack】学习随笔
参考链接:http://www.runoob.com/w3cnote/webpack-tutorial.html Webpack 是一个前端资源加载/打包工具. Webpack 可以将多种静态资源 j ...
- Git删除commit提交的log记录
基于 GitFlow 工作流,可能某个提交(commit)导致了 bug,或者有多个提交需要返工,此时你就会用到删除提交. 接下来的内容都基于下面这张 git log 提交记录图来写. git l ...
- PHP面试系列之Linux(一) ----- Linux基础
一.系统安全 sudo:以系统管理者的身份执行指令,也就是说,经由 sudo 所执行的指令就好像是 root 亲自执行. su:用于变更为其他使用者的身份,除 root 外,需要键入该使用者的密码. ...
- 【转】Java做服务器开发语言
版权声明:本文为博主原创文章,未经博主允许不得转载. 随着游戏市场的兴起,特别是网页游戏.手机游戏的崛起,对游戏开发技术的需求越来越多.网络游戏开发是一个庞大的体系,总体来说是客户端与服务器端.客户端 ...