centos6.9 编译安装 zabbix-3.0.15
本文采用编译安装,请在zabbix官网下载所需版本。此处安装版本是:zabbix-3.0.15.tar.gz
操作系统:centos 6.9
一、安装mysql
mysql-community-libs-5.7.21-1.el6.x86_64.rpm
mysql-community-client-5.7.21-1.el6.x86_64.rpm
mysql-community-libs-compat-5.7.21-1.el6.x86_64.rpm
mysql-community-common-5.7.21-1.el6.x86_64.rpm
mysql-community-server-5.7.21-1.el6.x86_64.rpm
mysql-community-devel-5.7.21-1.el6.x86_64.rpm
安装步骤此处略。
二、安装php(Zabbix 3.0对PHP的要求最低为5.4,已存在的请将PHP升级到5.4以上,注意,不支持PHP7)
1.获取yum源
rpm -ivh http://repo.webtatic.com/yum/el6/latest.rpm
2.安装下列所有包
yum -y install php56w php56w-gd php56w-mysqlnd php56w-bcmath php56w-mbstring php56w-xml php56w-ldap
....
3.安装完毕后,编辑php的ini文件
---注意date.timezone一定要写对,否则在配置完zabbix后,显示的界面全部报错。
vim /etc/php.ini, 请查找以下内容对应修改:
post_max_size = 16M
max_execution_time = 300
max_input_time = 300
date.timezone = Asia/Shanghai
always_populate_raw_post_data = -1
三、安装Apache
1.采用yum在线安装
yum -y install httpd
2.配置httpd.conf
vim /etc/httpd/conf/httpd.conf, 请查找以下内容对应修改:
DocumentRoot "/var/www/html/zabbix"
<Directory "/var/www/html/zabbix">
ServerName 127.0.0.1
DirectoryIndex index.html index.html.var index.php
四、安装和配置zabbix
1.创建zabbix用户和组:
groupadd zabbix
useradd -g zabbix zabbix
2.安装所需依赖:
yum install gcc* -y
yum install libxml2-devel -y
yum install net-snmp* -y
yum install curl-devel -y
yum -y install unixODBC-devel
rpm -ivh mysql-community-devel-5.7.21-1.el6.x86_64.rpm
yum -y install libssh2-devel
yum -y install openldap openldap-devel
yum -y install OpenIPMI OpenIPMI-devel
yum -y install java*
3.下载zabbix-3.0.15.tar.gz 并解压缩
wget https://jaist.dl.sourceforge.net/project/zabbix/ZABBIX Latest Stable/3.0.15/zabbix-3.0.15.tar.gz
tar -zxvf zabbix-3.0.15.tar.gz
cd zabbix-3.0.15
./configure --enable-server --enable-agent --with-mysql --enable-ipv6 --enable-java --with-net-snmp --with-libcurl --with-libxml2 --with-unixodbc --with-ssh2 --with-openipmi --with-openssl --prefix=/usr/local/zabbix
make install
五、设置web前端
mkdir /var/www/html/zabbix
cp -r /opt/zabbix-3.0.15/frontends/php/* /var/www/html/zabbix
chown -R apache:apache /var/www/html/zabbix
chmod +x /var/www/html/zabbix/conf/
六、修改配置文件zabbix_server.conf
vim /usr/local/zabbix/etc/zabbix_server.conf
DBName=zabbix
DBUser=zabbix
DBPassword=zabbix
七、添加Zabbix服务器和Zabbix代理启动脚本
cp /opt/zabbix-3.0.15/misc/init.d/fedora/core/zabbix_server /etc/init.d/zabbix_server
cp /opt/zabbix-3.0.15/misc/init.d/fedora/core/zabbix_agentd /etc/init.d/zabbix_agentd
八、创建zabbix数据库并把导入一些sql表
mysql>CREATE DATABASE zabbix CHARACTER SET utf8 COLLATE utf8_bin;
mysql>GRANT ALL PRIVILEGES ON zabbix.* TO zabbix@localhost IDENTIFIED BY 'zabbix';
mysql>SHOW DATABASES;
+--------------------+
| Database |
+--------------------+
| information_schema |
| mysql |
| performance_schema |
| zabbix |
+--------------------+
mysql>use zabbix;
mysql>source /opt/zabbix-3.0.15/database/mysql/schema.sql;
mysql>source /opt/zabbix-3.0.15/database/mysql/images.sql;
mysql>source /opt/zabbix-3.0.15/database/mysql/data.sql;
mysql>show tables;
九、启动服务,并设置开机自启
1.启动Apache\mysql\zabbix_server\zabbix_agentd服务
service httpd start
service mysqld start
/etc/init.d/zabbix_server start
/etc/init.d/zabbix_agentd start
如果启动失败,提示比如
[root@localhost mysql]# /etc/init.d/zabbix_server start
Starting zabbix_server: /etc/init.d/functions: line 722: /usr/local/sbin/zabbix_server: No such file or directory [FAILED]
[root@localhost zabbix]# /etc/init.d/zabbix_agentd start
Starting zabbix_agentd: /etc/init.d/functions: line 722: /usr/local/sbin/zabbix_agentd: No such file or directory [FAILED]
请修改以下文件:
/etc/rc.d/init.d/zabbix_server
/etc/rc.d/init.d/zabbix_agentd
查看BASEDIR= 修改成正确路径
2.设置开机自启
chkconfig httpd on
chkconfig mysqld on
chkconfig --add /etc/init.d/zabbix_server
chkconfig --add /etc/init.d/zabbix_agentd
chkconfig zabbix_server on
chkconfig zabbix_agentd on
十、浏览器访问zabbix页面并进行初始化
在浏览器中打开http://192.168.153.166/zabbix







centos6.9 编译安装 zabbix-3.0.15的更多相关文章
- 编译安装zabbix 3.0及分开部署配置详解
实验系统:CentOS 6.6_x86_64 实验前提:提前准备好编译环境,防火墙和selinux都关闭 实验说明:本实验共有4台主机,IP及角色分配如拓扑 下载地址:试验中用到mariadb软件的下 ...
- Centos6下编译安装gcc6.4.0
Centos6自带的gcc4.4.7不支持c++11, 于是编译安装最新版的gcc wget https://gmplib.org/download/gmp/gmp-6.1.2.tar.xz .tar ...
- CentOS6源码安装zabbix服务器
1.下载安装包并解压 2.预环境搭建 3.创建zabbix用户,编译安装zabbix 4.配置mysql 5.配置zabbix-server 6.配置apache和php 7.添加开机自启动 1 yu ...
- CentOS6.3编译安装Memcached
要用到如下源码包: /usr/local/src/memcached/libevent-2.0.21-stable.tar.gz /usr/local/src/memcached/memcached- ...
- CentOS6.3编译安装Nginx1.4.7 + MySQL5.5.25a + PHP5.3.28
[准备工作] #在编译安装lnmp之前,首先先卸载已存在的rpm包. rpm -e httpd rpm -e mysql rpm -e php yum -y remove httpd yum -y r ...
- centos6.7编译安装mysql5.7.17
centos6.7编译安装mysql5.7.17 2017-03-24 09:57:15 提示:mysql5.7.17和之前5.56以前的版本安装不一样,需要用cmake 另外,看本文档的mysql编 ...
- Centos7下安装zabbix 3.0.19
参考网站: https://www.cnblogs.com/xiewenming/p/7732144.html https://www.cnblogs.com/clsn/p/7885990.html ...
- 一键安装 zabbix 3.0 版本 脚本
原文地址: http://blog.csdn.net/u012449196/article/details/53859068 本文修改了原文中的部分错误,此脚本适用于zabbix 2.0 或 3.0 ...
- CentOS6.8编译安装LAMP
CentOS6.8编译安装Apache2.4.25.MySQL5.7.16.PHP5.6.29 初始化 #固定IP vi /etc/sysconfig/network-scripts/ifcfg-et ...
- Centos6.7 编译安装 Apache PHP
Centos6.7 编译安装 Apache PHP 原文地址:http://www.cnblogs.com/caoguo/p/4968039.html ##### Apache 编译安装 #### [ ...
随机推荐
- SpringSecurity-UsernamePasswordAuthenticationFilter的作用
UsernamePasswordAuthenticationFilter应该是我们最关注的Filter,因为它实现了我们最常用的基于用户名和密码的认证逻辑. 先看一下一个常用的form-login配置 ...
- Consul之:服务注册与发现
一.服务的管理(注册与发现)有三种方式: 1:通过配置文件的方式静态注册2:通过HTTP API接口来动态注册(spring cloud使用方式,spring cloud中使用的是consul api ...
- 【3D美术教程】手雷(传统与PBR流程)
转自:https://www.sohu.com/a/156489635_718614 随着最新的次时代技术PBR流程的普及,越来越多的公司由传统流程转向了PBR流程,主要原因在于PBR材质不仅效果上更 ...
- SqlServer常用内置函数
--======================================= -- SQL常用内置函数 --======================================= --判 ...
- 性能测试day04_性能监控
好了,今天接着来学习性能,在今天开始前,我今天在网上又看到了理发师经典模型,这里稍微提一下,详情可以百度哈,下面这张图是网上找到的经典场景性能相关的图,大致说明下: 这张图中展示的是1个标准的软件性能 ...
- mysql 多个字段合并
group_concat 函数默认“,”合并 select p.id as patent_id,p.application_no,p.name,p.inventer,group_concat(pi.` ...
- threading join用法
join():在子线程完成运行之前,这个子线程的父线程将一直被阻塞 import threading #线程import time def Beijing(n): print('Beijing tim ...
- ==、equals和hashCode小结
1.== ==是关系操作符,对于基本类型(byte,short,char,int,long,float,double,boolean),比较的是值是否相等:对于对象,比较的是对象的引用(也即栈内存中的 ...
- tensorflow 1.9 ,bazel 0.15.0,源码编ERROR, Skipping, '//tensorflow/tools/pip_package:build_pip_package',error loading packageCuda Configuration Error, Cannot find libdevice.10.bc under /usr/local/cuda-8.0
最近在看tensorflow 移动端部署,需要编译源码才支持,所以又拾起来了编译这项老工作,其中遇到问题: bazel build --cxxopt="-D_GLIBCXX_USE_CXX1 ...
- springboot整合zookeeper
在springboot中所有的整合都是以bean的形式注入对象,从数据库coon.redis conn.再到整合的zookeeper,依然是依照bean注入连接对象,通过zookeeper api对z ...