lepus3.7 天兔监控安装手册 CentOS6.5+mysql5.6
lepus3.7 天兔监控安装配置手册 CentOS6.5+mysql5.6
整体环境
192.168.1.250为监控机
192.168.1.248为被监控机
安装LAMP环境
[root@HE3~]#yum install gcc libffi-devel python-devel openssl-devel
[root@HE3~]# yum install urpmi xterm
[root@HE3mysqlmtop]# vi /etc/ld.so.conf
/usr/lib64
[root@HE3 ~]#/sbin/ldconfig
解压lamp环境包(下载地址见本文最后)
[root@HE3mysqlmtop]# tar xvf lamp_centos64_64_version2.tar.gz -C /usr/local/
vi/usr/local/apache/conf/httpd.conf
52行修改为监控机ip Listen 192.168.1.250:80
<Listen 80
---
>Listen 192.168.1.250:80
147行取消注释
<#LoadModule rewrite_module modules/mod_rewrite.so
---
>LoadModule rewrite_module modules/mod_rewrite.so
190行改为监控机ip
<#ServerName www.example.com:80
---
>ServerName 192.168.1.250:80
199行添加注释
< Require all denied
---
># Require all denied
248添加index.php
< DirectoryIndex index.html
---
> DirectoryIndex index.html index.php
447行取消注释
<#Include conf/extra/httpd-mpm.conf
---
>Include conf/extra/httpd-mpm.conf
465行取消注释
<#Include conf/extra/httpd-vhosts.conf
---
>Include conf/extra/httpd-vhosts.conf
vi/usr/local/apache/conf/extra/httpd-vhosts.conf
删除掉原来的替换为:
<VirtualHost*:80>
AddDefaultCharset UTF-8
DocumentRoot "/home/www/php"
ServerName mysqlmtop1.ikongjian.com
<Directory "/home/www/php">
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from All
</Directory>
ErrorLog"|/usr/local/apache/bin/rotatelogs /home/logs/apache/php_%Y%m%d_error.log86400 480"
CustomLog"|/usr/local/apache/bin/rotatelogs /home/logs/apache/php_%Y%m%d_access.log86400 480" common
</VirtualHost>
[root@HE3lepus]# cat /etc/hosts
127.0.0.1 localhost localhost.localdomain
::1 localhost6 localhost6.localdomain6
192.168.1.248 HE1
192.168.1.249 HE2
192.168.1.250 HE3 mysqlmtop1.ikongjian.com
192.168.1.251 HE4
[root@HE3~]# cd /usr/local/apache/bin/
[root@HE3 bin]#./apachectl start
安装Python基础模块
wget http://cdn.lepus.cc/cdncache/software/MySQLdb-python.zip
[root@HE3mysqlmtop]# unzip MySQLdb-python.zip
[root@HE3mysqlmtop]# cd MySQLdb1-master/
[root@HE3MySQLdb1-master]# which mysql_config
/usr/local/mysql/bin/mysql_config
[root@HE3MySQLdb1-master]# vi site.cfg
mysql_config = /usr/local/mysql/bin/mysql_config
[root@HE3MySQLdb1-master]# python setup.py build
[root@HE3MySQLdb1-master]# python setup.py install
安装Lepus采集器
安装Lepus监控系统
注:在安装Lepus系统之前,请先根据前面内容安装LAMP和Python运行基础环境。
上传软件包到监控机服务器并解压缩软件到您的系统
# unziplepus_vx.x.x.zip
在监控机创建监控数据库,并授权。
监控库
mysql> create database lepus default character set utf8;
mysql> grant select,insert,update,delete,create on lepus.* to 'lepus_user'@'%' identified by'MANAGER';
mysql> flush privileges;
[root@HE3Lepus_v3.8_beta]# mysql -uroot -p lepus < sql/lepus_table.sql
[root@HE3Lepus_v3.8_beta]# mysql -uroot -p lepus < sql/lepus_data.sql
mysql>use lepus
mysql>alter tablemysql_status modify column max_connect_errors bigint(18);
mysql>alter tablemysql_status_history modify column max_connect_errors bigint(18);
被监控库
mysql> grant select,super,process,reload,show databases,replication client on *.* to'lepus_monitor'@'%' identified by 'MANAGER';
mysql> flush privileges;
安装Lpeus程序
进入到Lepus软件包的python文件夹
# cd python/
授予install.sh可执行权限
# chmod +x install.sh
执行安装
# ./install.sh
修改配置文件
进入到安装目录,默认为/usr/local/lepus
[root@HE3~]# vi /usr/local/lepus/etc/config.ini
###监控机MySQL数据库连接地址###
[monitor_server]
host="192.168.1.250"
port=4008
user="lepus_user"
passwd="MANAGER"
dbname="lepus"
重启lepus进程
/usr/local/lepus/lepusstop
/usr/local/lepus/lepusstart
[root@HE3lepus]# tail -f logs/lepus.log
安装WEB管理台
进入到你的lepus软件目录
[root@HE3 ~]# cd/home/Lepus_v3.8_beta/
[root@HE3Lepus_v3.8_beta]# cp -r php /home/www
[root@HE3 ~]# vi/home/www/php/application/config/database.php
$db['default']['hostname'] = '192.168.1.250';
$db['default']['port'] = '4008';
$db['default']['username'] = 'lepus_user';
$db['default']['password'] = 'MANAGER';
$db['default']['database'] = 'lepus';
$db['default']['dbdriver'] = 'mysql';
登录进行添加主机和监控
通过浏览器输入mysqlmtop1.ikongjian.com打开监控界面,即可登录系统。.默认管理员账号密码admin/Lepusadmin登录后请修改管理员密码,增加普通账号。
保存后静候1分钟,点仪表盘即可出现监控信息
本文采用的lamp环境已经上传好,下载后直接压缩至/usr/local下即可
http://down.51cto.com/data/2215658
lepus3.7可以从官网下载
本文出自 “岁伏” 博客,请务必保留此出处http://suifu.blog.51cto.com/9167728/1770121
lepus3.7 天兔监控安装手册 CentOS6.5+mysql5.6的更多相关文章
- 分布式架构高可用架构篇_07_MySQL主从复制的配置(CentOS-6.7+MySQL-5.6)
参考: 龙果学院http://www.roncoo.com/share.html?hamc=hLPG8QsaaWVOl2Z76wpJHp3JBbZZF%2Bywm5vEfPp9LbLkAjAnB%2B ...
- Centos6.8 Mysql5.6 安装配置教程
MySQL是一个关系型数据库管理系统,由瑞典MySQL AB 公司开发,目前属于 Oracle 旗下产品.MySQL 最流行的关系型数据库管理系统,在 WEB 应用方面MySQL是最好的 RDBMS ...
- Linux上centOs6+安装mysql5.7详细教程 - 前端小鱼塘
https://coyhom.github.io/ 人类的本质是复读机,作为一个非linux专业人员学习linux最好的办法是重复 环境centos6.5 版本5.7 1: 检测系统是否自带安装mys ...
- 分布式架构高可用架构篇_06_MySQL源码编译安装(CentOS-6.7+MySQL-5.6)
redhat: 下载:http://dev.mysql.com/downloads/mysql/ 选择5.6 source包 解压 cmake . -DCMAKE_INSTALL_PREFIX=/us ...
- CentOS6.5+mysql5.1源码安装过程
一:先安装依赖包(不然配置的时候会报错的!) yum -y install ncurses* libtermcap* gcc-c++* 新建mysql用户 [root@HE1Packages]# gr ...
- lnmp环境搭建(centos6.9+mysql5.7+php7.1+nginx1.10)
安装前准备:CentOS 6.9 64位 最小化安装 yum install -y make gcc gcc-c++ perl zlib-devel libaio libpng libpng-deve ...
- vm12下Centos6安装mysql5.7
一.下载mysql的rpm tar文件 文件名称:mysql-5.7.18-1.el6.x86_64.rpm-bundle.tar官方地址:https://dev.mysql.com/get/Down ...
- MRTG开源监控安装手册
环境要求: CentOS6以上版本 2G内存 16G存储 源码包下载:第一部分:下载,第二部分:下载 1.安装snmp: yum install -y net-snmp net-snmp-devel ...
- CentOS6安装Mysql5.7.10亲测
亲测验证适用于5.7.10 1. 获得二进制文件 wget http://mirrors.sohu.com/mysql/MySQL-5.7/mysql-5.7.10-linux-glibc2.5-x8 ...
随机推荐
- 利用Openssl进行RSA加密签名算法
加密(签名)的过程是(M的e次方)mod n,在这里我们把消息M假定为一个数字,但实际上消息一般为字符串,所以必须有一个将字符串转化为数字的规则,并且要让这个数字的大小和n相当(也不能比 n大).这样 ...
- BodyContent揭秘及定制复杂的JSP标签
BodyContent揭秘及定制复杂的JSP标签 标签: jspintegerwrapperclass设计模式 2010-08-30 11:30 4555人阅读 评论(0) 收藏 举报 分类: HT ...
- [转] MMO即时战斗:地图角色同步管理和防作弊实现
一.前言 无论是端游.页游.手游如果是采用了MMO即时战斗游戏模式,基本都会遇到同屏多角色实时移动.释放技能.战斗等场景,于是自然也需要实现如何管理同屏内各种角色的信息同步:例如角色的位置.以及角色身 ...
- unity3d 多人寻路堵塞堆叠问题
使用unity提供的NavMeshAgent寻路,当有多个agent一起寻路时总会出现堵塞堆叠的问题. 本人使用了一个非常粗劣简单的方案解决此问题,当然跟魔兽的寻路完全没得比,但保证有比较好的性能,且 ...
- log4j配置日志系统
1. lib里加入3个包 slf4j-api, slf4j-log4j12, log4j 2. 在src下 创建log4j.properties ### direct log messages to ...
- Js实例——模态框弹出层
1.描述 百度登录就是一个模态框弹出层.思路分析:先将灰色大背景和登陆盒子设为不可见,利用JS将其动态加载可见. 2.代码 <!DOCTYPE html> <html> < ...
- Ubuntu Server 14.04 & Apache2.4 虚拟主机、模块重写、隐藏入口文件配置
环境: Ubuntu Server 14.04 , Apache2.4 一.Apache2.4 虚拟主机配置 01. 新建一份配置文件 在apache2.4中,虚拟主机的目录是通过/etc/apach ...
- Lua学习系列(一)
从现在开始,打算学习一门新的脚本语言-lua. 1.什么是lua? a) lua1 • Lua 1.0 was implemented as a library, in less then 6000 ...
- CDOJ 1271 Search gold
简单DP.dp[i][j]表示走到这格的最大金钱数. #include<cstdio> #include<cstring> #include<cmath> #inc ...
- tableView滑动到底部
- (void)scrollToBottom { NSInteger sectionCount = [self.dataSource numberOfSectionsInTableView:self] ...