一:先安装依赖包(不然配置的时候会报错的!)

yum -y install ncurses* libtermcap* gcc-c++*

新建mysql用户

[root@HE1Packages]# groupadd mysql
[root@HE1Packages]# useradd -g mysql -s /sbin/nologin mysql

二:获取mysql源码包

mysql官网下载源码即可

三:安装mysql

[root@HE1 mysql]# tar xvf mysql-5.1.51.tar.gz
[root@HE1 mysql]# cd mysql-5.1.51
[root@HE1 mysql-5.1.51]# ./configure --prefix=/usr/local/mysql--localstatedir=/usr/local/mysql/data --enable-assembler --enable-local-infile--enable-thread-safe-client --with-big-tables --with-charset=utf8--with-extra-charsets=gbk,gb2312,utf8,ascii --with-readline --with-ssl--with-embedded-server --with-pthread --with-mysqld-user=mysql--with-mysqld-ldflags=-all-static --with-client-ldflags=-all-static--with-plugins=partition,innobase,innodb_plugin >/home/mysql_setuplogs_configure.log2>&1
[root@HE1 mysql-5.1.51]# make >  /home/mysql_setuplogs_make.log2>&1
[root@HE1 mysql-5.1.51]# make install > /home/mysql_setuplogs_makeinstall.log2>&1
[root@HE1 local]# chown -R mysql. /usr/local/mysql
[root@HE1 local]# echo "exportPATH=$PATH:/usr/local/mysql/bin:/usr/local/mysql/lib" >>/etc/profile
[root@HE1 ~]# source /etc/profile
[root@HE1 mysql-5.1.51]# cp support-files/my-medium.cnf/etc/my.cnf
[root@HE1 mysql-5.1.51]# cp support-files/mysql.server.sh/etc/init.d/mysql
[root@HE1mysql-5.1.51]# chmod +x /etc/init.d/mysql
[root@HE1 bin]# mysql_install_db --user=mysql
[root@HE1 bin]# ./mysqld_safe --usermysql &  (可以启动但不能停止)
[root@HE1 bin]# mysqladmin -uroot password MANAGER
[root@HE1 bin]# mysqladmin -uroot -pMANAGER shutdown
[root@HE1 mysql]# cp/usr/local/mysql/share/mysql/mysql.server /etc/init.d/mysql
[root@HE1 init.d]# chmod 700 /etc/init.d/mysql
[root@HE1 init.d]# chkconfig --add mysql

提示:configure支持的选项非常多,详细的参数及说明建议参考官方文档,也可以通过./configure --help查看,这里仅列出常用及推荐使用的选项。

  • --prefix=PREFIX:指定程序安装路径;

  • --enable-assembler:使用汇编模式;

  • --enable-local-infile:启用对LOAD DATA LOCAL INFILE语法的支持(默认不支持);

  • --enable-profiling:Build a version with query profiling code (req.community-features)

  • --enable-thread-safe-client:使用编译客户端;

  • --with-big-tables:启用32位平台对4G大表的支持;

  • --with-charset=CHARSET:指定字符集;

  • --with-collation=:默认collation;

  • --with-extra-charsets=CHARSET,CHARSET,...:指定附加的字符集;

  • --with-fast-mutexes:Compile with fast mutexes

  • --with-readline:

  • --with-ssl:启用SSL的支持;

  • --with-server-suffix=:添加字符串到版本信息;

  • --with-embedded-server:编译embedded-server;

  • --with-pthread:强制使用pthread类库;

  • --with-mysqld-user=:指定mysqld守护进程的用户;

  • --with-mysqld-ldflags=:静态编译MySQL服务器端;

  • --with-client-ldflags=:静态编译MySQL客户端;

  • --with-plugins=PLUGIN,PLUGIN,...:MySQL服务器端支持的组件(默认为空),可选值较多:

  • partition:MySQL Partitioning Support;

  • daemon_example:This is an example plugin daemon;

  • ftexample:Simple full-text parser plugin;

  • archive:Archive Storage Engine;

  • blackhole:Basic Write-only Read-never tables;

  • csv:Stores tables in text CSV format,强制安装;

  • example:Example for Storage Engines for developers;

  • federated:Connects to tables on remote MySQL servers;

  • heap:Volatile memory based tables,强制安装;

  • ibmdb2i:IBM DB2 for i Storage Engine;

  • innobase:Transactional Tables using InnoDB;

  • innodb_plugin:Transactional Tables using InnoDB;

  • myisam:Traditional non-transactional MySQL tables,强制安装;

  • myisammrg:Merge multiple MySQL tables into one,强制安装;

  • ndbcluster:High Availability Clustered tables;

  • --with-plugin-PLUGIN:强制指定的插件链接至MySQL服务器;

  • --with-zlib-dir=:向MySQL提供一个自定义的压缩类库地址;

  • --without-server:仅安装MySQL客户端;

  • --without-query-cache:不要编译查询缓存;

  • --without-geometry:不要编译geometry-related部分;

  • --without-debug:编译为产品版,放弃debugging代码;

  • --without-ndb-debug:禁用special ndb debug特性;

提示:执行Configure时如果报bin/rm: cannot remove `libtoolt': No such file or directory错误,可按照下列步骤解决:

1、确认libtool是否已经安装,如果没有安装的话,则先安装libtool

# rpm -qa | grep libtool

# yum -y install libtool

2、分别执行以下三条命令:

# autoreconf --force --install

# libtoolize --automake --force

# automake --force --add-missing

再重新编译安装,问题解决!

来自 <http://blog.itpub.net/7607759/viewspace-684612/>

CentOS6.5中编译是遇见如下错误

error: No curses/termcap library found

checking fortgetent in -lncurses... no

checking fortgetent in -lcurses... no

checking fortgetent in -ltermcap... no

checking fortgetent in -ltinfo... no

checking fortermcap functions library... configure: error: No curses/termcap library found

安装之初我已经用yum安装了ncurses*了,不过rpm -qa发现缺少了

ncurses-devel

rpm -ivh 安装即可 ncurses-devel-5.7-3.20090208.el6.x86_64

gcc-c++

[root@HE1init.d]# rpm -qa|grep ncurses

ncurses-base-5.7-3.20090208.el6.x86_64

ncurses-5.7-3.20090208.el6.x86_64

ncurses-devel-5.7-3.20090208.el6.x86_64

ncurses-libs-5.7-3.20090208.el6.x86_64

[root@HE1init.d]# rpm -qa|grep gcc

gcc-4.4.7-4.el6.x86_64

libgcc-4.4.7-4.el6.x86_64

gcc-c++-4.4.7-4.el6.x86_64

CentOS6.5+mysql5.1源码安装过程的更多相关文章

  1. CentOS6.5+mysql5.5源码安装

    数据库安装 1新增mysql用户 [root@HE1mysql]# groupadd mysql -g 502 [root@HE1mysql]# useradd -g mysql -s /sbin/n ...

  2. mysql-5.5.28源码安装过程中错误总结

    介绍一下关于mysql-5.5.28源码安装过程中几大错误总结,希望此文章对各位同学有所帮助.系统centOS 6.3 mini (没有任何编译环境)预编译环境首先装了众所周知的 cmake(yum ...

  3. mysql5.6源码安装(转)

    mysql5.6源码安装 转自 jabbok博客园 https://www.cnblogs.com/jabbok/p/9418344.html 1 编译安装 1 2 3 4 5 6 groupadd ...

  4. Linux MySQL5.5源码安装

    环境:CentOS7,MySQL5.5 1.MySQL5.5源码下载 Oracle的网站打开较慢,http://mirrors.sohu.com/mysql/这里提供了MySQL的镜像.一般的,Lin ...

  5. ubuntu mysql5.7源码安装

    本系列的lnmp的大框架基本上是按照http://www.linuxzen.com/lnmphuan-jing-da-jian-wan-quan-shou-ce-si-lnmpda-jian-yuan ...

  6. Mysql5.5源码安装步骤笔记记录

    1.cmake软件的安装wget https://cmake.org/files/v3.5/cmake-3.5.0-rc3.tar.gztar xf cmake-3.5.0.tar.gzcd cmak ...

  7. Linux系统源码安装过程中的prefix选项

    在linux和unix环境中,源码安装是最常用的软件安装方式,一些软件除了提供源码外,也提供各种发行版的二进制安装包(如基于redhat包管理工具的rpm包),但强烈建议使用源码安装方式.原因是:(1 ...

  8. MYSQL5.5源码安装 linux下

    /* 首先安装必要的库 */ yum -y install gcc* ###### 安装 MYSQL ###### 首先安装camke 一.支持YUM,则 yum install -y cmake 二 ...

  9. gdb源码安装过程中的问题:no termcap library found

    gdb使用源码安装的时候遇到错误:no termcap library found ./configure -->  make --> make install 解决办法,下载termca ...

随机推荐

  1. hadoop2.2 datanode 启动不了

    FATAL org.apache.hadoop.hdfs.server.datanode.DataNode: Initialization failed for block pool Block po ...

  2. 清除浮动的方法 after伪类。

    .clearfix{ *zoom:1; } .clearfix:after{ content: ""; display: block; clear: both; } 在样式中加入上 ...

  3. NAVICAT 拒绝链接的问题

    处理步骤 1.先在原有的建一个新的用户 2.成功后,再点击原有的,即可使用

  4. ural1003 Parity

    Parity Time limit: 2.0 secondMemory limit: 64 MB Now and then you play the following game with your ...

  5. nginx 内存池分析

    最近nginx的源码刚好研究到内存池,这儿就看下nginx内存池的相关的东西. 一,为什么要使用内存池 大多数的解释不外乎提升程序的处理性能及减小内存中的碎片,对于性能优化这点主要体现在: (1)系统 ...

  6. PHP中对mysql预编译查询语句的一个封装

    原文地址:http://chen-shan.net/?p=474 为了防止sql注入,我们都使用过mysqli这个类,但是每次都需要绑定参数,绑定结果等,比较麻烦,所以可以把这些重复的语句封装成一个函 ...

  7. SQL复习四(完整性约束)

    完整性约束是为了表的数据的正确性.主要有主键,外键的约束. 1 主键 当某一列添加了主键约束后,该列的数据就不能重复出现.这样每行记录中其主键列就能唯一的标识着以行.如学生可以用学号作为唯一的标识. ...

  8. PHP运行方式

    原文链接:http://www.cnblogs.com/xia520pi/p/3914964.html 1.运行模式 关于PHP目前比较常见的五大运行模式: 1)CGI(通用网关接口 / Common ...

  9. mysql问题: alter导致速度慢

    1 如何并行执行. 数据库里有一个数据量非常大的表,当对这个表进行alter的时候,这时候该表是只读的,由于数据量很大alter时间很长,如果这时候有insert或update操作,有什么办法在这期间 ...

  10. (中等) HDU 1542 Atlantis,扫描线。

    Problem Description There are several ancient Greek texts that contain descriptions of the fabled is ...