Linux 下,mysql数据库报无法登陆错误:ERROR 1045 (28000): Access denied for use
今天在别人的服务器上登录mysql发现无法登陆(Mysql别人实现安装好的)
密码和用户名都是正确的,但登录后报如下错误:
ERROR 1045 (28000): Access denied for user ‘admin’@'localhost’ (using password: YES)
尝试了加入-h和-port也无法登陆,最后只能重新修改了。注--该方法也可以用于当忘记数据库密码时,找回数据库密码用
如下是我执行过程,完全执行后,可以顺利登录数据库:linux下的执行脚本:
- login as: root
- Access denied
- root@×××××××'s password:
- Last login: Tue Feb 21 03:56:49 2012 from 218.17.162.225
- [root@INOTRADE ~]# ps -A
- PID TTY TIME CMD
- 1 ? 00:00:01 init
- 1117 ? 00:00:00 udevd
- 1394 ? 00:00:00 syslogd
- 1405 ? 00:00:00 sshd
- 1414 ? 00:00:00 xinetd
- 1427 ? 00:00:00 couriertcpd
- 1429 ? 00:00:00 courierlogger
- 1437 ? 00:00:00 couriertcpd
- 1439 ? 00:00:00 courierlogger
- 1445 ? 00:00:00 couriertcpd
- 1447 ? 00:00:00 courierlogger
- 1454 ? 00:00:00 couriertcpd
- 1456 ? 00:00:00 courierlogger
- 1466 ? 00:00:00 qmail-send
- 1468 ? 00:00:00 splogger
- 1469 ? 00:00:00 qmail-lspawn
- 1470 ? 00:00:00 qmail-rspawn
- 1471 ? 00:00:00 qmail-clean
- 1486 ? 00:00:00 httpd
- 1528 ? 00:00:00 named
- 1573 ? 00:00:00 mysqld_safe
- 1623 ? 00:00:00 mysqld
- 1629 ? 00:00:00 httpd
- 1655 ? 00:00:00 httpsd
- 1659 ? 00:00:00 httpsd
- 1674 ? 00:00:00 crond
- 1682 ? 00:00:00 saslauthd
- 1683 ? 00:00:00 saslauthd
- 1689 ? 00:00:00 sshd
- 1691 pts/0 00:00:00 bash
- 1718 pts/0 00:00:00 ps
- // 无法登陆,密码正确的,不知道为什么,原来数据库表的访问权限也已经设置了的
- [root@INOTRADE ~]# mysql -uroot -p
- Enter password:
- [root@INOTRADE ~]# ERROR 1045 (28000): Access denied for user ‘admin’@'localhost’ (using password: YES)
- [root@INOTRADE ~]# mysql -uroot -p****** -hlocalhost
- [root@INOTRADE ~]# ERROR 1045 (28000): Access denied for user ‘admin’@'localhost’ (using password: YES)
- // 执行脚本,更新mysql数据库的数据,如用户名密码
- [root@INOTRADE ~]# sudo /etc/init.d/mysqld stop
- Stopping MySQL: [ OK ]
- [root@INOTRADE ~]# mysqld_safe --user=mysql --skip-grant-tables --skip-networking &
- [1] 1759
- ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
- [root@INOTRADE ~]# Starting mysqld daemon with databases from /var/lib/mysql
- -- 这步可能不会自动执行,等待十几秒后就可以直接回车返回到命令行模式下,然后登录到mysql服务器
- [root@INOTRADE ~]#
- [root@INOTRADE ~]# mysql -u root mysql
- Reading table information for completion of table and column names
- You can turn off this feature to get a quicker startup with -A
- Welcome to the MySQL monitor. Commands end with ; or \g.
- Your MySQL connection id is 1
- Server version: 5.0.77 Source distribution
- Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
- mysql> select host, user from user;
- +-----------+------------------+
- | host | user |
- +-----------+------------------+
- | % | admin |
- | localhost | admin |
- | localhost | horde |
- | localhost | pma_OBBVuV2L3mjn |
- +-----------+------------------+
- 4 rows in set (0.00 sec)
- -- 因为我数据库中没有root,换为admin了
- mysql> UPDATE user SET Password=PASSWORD('******') where USER='admin';
- Query OK, 2 rows affected (0.02 sec)
- Rows matched: 2 Changed: 2 Warnings: 0
- mysql> FLUSH PRIVILEGES;
- Query OK, 0 rows affected (0.02 sec)
- mysql> quit;
- Bye
- [root@INOTRADE ~]# /etc/init.d/mysqld restart
- STOPPING server from pid file /var/run/mysqld/mysqld.pid
- 120221 05:08:02 mysqld ended
- Stopping MySQL: [ OK ]
- Starting MySQL: [ OK ]
- [1]+ Done mysqld_safe --user=mysql --skip-grant-tables --skip-networking
- // 至此, 重启后就可以正常登录了
- [root@INOTRADE ~]# mysql -uadmin -p******
- Welcome to the MySQL monitor. Commands end with ; or \g.
- Your MySQL connection id is 3
- Server version: 5.0.77 Source distribution
- Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
- mysql> show databases;
- +-------------------------+
- | Database |
- +-------------------------+
- | information_schema |
- | ******* |
- | horde |
- | mysql |
- +-------------------------+
- 7 rows in set (0.01 sec)
- mysql> use ********;
- Reading table information for completion of table and column names
- You can turn off this feature to get a quicker startup with -A
- Database changed
- mysql> show tables;
- +------------------------------+
- | Tables_in_CQT_AMS |
- +------------------------------+
- | T_ALM_APPLICATION |
- | ***************** |
- | T_SYS_ROLE |
- | T_SYS_USER_INFO |
- | T_SYS_USER_ROLE |
- +------------------------------+
- 22 rows in set (0.00 sec)
- mysql> quit
- Bye
- [root@INOTRADE ~]#
Linux 下,mysql数据库报无法登陆错误:ERROR 1045 (28000): Access denied for use的更多相关文章
- Win7下mysql root账户登录提示:ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)解决方案
ERROR 1045 (28000): Ac-- password: YES)这个意思是密码不正确,那就修改密码: 如果你是服务器是 windows xp/2000/2003/nt 都可以使用这个方法 ...
- mac系统中搭建apache+mysql+php的开发环境,安装mysql后,登录报错:mac ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
php新手在mac系统中搭建apache+mysql+php的开发环境(按照这篇博客来操作的:http://my.oschina.net/joanfen/blog/171109?fromerr=xvC ...
- 【转载】重置密码解决MySQL for Linux错误 ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
重置密码解决MySQL for Linux错误 ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using passwor ...
- 重置密码解决MySQL for Linux错误 ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
出现报错: Warning: World-writable config file '/etc/my.cnf' is ignored // 该文件权限过高ERROR 1045 (28000): Acc ...
- mysql无法远程连接问题(ERROR 1045 (28000): Access denied for user 'root')
mysql版本 : 8.0.21 使用mysql 作为nextcloud的数据库.之前使用挺正常的,因为被黑客勒索过一次,重新启动了一个mysql的docker镜像. 结果数据库配置老是失败,next ...
- 在Linux下 MySQL错误 ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES) 解决办法【很管用】
一般这个错误是由密码错误引起,解决的办法自然就是重置密码. 假设我们使用的是root账户. 1.重置密码的第一步就是跳过MySQL的密码认证过程,方法如下: #vim /etc/my.cnf(注:wi ...
- 重置密码解决MySQL for Linux错误 ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using passwor
一般这个错误是由密码错误引起,解决的办法自然就是重置密码. 假设我们使用的是root账户. 1.重置密码的第一步就是跳过MySQL的密码认证过程,方法如下: #vim /etc/my.cnf(注:wi ...
- Linux mysql 5.6: ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
案例环境: 操作系统 :Red Hat Enterprise Linux Server release 5.7 (Tikanga) 64 bit 数据库版本 : Mysql 5.6.19 64 bit ...
- 解决mysql登录报错ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)问题
问题描述: 在ubuntu14.04上安装完MYSQL后,MYSQL默认给分配了一个默认密码,但当自己在终端上使用默认密码登录的时候,总会提示一个授权失败的错误. 报错信息:Access denied ...
随机推荐
- C++ 中引用与指针的区别
1.引用只是变量的一个别名,并不占用内存空间,而指针是一个变量,里面保存着被指向的变量在内存中的地址: 2 引用只能在定义时被初始化一次,之后不可变,而指针可变: 3 引用没有 const,指针有 c ...
- bat自动执行telnet
@del c:\temp.vbs @echo on error resume next >>c:\temp.vbs @echo dim WshShell>>c:\temp.vb ...
- 【故障处理】ORA-30012的解决过程
[故障处理]ORA-30012的解决过程 1 BLOG文档结构图 2 前言部分 2.1 导读和注意事项 各位技术爱好者,看完本文后,你可以掌握如下的技能,也可以学到一些其它你所不知道的知识,~O ...
- 关于Redis中的字符串对象
一.SDS redis中定义Object types有5种 /* Object types */ #define REDIS_STRING 0 #define REDIS_LIST 1 #define ...
- npm 配置全局文件
nodejs.npm 按照默认安装完成即可. 1.设置一下全局目录:配置npm的全局模块的存放路径以及cache的路径,将以上两个文件夹放在NodeJS的主目录下,便在NodeJs下建立"n ...
- ELK 信息统计分析-1
Aggregations 格式如下: "aggregations"{ //可以简写为aggs "<aggregation_name>":{ //名称 ...
- Error: Could not access the Package Manager. Is the system running?
最近在搭建cordova,android 开发环境,安装android studio之后创建一个demo之后,运行想看一下效果,在运行过程中创建一个虚拟机(arm)的,等了有1分钟左右,再次运行程序, ...
- Git指令总结和图表
Git 是一个很强大的分布式版本控制系统.它不但适用于管理大型开源软件的源代码,管理私人的文档和源代码也有很多优势. Git常用操作命令: 1) 远程仓库相关命令 检出仓库:$ git clone g ...
- 新手在sae部署程序容易忽略的一个细节
从来没用过这类云空间服务,尝了下鲜试用一下sae,但是部署的时候发现问题了,各种404..各种无奈啊..虽然百度无数篇介绍,但是都千篇一律没什么启发.. 但是巧在我部署的应用有个欢迎页面,点击链接的时 ...
- [转]VS2015 cordova尝试-camera
本文转自:http://blog.csdn.net/greystar/article/details/47973837 1. 确保环境正常,如出现错误 ,安下载android sdk 相关版本,我在这 ...