CentOS7上elasticsearch5.0启动失败

刚一启动完直接就退出了

$ ./elasticsearch
...
ERROR: bootstrap checks failed
max file descriptors [] for elasticsearch process likely too low, increase to at least []
max virtual memory areas vm.max_map_count [] likely too low, increase to at least []
[--31T04::,][INFO ][o.e.n.Node ] [vJDcSkt] stopping ...
[--31T04::,][INFO ][o.e.n.Node ] [vJDcSkt] stopped
[--31T04::,][INFO ][o.e.n.Node ] [vJDcSkt] closing ...
[--31T04::,][INFO ][o.e.n.Node ] [vJDcSkt] closed

解决办法:

问题1:max file descriptors [4096] for elasticsearch process likely too low, increase to at least [65536]

修改/etc/security/limits.conf文件,添加或修改如下行:

hard    nofile           65536

soft    nofile           65536

问题2:max virtual memory areas vm.max_map_count [65530] likely too low, increase to at least [262144]

使用下面的方法临时使其生效

sudo sysctl -w vm.max_map_count=

或者修改 /etc/sysctl.conf 文件,添加 “vm.max_map_count”设置

设置后,可以使用

sysctl -a

max virtual memory areas vm.max_map_count [65530] likely too low, increase to at least [262144]

 1 [root@localhost ~]# cat /etc/sysctl.conf | grep -v "vm.max_map_count" > /tmp/system_sysctl.conf
2 [root@localhost ~]# echo "vm.max_map_count=262144" >> /tmp/system_sysctl.conf
3 [root@localhost ~]# mv /tmp/system_sysctl.conf /etc/sysctl.conf
4 mv:是否覆盖"/etc/sysctl.conf"? y
5 [root@localhost ~]# cat /etc/sysctl.conf
6 # System default settings live in /usr/lib/sysctl.d/00-system.conf.
7 # To override those settings, enter new settings here, or in an /etc/sysctl.d/<name>.conf file
8 #
9 # For more information, see sysctl.conf(5) and sysctl.d(5).
10 vm.max_map_count=262144
11 [root@localhost ~]# sysctl -p
12 vm.max_map_count = 262144

CentOS7上elasticsearch5.0启动失败的更多相关文章

  1. CentOS7上elasticsearch5.5启动报错

    ERROR: [2] bootstrap checks failed [1]: max file descriptors [4096] for elasticsearch process is too ...

  2. CentOS7安装vncserver(启动失败及连接黑屏解决办法)

    CentOS7安装vncserver(启动失败及连接黑屏解决办法) 转载weixin_34167043 最后发布于2017-11-09 15:11:00 阅读数 42  收藏 展开 AutoSAR入门 ...

  3. Centos7上MariaDB数据库启动问题解决

    安装MariaDB数据库后出现服务启动失败问题, 解决办法:卸载再安装!(确定无3306端口占用) 一.卸载数据库: [root@localhost logs]# yum -y remove mari ...

  4. linux中mysql连接不上,服务启动失败等问题解决

    confluence问题解决方式 1)针对confluence访问页面报500与连接失败等问题 首先我们登陆部署confluence的服器 10.15.4.115 2)重启mysql服务,发现重启失败 ...

  5. Linux suse x86_64 环境上部署Hadoop启动失败原因分析

    一.问题症状: 在安装hadoop的时候报类似如下的错误: # A fatal error has beendetected by the Java Runtime Environment: # #  ...

  6. RedHat 6.4 安装WAS 7.0 启动失败com.ibm.websphere.ssl.SSLException

    问题描述 RedHat 6.4 安装 WAS 7.0,安装完成之后启动WAS失败,异常信息如下: [5/7/15 9:59:55:185 CST] 00000000 WsServerImpl E WS ...

  7. docker学习(一)在centos7上安装与启动docker

    CentOS Docker 安装 1.Docker支持以下的CentOS版本: CentOS 7 (64-bit) CentOS 6.5 (64-bit) 或更高的版本 前提条件 目前,CentOS ...

  8. CentOS7下MySQL服务启动失败原因及解决方法

    在重启阿里的CentOS7服务器后,重启MySQL 出现错误 Starting mysqld (via systemctl): Job for mysqld.service failed becaus ...

  9. centos7上mysql无法启动也没有日志

    报错的原因就是 [root@localhost duanxinli]# journalctl -xe-- Subject: Unit mysqld.service has begun start-up ...

随机推荐

  1. Android Exception 15(关于使用RecyclerView的异常)

    04-07 16:32:32.815: E/AndroidRuntime(16173): FATAL EXCEPTION: main 04-07 16:32:32.815: E/AndroidRunt ...

  2. jsoup爬虫简书首页数据做个小Demo

    代码地址如下:http://www.demodashi.com/demo/11643.html 昨天LZ去面试,遇到一个大牛,被血虐一番,发现自己基础还是很薄弱,对java一些原理掌握的还是不够稳固, ...

  3. ucos-ii变量名称表

  4. webpack-dev-server 无法通过ip访问的问题

    使用Vue-cli生成的webpack脚手架,之前一直是可以通过本地ip + 端口来访问的.今天忽然不可以,百度一下才知道缺少了host参数. 打开package.json.在.scripts.dev ...

  5. Centos使用光盘作为本地yum源

    [root@localhost CentOS]# mkdir /media/CentOS把光盘加载到本地[root@localhost CentOS]# mount /dev/cdrom /media ...

  6. Atitit. 木马病毒的外部class自动加载机制------加载class的方法总结

    Atitit. 木马病毒的外部class自动加载机制------加载class的方法总结 Atitit.java load class methods 1. 动态加载jar文件和class文件. 1 ...

  7. Atitit.虚拟机与指令系统的设计

    Atitit.虚拟机与指令系统的设计 1. 两种计算模型  ,堆栈机和状态机(基于寄存器的虚拟机1 1.1.1. 堆栈机1 1.1.2. 状态机2 2. 为什么状态机比堆栈机快呢?3 2.1. Sta ...

  8. C#实现插件的“动态替换”

    如果某个"功能"需要动态更新?这种动态更新,可能是需求驱动的,也可能是为了修改 BUG,面对这种场景,如何实现“热插拔”呢?先解释一下“热插拔”:在系统运行过程动态替换某些功能,不 ...

  9. PHP 7的一些引人注目的新特性简单介绍

    1. ?? 运算符(NULL 合并运算符)把这个放在第一个说是因为我觉得它很有用.用法: ? 1 $a = $_GET['a'] ?? 1; 它相当于: ? 1 2 <?php $a = iss ...

  10. 阿里云服务器 端口开放问题 浏览器钟输入ip 访问服务器

    在这里先用一堆粗口强烈吐槽阿里云服务器控制台,屎一样的界面,简直非人类的操作.想找一个功能简直无从下手. 场景: 今天刚在阿里云买了个服务器,打算愉快的用五分钟将数据库,apache,安装完毕,然后去 ...