笔者好久没有使用opatchauto打过补丁了,搜了下自己的历史随笔,上次opatchauto打补丁的记录还是Oracle 11g版本:

而11g版本如今已经不再向客户推荐,19c也已经成为当下强力推荐的长期支持版本,我们知道19c的补丁也改为RU,今天给一个客户做测试,为了规避已知bug,恰好需要应用RU补丁,索性就做个记录备忘。

DBA很熟悉打补丁都要看对应的readme文件,从本次readme内容来看,19c实际不再需要配置响应文件,也无需手工执行DB脚本,不得不说O在自动化应用补丁的工作上又有了很大进步。

实际步骤只需两步,本次应用补丁不幸遇到一些问题,汇总到第三部分供大家参考。

1.更新OPatch版本

下载需要的补丁介质,我习惯将其权限修改如下:

[root@db193 media]# chown grid:oinstall p*
[root@db193 media]# chmod 775 p*
[root@db193 media]# ls -lrth
总用量 2.6G
-rwxrwxr-x 1 grid oinstall 116M 9月 13 15:10 p6880880_190000_Linux-x86-64.zip
-rwxrwxr-x 1 grid oinstall 2.5G 9月 13 15:12 p32895426_190000_Linux-x86-64.zip

在所有节点的GI HOME和DB HOME下,都更新为符合应用补丁需求的OPatch版本。 将之前OPatch备份,解压新版本的OPatch到$ORACLE_HOME目录下,最后检查OPatch版本。

--更新OPatch版本 @all nodes including GI HOME and DB HOME
mv OPatch OPatch_bak
unzip p6880880_112000_Linux-x86-64.zip -d $ORACLE_HOME
$ORACLE_HOME/OPatch/opatch version

这点和之前一样,同样GI的$ORACLE_HOME目录权限默认无法写,需要更改下,我通常会采用以下两种方法:

--方法1:将GI的$ORACLE_HOME目录权限临时改为775(注意只改这一层即可!),操作完成后再修改回原来的755:
[root@db193 media]# chmod 775 /u01/app/19.3.0/grid
mv OPatch OPatch_bak
[grid@db193 grid]$ unzip /u01/media/p6880880_190000_Linux-x86-64.zip -d $ORACLE_HOME [grid@db193 ~]$ $ORACLE_HOME/OPatch/opatch version
OPatch Version: 12.2.0.1.27 OPatch succeeded. [root@db193 media]# chmod 755 /u01/app/19.3.0/grid --方法2:直接使用root用户解压OPatch,然后修改OPatch目录及子目录权限:
[root@db195 grid]# mv OPatch OPatch_bak
[root@db195 grid]# unzip /u01/media/p6880880_190000_Linux-x86-64.zip -d /u01/app/19.3.0/grid
[root@db195 grid]# chown -R grid:oinstall OPatch

2.使用opatch auto应用补丁

实际按照readme,我的环境是最典型的,直接在每个节点分别执行opatchauto apply:

--opatchauto
As root user, execute the following command on each node of the cluster: # <GI_HOME>/OPatch/opatchauto apply <UNZIPPED_PATCH_LOCATION>/32895426
# /u01/app/19.3.0/grid/OPatch/opatchauto apply /u01/media/32895426 [root@db193 ~]# /u01/app/19.3.0/grid/OPatch/opatchauto apply /u01/media/32895426
[root@db195 ~]# /u01/app/19.3.0/grid/OPatch/opatchauto apply /u01/media/32895426

3.本次遇到问题处理

3.1 节点1应用补丁,提示空间不足

实际上,打补丁空间剩余建议至少10GB+,这里错误显示至少需要7465.104MB,实际肯定要多冗余一些空间。

仔细看19c的RU也比之前更智能了,空间不足实际是在补丁应用校验阶段就报出,这是个值得称赞的改进,要知道之前很多客户案例都是因为空间不足导致补丁应用中途失败的,现在把这个空间问题提前校验就免去了很多不必要的麻烦:

[root@db193 ~]# /u01/app/19.3.0/grid/OPatch/opatchauto apply /u01/media/32895426

OPatchauto session is initiated at Mon Sep 13 16:17:34 2021

System initialization log file is /u01/app/19.3.0/grid/cfgtoollogs/opatchautodb/systemconfig2021-09-13_04-17-45PM.log.

会话日志文件是/u01/app/19.3.0/grid/cfgtoollogs/opatchauto/opatchauto2021-09-13_04-19-50PM.log
此会话的 ID 为 ESYS Executing OPatch prereq operations to verify patch applicability on home /u01/app/19.3.0/grid Executing OPatch prereq operations to verify patch applicability on home /u01/app/oracle/product/19.3.0/db_1
Patch applicability verification failed on home /u01/app/19.3.0/grid Patch applicability verification failed on home /u01/app/oracle/product/19.3.0/db_1 未能执行 [OPatchAutoBinaryAction] 补丁程序操作, 有关详细信息, 请查看日志。故障: Patch Target : db193->/u01/app/oracle/product/19.3.0/db_1 类型 [rac]
Details: [
---------------------------Patching Failed---------------------------------
Command execution failed during patching in home: /u01/app/oracle/product/19.3.0/db_1, host: db193.
Command failed: /u01/app/oracle/product/19.3.0/db_1/OPatch/opatchauto apply /u01/media/32895426 -oh /u01/app/oracle/product/19.3.0/db_1 -target_type rac_database -binary -invPtrLoc /u01/app/19.3.0/grid/oraInst.loc -jre /u01/app/19.3.0/grid/OPatch/jre -persistresult /u01/app/oracle/product/19.3.0/db_1/opatchautocfg/db/sessioninfo/sessionresult_analyze_db193_rac_2.ser -analyze -online -prepare_home
Command failure output:
==Following patches FAILED in analysis for apply: Patch: /u01/media/32895426/32916816
Log: /u01/app/oracle/product/19.3.0/db_1/cfgtoollogs/opatchauto/core/opatch/opatch2021-09-13_16-21-05下午_1.log
Reason: Failed during Analysis: CheckSystemSpace Failed, [ Prerequisite Status: FAILED, Prerequisite output:
The details are:
Required amount of space(7465.104MB) is not available.] Patch: /u01/media/32895426/32904851
Log: /u01/app/oracle/product/19.3.0/db_1/cfgtoollogs/opatchauto/core/opatch/opatch2021-09-13_16-21-05下午_1.log
Reason: Failed during Analysis: CheckSystemSpace Failed, [ Prerequisite Status: FAILED, Prerequisite output:
The details are:
Required amount of space(7465.104MB) is not available.] After fixing the cause of failure Run opatchauto resume ]
OPATCHAUTO-68061: 业务流程引擎失败。
OPATCHAUTO-68061: 业务流程引擎失败, 返回代码为 1
OPATCHAUTO-68061: 有关详细资料, 请查看日志。
OPatchAuto 失败。 OPatchauto session completed at Mon Sep 13 16:25:15 2021
Time taken to complete the session 7 minutes, 42 seconds opatchauto failed with error code 42

清理一些日志空间后,再次执行尝试:

[root@db193 ~]# /u01/app/19.3.0/grid/OPatch/opatchauto apply /u01/media/32895426

OPatchauto session is initiated at Mon Sep 13 16:40:14 2021

System initialization log file is /u01/app/19.3.0/grid/cfgtoollogs/opatchautodb/systemconfig2021-09-13_04-40-25PM.log.

会话日志文件是/u01/app/19.3.0/grid/cfgtoollogs/opatchauto/opatchauto2021-09-13_04-41-21PM.log
此会话的 ID 为 7M6S Executing OPatch prereq operations to verify patch applicability on home /u01/app/19.3.0/grid Executing OPatch prereq operations to verify patch applicability on home /u01/app/oracle/product/19.3.0/db_1
Patch applicability verified successfully on home /u01/app/oracle/product/19.3.0/db_1 Patch applicability verified successfully on home /u01/app/19.3.0/grid Executing patch validation checks on home /u01/app/19.3.0/grid
Patch validation checks successfully completed on home /u01/app/19.3.0/grid Executing patch validation checks on home /u01/app/oracle/product/19.3.0/db_1
Patch validation checks successfully completed on home /u01/app/oracle/product/19.3.0/db_1 Verifying SQL patch applicability on home /u01/app/oracle/product/19.3.0/db_1
SQL patch applicability verified successfully on home /u01/app/oracle/product/19.3.0/db_1 Preparing to bring down database service on home /u01/app/oracle/product/19.3.0/db_1
Successfully prepared home /u01/app/oracle/product/19.3.0/db_1 to bring down database service Performing prepatch operations on CRS - bringing down CRS service on home /u01/app/19.3.0/grid
Prepatch operation log file location: /u01/app/grid/crsdata/db193/crsconfig/crs_prepatch_apply_inplace_db193_2021-09-13_04-48-22PM.log
CRS service brought down successfully on home /u01/app/19.3.0/grid Performing prepatch operation on home /u01/app/oracle/product/19.3.0/db_1
Perpatch operation completed successfully on home /u01/app/oracle/product/19.3.0/db_1 Start applying binary patch on home /u01/app/oracle/product/19.3.0/db_1
Binary patch applied successfully on home /u01/app/oracle/product/19.3.0/db_1 Performing postpatch operation on home /u01/app/oracle/product/19.3.0/db_1
Postpatch operation completed successfully on home /u01/app/oracle/product/19.3.0/db_1 Start applying binary patch on home /u01/app/19.3.0/grid
Binary patch applied successfully on home /u01/app/19.3.0/grid Performing postpatch operations on CRS - starting CRS service on home /u01/app/19.3.0/grid
Postpatch operation log file location: /u01/app/grid/crsdata/db193/crsconfig/crs_postpatch_apply_inplace_db193_2021-09-13_05-16-37PM.log
CRS service started successfully on home /u01/app/19.3.0/grid Preparing home /u01/app/oracle/product/19.3.0/db_1 after database service restarted
No step execution required......... Trying to apply SQL patch on home /u01/app/oracle/product/19.3.0/db_1
SQL patch applied successfully on home /u01/app/oracle/product/19.3.0/db_1 OPatchAuto 成功。 --------------------------------Summary-------------------------------- Patching is completed successfully. Please find the summary as follows: Host:db193
RAC Home:/u01/app/oracle/product/19.3.0/db_1
Version:19.0.0.0.0
Summary: ==Following patches were SKIPPED: Patch: /u01/media/32895426/32915586
Reason: This patch is not applicable to this specified target type - "rac_database" Patch: /u01/media/32895426/32585572
Reason: This patch is not applicable to this specified target type - "rac_database" Patch: /u01/media/32895426/32918050
Reason: This patch is not applicable to this specified target type - "rac_database" ==Following patches were SUCCESSFULLY applied: Patch: /u01/media/32895426/32904851
Log: /u01/app/oracle/product/19.3.0/db_1/cfgtoollogs/opatchauto/core/opatch/opatch2021-09-13_16-51-45下午_1.log Patch: /u01/media/32895426/32916816
Log: /u01/app/oracle/product/19.3.0/db_1/cfgtoollogs/opatchauto/core/opatch/opatch2021-09-13_16-51-45下午_1.log Host:db193
CRS Home:/u01/app/19.3.0/grid
Version:19.0.0.0.0
Summary: ==Following patches were SUCCESSFULLY applied: Patch: /u01/media/32895426/32585572
Log: /u01/app/19.3.0/grid/cfgtoollogs/opatchauto/core/opatch/opatch2021-09-13_17-03-57下午_1.log Patch: /u01/media/32895426/32904851
Log: /u01/app/19.3.0/grid/cfgtoollogs/opatchauto/core/opatch/opatch2021-09-13_17-03-57下午_1.log Patch: /u01/media/32895426/32915586
Log: /u01/app/19.3.0/grid/cfgtoollogs/opatchauto/core/opatch/opatch2021-09-13_17-03-57下午_1.log Patch: /u01/media/32895426/32916816
Log: /u01/app/19.3.0/grid/cfgtoollogs/opatchauto/core/opatch/opatch2021-09-13_17-03-57下午_1.log Patch: /u01/media/32895426/32918050
Log: /u01/app/19.3.0/grid/cfgtoollogs/opatchauto/core/opatch/opatch2021-09-13_17-03-57下午_1.log OPatchauto session completed at Mon Sep 13 17:26:52 2021
Time taken to complete the session 46 minutes, 39 seconds
[root@db193 ~]#

好家伙,整个过程居然花了46分钟..不过整体都是自动化执行的,也非常方便,期间可以休息一会儿,喝杯咖啡顺便看着不报错即可。

3.2 节点2应用补丁,提示权限不够

在节点2应用补丁之前,进一步清理了能够清理的日志,想加快补丁应用的时间。

本以为节点1顺利成功,节点2也不会有啥问题了,结果还真的遇到了问题,在节点2执行补丁应用时,报错有文件权限不够:

[root@db195 ~]# /u01/app/19.3.0/grid/OPatch/opatchauto apply /u01/media/32895426

OPatchauto session is initiated at Mon Sep 13 17:29:29 2021

System initialization log file is /u01/app/19.3.0/grid/cfgtoollogs/opatchautodb/systemconfig2021-09-13_05-29-48PM.log.

会话日志文件是/u01/app/19.3.0/grid/cfgtoollogs/opatchauto/opatchauto2021-09-13_05-30-51PM.log
此会话的 ID 为 AMSA Executing OPatch prereq operations to verify patch applicability on home /u01/app/19.3.0/grid Executing OPatch prereq operations to verify patch applicability on home /u01/app/oracle/product/19.3.0/db_1
Patch applicability verified successfully on home /u01/app/oracle/product/19.3.0/db_1 Patch applicability verified successfully on home /u01/app/19.3.0/grid Executing patch validation checks on home /u01/app/19.3.0/grid
Patch validation checks successfully completed on home /u01/app/19.3.0/grid Executing patch validation checks on home /u01/app/oracle/product/19.3.0/db_1
Patch validation checks successfully completed on home /u01/app/oracle/product/19.3.0/db_1 Verifying SQL patch applicability on home /u01/app/oracle/product/19.3.0/db_1
SQL patch applicability verified successfully on home /u01/app/oracle/product/19.3.0/db_1 Preparing to bring down database service on home /u01/app/oracle/product/19.3.0/db_1
Successfully prepared home /u01/app/oracle/product/19.3.0/db_1 to bring down database service Performing prepatch operations on CRS - bringing down CRS service on home /u01/app/19.3.0/grid
Prepatch operation log file location: /u01/app/grid/crsdata/db195/crsconfig/crs_prepatch_apply_inplace_db195_2021-09-13_05-40-09PM.log
CRS service brought down successfully on home /u01/app/19.3.0/grid Performing prepatch operation on home /u01/app/oracle/product/19.3.0/db_1
Perpatch operation completed successfully on home /u01/app/oracle/product/19.3.0/db_1 Start applying binary patch on home /u01/app/oracle/product/19.3.0/db_1
Binary patch applied successfully on home /u01/app/oracle/product/19.3.0/db_1 Performing postpatch operation on home /u01/app/oracle/product/19.3.0/db_1
Postpatch operation completed successfully on home /u01/app/oracle/product/19.3.0/db_1 Start applying binary patch on home /u01/app/19.3.0/grid
Failed while applying binary patches on home /u01/app/19.3.0/grid 未能执行 [OPatchAutoBinaryAction] 补丁程序操作, 有关详细信息, 请查看日志。故障:
Patch Target : db195->/u01/app/19.3.0/grid 类型 [crs]
Details: [
---------------------------Patching Failed---------------------------------
Command execution failed during patching in home: /u01/app/19.3.0/grid, host: db195.
Command failed: /u01/app/19.3.0/grid/OPatch/opatchauto apply /u01/media/32895426 -oh /u01/app/19.3.0/grid -target_type cluster -binary -invPtrLoc /u01/app/19.3.0/grid/oraInst.loc -jre /u01/app/19.3.0/grid/OPatch/jre -persistresult /u01/app/19.3.0/grid/opatchautocfg/db/sessioninfo/sessionresult_db195_crs_1.ser -analyzedresult /u01/app/19.3.0/grid/opatchautocfg/db/sessioninfo/sessionresult_analyze_db195_crs_1.ser
Command failure output:
==Following patches FAILED in apply: Patch: /u01/media/32895426/32585572
Log: /u01/app/19.3.0/grid/cfgtoollogs/opatchauto/core/opatch/opatch2021-09-13_17-56-51下午_1.log
Reason: Failed during Patching: oracle.opatch.opatchsdk.OPatchException: ApplySession 在系统修改阶段失败... 'ApplySession::apply failed: java.io.IOException: oracle.sysman.oui.patch.PatchException: java.io.FileNotFoundException: /u01/app/oraInventory/ContentsXML/oui-patch.xml (权限不够)' After fixing the cause of failure Run opatchauto resume ]
OPATCHAUTO-68061: 业务流程引擎失败。
OPATCHAUTO-68061: 业务流程引擎失败, 返回代码为 1
OPATCHAUTO-68061: 有关详细资料, 请查看日志。
OPatchAuto 失败。 OPatchauto session completed at Mon Sep 13 17:57:49 2021
Time taken to complete the session 28 minutes, 22 seconds opatchauto failed with error code 42
[root@db195 ~]#

查看对应的日志/u01/app/19.3.0/grid/cfgtoollogs/opatchauto/core/opatch/opatch2021-09-13_17-56-51下午_1.log,里面有错误号:OUI-67124,但没啥价值。回到最直观的这个文件权限错误,对比了两个节点发现节点2这个文件权限确实不一样,手工更正为和节点1一致:

--/u01/app/oraInventory/ContentsXML/oui-patch.xml

[root@db195 ~]# ls -l /u01/app/oraInventory/ContentsXML/oui-patch.xml
-rw-r--r-- 1 oracle oinstall 174 9月 13 17:56 /u01/app/oraInventory/ContentsXML/oui-patch.xml
[root@db195 ~]#
[root@db195 ~]# chown grid:oinstall /u01/app/oraInventory/ContentsXML/oui-patch.xml
[root@db195 ~]# chmod 664 /u01/app/oraInventory/ContentsXML/oui-patch.xml
[root@db195 ~]# ls -l /u01/app/oraInventory/ContentsXML/oui-patch.xml
-rw-rw-r-- 1 grid oinstall 174 9月 13 17:56 /u01/app/oraInventory/ContentsXML/oui-patch.xml
[root@db195 ~]#

然后按照提示,尝试继续应用补丁:

--opatchauto resume
/u01/app/19.3.0/grid/OPatch/opatchauto resume

结果很不幸,依然失败:

[root@db195 ~]# /u01/app/19.3.0/grid/OPatch/opatchauto resume

OPatchauto session is initiated at Mon Sep 13 19:58:29 2021
会话日志文件是/u01/app/19.3.0/grid/cfgtoollogs/opatchauto/opatchauto2021-09-13_07-58-30PM.log
恢复 ID 为 AMSA 的现有会话 Start applying binary patch on home /u01/app/19.3.0/grid
Failed while applying binary patches on home /u01/app/19.3.0/grid 未能执行 [OPatchAutoBinaryAction] 补丁程序操作, 有关详细信息, 请查看日志。故障:
Patch Target : db195->/u01/app/19.3.0/grid 类型 [crs]
Details: [
---------------------------Patching Failed---------------------------------
Command execution failed during patching in home: /u01/app/19.3.0/grid, host: db195.
Command failed: /u01/app/19.3.0/grid/OPatch/opatchauto apply /u01/media/32895426 -oh /u01/app/19.3.0/grid -target_type cluster -binary -invPtrLoc /u01/app/19.3.0/grid/oraInst.loc -jre /u01/app/19.3.0/grid/OPatch/jre -persistresult /u01/app/19.3.0/grid/opatchautocfg/db/sessioninfo/sessionresult_db195_crs_1.ser -analyzedresult /u01/app/19.3.0/grid/opatchautocfg/db/sessioninfo/sessionresult_analyze_db195_crs_1.ser
Command failure output:
==Following patches FAILED in apply: Patch: /u01/media/32895426/32585572
Log: /u01/app/19.3.0/grid/cfgtoollogs/opatchauto/core/opatch/opatch2021-09-13_19-59-27下午_1.log
Reason: Failed during Analysis: CheckNApplyReport Failed, [ Prerequisite Status: FAILED, Prerequisite output:
The details are:
Unable to create patchObject
Possible causes are:
ORACLE_HOME/inventory/oneoffs/32585572 is corrupted. PatchObject constructor: Input file "/u01/app/19.3.0/grid/inventory/oneoffs/32585572/etc/config/actions" or "/u01/app/19.3.0/grid/inventory/oneoffs/32585572/etc/config/inventory" does not exist.
] After fixing the cause of failure Run opatchauto resume ]
OPATCHAUTO-68061: 业务流程引擎失败。
OPATCHAUTO-68061: 业务流程引擎失败, 返回代码为 1
OPATCHAUTO-68061: 有关详细资料, 请查看日志。
OPatchAuto 失败。 OPatchauto session completed at Mon Sep 13 19:59:40 2021
Time taken to complete the session 1 minute, 11 seconds

这个报错MOS没有搜到特别匹配的已知问题,但这个报错提示明显,就是缺少文件,同样去比对两边的/u01/app/19.3.0/grid/inventory/oneoffs目录,将少的文件从1节点cp到2节点:

--节点1目录下文件夹:
[root@db193 oneoffs]# ls -lrth
总用量 0
drwxr-x--- 4 grid oinstall 29 4月 18 2019 29401763
drwxr-x--- 4 grid oinstall 29 4月 18 2019 29517242
drwxr-x--- 4 grid oinstall 29 4月 18 2019 29517247
drwxr-x--- 4 grid oinstall 29 4月 18 2019 29585399
drwxr-xr-x 4 grid oinstall 29 9月 13 17:04 32585572
drwxr-xr-x 4 grid oinstall 29 9月 13 17:10 32904851
drwxr-xr-x 4 grid oinstall 29 9月 13 17:13 32915586
drwxr-xr-x 4 grid oinstall 29 9月 13 17:15 32916816
drwxr-xr-x 4 grid oinstall 29 9月 13 17:16 32918050
[root@db193 oneoffs]# pwd
/u01/app/19.3.0/grid/inventory/oneoffs --节点2目录下文件夹:
[root@db195 oneoffs]# ls -lrth
总用量 0
drwxr-x--- 4 grid oinstall 29 7月 31 2019 29401763
drwxr-x--- 4 grid oinstall 29 7月 31 2019 29517247
drwxr-x--- 4 grid oinstall 29 7月 31 2019 29585399
drwxr-x--- 4 grid oinstall 29 7月 31 2019 29517242
[root@db195 oneoffs]# pwd
/u01/app/19.3.0/grid/inventory/oneoffs --从节点1用grid用户拷贝这些缺少的文件夹和内容到节点2后,再次查看:
[grid@db193 oneoffs]$ scp -r 32* db195:/u01/app/19.3.0/grid/inventory/oneoffs/
inventory.xml 100% 2081 715.6KB/s 00:00
actions.xml 100% 2081 667.9KB/s 00:00
inventory.xml 100% 647KB 12.0MB/s 00:00
actions.xml 100% 5337KB 19.2MB/s 00:00
inventory.xml 100% 33KB 7.8MB/s 00:00
actions.xml 100% 84KB 11.5MB/s 00:00
inventory.xml 100% 139KB 9.5MB/s 00:00
actions.xml 100% 232KB 7.5MB/s 00:00
inventory.xml 100% 2197 831.3KB/s 00:00
actions.xml 100% 2651 1.0MB/s 00:00 [root@db195 oneoffs]# ls -lrth
总用量 0
drwxr-x--- 4 grid oinstall 29 7月 31 2019 29401763
drwxr-x--- 4 grid oinstall 29 7月 31 2019 29517247
drwxr-x--- 4 grid oinstall 29 7月 31 2019 29585399
drwxr-x--- 4 grid oinstall 29 7月 31 2019 29517242
drwxr-xr-x 4 grid oinstall 29 9月 13 20:51 32585572
drwxr-xr-x 4 grid oinstall 29 9月 13 20:51 32904851
drwxr-xr-x 4 grid oinstall 29 9月 13 20:51 32915586
drwxr-xr-x 4 grid oinstall 29 9月 13 20:51 32916816
drwxr-xr-x 4 grid oinstall 29 9月 13 20:51 32918050

确保所有文件一致时,此时再次尝试应用补丁成功,最后可以查询下补丁应用情况:

--node1@grid
[grid@db193 ~]$ $ORACLE_HOME/OPatch/opatch lspatches
32918050;TOMCAT RELEASE UPDATE 19.0.0.0.0 (32918050)
32916816;OCW RELEASE UPDATE 19.12.0.0.0 (32916816)
32915586;ACFS RELEASE UPDATE 19.12.0.0.0 (32915586)
32904851;Database Release Update : 19.12.0.0.210720 (32904851)
32585572;DBWLM RELEASE UPDATE 19.0.0.0.0 (32585572) OPatch succeeded. --node2@grid
[grid@db195 ~]$ $ORACLE_HOME/OPatch/opatch lspatches;
32918050;TOMCAT RELEASE UPDATE 19.0.0.0.0 (32918050)
32916816;OCW RELEASE UPDATE 19.12.0.0.0 (32916816)
32915586;ACFS RELEASE UPDATE 19.12.0.0.0 (32915586)
32904851;Database Release Update : 19.12.0.0.210720 (32904851)
32585572;DBWLM RELEASE UPDATE 19.0.0.0.0 (32585572) OPatch succeeded. --node1@oracle
[oracle@db193 ~]$ $ORACLE_HOME/OPatch/opatch lspatches
32916816;OCW RELEASE UPDATE 19.12.0.0.0 (32916816)
32904851;Database Release Update : 19.12.0.0.210720 (32904851) OPatch succeeded. --node2@oracle
[oracle@db195 ~]$ $ORACLE_HOME/OPatch/opatch lspatches
32916816;OCW RELEASE UPDATE 19.12.0.0.0 (32916816)
32904851;Database Release Update : 19.12.0.0.210720 (32904851) OPatch succeeded. --DB
[oracle@db193 ~]$ sqlplus / as sysdba SQL*Plus: Release 19.0.0.0.0 - Production on Mon Sep 13 22:48:34 2021
Version 19.12.0.0.0 Copyright (c) 1982, 2021, Oracle. All rights reserved. Connected to:
Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production
Version 19.12.0.0.0 SQL> set lines 1000
SQL> select * from v$version; BANNER BANNER_FULL BANNER_LEGACY CON_ID
-------------------------------------------------------------------------------- ---------------------------------------------------------------------------------------------------------------------------------------------------------------- -------------------------------------------------------------------------------- ----------
Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production 0
Version 19.12.0.0.0 SQL> select * from dba_registry_history; ACTION_TIME ACTION NAMESPACE VERSION ID COMMENTS BUNDLE_SERIES
--------------------------------------------------------------------------- ------------------------------ ------------------------------ ------------------------------ ---------- --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- ------------------------------
BOOTSTRAP DATAPATCH 19 RDBMS_19.12.0.0.0DBRU_LINUX.X64_210715
01-AUG-19 02.04.17.106249 AM RU_APPLY SERVER 19.0.0.0.0 Patch applied on 19.3.0.0.0: Release_Update - 190410122720
13-SEP-21 09.54.32.352018 PM RU_APPLY SERVER 19.0.0.0.0 Patch applied from 19.3.0.0.0 to 19.12.0.0.0: Release_Update - 210716141810 SQL>

至此,19c RAC的RU补丁应用完成。

Oracle 19c RAC自动应用RU补丁过程的更多相关文章

  1. Oracle 11g RAC 自动应用PSU补丁简明版

    环境:Oracle RAC(GI 11.2.0.4 + DB 11.2.0.4) 本文应用补丁信息: Patch 23615403 - Combo of OJVM Component 11.2.0.4 ...

  2. Linux平台 Oracle 19c RAC安装Part3:DB配置

    Linux平台 Oracle 19c RAC安装Part3:DB配置 四.DB(Database)配置 4.1 解压DB的安装包 4.2 DB软件配置 4.3 ASMCA创建磁盘组 4.4 DBCA建 ...

  3. Linux平台 Oracle 19c RAC安装Part2:GI配置

    三.GI(Grid Infrastructure)安装 3.1 解压GI的安装包 3.2 安装配置Xmanager软件 3.3 共享存储LUN的赋权 3.4 使用Xmanager图形化界面配置GI 3 ...

  4. Linux平台 Oracle 19c RAC安装Part1:准备工作

    一.实施前期准备工作 1.1 服务器安装操作系统 1.2 Oracle安装介质 1.3 共享存储规划 1.4 网络规范分配 二.安装前期准备工作 2.1 各节点系统时间校对 2.2 各节点关闭防火墙和 ...

  5. Windows Server 2019 安装 Oracle 19C RAC(VMWare虚拟机环境)

    软件 Windows Server 2019 Standard Oracle 19C Oracle Grid 19 VMware Workstation 16 规划 共享存储,使用Windows Se ...

  6. Oracle 11g RAC 环境打PSU补丁的详细步骤

    首先重要的事情说三遍:操作之前还是自己先看文档!操作之前还是自己先看文档!!操作之前还是自己先看文档!!! 把11.2.0.4 RAC 环境打PSU补丁的步骤详细记录一下,方便参考. 环境:11.2. ...

  7. 测试:Oracle 19c RAC添加私网

    最近有个客户需求是在某12.2版本的RAC环境上添加心跳网络,顺便考虑将之前的心跳网络改为asm专用.我目前只有19c的RAC的测试环境(19c是12c的最终稳定版本),直接测试验证下过程备忘. 1. ...

  8. Oracle 11g RAC 应用补丁简明版

    之前总结过<Oracle 11.2.0.4 RAC安装最新PSU补丁>, 这次整理为简明版,忽略一切输出的显示,引入一些官方的说明,增加OJVM PSU的补丁应用. 环境:RHEL6.5 ...

  9. 【Oracle RAC】Linux系统Oracle12c RAC安装配置详细记录过程V2.0(图文并茂)

    [Oracle RAC]Linux系统Oracle12c RAC安装配置详细过程V2.0(图文并茂) 2 Oracle12c RAC数据库安装准备工作2.1 安装环境介绍2.2 数据库安装软件下载3 ...

  10. 【Oracle RAC】Linux系统Oracle18c RAC安装配置详细记录过程(图文并茂)

    本文Oracle 18c GI/RAC on Oracle Linux step-by-step 的安装配置步骤,同时也包含dbca 创建数据库的过程. 1. 关闭SELINUX,防火墙vi /etc ...

随机推荐

  1. 三、mycat实验数据

    系列导航 一.Mycat实战---为什么要用mycat 二.Mycat安装 三.mycat实验数据 四.mycat垂直分库 五.mycat水平分库 六.mycat全局自增 七.mycat-ER分片 最 ...

  2. 【调试】kdump原理及其使用方法

    kdump机制 简介 Kdump是在系统崩溃.死锁或死机时用来转储内存运行参数的一个工具和服务,是一种新的crash dump捕获机制,用来捕获kernel crash(内核崩溃)的时候产生的cras ...

  3. Vue3.0 + Element Plus整合实战

    mall-vue3-manage 基于vue3.0 + Element Plus. 整合最新的 Echarts5 强劲的渲染引擎.富文本编辑器 Wangeditor 的后端管理项目. 版本 vue 3 ...

  4. python之HtmlTestRunner(二)view无法打开问题解决

    默认使用python之HtmlTestRunner会遇到测试报告中的view无法打开的情况 view打不开的情况解决 打开\Lib\site-packages\HtmlTestRunner\templ ...

  5. python之单线程、多线程、多进程

    一.基本概念 进程(Process) 是计算机中的程序关于某数据集合上的一次运行活动,是系统进行资源分配和调度的基本单位,是操作系统结构的基础. 在当代面向线程设计的计算机结构中,进程是线程的容器.程 ...

  6. 机器学习-线性分类-支持向量机SVM-合页损失-SVM输出概率值-16

    目录 1. SVM概率化输出 2. 合页损失 1. SVM概率化输出 标准的SVM进行预测 输出的结果是: 是无法输出0-1之间的 正样本 发生的概率值 sigmoid-fitting 方法: 将标准 ...

  7. Spring 事务失效场景总结

    本文为博主原创,未经允许不得转载: 1. spring的事务注解@Transactional只能放在public修饰的方法上才起作用,如果放在其他非public(private,protected)方 ...

  8. Feign源码解析7:nacos loadbalancer不支持静态ip的负载均衡

    背景 在feign中,一般是通过eureka.nacos等获取服务实例,但有时候调用一些服务时,人家给的是ip或域名,我们这时候还能用Feign这一套吗? 可以的. 有两种方式,一种是直接指定url: ...

  9. SpringMVC05——SSM整合

    整合SSM 需求:熟练掌握MySQL数据库,Spring,JavaWeb及MyBatis知识,简单的前端知识 CREATE DATABASE `ssmbuild`; USE `ssmbuild`; D ...

  10. 人大金仓学习之一_kwr的简单学习

    人大金仓学习之一_kwr的简单学习 摘要 周末在家想着学习一下数据库相关的内容. 网上找了不少资料, 想着直接在本地机器上面进行一下安装与验证 理论上linux上面应该更加简单. windows 上面 ...