Windows Server 2019 安装 Oracle 19C RAC(VMWare虚拟机环境)
软件
- Windows Server 2019 Standard
- Oracle 19C
- Oracle Grid 19
- VMware Workstation 16
规划
- 共享存储,使用Windows Server 2019的iSCSI
- 网络规划:VMWare划分3个自定义网段,分别为存储网络、心跳网络和服务网络
- 网络:使用工作组+HOST方式,未使用DNS
- Grid存储规划:OCR+MGMT+DATA+FRA
注意事项
- Administrator账号密码一致
- 关闭3个防火墙
- 修改主机名
- 重命名网卡
安装步骤
安装RAC节点主机
安装RAC节点虚拟机
注意账号为Administrator,密码可设置8位大小写字母+数字

虚拟机名称、位置随意,虚拟机主要内容为操作系统+Oracle安装文件+Oracle安装后的文件,DB数据文件(DATA、MGMT等在磁盘阵列中)

磁盘大小适当大一些,否则格式化后C盘扩展不易操作,使用单文件以提高性能

内存8G(Grid有警告,低一些并忽略警告也可以),添加3个网络的网卡

RAC节点主机设置网卡
配置静态IP,避免VM DHCP分配IP变动,不配置DNS,使用HOST解析主机名,网卡名称命名一致,去掉IPV6协议

关闭防火墙
域、专用、公用(不要忘了域)

调整UAC
操作由GRID安装程序代操作(静默安装),弹窗会造成安装失败

关闭DEP

重命名主机
主机名称配置HOST的IP解析

修改节点HOST配置
C:\Windows\System32\drivers\etc\hosts
# localhost name resolution is handled within DNS itself.
127.0.0.1 localhost
# storage
192.168.30.101 LRAC1SCSI
192.168.30.102 LRAC2SCSI
# SCSI
192.168.30.110 LSCSI
# private
192.168.40.101 LRAC1-pri
192.168.40.102 LRAC2-pri
# public
192.168.50.101 LRAC1
192.168.50.102 LRAC2
# public vip
192.168.50.111 LRAC1-vip
192.168.50.112 LRAC2-vip
# SCAN
192.168.50.120 LRAC-cluster-scan
RAC节点主机修改注册表
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
DisableDHCPMediaSense=1(DWORD)
节点间时间同步
应使用时间同步服务器,或使用互联网同步,简单测试,可使用节点2同步节点1。
修改注册表
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Config

安装iSCSI
安装ISCSI虚拟机
存储适当大些,存储操作系统+Oracle DB、RAC的控制、数据文件,MGMT要求27G+。
配置net3网络网卡。
基础配置
- 关闭防火墙
- 修改网卡名、配置IP
- 重命名主机名
- 配置host(仅配置30即可)
安装iSCSI服务

新建iSCSI虚拟盘
挂在C盘下即可。使用动态存储方式(虚拟机)。
目标使用DNS配置,不启用验证。

添加OCR10G,MGMT30G。
RAC节点使用iSCSI发起
目标主机名:LSCSI,快速连接。卷和设备:自动配置。
RAC节点加载磁盘。
联机、GTP分区初始化、新建简单卷(不分批盘符、不格式化),形成RAW磁盘文件。(某个节点进行了初始化、新建卷后,其他节点联机即可)
安装Grid
SCAN名称在HOST中配置IP解析(SCAN的作用是使用SCAN代理各VIP,在实例监听处配置对SCAN的监听即可,不必配置各节点VIP/IP的监听,便于节点变更等时的运维)

在HOST中配置VIP的IP解析(VIP的作用是当主机网络故障时,VIP可快速切换到无故障的主机网卡上,避免直接请求物理IP因网卡故障出现服务不可用)

不使用的nat最好禁用掉,private和public因使用不同的网段,asm和private可使用同一网段。public和VIP、scan应在一个网段中。

标记磁盘组OCR、MGMT、DATA,并为OCR等设置磁盘组。


设置安装路径:
主路径:安装包所在目录
基路径:安装后文件所在路径。

忽略以下警告或失败
账号不一致是因为使用的不是域账号,使用的是Windows内置账号。
ASM检查失败是因为使用iSCSI配置。

安装db数据库软件
仅设置软件

RAC

勾选节点

企业版或标准版

如果使用域,建议使用Windows域账号,否则只能使用内置账号。(network/system)

与Grid选择不同的目录,因为有相同的子文件路径。

创建ASM磁盘组(Data、FRA)
asmca命令(ASM 配置助手)

data

fra

创建数据库
dbca命令(DB配置助手)

数据文件选择Data、恢复区选择FRA

运维
Oracle服务列表

- Oracle Trace File Analyzer
- Oracle ASMService+ASM1 ASM服务
- OracleJobSchedule 保持禁用
- OracleMGMTDBService-MGMTDB MGMT(Management 管理)DB服务
- OracleOHService
- OracleOraGI19Home1TNSListener DB监听服务(Oracle Grid Infrastructure 19C Home1 TNS Listener)
- OracleOraGI19Home1TNSListenerASMNET1LSNR_ASM ASM Net 监听器
- OracleOraGI19Home1TNSListenerLISTENER_SCAN1 Scan 监听器
- OracleOraGI19Home1TNSListenerMGMTLSNR Mgmt 监听器
- OracleRemExecServiceV2 内存执行服务
- OracleServiceORCL1 Oracle DB服务
- OracleVssWriterORCL1
Windows Server 2019 安装 Oracle 19C RAC(VMWare虚拟机环境)的更多相关文章
- windows server 2003安装Oracle webtier 32位因环境变量原因报错
在服务中启动Oracle processer manager时报错:错误1053:服务没有及时响应启动或控制请求 原因是本系统还安装过BI和Oracle数据库等产品 解决方法:删除和本次安装无关的环境 ...
- Windows Server 2019安装OpenSSH Server简明教程
Windows Server 2019安装OpenSSH Server简明教程 Windows Server 2019内置OpenSSH Server组件了.只不过OpenSSH Server默认 ...
- 在Windows Server 下安装 Oracle 11G 的一般步骤
- MySQL 8.0.18 在 Windows Server 2019 上的安装(ZIP)公开
AskScuti MySQL : Windows Server 2019 安装 MySQL 8.0 温馨提示:为了展现我最“魅力”的一面,请用谷歌浏览器撩我. 一切就绪,点我开撩
- MySQL 8.0.18 在 Windows Server 2019 上的安装(MSI)公开
AskScuti MySQL : Windows Server 2019 安装 MySQL 8.0 温馨提示:为了展现我最“魅力”的一面,请用谷歌浏览器撩我.那个 IE 啊,我很无奈. 一切就绪,点我 ...
- 0级搭建类012-Windows Server 2019安装(2019) 公开
项目文档引子系列是根据项目原型,制作的测试实验文档,目的是为了提升项目过程中的实际动手能力,打造精品文档AskScuti. 项目文档引子系列目前不对外发布,仅作为博客记录.如学员在实际工作过程中需提前 ...
- Linux平台 Oracle 19c RAC安装Part2:GI配置
三.GI(Grid Infrastructure)安装 3.1 解压GI的安装包 3.2 安装配置Xmanager软件 3.3 共享存储LUN的赋权 3.4 使用Xmanager图形化界面配置GI 3 ...
- Linux平台 Oracle 19c RAC安装Part3:DB配置
Linux平台 Oracle 19c RAC安装Part3:DB配置 四.DB(Database)配置 4.1 解压DB的安装包 4.2 DB软件配置 4.3 ASMCA创建磁盘组 4.4 DBCA建 ...
- 1级搭建类111-Oracle 19c SI FS(Windows Server 2019)公开
Oracle 19c 单实例文件系统在Windows Server 2019上的安装 在线查看
- Windows Server 2019 容器化探索-Docker安装
Docker on Windows Server 2019 微软自Windows Server 2016开始支持Docker,今天我们将介绍在Windows Server 2019上安装并使用Dock ...
随机推荐
- Electron学习(四)之应用程序打包
highlight: a11y-dark 写在前面 人真的是会变得越来越懒的,也正是人的惰性吧,真的是很讽刺. 关于这个应用程序的开发,断更了很久,但是代码部分还算没落下吧,终于在周一.周二终把这个应 ...
- spring native 初体验实现 小米控制美的空调
目前关于 spring native 分享的文章还比较少 写这篇文章的主要目前是分享一下自己写的一个 小米控制美的空调 的程序 集成 spring native 过程中碰到的一些问题和解决方法 先放地 ...
- http服务(postman调用方法及反参)
#region 监听url #region 监听url路径请求 static HttpListener httpobj; private void listeningUrl() { //提供一个简单的 ...
- .NET 实现启动时重定向程序运行路径及 Windows 服务运行模式部署
日常工作中有时候会遇到需要将程序直接在服务器上运行,而不依赖于 IIS 托管的情况,直接运行有两种方式,一种是部署为 服务模式,另一种则是 直接启动 .NET 发布之后的 exe 文件以 控制台模式运 ...
- win7通过netsh命令禁用、启用本地连接 定时关闭开启网络连接
1) 先检查网络接口名称 C:\Windows\system32>netsh interface show interface 管理员状态 状态 类型 接口名称 ---------------- ...
- echarts 改变个别省份的边界线颜色
想要实现地图,首先要引入china.js文件,如果有引入就直接调过本步骤去下方看代码,没有引入可以点击下方链接自行Ctrl c + Ctrl v china.js import "../.. ...
- k8s 中 Pod 的控制器
k8s 中 Pod 的控制器 前言 Replication Controller ReplicaSet Deployment 更新 Deployment 回滚 deployment StatefulS ...
- [题解] HDU 5115 Dire Wolf 区间DP
考虑先枚举所有的物品中最后拿走的,这样就分成了2个子问题,即先拿完左边的,再拿完右边的,最后拿选出的那个.令dp(i,j)表示拿完[i,j]所有物品的最小代价.你可能会说,我们拿[i,j]这一段物品的 ...
- cf1082 A. Vasya and Book
中文题意: 思路:我们先看看能不能直接从x翻到y,abs(y-x)%d==0,可以就直接输出abs(y-x)/d咯,不行的话之后有2种操作 1.先翻回到第一页,从第一页看看能不能范到y,不能的话翻到最 ...
- Linux 下搭建 Kafka 环境
Linux 下搭建 Kafka 环境 作者:Grey 原文地址: 博客园:Linux 下搭建 Kafka 环境 CSDN:Linux 下搭建 Kafka 环境 环境要求 操作系统:CentOS 7 下 ...