ubuntu添加新硬盘,进行分区,并挂载到/home目录。

1、查看已有的磁盘,可以看到sdb还没有分区。

> sudo fdisk -l

可以看到各个硬盘的设备名,一般以sda、sdb、sdc命名,下面以/dev/sdb为例,

2、进入sdb进行分区

>sudo fdisk /dev/sdb

输入m查看帮助信息,一般要对照帮助进行操作,避免出错;

输入n新建分区;

输入分区号1,然后输入大小,默认是一个分区,全部的空间大小;

然后查看要创建的分区表,这时还没有创建,按w保存退出后才成功。

可以再次执行 sudo fdisk -l 查看是否创建。

3、将新分区格式化为ext4

>sudo mkfs -t ext4 /dev/sdb1

4、 创建临时目录,用来临时挂载新分区

> sudo mkdir /mnt/newpart

5、将新分区挂载到新文件夹

> sudo mount /dev/sdb1 /mnt/newpart

至此,可以对/mnt/newpart目录进行读写操作。

6、将/home目录下的文件拷贝到新分区

>cd /home

>sudo cp -ax * /mnt/newpart

拷贝时间也许较长,耐心等待。

7、重命名原/home目录,并新建一个新的空/home目录,并将新分区挂载过来

> cd /

> sudo mv /home /home.old

> sudo mkdir /home

> sudo mount /dev/sdb1 /home

8、查看uuid,找到新分区id

> sudo blkid

9、找到新分区的uuid,加入/etc/fstab

> sudo vim /etc/fstab

加入UUID=20984cef-05e4-44c1-bc12-758fc1ecd2e3 /home ext4 defaults 0 2

10、最后修改权限问题

进入新挂载的/home 查看是否都是对应文件夹对应用户的权限,进行相应的更改。

> sudo chown user:user /user

至此,就把新硬盘的存储空间加到/home目录中。

ubuntu添加新硬盘进行分区,并挂载到/home的更多相关文章

  1. 给虚拟机添加新硬盘并分区,fdisk查看分区,分区,重新读取分区表信息partprobe,格式化,挂载,查看分区挂载信息,自动挂载文件/etc/fstab,/etc/fstab文件错误导致重启崩溃后的修复

    1.虚拟机关机断电 2.添加硬盘 2.开机 3.fdisk -l查看刚才新添加的硬盘 [root@localhost ~]# fdisk -l 磁盘 /dev/sda:21.5 GB, 2147483 ...

  2. Centos添加新硬盘、分区、格式化、自动挂载

    创建分区 #fdisk /dev/hdb 格式化新创建的分区 #mkfs.ext3 /dev/hdb1 使新创建的分区挂载/mnt/data01目录下 #mount /dev/hdb1 /mnt/da ...

  3. Linux添加新硬盘及分区,格式化,挂载

    1.查看分区信息: [root@localhost /]# fdisk -l Disk /dev/vdb: 209.7 GB, 209715200000 bytes16 heads, 63 secto ...

  4. ubuntu 添加新硬盘

    查看硬盘: # fdisk -l ... Disk /dev/sdb: 274.9 GB, 274877906944 bytes 255 heads, 63 sectors/track, 33418 ...

  5. VirtualBox中虚拟Ubuntu添加新的虚拟硬盘

    VirtualBox中装好Ubuntu后,发现硬盘空间不够使用 了.以下是搜集整理的解决办法: 1. 添加新硬盘 设置 -> Storage -> SATA控制器->右击,选择&qu ...

  6. 在ubuntu中添加新硬盘

    在ubuntu中添加新硬盘 转载于 http://www.cnblogs.com/unipower/archive/2009/03/08/1406230.html  前言 安装新硬盘这种事情并不会经常 ...

  7. CentOS添加新硬盘到新的分区(xfs/ext4) 或者添加新分区

    CentOs添加新硬盘到新的分区(xfs/ext4)  添加新分区 转载请注明:http://www.cnblogs.com/juandx/p/5618162.html 这篇文章介绍怎么添加一块新的硬 ...

  8. Linux添加新硬盘自动挂载硬盘

    Linux添加新硬盘自动挂载硬盘的具体步骤 1.插入新硬盘,启动Linux服务器,使用fdisk -l 查看硬盘 #fdisk -l Disk /dev/sdb: 1000.2 GB, 1000204 ...

  9. linux fdisk 添加硬盘,分区,挂载,永久挂载

    具体步骤: 1.SSH登陆服务器: 2.列出所有硬盘: 命令:ll /dev/disk/by-path 我这里还有个sda 3.查看磁盘分区情况: 命令 :fdisk -l 最上面两部分表示我有两个物 ...

  10. linux 添加新硬盘的方法

    在服务器上把硬盘接好,启动linux,以root登陆. 比如我新加一块SCSI硬盘,需要将其分成三个区: #fdisk /dev/sdb 进入fdisk模式: Command (m for help) ...

随机推荐

  1. Neighborhood Attention Transformer概述

    0.前言 相关资料: arxiv github 论文解读(CSDN) 论文基本信息: 作者单位:Facebook 发表时间:arxiv2022(2022.4.14) 1.针对的问题 1.之前的视觉Tr ...

  2. postman连接mysql数据库

    转载:https://www.cnblogs.com/pengxiaojie/p/13495237.html 1.安装 2.启动服务 3.执行sql语句 安装: 想要postman连接mysql,需要 ...

  3. 05 RDD练习:词频统计,学习课程分数

    .词频统计: 1.读文本文件生成RDD lines 2.将一行一行的文本分割成单词 words flatmap() 3.全部转换为小写 lower() 4.去掉长度小于3的单词 filter() 5. ...

  4. Eureka出现Connect to localhost:8761 timed out问题

    原先使用application.properties spring.application.name=hello-serviceeureka.client.service-url.defauleZon ...

  5. 向mysql插入数据报错 pymysql.err.DataError: (1406, "Data too long for column 'class' at row 1") 解决方案

    这个问题一开始更换数据类型或者数据类型的大小,发现还是不行.后面通过网上查询了一条神奇的sql语句分分钟钟的解决了 问题原因明明是: 字段的长度不够存放数据 解决方案: 在mysql命令行输入如下:S ...

  6. Java面向对象之接口的定义与实现

    接口 普通类:只有具体实现 抽象类:具体实现和规范(抽象方法)都有! 接口:只有规范!自己无法写方法.专业的约束!约束和实现分离:面向接口编程 接口就是规范,定义的是一组规则,体现了现实世界中&quo ...

  7. frp使用教程

    内网穿透工具---frp使用教程 https://blog.csdn.net/u011215939/article/details/103383373

  8. Docker之Nginx保姆级别安装

    Docker之Nginx保姆级别安装: 如果觉得样式不好:跳转即可 http://www.lifengying.site/(md文件复制过来有些样式会不一样) 学英语网站项目:自己先保证Redis.N ...

  9. linux挂载磁盘步骤

    一.查看需要挂载设备,如下sda(默认路径/dev/sda) 二.新建分区,执行如下命令进入操作 fdisk /dev/sda 1.m 查看可操作的命令 2.键入 n ,根据需要新建分区 3.键入 d ...

  10. 前端使用xlsx file-saver xlsx-style导出

    import FileSaver from 'file-saver' import XLSXStyle from "xlsx-style"; import XLSX from 'x ...