一、准备工作

安装包的下载:elasticsearch-6.8.1.tar.gz

集群服务器:A     B

一、单节点elasticsearch的安装部署

a、进入es的下载目录home:解压tar包

tar -zxvf elasticsearch-6.8.1.tar.gz

b、将解压后的目录名elasticsearch-6.8.1 修改为elasticsearch:

cd /home

进入elasticsearch的config目录下,修改elasticsearch.yml:修改配置文件的IP、端口信息

cd elasticsearch/config

node.name: node-163
node.master: true
node.data: true
path.logs: /home/elastic/logs
bootstrap.memory_lock: false
bootstrap.system_call_filter: false
network.host: 10.68.120.163
http.port: 9200
http.cors.enabled: true
http.cors.allow-origin: "*"

详细截图如下:

c、添加用户,因为启动es需要单独创建用户:

useradd elastic -g elastic -p elasticsearch

chown -R  elastic.elastic   elasticsearch/ (递归修改权限)

chmod 777 elasticsearch/ bin/

su elastic (切换用户)
d、进入 elasticsearch 的bin目录下执行 ./elasticsearch 。如果日志中没有ERROR标志的错误,说明启动成功,./bin/elasticsearch -d (-d为在后台启动,不加-d时可以看到启动过程,出现started时启动完成)

e、验证是否成功。关闭防火墙(systemctl stop firewalld),然后在浏览器中访问192.168.80.129:9200 ,或者 curl 192.168.80.129:9200,如下所示启动成功

三、elasticsearch集群的安装部署

a、主节点:

进入到es目录下,解压3份elasticsearch安装包,分别改名es-master,es-slave1。主节点目录结构:

修改主节点的配置文件:修改es-master/config下的elasticsearch.yml 如下格式:此时主节点默认的端口号为9200.

http.cors.enabled: true

http.cors.allow-origin: "*"

cluster.name: kainan(和其他几个节点的名字一样)

node.name: master

node.master: true

network.host: 主节点的IP地址

详细截图如下:

b、子节点:子节点目录结构:

修改子节点的配置文件:修改es-slave1/config下的elasticsearch.yml 如下格式:此时子节点默认的端口号为8200,如果手动配置,冒号后面要加空格

cluster.name: kainan(与主节点相同)

node.name: slave1

network.host: 子节点IP地址

http.port: 8200

discovery.zen.ping.unicast.hosts: ["主节点IP地址"]

详细截图如下:

如果存在多个节点配置安装目录结构与节点1相同即可。

c、给文件夹赋权限

添加用户:

groupadd   elastic

adduser -g elastic -d /home/elastic   elastic

chown :chown 777 elasticsearch/ bin/

chmod:chown -R elastic.elastic elastic

当主节点与子节点修改完用户权限后即可启动es。

d、启动es。切换elastic用户,先启动master,再启动slave1等子节点服务器

切换用户:su elastic

进入es的安装目录的bin目录下执行:./elasticsearch -d

四、elasticsearch集群的安装部署的常见报错

问题1:[2018-08-07T11:35:38,130][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [node-001] uncaught exception in thread [main]

原因:elasticsearch不支持root用户登录,新增用户并切换到其他用户启动es服务。

问题2:[2018-11-16T13:53:00,839][WARN ][o.e.b.JNANatives ] unable to install syscall filter:   system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk  bootstrap checks failed

解决版本:一般在配置文件中新增:bootstrap.system_call_filter: false

问题3:2020-06-08 09:50:26,077 main ERROR RollingFileManager (/home/elastic/es-master/logs/note1.log) java.io.FileNotFoundException: /home/elastic/es-master/logs/note1.log (Permission denied) java.io.FileNotFoundException: /home/elastic/es-master/logs/note1.log (Permission denied)

原因:一般由于提示文件的权限不足导致,需要给提示文件修改用户组。

问题4:uncaught exception in thread [main]

原因:发现了另一个 elasticsearch 服务,ps -ef |grep elasticsearch  虽然不清楚是如何启动的,kill 掉即可:

linux下部署Elasticsearch6.8.1版本的集群的更多相关文章

  1. 解决linux下部署科大讯飞时的版本过低问题

    在将项目部     署到阿里云服务器之后,需要将科大讯飞SDK下的libmsc64.so依赖库文件上传至/usr/java/jdk1.8.0_121/jre/lib/amd64路径下   在Windo ...

  2. 【k8s学习笔记】使用 kubeadm 部署 v1.18.5 版本 Kubernetes集群

    说明 本文系搭建kubernetes v1.18.5 集群笔记,使用三台虚拟机作为 CentOS 测试机,安装kubeadm.kubelet.kubectl均使用yum安装,网络组件选用的是 flan ...

  3. linux下实现redis共享session的tomcat集群

    为了实现主域名与子域名的下不同的产品间一次登录,到处访问的效果,因此采用rediss实现tomcat的集群效果.基于redis能够异步讲缓存内容固化到磁盘上,从而当服务器意外重启后,仍然能够让sess ...

  4. 二进制部署1.23.4版本k8s集群-5-部署Master节点服务

    1.安装Docker 在21.22.200三台机器上安装Docker.安装命令: 在21.22.200三台主机上部署Docker. ~]# curl -fsSL https://get.docker. ...

  5. linux下一个apache+tomcat负载均衡和集群

    先说一下我的环境 一个ubuntu虚拟机, 一个apache2.2示例 两tomcat1.7示例 1.安装apacheserver sudo apt-get install apache2 假设要重新 ...

  6. linux下安装 zookeeper-3.4.9并搭建集群环境

    本文主要记录作者在实践过程中实现在centos7环境下安装zookeeper并搭建集群的详细步骤,关于zookeeper本文将不做详细介绍,安装步骤详情如下: 前提准备:3台linux服务器(因为zo ...

  7. Linux下Apache与Tomcat的完全分布式集群配置(负载均衡)

    最近公司要给客户提供一套集群方案,项目组采用了Apache和Tomcat的集群配置,用于实现负载均衡的实现. 由于以前没有接触过Apache,因此有些手生,另外在网上搜寻了很多有关这方面的集群文章,但 ...

  8. 二进制部署1.23.4版本k8s集群-6-部署Node节点服务

    本例中Master节点和Node节点部署在同一台主机上. 1 部署kubelet 1.1 集群规划 主机名 角色 IP CFZX55-21.host.com kubelet 10.211.55.21 ...

  9. 二进制部署1.23.4版本k8s集群-1-系统安装及环境准备

    1. 致谢 这篇文章参考了老男孩王导的视频,在此表示感谢和致敬! 2. 安装CentOS操作系统 系统镜像:CentOS-7-x86_64-DVD-2009.iso 安装过程略. 3. 环境准备 3. ...

随机推荐

  1. NOIP 模拟 $30\; \rm 毛二琛$

    题解 \(by\;zj\varphi\) 原题问的就是对于一个序列,其中有的数之间有大小关系限制,问有多少种方案. 设 \(dp_{i,j}\) 表示在前 \(i\) 个数中,第 \(i\) 个的排名 ...

  2. NOIP 模拟 $13\; \text{工业题}$

    题解 本题不用什么推式子,找规律(而且也找不出来) 可以将整个式子看成一个 \(n×m\) 矩阵 考虑 \(f_{i,j}\),它向右走一步给出 \(f_{i,j}×a\) 的贡献,向下走一步给出 \ ...

  3. SpringBoot和mybatis整合报错:Caused by: org.apache.ibatis.builder.BuilderException: Error creating document instance. Cause: org.xml.sax.SAXParseException; lineNumber: 152; columnNumber: 10; 元素类型为 "mapper"

    很明显,报错是xml有问题,于是去检查,发现: 由于粗心,保存的时候,按的太频繁,多按了个s在里面,导致启动报错!

  4. docker部署mysql5-7-31

    快速开始 docker run -itd --name mysql-test -p 3306:3306 -e MYSQL_ROOT_PASSWORD=123456 mysql docker-compo ...

  5. java字符串(String和StringBuilder)

    1.String 1.1.创建String对象的方法(三种方式) String s1 = "zhang"; 创建一个字符串对象zhang,名为s1 String s2 = new ...

  6. Mybatis中多表联查,查询出来的字段出现重名,造成数据异常的解决方法!

    在做一对多出现的问题,引发的思考:当数据库表中,主表的主键id和明细表的中的字段名相同时怎么办?Mybatis进行自动映射赋值的时候会不会出现异常?                      注意:M ...

  7. Flink中的Time与Window

    一.Time 在Flink的流式处理中,会涉及到时间的不同概念 Event Time(事件时间):是事件创建的时间.它通常由事件中的时间戳描述,例如采集的日志数据中,每一条日志都会记录自己的生成时间, ...

  8. Spring系列之集成Druid连接池及监控配置

    前言 前一篇文章我们熟悉了HikariCP连接池,也了解到它的性能很高,今天我们讲一下另一款比较受欢迎的连接池:Druid,这是阿里开源的一款数据库连接池,它官网上声称:为监控而生!他可以实现页面监控 ...

  9. Mysql时间戳转Java时间戳

    MySQL 时间戳和Java返回的时间戳是不一样的 例如: 当前时间是 2014-08-04 10:42:55.204000 使用mysql时间戳函数UNIX_TIMESTAMP 返回的结果为: 14 ...

  10. Ansible部署及配置介绍

    原文转自:https://www.cnblogs.com/itzgr/p/10233932.html作者:木二 目录 一 Ansible的安装部署 1.1 PIP方式 1.2 YUM方式 二 Ansi ...