问题详情

[hadoop@master azkaban]$ ll
total
drwxrwxr-x hadoop hadoop May : azkaban-2.5.
drwxrwxr-x hadoop hadoop May : azkaban-executor-2.5.
drwxrwxr-x hadoop hadoop May : azkaban-web-2.5.
[hadoop@master azkaban]$ cd azkaban-web-2.5./
[hadoop@master azkaban-web-2.5.]$ ll
total
-rw-rw-r-- hadoop hadoop May : azkaban-access.log
-rw-r--r-- hadoop hadoop Apr azkaban.version
-rw-rw-r-- hadoop hadoop May : azkaban-webserver.log
drwxr-xr-x hadoop hadoop Apr bin
drwxr-xr-x hadoop hadoop May : conf
-rw-rw-r-- hadoop hadoop May : currentpid
drwxr-xr-x hadoop hadoop May : extlib
-rw-rw-r-- hadoop hadoop May : keystore
drwxr-xr-x hadoop hadoop May : lib
drwxr-xr-x hadoop hadoop Apr plugins
drwxrwxr-x hadoop hadoop May : temp
drwxr-xr-x hadoop hadoop May : web
[hadoop@master azkaban-web-2.5.]$ cd bin/
[hadoop@master bin]$ ll
total
-rwxr-xr-x hadoop hadoop Apr azkaban-web-shutdown.sh
-rwxr-xr-x hadoop hadoop Apr azkaban-web-start.sh
-rwxr-xr-x hadoop hadoop Apr schedule2trigger.sh
-rwxr-xr-x hadoop hadoop Apr start-web.sh
[hadoop@master bin]$ ./azkaban-web-start.sh

lib/commons-dbcp-1.4.jar:./../lib/commons-dbutils-1.5.jar:./../lib/commons-email-1.2.jar:./../lib/commons-fileupload-1.2..jar:./../lib/commons-io-2.4.jar:./../lib/commons-jexl-2.1..jar:./../lib/commons-lang-2.6.jar:./../lib/commons-logging-1.1..jar:./../lib/commons-pool-1.6.jar:./../lib/guava-13.0..jar:./../lib/h2-1.3..jar:./../lib/httpclient-4.2..jar:./../lib/httpcore-4.2..jar:./../lib/jackson-core-asl-1.9..jar:./../lib/jackson-mapper-asl-1.9..jar:./../lib/jetty-6.1..jar:./../lib/jetty-util-6.1..jar:./../lib/joda-time-2.0.jar:./../lib/jopt-simple-4.3.jar:./../lib/junit-4.8.jar:./../lib/log4j-1.2..jar:./../lib/mail-1.4..jar:./../lib/mysql-connector-java-5.1..jar:./../lib/servlet-api-2.5.jar:./../lib/slf4j-api-1.6..jar:./../lib/slf4j-log4j12-1.6..jar:./../lib/velocity-1.7.jar:./../lib/velocity-tools-2.0.jar:./../extlib/mysql-connector-java-5.1..jar:./../plugins/*/*.jar:/home/hadoop/app/hadoop-2.6.0/conf:/home/hadoop/app/hadoop-2.6.0/*:/home/hadoop/app/hive/conf:/home/hadoop/app/hive/lib/*
[hadoop@master bin]$ 2017/07/05 23:58:24.545 +0800 ERROR [AzkabanWebServer] [Azkaban] Starting Jetty Azkaban Executor...
2017/07/05 23:58:24.633 +0800 INFO [AzkabanServer] [Azkaban] Loading azkaban settings file from ./../conf
2017/07/05 23:58:24.634 +0800 INFO [AzkabanServer] [Azkaban] Loading azkaban properties file
2017/07/05 23:58:24.967 +0800 INFO [AzkabanWebServer] [Azkaban] Setting up Jetty Https Server with port:8443 and numThreads:25
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/home/hadoop/app/azkaban/azkaban-web-2.5.0/lib/slf4j-log4j12-1.6.4.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/home/hadoop/app/hive-1.0.0/lib/hive-jdbc-1.0.0-standalone.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
2017/07/05 23:58:25.362 +0800 INFO [log] [Azkaban] Logging to org.slf4j.impl.Log4jLoggerAdapter(org.mortbay.log) via org.mortbay.log.Slf4jLog
2017/07/05 23:58:26.426 +0800 INFO [AzkabanWebServer] [Azkaban] Loading user manager class azkaban.user.XmlUserManager
2017/07/05 23:58:26.427 +0800 ERROR [AzkabanWebServer] [Azkaban] Could not instantiate UserManager azkaban.user.XmlUserManager
Exception in thread "main" java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
at azkaban.webapp.AzkabanWebServer.loadUserManager(AzkabanWebServer.java:230)
at azkaban.webapp.AzkabanWebServer.<init>(AzkabanWebServer.java:181)
at azkaban.webapp.AzkabanWebServer.main(AzkabanWebServer.java:726)
Caused by: java.lang.reflect.InvocationTargetException
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
at azkaban.webapp.AzkabanWebServer.loadUserManager(AzkabanWebServer.java:226)
... 2 more
Caused by: java.lang.IllegalArgumentException: User xml file conf/azkaban-users.xml doesn't exist.
at azkaban.user.XmlUserManager.parseXMLFile(XmlUserManager.java:87)
at azkaban.user.XmlUserManager.<init>(XmlUserManager.java:81)
... 7 more

  先ctrl + c停止它,

[hadoop@master conf]$ pwd
/home/hadoop/app/azkaban/azkaban-web-2.5./conf
[hadoop@master conf]$ ll
total
-rw-r--r-- hadoop hadoop May : azkaban.properties
-rw-r--r-- hadoop hadoop May : azkaban-users.xml
[hadoop@master conf]$

user.manager.xml.file=/home/hadoop/app/azkaban/azkaban-web-2.5./conf/azkaban-users.xml

  然后,接着

[hadoop@master ~]$ su root
Password:
[root@master hadoop]# cd
[root@master ~]# service mysqld start
Starting mysqld: [ OK ]
[root@master ~]#

// ::17.988 + INFO [log] [Azkaban] jetty-6.1.
// ::18.228 + WARN [log] [Azkaban] failed SslSocketConnector@0.0.0.0:8443: java.io.FileNotFoundException: /home/hadoop/app/azkaban/azkaban-web-2.5.0/bin/keystore (No such file or directory)
2017/07/06 00:06:18.228 +0800 WARN [log] [Azkaban] failed Server@294a671: java.io.FileNotFoundException: /home/hadoop/app/azkaban/azkaban-web-2.5.0/bin/keystore (No such file or directory)
2017/07/06 00:06:18.228 +0800 WARN [AzkabanWebServer] [Azkaban] java.io.FileNotFoundException: /home/hadoop/app/azkaban/azkaban-web-2.5.0/bin/keystore (No such file or directory)
/home/hadoop/app/azkaban/azkaban-web-2.5.0/bin/keystore (No such file or directory)

  方法一:

# Azkaban Jetty server properties.
jetty.maxThreads=
jetty.ssl.port=
jetty.port=
jetty.keystore=/home/hadoop/app/azkaban/azkaban-web-2.5./keystore
jetty.password=mysteel
jetty.keypassword=mysteel
jetty.truststore=/home/hadoop/app/azkaban/azkaban-web-2.5./keystore
jetty.trustpassword=mysteel

  接着,出现,这界面怎么这么丑,跟平常不一样。

  具体解决,见

azkaban web ui界面出现异常诡异“丑”界面的问题解决(图文详解)

欢迎大家,加入我的微信公众号:大数据躺过的坑     免费给分享
 
 
 

同时,大家可以关注我的个人博客:

 http://www.cnblogs.com/zlslch/   和  http://www.cnblogs.com/lchzls/ 

  人生苦短,我愿分享。本公众号将秉持活到老学到老学习无休止的交流分享开源精神,汇聚于互联网和个人学习工作的精华干货知识,一切来于互联网,反馈回互联网。
  目前研究领域:大数据、机器学习、深度学习、人工智能、数据挖掘、数据分析。 语言涉及:Java、Scala、Python、Shell、Linux等 。同时还涉及平常所使用的手机、电脑和互联网上的使用技巧、问题和实用软件。 只要你一直关注和呆在群里,每天必须有收获

以及对应本平台的QQ群:161156071(大数据躺过的坑)

启动azkaban时出现User xml file conf/azkaban-users.xml doesn't exist问题解决(图文详解)的更多相关文章

  1. 基于Web的Kafka管理器工具之Kafka-manager启动时出现Exception in thread "main" java.lang.UnsupportedClassVersionError错误解决办法(图文详解)

    不多说,直接上干货! 前期博客 基于Web的Kafka管理器工具之Kafka-manager的编译部署详细安装 (支持kafka0.8.0.9和0.10以后版本)(图文详解)   问题详情 我在Kaf ...

  2. ubuntu系统里vi编辑器时,按方向箭头输入是乱码的ABCD字母?(图文详解)

    不多说,直接上干货! 问题详情 ubuntu系统里vi编辑器时,按方向箭头输入是乱码的ABCD字母?  解决办法 是由于预装的vim软件没更新,运行   sudo apt-get install vi ...

  3. Windows环境下执行hadoop命令出现Error: JAVA_HOME is incorrectly set Please update D:\SoftWare\hadoop-2.6.0\conf\hadoop-env.cmd错误的解决办法(图文详解)

    不多说,直接上干货! 导读   win下安装hadoop 大家,别小看win下的安装大数据组件和使用  玩过dubbo和disconf的朋友们,都知道,在win下安装zookeeper是经常的事   ...

  4. kafka启动时出现FATAL Fatal error during KafkaServer startup. Prepare to shutdown (kafka.server.KafkaServer) java.io.IOException: Permission denied错误解决办法(图文详解)

    首先,说明,我kafk的server.properties是 kafka的server.properties配置文件参考示范(图文详解)(多种方式) 问题详情 然后,我启动时,出现如下 [hadoop ...

  5. 全网最详细的启动或格式化zkfc时出现java.net.NoRouteToHostException: No route to host ... Will not attempt to authenticate using SASL (unknown error)错误的解决办法(图文详解)

    不多说,直接上干货! 全网最详细的启动zkfc进程时,出现INFO zookeeper.ClientCnxn: Opening socket connection to server***/192.1 ...

  6. 安装Phoenix时./sqlline.py执行报错File "./sqlline.py", line 27, in <module> import argparse ImportError: No module named argparse解决办法(图文详解)

    不多说,直接上干货! 前期博客 Apache版Phoenix的安装(图文详解) 问题现象 Traceback (most recent call last): File , in <module ...

  7. cloudera-server启动File not found : /usr/sbin/cmf-server解决办法(图文详解)

    解决方法 见 cloudera-agent启动File not found : /usr/sbin/cmf-agent解决办法(图文详解) 欢迎大家,加入我的微信公众号:大数据躺过的坑        ...

  8. 错误:android.view.InflateException: Binary XML file line #167: Binary XML file line #167: Error inflating class <unknown>

    1:错误日志 java.lang.RuntimeException: Unable to start activity ComponentInfo{com.8.activity.RecordActiv ...

  9. azkaban web ui界面出现异常诡异“丑”界面的问题解决(图文详解)

    前期博客 启动azkaban时出现User xml file conf/azkaban-users.xml doesn't exist问题解决(图文详解) 问题详情 [hadoop@master co ...

随机推荐

  1. springboot对传参的拦截统一处理

    在学习某网<java秒杀系统方案优化>的课程中,学到了一种springboot对传参的拦截统一处理的方式,特记录一下. 如后台方法一般需要根据token从Session中获取User对象, ...

  2. 【转】【录教程必备】推荐几款屏幕录制工具(可录制GIF)

    我们经常会遇到一些场景,需要你向别人展示一些操作或是效果——例如告诉别人某某软件的配置步骤啊.刚设计出来网站的动画效果怎么样啊.某某电影里面的一个镜头多么经典啊.打得大快人心的NBA绝杀瞬间是怎么回事 ...

  3. react native 之 redux

    第一章  认识redux 说的通俗且直白一点呢,就是redux提供了一个store,独立的一个内存区,然后放了一些state,你可以在任何component中访问到state,这些state要更改怎么 ...

  4. hihocoder hiho一下 第二十六周 最小生成树一·(Prim算法)

    题目1 : 最小生成树一·Prim算法 时间限制:10000ms 单点时限:1000ms 内存限制:256MB 描述 最近,小Hi很喜欢玩的一款游戏模拟城市开放出了新Mod,在这个Mod中,玩家可以拥 ...

  5. 关于eclipse的resource文件没有发布到tomcat上的解决方案

    版权声明:本文为博主原创文章,未经博主允许不得转载. https://blog.csdn.net/luman1991/article/details/53457302

  6. hdu 1963 Investment 解题报告

    题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1963 题目意思:有 本金 money,还有一些股票的种类,第 i 种股票买入需要 value[i] 这 ...

  7. Android font

    ╔════╦════════════════════════════╦═════════════════════════════╗ ║ ║ FONT FAMILY ║ TTF FILE ║ ╠════ ...

  8. POJ1113:Wall (凸包:求最小的多边形,到所有点的距离大于大于L)

    Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the ...

  9. Python3中使用PyMongo的方法详解

    前言 本文主要给大家介绍的是关于在Python3使用PyMongo的方法,分享出来供大家参考学习,下面话不多说了,来一起看看详细介绍: MongoDB存储 在这里我们来看一下Python3下Mongo ...

  10. 【转】cocos2dx 内存管理机制

    原文地址: http://www.zaojiahua.com/memory-management.html cocos2dx采用的是在堆上分配内存空间,想想看你在写程序的时候对于cocos2dx中的类 ...