hadoop笔记之Hive的管理(web界面方式)
Hive的管理(二)
Hive的管理(二)
Web界面方式
- 端口号9999
- 启动方式:
hive --service hwi - 通过浏览器来访问:
http://<IP地址>:9999/hwi/
web管理器编译与配置
初次执行hive --service hwi的可能会出现一个错误
ls:cannot access /root.training.apache-hive-0.13.0-bin/lib/hive-hwi-*.war:No such file or directory
通常一个web程序就是一个war包,而在当前hive0.13版本中没有自带这个web管理工具,所以我们要编译一下
从apache网站上可以把apache-hive-0.13.0-src.tar.gz源代码下载下来
下载下来以后,解压这个文件
tar -zxvf apache-hive-0.13.0-src.tar.gz
进入到源代码文件夹内,ls看一下下面有个hwi的目录,进入该目录下,发现里面有个web目录,将该目录中的所有文件打包成一个war包
cd apache-hive-0.13.0-src
pwd
ls
cd hwi/
ls
jar cvfM0 hive-hwi-0.13.0.war -C web/ .
把war包成功打包之后,将war包拷贝到hive的lib目录下
cp hive-hwi-0.13.0.war ~/training/apache-hive-0.13.0-bin/lib/
拷贝过去之后,还需要去更改hive配置文件
cd ~/training/apache-hive-0.13.0-bin/conf/
vi hive-site.xml
去官网看相关配置参数,然后将其加入配置文件中
<property>
<name>hive.hwi.listen.host</name>
<value>0.0.0.0</value>
</property>
<property>
<name>hive.hwi.listen.port</name>
<value>9999</value>
</property>
<property>
<name>hive.hwi.war.file</name>
<value>lib/hive-hwi-0.13.0.war</value> </property>
保存退出之后,用hive --service hwi重新启动
INFO hwi.HWIServer: HWI is starting up
web管理工具成功启动
下面打开浏览器,进入web管理界面
http://<IP地址>:9999/hwi/
这个时候会出现错误HTTP ERROR 500
这个错误是因为我们需要把jdk里面的jar包拷贝到hive的目录当中去,只有这样才能成功访问web管理器
cp ~/training/jdk1.7.0_75/lib/tools.jar ~/training/apache-hive-0.13.0-bin/lib/
web管理器查询操作
然后重启web管理器hive --service hwi
刷新一下网页,
在这里我们可以进行查询操作(注意:在web管理器下我们只能进行查询操作)
- Browse Schema 查看已经存在的数据库
- Create Session 创建一个session,点击submit提交然后执行一个查询操作
创建查询,silent mode静默模式on,start query执行查询yes,然后点击提交
出现Session is in QUERY_RUNNING state. Changes are not possible!查询在执行状态不能够被更改,这个时候可以点击View File来查看结果
hadoop笔记之Hive的管理(web界面方式)的更多相关文章
- hadoop笔记之Hive的管理(远程登录方式)
Hive的管理(三) Hive的管理(三) Hive的远程服务 远程服务启动方式 端口号10000 启动方式:hive --service hiveserver (注意:以JDBC或ODBC的程序登录 ...
- hadoop笔记之Hive的管理(CLI方式)
Hive的管理(一) Hive的管理(一) Hive的启动方式 CLI(命令行)方式 Web界面方式 远程服务启动方式 CLI方式 1. 进入命令行方式 直接输入<HIVE_HOME>/b ...
- HADOOP docker(七):hive权限管理
1. hive权限简介1.1 hive中的用户与组1.2 使用场景1.3 权限模型1.3 hive的超级用户2. 授权管理2.1 开启权限管理2.2 实现超级用户2.3 实现hiveserver2用户 ...
- hadoop笔记之Hive的数据存储(内部表)
Hive的数据存储(内部表) Hive的数据存储(内部表) 基于HDFS 可使用hadoop给我们提供的web管理工具查看数据.打开管理工具localhost:9000–>Utilities下的 ...
- tomcat管理web界面
在/usr/tomcat/apache-tomcat-7.0.47/conf/tomcat-users.xml里 <?xml version='1.0' encoding='utf-8'?> ...
- hadoop笔记之Hive入门(什么是Hive)
Hive入门(一) Hive入门(一) 什么是Hive? Hive是个数据仓库,数据仓库就是数据库,但又与一般意义上的数据库有点区别 实际上,Hive是构建在hadoop HDFS上的一个数据仓库. ...
- hadoop笔记之Hive入门(Hive的体系结构)
Hive入门(二) Hive入门(二) Hive的体系结构 ○ Hive的元数据 Hive将元数据存储在数据库中(metastore),支持mysql.derby.oracle等数据库,Hive默认是 ...
- hadoop 笔记(hive)
//**********************************//安装配置1. 修改配置文件 1.1 在conf文件夹下 touch hive-site.xml <configurat ...
- hadoop笔记之Hive的数据存储(视图)
Hive的数据存储(视图) Hive的数据存储(视图) 视图(view) 视图是一种虚表,是一个逻辑概念:可以跨越多张表 既然视图是一种虚表,那么也就是说用操作表的方式也可以操作视图 但是视图是建立在 ...
随机推荐
- TcpClient
public class TcpClientSession { protected TcpClient Client { get; set; } /// <summary> /// 远程地 ...
- 读取hdfs文件内容
基础环境: cdh2.71 需要注意: url地址参照 <property> <name>dfs.namenode.servicerpc-address</name> ...
- HDU 1004 - Let the Balloon Rise(map 用法样例)
Problem Description Contest time again! How excited it is to see balloons floating around. But to te ...
- Inno Setup打包的程序提升为管理员权限
Inno Setup打包的程序在Win7 64位系统上安装,安装步骤最后一步若选中运行程序,会跳出一个错误提示框. 这是因为64位win7系统运行程序时需要管理员权限,而打包的文件并没有这个权限就试图 ...
- php设计模式笔记--总结篇
一.引入 设计模式的一般定义不再说,只大概说一下我理解的设计模式,我理解的设计模式的主要目的是利用面向对象(类.接口等)特点,让代码更加易于扩展,易于重用,易于维护.这三个特点也就要求我们不要将太多 ...
- Thinkphp3.2使用scws中文分词 提取关键词
SCWS 是 Simple Chinese Word Segmentation 的首字母缩写(即:简易中文分词系统).1.下载scws官方提供的类(这里使用的是pscws第四版的)http://www ...
- php 数组去除空值
/** * 方法库-数组去除空值 * @param string $num 数值 * @return string */ public function array_remove_empty(& ...
- [置顶] CSDN博客第三期云计算最佳博主评选
CSDN博客第二期云计算最佳博主排行圆满结束,恭喜所有上榜用户,为继续展示云计算方向的优秀博主,发掘潜力新星,为云计算方向的博客用户提供平台,CSDN博客第三期云计算最佳博主排行开始.同时,获奖者有机 ...
- [开源]在iOS上实现Android风格的控件Toast
[开源]在iOS上实现Android风格的控件Toast iOS的风格和Apple其他产品一样,简单而粗暴.没有给人其他选择的余地,让你又爱又恨.同样的,Apple对待iOS平台的开发人员和对待大众消 ...
- Eclipse 快捷键操作和常用设置
自动提示功能:一般的关键字,都有提示内容 像syso 就是System.out.println();for 循环 等 它的快捷键是 (Alt+/) 格式化代码: 有时候代码写多了 比较乱的话可以用快捷 ...