SharePoint运行状况分析器有关磁盘空间不足的警告
对于负责管理SharePoint内部部署安装的SharePoint管理员,SharePoint Health Analyzer是一款出色的工具。此功能不仅有助于解决服务器故障和服务失败的问题,还提供了有关如何解决问题的提示。总的来说,我觉得这个功能非常有帮助。但是,在某些情况下,健康分析器中的错误和警告可能完全是虚假的,必须予以忽略。虚假警告的一个例子是我在咨询期间在很多SharePoint服务器上看到的低磁盘警告。在虚拟环境中运行的SharePoint服务器上这些特别常见,我将在一分钟内解释。有关此警告的有趣之处在于,即使您的硬盘驱动器仅使用1%的磁盘空间,运行状况分析仪仍可能会警告您存在可用空间不足的风险。因此,即使在全新安装的SharePoint服务器上也可以看到以下警告。
Health Analyzer 警告信息
在Health Analyzer中看到的警告消息是:
“Drives are at risk of running out of free space.”
SPTimerService (SPTimerV4) 失败的服务警告信息
Health Analyzer如何计算低磁盘空间?
要了解低磁盘警告,我们需要查看运行状况分析器如何计算低磁盘空间。根据上述警告消息中的说明,SharePoint会根据物理内存计算出较低的磁盘空间。警告的解释说明“可用驱动器空间小于物理内存值的五倍”。这是很危险的,因为它没有提供足够的空间来存储持续运行的内存。它也可能导致虚拟内存交换文件出现问题。“
注:操作系统使用Windows计算机上的页面文件(也称为交换文件),就好像它是RAM一样。无论系统上安装了多少RAM,每台Windows计算机都使用页面文件。 pagefile.sys是一个隐藏文件,它默认存储在驱动器C的根目录下。
大多数99%的客户在虚拟环境中运行SharePoint,也是这样。托管SharePoint Server安装的Windows Server的典型驱动器大小大约为100 GB,所有Windows更新的标准安装大约使用25 -30GB,取决于RAM的数量(影响页面文件的大小)和安装的应用程序。因此,如果100GB驱动器上的可用磁盘空间为75GB,并且您已将16GB的RAM分配给SharePoint服务器,则仍会收到上述警告,原因如下:
16GB的RAM x 5 = 80GB。当磁盘空间低于80GB(例如79GB)时,您将看到低磁盘空间警告。
警告!服务器磁盘空间不足可能会造成灾难性后果,并可能导致服务器崩溃。仅仅因为运行状况分析器关于磁盘空间不足的警告通常可能是骗人的,您不应该始终忽略此警告。这正是我不建议删除警告消息的原因。请确保您密切关注所有服务器上的可用磁盘空间,并立即采取适当的行动。
Default Memory Dump Settings
以下是如何处理Windows客户端和服务器中的内存转储设置。这可能不适用于所有人,但我关闭了服务器上的内存转储。这些是我在我的网络上的所有客户端和工作站上使用的内存转储设置。至少我推荐客户推荐了做这些相同的设置。首先让我们看看默认的内存转储设置。该屏幕截图来自Windows Server 2016数据管理中心,此版本SharePoint Server 2016 Enterprise。请注意,显示操作系统列表的默认时间设置为30秒,并且内存转储设置为自动内存转储。
以下选项可供您配置内存转储。小内存转储将创建256KB内存内容的有限转储。内核内存转储仅限于操作系统内核内存的转储,并且完整的内存转储将执行系统内存中所有内容的全部内存转储。自动内存转储是默认设置。将该选项设置为none将关闭内存转储。
通常选择禁用内存转储,主要原因是不打算使用它,如果遇到系统崩溃,甚至不会重新启动,那么当然我将无法更改设置并创建转储文件。到目前为止,还没有遇到过我真的需要调试文件太糟糕的情况。如果我的SharePoint服务器崩溃了,我们可以重新从头开始重建它,如果不是更多的话,我可能会重新编译它两次或三次,直到我需要调试内存转储为止......这就是如果我幸运的话。如果我必须将调试文件发送给供应商,可能需要几天时间才能获得答案......如果他们没有解决方案,则可能无法解决我的问题。因为SharePoint数据保存在SQL Server中,所以只要拥有SQL Server数据库,重建SharePoint就不会太困难。这就是为什么你要确保你的SQL Server是集群化的,有不间断电源保护的,并且SQL数据库是经常备份的。相同的参数适用于域控制器(DC)。我的网络上总是有两个或更多的DC,并且每天备份我的Active Directory(AD)数据库。 AD和AD集成的DNS数据库被复制到其他服务器。更换损坏的DC相对容易。所以现在你知道为什么我觉得这个调试文件(memory.dmp)不适用于每个人。
SharePoint运行状况分析器有关磁盘空间不足的警告的更多相关文章
- SharePoint 事件 2137 / 2138 :SharePoint 运行状况分析器检测到错误。驱动器的可用空间不足。
转自MSDN:http://technet.microsoft.com/zh-cn/library/ff805057.aspx 摘要:服务器场中的一个或多个服务器上的磁盘驱动器的可用空间不足. 注意: ...
- kvm 下运行的 WINWS7磁盘空间不足 增加磁盘 实战(这个有问题,还未解决)
创建一个新硬盘: [root@NB vhost]# qemu-img create -f qcow2 add_win_desk.img 5G Formatting encryption=off clu ...
- macbook清理磁盘空间
前言:作为一名程序员,使用MacBook时间久了之后难免都会遇到“磁盘空间不足”的警告,这时就可以清理如下文件夹,一般就可以清理出几十个G的大小! 1.删除“~/资源库/Developer/Xcode ...
- 运行R 报错R cannot R_TempDir, 继而发现/dev/mapper/VG00-LV01 磁盘空间已满
今天在运行R脚本的时候报了个错:Fatal error: cannot create 'R_TempDir'.排除了是自己写的代码的问题,想着应该是某个没见过的原因,google之,发现网上的说法是/ ...
- 释放Linux磁盘空间的一种方法
1.用df 检查发现/根目录可用空间为0 [root@/]#df -h 2.用du检查发现 各目录占用的空间都很少,有约3G的空间莫名其妙地丢了. [root@/]# du -m ...
- df 和du 命令统计磁盘空间不准确
Linux & Unix 中 df 和 du 命令统计磁盘空间数值不一致 经常会使用 df 和 du 分别查看磁盘空闲空间和占用空间,偶尔会发现 df(空闲空间) 会小于磁盘大小减去 du(占 ...
- 和系统运行状况相关的Shell命令总结
1. Linux的实时监测命令(watch): watch 是一个非常实用的命令,可以帮你实时监测一个命令的运行结果,省得一遍又一遍的手动运行.该命令最为常用的两个选项是-d和-n,其中-n表 ...
- Linux磁盘空间被占用问题 (分区目录占用空间比实际空间要大: 资源文件删除后, 空间没有真正释放)
问题说明:IDC里的一台服务器的/分区使用率爆满了!已达到100%!经查看发现有个文件过大(80G),于是在跟有关同事确认后rm -f果断删除该文件.但是发现删除该文件后,/分区的磁盘空间压根没有释放 ...
- (转)Linux服务器磁盘空间占满问题
转自:https://www.cnblogs.com/cindy-cindy/p/6796684.html 下面我们一起来看一篇关于Linux服务器磁盘占满问题解决(/dev/sda3 满了),希望碰 ...
随机推荐
- IP简介2
本笔记介绍java net IP A 类 主要是大型的交换机 1-126 B类 128-191 分配给各个国家的典型的服务器 每个网段支持255*255个设备 每一个B类都可以分配444416个C ...
- python--环境变量的使用
用python 环境变量取代sys.path echo -en "PYTHONPATH=$PYTHONPATH:~/demo" >>~/.bashrc export ~ ...
- [原创]Devexpress XtraReports 系列 1 创建静态报表
在各种管理系统中,报表是必不可少的.报表是数据最直观体现的方式之一 以前,屌丝我是微软的忠实粉丝,所以报表工具就是微软自带的RDLC... 不可否认的是RDLC的功能是非常强大的.能够满足绝大多数的要 ...
- 9. 那些强悍的PHP一句话后门
强悍的PHP一句话后门 这类后门让网站.服务器管理员很是头疼,经常要换着方法进行各种检测,而很多新出现的编写技术,用普通的检测方法是没法发现并处理的.今天我们细数一些有意思的PHP一句话木马. 利用4 ...
- 散列表(Hash table)及其构造
散列表(Hash table) 散列表,是根据关键码值(Key value)而直接进行访问的数据结构.它通过把关键码值映射到表中一个位置来访问记录,以加快查找的速度.这个映射函数叫做散列函数,存放记录 ...
- IT兄弟连 Java语法教程 编写Java源代码
现在我们来一步一步的编写第一个Java程序,鼎鼎大名的“HelloWorld”. 编写Java源代码 编写Java源代码可以使用任何无格式的文本编辑器,在Windows操作系统上可以使用记事本.Edi ...
- IT兄弟连 JavaWeb教程 过滤器3
过滤器案例:字符编码过滤器 在JavaWeb程序开发中,由于Web容器内部所使用编码格式并不支持中文字符集,所以,处理浏览器请求中的中文数据就会出现乱码现象. 图3 无字符编码过滤器 从上图可以看出 ...
- Sonya and Matrix Beauty Codeforces - 1080E
https://codeforces.com/contest/1080/problem/E 比赛时候一个多小时码不出来... 来看遇到的困难: 1.没有能用的随机unsignedlonglong函数 ...
- SocLib的安装
一.soclib的安装 1.安装g++,一般Ubuntu系统都自带了,所以无需安装.后面这两个软件需要提前安装,不然后面执行相关操作是会报错:sudo apt-get install automake ...
- NET Core 2.0 的 REST API
用ASP.NET Core 2.0 建立规范的 REST API -- 预备知识 (2) + 准备项目 上一部分预备知识在这 http://www.cnblogs.com/cgzl/p/9010978 ...